]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
updated source url to https
[packages/gdb.git] / gdb.spec
index b6d541ca537f6943ed1de27fb9c7ac8cf75b6df7..ac15b73e86554cad5e172c310b1216ec560ef541 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -3,9 +3,10 @@
 # TODO
 # - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
+# - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
 #
 # Conditional build:
-%bcond_without guile           # Guile embedded scripting
+%bcond_with    guile           # Guile embedded scripting
 %bcond_without python          # build without python support
 
 Summary:       A GNU source-level debugger for C, C++ and Fortran
@@ -20,12 +21,12 @@ Summary(uk.UTF-8):  Символьний відладчик для С та інш
 Summary(zh_CN.UTF-8):  [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
 Name:          gdb
-Version:       8.2
-Release:       1
+Version:       9.1
+Release:       2
 License:       GPL v3+
 Group:         Development/Debuggers
-Source0:       http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
-# Source0-md5: b5a49dbff00d9a87fbe114d14b3101c0
+Source0:       https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
+# Source0-md5: f7e9f6236c425097d9e5f18a6ac40655
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
 Source3:       %{name}-gstack.man
@@ -56,7 +57,10 @@ BuildRequires:       babeltrace-devel >= 1.1.0
 BuildRequires: expat-devel
 BuildRequires: flex >= 2.6.4
 BuildRequires: gettext-tools >= 0.12.1
-%{?with_guile:BuildRequires:   guile-devel >= 2.0}
+%if %{with guile}
+BuildRequires: guile-devel >= 2.0
+BuildRequires: guile-devel < 2.2
+%endif
 %ifarch %{ix86} %{x8664}
 BuildRequires: libipt-devel
 %endif
@@ -69,17 +73,19 @@ BuildRequires:      ncurses-devel >= 5.2
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
 BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: source-highlight-devel >= 3.0
 BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.4
+BuildRequires: xxHash-devel
 BuildRequires: xz
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
 %if %{with python}
-BuildRequires: python-devel
+BuildRequires: python3-devel
 BuildRequires: rpm-pythonprov
 Obsoletes:     python-gdb
 # for traceback module
-Requires:      python-modules
+Requires:      python3-modules
 %endif
 %{?with_guile:Requires:        guile >= 2.0.12}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -168,7 +174,7 @@ Requires:   expat-devel
 Requires:      libselinux-devel
 Requires:      libsepol-devel
 Requires:      ncurses-devel
-Requires:      python-devel
+Requires:      python3-devel
 Requires:      readline-devel
 Requires:      xz-devel
 Requires:      zlib-devel
@@ -212,7 +218,20 @@ cat > gdb/version.in << EOF
 %{version}-%{release} (PLD Linux)
 EOF
 
-sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python3}\1,' \
+      contrib/dg-extract-results.py \
+      gdb/contrib/test_pubnames_and_indexes.py \
+      gdb/testsuite/analyze-racy-logs.py \
+      gdb/testsuite/print-ts.py
+
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
+      gdb/copyright.py
+
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
+      gdb/contrib/cc-with-tweaks.sh \
+      gdb/gcore \
+      gdb/gcore.in \
+      src-release.sh
 
 %build
 # omit hand-written gdb/testsuite aclocal.m4
@@ -232,52 +251,54 @@ for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
        cd $olddir
 done
 cp -f /usr/share/automake/config.* .
+install -d build && cd build
 # don't --enable-shared here, there would be libs version mismatch with binutils
-%configure \
-       --with-gdb-datadir=%{_datadir}/gdb \
-       --with-separate-debug-dir=/usr/lib/debug \
-%if %{with python}
-       --with-python=yes \
-       --with-pythondir=%{py_sitescriptdir} \
-%else
-       --without-python \
-%endif
-%if %{with guile}
-       --with-guile \
-%else
-       --without-guile \
-%endif
+../%configure \
        --disable-gdbtk \
        --disable-shared \
+       --disable-silent-rules \
        --enable-gdbcli \
        --enable-gdbmi \
        --enable-multi-ice \
        --enable-netrom \
        --enable-nls \
        --enable-tui \
-       --with-system-readline \
        --with-cpu=%{_target_cpu} \
+       --with-gdb-datadir=%{_datadir}/gdb \
+       --with-guile%{!?with_guile:=no} \
 %ifnarch alpha
        --with-mmalloc \
 %endif
+%if %{with python}
+       --with-python="%{__python3}" \
+       --with-pythondir=%{py3_sitescriptdir} \
+%else
+       --without-python \
+%endif
+       --with-separate-debug-dir=/usr/lib/debug \
+       --with-system-readline \
        --without-included-gettext \
        --without-included-regex \
        --without-x
 
-%{__make}
+# V=1 because only some subdirs honour --enable-silent-rules
+%{__make} \
+       V=1
+
 %{__make} -j1 info
 
 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
-%{__make} -C gdb libgdb.a
+%{__make} -C gdb libgdb.a \
+       V=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_infodir}
 
-%{__make} -j1 install install-info \
+%{__make} -C build -j1 install install-info \
        DESTDIR=$RPM_BUILD_ROOT
 
-cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
+cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
 
 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
 # window is created too.
@@ -296,20 +317,19 @@ for LIB in lib lib64 libx32; do
        install -d $LIBPATH
 done
 
-%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
-%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
-%py_postclean
+%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
+%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
 %endif
 
 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
 
-install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
+cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
 
 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
 # These are part of binutils:
 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
-%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
+%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfd_stdint,bfdlink,diagnostics,dis-asm,symcat,plugin-api}.h
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
 
@@ -361,7 +381,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gdbserver
 %{_mandir}/man1/gdbserver.1*
+%ifnarch %{arm}
 %attr(755,root,root) %{_libdir}/libinproctrace.so
+%endif
 
 %files lib
 %defattr(644,root,root,755)
This page took 0.03254 seconds and 4 git commands to generate.