]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- up to 8.2
[packages/gdb.git] / gdb.spec
index 946cc41691f06ba31befb42df9f7e3d295cc70a4..92da00693088470933d6ccdecd4709518362a541 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -1,6 +1,7 @@
 # NOTE: -lib package is used by fpc.spec
 
 # TODO
+# - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
 #
 # Conditional build:
@@ -18,14 +19,13 @@ Summary(tr.UTF-8):  C ve diğer diller için sembolik hata ayıklayıcı
 Summary(uk.UTF-8):     Символьний відладчик для С та інших мов
 Summary(zh_CN.UTF-8):  [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
-%define                snap    20120926
 Name:          gdb
-Version:       7.11.1
+Version:       8.2
 Release:       1
 License:       GPL v3+
 Group:         Development/Debuggers
 Source0:       http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
-# Source0-md5: 5aa71522e488e358243917967db87476
+# Source0-md5: b5a49dbff00d9a87fbe114d14b3101c0
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
 Source3:       %{name}-gstack.man
@@ -35,13 +35,14 @@ Patch102:   gdb-6.6-buildid-locate-rpm.patch
 Patch103:      gdb-6.6-buildid-locate-core-as-arg.patch
 Patch104:      gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
 Patch105:      gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
+Patch106:      gdb-6.6-buildid-locate-rpm-scl.patch
 Patch110:      gdb-6.3-gstack-20050411.patch
-Patch111:      gdb-gdb-add-index-script.patch
+
 Patch112:      gdb-archer-vla-tests.patch
-Patch113:      gdb-vla-intel.patch
-Patch114:      gdb-vla-intel-04of23-fix.patch
-Patch115:      gdb-vla-intel-stringbt-fix.patch
-Patch116:      gdb-vla-intel-logical-not.patch
+Patch113:      gdb-vla-intel-fortran-strides.patch
+Patch114:      gdb-vla-intel-stringbt-fix.patch
+Patch115:      gdb-vla-intel-fortran-vla-strings.patch
+Patch116:      gdb-vla-intel-tests.patch
 Patch1000:     %{name}-readline.patch
 Patch1001:     %{name}-info.patch
 Patch1002:     %{name}-passflags.patch
@@ -51,18 +52,24 @@ URL:                http://www.gnu.org/software/gdb/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 BuildRequires: bison
-BuildRequires: babeltrace-devel
+BuildRequires: babeltrace-devel >= 1.1.0
 BuildRequires: expat-devel
-BuildRequires: flex
-BuildRequires: gettext-tools
+BuildRequires: flex >= 2.6.4
+BuildRequires: gettext-tools >= 0.12.1
 %{?with_guile:BuildRequires:   guile-devel >= 2.0}
 BuildRequires: libselinux-devel
+BuildRequires: libstdc++-devel >= 6:4.8
 BuildRequires: libtool
+BuildRequires: make >= 3.81
+BuildRequires: mpfr-devel
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
 BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.4
+BuildRequires: xz
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
 %if %{with python}
 BuildRequires: python-devel
@@ -71,7 +78,7 @@ Obsoletes:    python-gdb
 # for traceback module
 Requires:      python-modules
 %endif
-%{?with_guile:Requires:        guile >= 2.0}
+%{?with_guile:Requires:        guile >= 2.0.12}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -173,8 +180,8 @@ GDB w postaci biblioteki statycznej.
 %setup -q
 
 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
-rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
-rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
+%{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
+%{__rm} gdb/m2-exp.c gdb/p-exp.c
 
 %patch100 -p1
 %patch101 -p1
@@ -182,8 +189,9 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 %patch103 -p1
 %patch104 -p1
 %patch105 -p1
+%patch106 -p1
 %patch110 -p1
-%patch111 -p1
+
 %patch112 -p1
 %patch113 -p1
 %patch114 -p1
@@ -266,16 +274,17 @@ install -d $RPM_BUILD_ROOT%{_infodir}
 %{__make} -j1 install install-info \
        DESTDIR=$RPM_BUILD_ROOT
 
-# gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
+cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
+
+# gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
 # window is created too.
 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
-cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
 
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
-rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
 
 %if %{with python}
 # Temporarily now:
This page took 0.030931 seconds and 4 git commands to generate.