]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- up to 20090311
[packages/gdb.git] / gdb.spec
index beb73ea27ad035c28855c53fc2bf6eca37ea5e04..13353d4ccbbd22d8ddcb7716efc8de1f6e88e41a 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -2,41 +2,41 @@
 # NOTE:        Do not remove -lib package, it is required by FPC
 #
 Summary:       A GNU source-level debugger for C, C++ and Fortran
-Summary(de.UTF-8):   Symbolischer Debugger für C und andere Sprachen
-Summary(es.UTF-8):   Depurador de programas C y otras lenguajes
-Summary(fr.UTF-8):   Débugger symbolique pour C et d'autres langages
-Summary(pl.UTF-8):   Symboliczny odpluskwiacz dla C i innych języków
-Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
-Summary(ru.UTF-8):   Символический отладчик для C и других языков
-Summary(tr.UTF-8):   C ve diğer diller için sembolik hata ayıklayıcı
-Summary(uk.UTF-8):   Символьний відладчик для С та інших мов
-Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
-Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
+Summary(de.UTF-8):     Symbolischer Debugger für C und andere Sprachen
+Summary(es.UTF-8):     Depurador de programas C y otras lenguajes
+Summary(fr.UTF-8):     Débugger symbolique pour C et d'autres langages
+Summary(pl.UTF-8):     Symboliczny odpluskwiacz dla C i innych języków
+Summary(pt_BR.UTF-8):  Depurador de programas C e outras linguagens
+Summary(ru.UTF-8):     Символический отладчик для C и других языков
+Summary(tr.UTF-8):     C ve diğer diller için sembolik hata ayıklayıcı
+Summary(uk.UTF-8):     Символьний відладчик для С та інших мов
+Summary(zh_CN.UTF-8):  [开发]C和其他语言的调试器
+Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
+%define        snap    20090311
 Name:          gdb
-Version:       6.6
-Release:       1
-License:       GPL
+Version:       6.8.50
+Release:       0.%{snap}.1
+License:       GPL v3+
 Group:         Development/Debuggers
-Source0:       ftp://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
-# Source0-md5: a4df41d28dd514d64e8ccbfe125fd9a6
+# Source0:     http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
+Source0:       ftp://sourceware.org/pub/gdb/snapshots/current/gdb-%{version}.%{snap}.tar.bz2
+# Source0-md5: 911b57b37260317251b55ab3393913a5
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
 Patch0:                %{name}-readline.patch
 Patch1:                %{name}-info.patch
 Patch2:                %{name}-passflags.patch
-# updated from http://www.math.uni.wroc.pl/~hebisch/gpc/gdb-6.1.diff
-Patch3:                %{name}-gpc.patch
-Patch4:                %{name}-gdbinit-stat.patch
 Patch5:                %{name}-pretty-print-by-default.patch
 Patch6:                %{name}-absolute-gnu_debuglink-path.patch
+URL:           http://www.gnu.org/software/gdb/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: flex
 BuildRequires: libtool
 BuildRequires: ncurses-devel >= 5.2
-BuildRequires: readline-devel >= 4.3
-BuildRequires: texinfo
+BuildRequires: readline-devel >= 6.0
+BuildRequires: texinfo >= 4.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -93,9 +93,9 @@ verir.
 
 %package lib
 Summary:       GDB in the form of a static library
-Summary(pl.UTF-8):   GDB w postaci biblioteki statycznej
+Summary(pl.UTF-8):     GDB w postaci biblioteki statycznej
 Group:         Development/Debuggers
-#Requires:     binutils-static >= 2.17.50
+#Requires:     binutils-devel >= 2.17.50
 
 %description lib
 GDB in the form of a static library.
@@ -104,12 +104,10 @@ GDB in the form of a static library.
 GDB w postaci biblioteki statycznej.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}.%{snap}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4 -p0
 %patch5 -p1
 %patch6 -p1
 
@@ -124,9 +122,8 @@ for dir in `find gdb/ -name 'configure.in'`; do
        cd $olddir
 done
 cp -f /usr/share/automake/config.* .
-# !! Don't enable shared here !!
-# This will cause serious problems --misiek
-%configure2_13 \
+# don't --enable-shared here, there would be libs version mismatch with binutils
+%configure \
        --disable-gdbtk \
        --disable-shared \
        --enable-gdbcli \
@@ -136,12 +133,12 @@ cp -f /usr/share/automake/config.* .
        --enable-nls \
        --enable-tui \
        --with-cpu=%{_target_cpu} \
-       --without-included-gettext \
-       --without-included-regex \
-       --without-x \
 %ifnarch alpha
-       --with-mmalloc
+       --with-mmalloc \
 %endif
+       --without-included-gettext \
+       --without-included-regex \
+       --without-x
 
 %{__make}
 %{__make} info
@@ -166,11 +163,11 @@ install gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post  -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%postun        -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
 %defattr(644,root,root,755)
This page took 0.16893 seconds and 4 git commands to generate.