]> git.pld-linux.org Git - packages/ekg2.git/blobdiff - ekg2.spec
- daily snapshots use bzip2 now.
[packages/ekg2.git] / ekg2.spec
index 1ecb12df7d09589623ec186c516a24e9dd3134b4..7da2cb258553d140a7c5c772f01743d12486aa13 100644 (file)
--- a/ekg2.spec
+++ b/ekg2.spec
@@ -3,6 +3,7 @@
 %bcond_with    yesterday_snapshot      # Build most current ekg2 snapshot
                                        # (must use ./builder -n5 or plain rpmbuild)
 %bcond_without aspell                  # build without spell-checking support with aspell
+%bcond_without feed                    # don't build feed plugin
 %bcond_without gadugadu                # don't build gg plugin
 %bcond_without gpg                     # don't build gpg plugin
 %bcond_without gtk                     # don't build gtk plugin
 %bcond_without perl                    # don't build Perl plugin
 %bcond_without python                  # don't build Python plugin
 %bcond_without readline                # don't build readline interface
-%bcond_without sqlite                  # don't build logsqlite plugin based on sqlite (conflicts with sqlite3)
-%bcond_with    sqlite3                 # build logsqlite plugin based on sqlite3
+%bcond_with    sqlite                  # build logsqlite plugin based on sqlite (conflicts with sqlite3)
+%bcond_without sqlite3                 # don't build logsqlite plugin based on sqlite3
 %bcond_without xosd                    # don't build xosd plugin
 
-%if %{with yesterday_snapshot}
-%define                _snap %(date +%%Y%%m%%d -d yesterday)
-%define                _ver 0.0.%{_snap}
-%else
+%if %{without yesterday_snapshot}
 %define                _snap 0.1.1
 %define                _ver 0.1.1
+%else
+%define                _snap %(date +%%Y%%m%%d -d yesterday)
+%define                _ver 0.0.%{_snap}
 %endif
 
 %if %{without jabber}
 %undefine with_gnutls
 %endif
 
-%if %{with sqlite3}
-%undefine sqlite
+%if %{with sqlite}
+%undefine sqlite3
 %endif
 
 Summary:       Multi-protocol instant messaging and chat client
 Summary(pl.UTF-8):     Wieloprotokołowy komunikator internetowy
 Name:          ekg2
 Version:       %{_ver}
-Release:       3
+Release:       3.2
 Epoch:         2
 License:       GPL v2+
 Group:         Applications/Communications
-Source0:       http://pl.ekg2.org/%{name}-%{_snap}.tar.gz
+Source0:       http://pl.ekg2.org/%{name}-%{_snap}.tar.bz2
 # Source0-md5: 8c64ab909687b9ac3798caa7736d7b2a
 Patch0:                %{name}-perl-install.patch
-#Patch1:               %{name}-no_scripts.patch
+#Patch1:       %{name}-no_scripts.patch
 URL:           http://ekg2.org/
 %{?with_aspell:BuildRequires:  aspell-devel}
 BuildRequires: autoconf
 BuildRequires: automake
-%{?with_jabber:BuildRequires:  expat-devel}
+%if %{with feed} || %{with jabber}
+BuildRequires: expat-devel
+%endif
 BuildRequires: gettext-devel
 %{?with_gadugadu:BuildRequires:        giflib-devel}
 %{?with_gnutls:BuildRequires:  gnutls-devel >= 1.2.5}
@@ -93,6 +96,18 @@ Header files for ekg2.
 %description devel -l pl.UTF-8
 Pliki nagłówkowe ekg2.
 
+%package plugin-feed
+Summary:       feed plugin for ekg2
+Summary(pl.UTF-8):     Wtyczka feed dla ekg2
+Group:         Applications/Communications
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description plugin-feed
+feed plugin for ekg2.
+
+%description plugin-feed -l pl.UTF-8
+Wtyczka feed dla ekg2.
+
 %package plugin-gpg
 Summary:       gpg plugin for ekg2
 Summary(pl.UTF-8):     Wtyczka gpg dla ekg2
@@ -130,6 +145,18 @@ Ioctld plugin for ekg2 (contains suid root binary!).
 %description plugin-ioctld -l pl.UTF-8
 Wtyczka ioctld dla ekg2 (zawiera program z ustawionym suid root!).
 
+%package plugin-jogger
+Summary:       Jogger plugin for ekg2
+Summary(pl.UTF-8):     Wtyczka jogger dla ekg2
+Group:         Applications/Communications
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description plugin-jogger
+Jogger plugin for ekg2.
+
+%description plugin-jogger -l pl.UTF-8
+Wtyczka jogger dla ekg2.
+
 %package plugin-logsqlite
 Summary:       SQLite log plugin for ekg2
 Summary(pl.UTF-8):     Wtyczka logowania do SQLite dla ekg2
@@ -195,6 +222,18 @@ Jabber protocol plugin for ekg2.
 %description plugin-protocol-jabber -l pl.UTF-8
 Wtyczka protokołu Jabber dla ekg2.
 
+%package plugin-protocol-polchat
+Summary:       Polchat protocol plugin for ekg2
+Summary(pl.UTF-8):     Wtyczka protokołu polchat dla ekg2
+Group:         Applications/Communications
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description plugin-protocol-polchat
+Polchat protocol plugin for ekg2.
+
+%description plugin-protocol-polchat -l pl.UTF-8
+Wtyczka protokołu polchat dla ekg2.
+
 %package plugin-readline
 Summary:       readline interface
 Summary(pl.UTF-8):     Interfejs readline
@@ -274,13 +313,20 @@ cd ..
 %{__autoconf}
 %{__autoheader}
 %{__automake}
+# for hostent.h_addr (should be in CPPFLAGS, but it's overridden in plugins/jabber)
+CFLAGS="%{rpmcflags} -D_GNU_SOURCE"
 %configure \
+       --enable-unicode \
        --with%{!?with_aspell:out}-aspell \
        --with%{!?with_gadugadu:out}-libgadu \
        %{!?with_gpg:--without-gpg} \
        --with%{!?with_gtk:out}-gtk \
        --with%{!?with_gnutls:out}-libgnutls \
-       --with%{!?with_jabber:out}-expat \
+%if %{with feed} || %{with jabber}
+               --with-expat \
+%else
+               --without-expat \
+%endif
        --with%{!?with_libgsm:out}-libgsm \
        %{!?with_perl:--without-perl} \
        --with%{!?with_python:out}-python \
@@ -337,10 +383,18 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/%{name}/scripts
 %{_datadir}/%{name}/themes
 
+%if %{without yesterday_snapshot}
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/ekg2-config
 %{_includedir}/ekg2
+%endif
+
+%if %{with yesterday_snapshot}
+%files plugin-feed
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/plugins/feed.so
+%endif
 
 %if %{with gpg}
 %files plugin-gpg
@@ -360,6 +414,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}/plugins/ioctld
 %attr(4755,root,root) %{_libexecdir}/ioctld
 
+%if %{with yesterday_snapshot}
+%files plugin-jogger
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/plugins/jogger.so
+%endif
+
 %if %{with sqlite} || %{with sqlite3}
 %files plugin-logsqlite
 %defattr(644,root,root,755)
@@ -390,6 +450,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}/plugins/jabber
 %endif
 
+%if %{with yesterday_snapshot}
+%files plugin-protocol-polchat
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/plugins/polchat.so
+%endif
+
 %if %{with readline}
 %files plugin-readline
 %defattr(644,root,root,755)
This page took 0.036592 seconds and 4 git commands to generate.