]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - drupal-mod.spec
better arch selection for ocaml_opt bcond
[projects/template-specs.git] / drupal-mod.spec
index debdfe2085f3acb85dda8a62762801fefd1bbd52..bf26bc13cd32629f616e81470023c2d74e7f3b81 100644 (file)
@@ -1,9 +1,9 @@
-%define                modname image
-Summary:       Drupal Image Module
+%define                modname ...
+Summary:       Drupal ... Module
 Name:          drupal-mod-%{modname}
 Version:       4.6.0
 Release:       0.1
-License:       GPL
+License:       GPL / GPL v2
 Group:         Applications/WWW
 Source0:       http://drupal.org/files/projects/%{modname}-%{version}.tar.gz
 # Source0-md5: 0d218124ee86584375d4981ee1646a06
@@ -21,16 +21,19 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _htdocs         %{_drupaldir}/htdocs
 %define                _podir          %{_drupaldir}/po/%{modname}
 %define                _htmlmoddir     %{_htdocs}/modules
+%define                _htmlmoddir     %{_htdocs}/modules/%{modname}
 
 %description
 
 %prep
 %setup -q -n %{modname}
-#rm -f LICENSE.txt # pure GPL
+#rm -f LICENSE.txt # GPL
+#rm -f LICENSE.txt # GPL v2
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_moddir},%{_podir},%{_htmlmoddir},%{_incdir},%{_htdocs}}
+install -d $RPM_BUILD_ROOT%{_moddir}
 
 install *.module $RPM_BUILD_ROOT%{_moddir}
 install *.inc $RPM_BUILD_ROOT%{_incdir}
@@ -49,9 +52,22 @@ from %{_podir} via drupal locatization admin.
 EOF
 fi
 
+#%post
+if [ "$1" = 1 ]; then
+%banner -e %{name} <<EOF
+To create ... MySQL database tables, import:
+zcat %{_docdir}/%{name}-%{version}/%{modname}.mysql.gz | mysql drupal
+For Postgresql file is:
+%{_docdir}/%{name}-%{version}/%{modname}.pgsql.gz
+EOF
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc *.txt po/*.pot *.php
+%doc *.txt
+%doc %{modname}.{mysql,pgsql}
+%doc %{modname}.mysql
 %{_moddir}/*.module
 %{_incdir}/*.inc
 %{_podir}
This page took 0.044004 seconds and 4 git commands to generate.