]> git.pld-linux.org Git - packages/domoticz.git/blobdiff - domoticz.spec
boost rebuild
[packages/domoticz.git] / domoticz.spec
index 7f0a9c446d24b1dd24d0648498fccbe232d81a9b..1de1f594679e3c9745fca14bdb8c80225c4d0b4c 100644 (file)
@@ -1,30 +1,30 @@
 Summary:       Open source Home Automation System
 Name:          domoticz
-Version:       2020.2
-Release:       3
+Version:       2021.1
+Release:       7
 License:       GPLv3+ and ASL 2.0 and Boost and BSD and MIT
 Group:         Base
 URL:           http://www.domoticz.com
-Source0:       https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
-# Source0-md5: fd383a13d13d0976c72f332d6db1d24e
+Source0:       https://github.com/domoticz/domoticz/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 28349806fc3ddb0514ea7d9255ceecd0
 Source1:       %{name}.service
 Source2:       %{name}.conf
 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
 Patch0:                %{name}-tinyxpath.patch
-# Use system openzwave includes
-Patch1:                %{name}-openzwave.patch
 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
-Patch2:                %{name}-python.patch
-Patch3:                no-git.patch
-Patch4:                boost-1.73.patch
+Patch1:                %{name}-python.patch
+Patch2:                no-git.patch
+Patch3:                %{name}-gpio.patch
+Patch4:                %{name}-no_updates.patch
 BuildRequires: boost-devel >= 1.66.0
 BuildRequires: cereal-devel
 BuildRequires: cmake >= 3.16.0
 BuildRequires: curl-devel
 BuildRequires: jsoncpp-devel
+BuildRequires: libfmt-devel
 BuildRequires: libmosquitto-devel
 BuildRequires: libopenzwave-devel >= 1.5.0
-BuildRequires: libstdc++-devel >= 6:4.8.1
+BuildRequires: libstdc++-devel >= 6:4.9
 BuildRequires: libusb-compat-devel
 BuildRequires: linux-libc-headers
 BuildRequires: lua53-devel
@@ -33,6 +33,7 @@ BuildRequires:        openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: python3 >= 1:3.4
 BuildRequires: python3-devel >= 1:3.4
+BuildRequires: rpmbuild(macros) >= 1.644
 BuildRequires: sqlite3-devel
 BuildRequires: tinyxml-devel
 BuildRequires: tinyxpath-devel
@@ -41,9 +42,13 @@ Requires(pre):       /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      fonts-TTF-Google-Droid
+Requires:      fonts-TTF-OpenSans
 Requires:      libopenzwave >= 1.5.0
+Requires:      setup >= 2.10.1
+Suggests:      python3-libs
 Provides:      group(domoticz)
 Provides:      user(domoticz)
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Domoticz is a Home Automation System that lets you monitor and
@@ -69,8 +74,10 @@ echo "#define APPDATE ${APPDATE}" >> appversion.h
 
 %build
 install -d build && cd build
+export CXXFLAGS="%{rpmcxxflags} -DPYTHON_LIBDIR=\\\"%{_libdir}\\\""
 %cmake \
        -DUSE_BUILTIN_JSONCPP=NO \
+       -DUSE_BUILTIN_LIBFMT=NO \
        -DUSE_BUILTIN_MINIZIP=NO \
        -DUSE_BUILTIN_MQTT=NO \
        -DUSE_BUILTIN_SQLITE=NO \
@@ -103,13 +110,19 @@ cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
 
 # Unbundle DroidSans.ttf
-%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/DroidSans.ttf
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/{Droid,Open}Sans.ttf
 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
        $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
+ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
+       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/OpenSans.ttf
 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
        $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
+ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
+       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/OpenSans.ttf
 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
        $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
+ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
+       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/OpenSans.ttf
 
 # OpenZWave Control Panel temp file
 ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
@@ -120,7 +133,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %pre
 %groupadd -g 342 domoticz
-%useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout -g domoticz domoticz
+%useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout,i2c -g domoticz domoticz
 
 %post
 %systemd_post %{name}.service
@@ -130,8 +143,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %postun
 if [ "$1" = "0" ]; then
-       %userremove mpd
-       %groupremove mpd
+       %userremove domoticz
+       %groupremove domoticz
 fi
 %systemd_reload
 
This page took 0.106074 seconds and 4 git commands to generate.