]> git.pld-linux.org Git - packages/dahdi-linux.git/blobdiff - dahdi-linux.spec
- rebuild for kernel-3.10.13-1
[packages/dahdi-linux.git] / dahdi-linux.spec
index 75c9e465178528c85011b700321dc16eee115c93..882ecc9d9f731838608bc3ea2ed57a8db2b241a5 100644 (file)
 %undefine      with_dist_kernel
 %endif
 
-%define                rel     28
+%define                rel     8
 %define                pname   dahdi-linux
 %define                FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
 Summary:       DAHDI telephony device support
 Summary(pl.UTF-8):     Obsługa urządzeń telefonicznych DAHDI
 Name:          %{pname}%{_alt_kernel}
-Version:       2.6.0
+Version:       2.7.0.1
 Release:       %{rel}
-License:       GPL
+License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/dahdi-linux-%{version}.tar.gz
-# Source0-md5: ea35ad29dafe5490028ff642c35ef9a2
+# Source0-md5: bd91e46c60b6cdcdee95d7b0fec45e32
 Source3:       %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
 # Source3-md5: 88db9b7a07d8392736171b1b3e6bcc66
 Source4:       %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
@@ -54,10 +54,6 @@ Source6:     %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
 # Source6-md5: 2ea860bb8a9d8ede2858b9557b74ee3c
 Source7:       %{FIRMWARE_URL}/dahdi-fw-hx8-2.06.tar.gz
 # Source7-md5: a7f3886942bb3e9fed349a41b3390c9f
-Patch0:                %{pname}-build.patch
-# http://oss.axsentis.de/people/stkn/openzap/dahdi-2.4.0-linux-2.6.37.patch
-Patch1:                dahdi-2.4.0-linux-2.6.37.patch
-Patch2:                dahdi-linux-kernel-3.4.patch
 URL:           http://www.asterisk.org/
 %if %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build
@@ -91,15 +87,15 @@ Sterownik do urządzeń telefonicznych DAHDI.
 
 %package devel
 Summary:       Header files for dahdi interface
+Summary(pl.UTF-8):     Pliki nagłówkowe interfejsu dahdi
 Group:         Development/Libraries
-# if base package contains shared library for which these headers are
-#Requires:     %{name} = %{version}-%{release}
-# if -libs package contains shared library for which these headers are
-#Requires:     %{name}-libs = %{version}-%{release}
 
 %description devel
 Header files for dahdi interface.
 
+%description devel -l pl.UTF-8
+Pliki nagłówkowe interfejsu dahdi.
+
 %package udev
 Summary:       udev rules for DAHDI kernel modules
 Summary(pl.UTF-8):     Reguły udev dla modułów jądra Linuksa dla DAHDI
@@ -134,9 +130,6 @@ Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.
 
 %prep
 %setup -q -n %{pname}-%{version}
-%patch0 -p1
-#%patch1 -p1
-%patch2 -p1
 
 for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7}; do
        ln -s $a drivers/dahdi/firmware
@@ -154,24 +147,10 @@ chmod a+rx download-logger
 %{__make} include/dahdi/version.h
 
 %if %{with kernel}
-%build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include
-
-# check that all built .ko is handled by build_kernel_modules
-# (renamed to either -dist, -up, or -smp suffix)
-# if some missing, check the 'modules*' macros above
-check_modules() {
-       err=0
-       for a in drivers/dahdi/{*/,}*.ko; do
-               [[ $a = *-dist.ko ]] && continue
-               [[ $a = *-up.ko ]] && continue
-               [[ $a = *-smp.ko ]] && continue
-               echo >&2 "unpackaged module: ${a%.ko}"
-               err=1
-       done
-
-       [ $err = 0 ] || exit 1
-}
-#check_modules
+# hack: build library first (using explicit "lib" target), then modules without cleaning (-c)
+%build_kernel_modules lib SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi/oct612x DAHDI_INCLUDE=$PWD/../../include
+
+%build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include -c
 %endif
 
 %install
@@ -186,10 +165,8 @@ cd ../..
 %if %{with userspace}
 install -d $RPM_BUILD_ROOT/etc/udev/rules.d
 
-%{make} \
-       DESTDIR=$RPM_BUILD_ROOT \
-       install-devices \
-       install-include
+%{__make} install-devices install-include \
+       DESTDIR=$RPM_BUILD_ROOT
 %endif
 
 %clean
@@ -215,5 +192,21 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with kernel}
 %files -n kernel%{_alt_kernel}-%{pname}
 %defattr(644,root,root,755)
-/lib/modules/%{_kernel_ver}/misc/*.ko*
+/lib/modules/%{_kernel_ver}/misc/dahdi*.ko*
+/lib/modules/%{_kernel_ver}/misc/pciradio.ko*
+/lib/modules/%{_kernel_ver}/misc/tor2.ko*
+/lib/modules/%{_kernel_ver}/misc/wcb4xxp.ko*
+/lib/modules/%{_kernel_ver}/misc/wcfxo.ko*
+/lib/modules/%{_kernel_ver}/misc/wct1xxp.ko*
+/lib/modules/%{_kernel_ver}/misc/wct4xxp.ko*
+/lib/modules/%{_kernel_ver}/misc/wctc4xxp.ko*
+/lib/modules/%{_kernel_ver}/misc/wctdm.ko*
+/lib/modules/%{_kernel_ver}/misc/wctdm24xxp.ko*
+/lib/modules/%{_kernel_ver}/misc/wcte11xp.ko*
+/lib/modules/%{_kernel_ver}/misc/wcte12xp.ko*
+%if %{with xpp}
+/lib/modules/%{_kernel_ver}/misc/xpd_*.ko*
+/lib/modules/%{_kernel_ver}/misc/xpp.ko*
+/lib/modules/%{_kernel_ver}/misc/xpp_usb.ko*
+%endif
 %endif
This page took 0.040496 seconds and 4 git commands to generate.