]> git.pld-linux.org Git - packages/clamav.git/blobdiff - clamav.spec
systemd-cronjobs support added
[packages/clamav.git] / clamav.spec
index 4413ef03d58ee952abcd44800a8711f124f28346..23ed6786375c539ab2a0e3a56a7c37e196d4a67f 100644 (file)
 %undefine with_llvm
 %endif
 
+%bcond_with    system_llvm
+
 Summary:       An anti-virus utility for Unix
 Summary(pl.UTF-8):     Narzędzie antywirusowe dla Uniksów
 Name:          clamav
-Version:       0.98.7
+Version:       0.99.2
 Release:       2
 License:       GPL v2+
 Group:         Daemons
-Source0:       http://downloads.sourceforge.net/clamav/%{name}-%{version}.tar.gz
-# Source0-md5: 157c601161da1c2d5a0e48ea1b49e067
+Source0:       http://www.clamav.net/downloads/production/%{name}-%{version}.tar.gz
+# Source0-md5: 61b51a04619aeafd965892a53f86d192
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}-milter.init
@@ -32,6 +34,8 @@ Source8:      %{name}-post-updatedb
 Source9:       %{name}-milter.sysconfig
 Source10:      %{name}.tmpfiles
 Source11:      clamd.service
+Source12:      cronjob-clamav.timer
+Source13:      cronjob-clamav.service.in
 Patch0:                %{name}-pld_config.patch
 Patch1:                %{name}-nolibs.patch
 %if "%{pld_release}" == "ac"
@@ -45,16 +49,18 @@ URL:                http://www.clamav.net/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
+BuildRequires: check-devel
 BuildRequires: curl-devel
 BuildRequires: gmp-devel
 BuildRequires: libltdl-devel
 %{?with_milter:BuildRequires:  libmilter-devel}
-BuildRequires: libstdc++-devel
+BuildRequires: libstdc++-devel >= 5:3.4
 BuildRequires: libtool
 %{?with_milter:BuildRequires:  libwrap-devel}
-%{?with_llvm:BuildRequires:    llvm-devel}
+%{?with_llvm:%{?with_system_llvm:BuildRequires:        llvm-devel < 3.7}}
 BuildRequires: ncurses-devel
 BuildRequires: openssl-devel
+BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.647
 BuildRequires: zlib-devel
@@ -194,7 +200,7 @@ Biblioteki statyczne clamav.
        --disable-silent-rules \
        --disable-clamav \
        --enable-clamdtop \
-       %{?with_llvm:--enable-llvm --with-system-llvm} \
+       %{?with_llvm:--enable-llvm %{?with_system_llvm:--with-system-llvm}} \
        %{?with_milter:--enable-milter} \
        --with-dbdir=/var/lib/%{name} \
        --with-no-cache \
@@ -237,6 +243,8 @@ install -p %{SOURCE8} $RPM_BUILD_ROOT%{_sbindir}
 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
+cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/cronjob-%{name}.timer
+sed -e's#@sbindir@#%{_sbindir}#' <  %{SOURCE13} > $RPM_BUILD_ROOT%{systemdunitdir}/cronjob-%{name}.service
 
 # NOTE: clamd uses sane rights to it's clamd.pid file
 # So better keep it dir
@@ -267,14 +275,14 @@ rm -rf $RPM_BUILD_ROOT
 touch /var/log/freshclam.log
 chown clamav:root /var/log/freshclam.log
 chmod 640 /var/log/freshclam.log
-%systemd_post clamd.service
+%systemd_post clamd.service cronjob-clamav.timer
 
 %preun
 if [ "$1" = "0" ]; then
        %service clamd stop
        /sbin/chkconfig --del clamd
 fi
-%systemd_preun clamd.service
+%systemd_preun clamd.service cronjob-clamav.timer
 
 %postun
 if [ "$1" = "0" ]; then
@@ -317,6 +325,9 @@ touch /var/lock/subsys/clamd
 %triggerpostun -- %{name} < 0.97.7-4
 %systemd_trigger clamd.service
 
+%triggerpostun -- %{name} < 0.99.2-2
+%systemd_service_enable cronjob-clamav.timer
+
 %post milter
 /sbin/chkconfig --add clamav-milter
 %service clamav-milter restart "Clam Antivirus daemon"
@@ -346,6 +357,8 @@ fi
 %attr(755,root,root) %{_sbindir}/clamav-post-updatedb
 %{systemdtmpfilesdir}/%{name}.conf
 %{systemdunitdir}/clamd.service
+%{systemdunitdir}/cronjob-clamav.service
+%{systemdunitdir}/cronjob-clamav.timer
 %attr(755,clamav,root) %dir /var/lib/%{name}
 %attr(640,clamav,root) %ghost /var/log/freshclam.log
 %attr(750,clamav,clamav) %dir /var/run/%{name}
@@ -357,7 +370,9 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/clamd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clamd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/clamav
-%{_mandir}/man[15]/*
+%{_mandir}/man1/*
+%{_mandir}/man5/clamd*
+%{_mandir}/man5/freshclam*
 %{_mandir}/man8/clamd*
 
 %if %{with milter}
@@ -370,6 +385,7 @@ fi
 #%attr(755,root,root) %{_sysconfdir}/log.d/scripts/services/clamav-milter
 #%{_sysconfdir}/log.d/conf/services/clamav-milter.conf
 %attr(755,root,root) %{_sbindir}/clamav-milter
+%{_mandir}/man5/clamav-milter*
 %{_mandir}/man8/clamav-milter.8*
 %attr(700,clamav,clamav) /var/spool/clamav
 %endif
@@ -377,11 +393,11 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libclamav.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libclamav.so.6
+%attr(755,root,root) %ghost %{_libdir}/libclamav.so.7
 %attr(755,root,root) %{_libdir}/libclamunrar.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libclamunrar.so.6
+%attr(755,root,root) %ghost %{_libdir}/libclamunrar.so.7
 %attr(755,root,root) %{_libdir}/libclamunrar_iface.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libclamunrar_iface.so.6
+%attr(755,root,root) %ghost %{_libdir}/libclamunrar_iface.so.7
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.054681 seconds and 4 git commands to generate.