]> git.pld-linux.org Git - packages/cairo.git/blobdiff - cairo.spec
- updated to 1.14.12 (bugfix release)
[packages/cairo.git] / cairo.spec
index 3b0922faa84bd6efc746500a37fb2777fd904f90..474d5fa7c77ce3de23e5d538316dbe9840a3270d 100644 (file)
@@ -4,7 +4,7 @@
 %bcond_with    cogl            # Cogl surface backend [incompatible with cogl 1.12.x]
 %bcond_with    directfb        # DirectFB surface backend
 %bcond_with    drm             # DRM surface backend
-%bcond_without gl              # OpenGL surface backend
+%bcond_with    gl              # OpenGL surface backend, http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2015-May/024387.html
 %bcond_with    glesv2          # OpenGLESv2 surface backend (mutually exclusive with gl)
 %bcond_with    openvg          # OpenVG surface backend
 %bcond_without pdf             # PDF surface backend
 %bcond_without xcb             # XCB backend
 %endif
 %bcond_with    tests           # perform tests (can fail due to out of memory)
-#
+
 %if %{with glesv2}
 %undefine      with_gl
 %endif
 Summary:       Cairo - multi-platform 2D graphics library
 Summary(pl.UTF-8):     Cairo - wieloplatformowa biblioteka graficzna 2D
 Name:          cairo
-Version:       1.12.16
+Version:       1.14.12
 Release:       1
 License:       LGPL v2.1 or MPL v1.1
 Group:         Libraries
-Source0:       http://cairographics.org/releases/%{name}-%{version}.tar.xz
-# Source0-md5: a1304edcdc99282f478b995ee5f8f854
+Source0:       https://www.cairographics.org/releases/%{name}-%{version}.tar.xz
+# Source0-md5: 9f0db9dbfca0966be8acd682e636d165
 Patch0:                %{name}-link.patch
-URL:           http://cairographics.org/
+Patch1:                %{name}-gobject-deps.patch
+URL:           https://www.cairographics.org/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
 %if %{with gl} || %{with glesv2} || %{with openvg}
 BuildRequires: EGL-devel >= 1.1
@@ -49,20 +50,21 @@ BuildRequires:      binutils-devel
 %{?with_cogl:BuildRequires:    cogl-devel}
 BuildRequires: fontconfig-devel >= 2.2.95
 BuildRequires: freetype-devel >= 1:2.3.0
-BuildRequires: glib2-devel >= 1:2.0
+BuildRequires: glib2-devel >= 1:2.14
 %{?with_apidocs:BuildRequires: gtk-doc >= 1.15}
 %{?with_drm:BuildRequires:     libdrm-devel}
 BuildRequires: libpng-devel >= 2:1.4.0
 %if %{with svg} && %{with tests}
-BuildRequires: librsvg-devel >= 2.15.0
+BuildRequires: librsvg-devel >= 2.35.0
 %endif
 %if %{with ps} && %{with tests}
 BuildRequires: libspectre-devel >= 0.2.0
 %endif
 BuildRequires: libtool >= 2:2.2
 %{?with_xcb:BuildRequires:     libxcb-devel >= 1.6}
-BuildRequires: pixman-devel >= 0.22.0
-BuildRequires: pkgconfig >= 1:0.9
+BuildRequires: lzo-devel >= 2
+BuildRequires: pixman-devel >= 0.30.0
+BuildRequires: pkgconfig >= 1:0.18
 %if %{with pdf} && %{with tests}
 BuildRequires: poppler-glib-devel >= 0.17.4
 %endif
@@ -83,7 +85,7 @@ BuildRequires:        zlib-devel
 Requires:      fontconfig-libs >= 2.2.95
 Requires:      freetype >= 1:2.3.0
 %{?with_xcb:Requires:  libxcb >= 1.6}
-Requires:      pixman >= 0.22.0
+Requires:      pixman >= 0.30.0
 %{?with_drm:Requires:  udev-libs >= 1:136}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -134,7 +136,8 @@ Requires:   freetype-devel >= 1:2.3.0
 %{?with_drm:Requires:  libdrm-devel}
 Requires:      libpng-devel >= 2:1.4.0
 %{?with_xcb:Requires:  libxcb-devel >= 1.6}
-Requires:      pixman-devel >= 0.22.0
+Requires:      lzo-devel >= 2
+Requires:      pixman-devel >= 0.30.0
 %{?with_drm:Requires:  udev-devel >= 1:136}
 %if "%{pld_release}" == "ac"
 Requires:      xrender-devel >= 0.6
@@ -168,6 +171,7 @@ Summary:    GObject functions library for Cairo graphics library
 Summary(pl.UTF-8):     Biblioteka funkcji GObject dla biblioteki graficznej Cairo
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      glib2 >= 1:2.14
 
 %description gobject
 GObject functions library for Cairo graphics library.
@@ -181,7 +185,7 @@ Summary(pl.UTF-8):  Pliki nagłówkowe biblioteki Cairo GObject
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      %{name}-gobject = %{version}-%{release}
-Requires:      glib2-devel >= 1:2.0
+Requires:      glib2-devel >= 1:2.14
 
 %description gobject-devel
 Header files for Cairo GObject library.
@@ -219,6 +223,9 @@ Summary:    Cairo API documentation
 Summary(pl.UTF-8):     Dokumentacja API Cairo
 Group:         Documentation
 Requires:      gtk-doc-common
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description apidocs
 Cairo API documentation.
@@ -229,6 +236,7 @@ Dokumentacja API Cairo.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{?with_apidocs:%{__gtkdocize}}
@@ -239,25 +247,23 @@ Dokumentacja API Cairo.
 %{__automake}
 %configure \
        --disable-silent-rules \
-       %{?with_cogl:--enable-cogl} \
-       %{?with_directfb:--enable-directfb} \
+       %{__enable_disable cogl} \
+       %{__enable_disable directfb} \
+       %{__enable_disable gl} \
+       %{__enable_disable glesv2} \
+       %{__enable_disable apidocs gtk-doc} \
+       %{__enable_disable pdf} \
+       %{__enable_disable ps} \
+       %{__enable_disable qt} \
+       %{__enable_disable svg} \
+       %{__enable_disable openvg vg} \
+       %{__enable_disable xcb} \
        --enable-ft \
-       %{?with_gl:--enable-gl} \
-       %{?with_glesv2:--enable-glesv2} \
-       %{?with_apidocs:--enable-gtk-doc} \
-       %{?with_pdf:--enable-pdf} \
        --enable-png \
-       %{?with_ps:--enable-ps} \
-       %{?with_qt:--enable-qt} \
-       %{!?with_svg:--disable-svg} \
        --enable-tee \
-       %{?with_openvg:--enable-vg} \
-       %{?with_xcb:--enable-xcb} \
        --enable-xml \
        --with-html-dir=%{_gtkdocdir}
 
-%{__sed} -i 's/gobject-2.0 glib-2.0//' src/cairo.pc
-
 %{__make}
 %{?with_tests:%{__make} check}
 
This page took 0.040137 seconds and 4 git commands to generate.