]> git.pld-linux.org Git - packages/cacti-plugin-weathermap.git/blobdiff - cacti-plugin-weathermap.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/cacti-plugin-weathermap.git] / cacti-plugin-weathermap.spec
index 4a966e7ae6aca97be89017009cf7aee68e10f6f5..9c80ee93bda7e0fb9ea580a16958134512b5ecd0 100644 (file)
@@ -1,23 +1,40 @@
 # TODO
 #  - config file, patches, package for not cacti plugin
-%define                namesrc weathermap
-%include       /usr/lib/rpm/macros.perl
+#  - system vera ttf fonts, jquery
+%define                plugin  weathermap
+%define                php_min_version 5.2.0
 Summary:       Plugin for Cacti - WeatherMap
 Summary(pl.UTF-8):     Wtyczka do Cacti - WeatherMap (mapa pogody)
 Name:          cacti-plugin-weathermap
-Version:       0.941
+Version:       0.97a
 Release:       0.1
 License:       GPL v2
 Group:         Applications/WWW
-Source0:       http://www.network-weathermap.com/files/php-%{namesrc}-%{version}.zip
-# Source0-md5: 8214a2a323db250ac3b783fc5674b163
-URL:           http://www.network-weathermap.com
+Source0:       http://www.network-weathermap.com/files/php-%{plugin}-%{version}.zip
+# Source0-md5: 7eb70243fef163721423b3e87d7e84b4
+URL:           http://www.network-weathermap.com/
 BuildRequires: rpm-perlprov
+BuildRequires: rpm-php-pearprov >= 4.4.2-11
+BuildRequires: rpmbuild(macros) >= 1.554
+BuildRequires: sed >= 4.0
+BuildRequires: unzip
 Requires:      cacti
+Requires:      php(core) >= %{php_min_version}
+Requires:      php(date)
+Requires:      php(gd)
+Requires:      php(mysql)
+Requires:      php(pcre)
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                webcactipluginroot /usr/share/cacti/plugins/%{namesrc}
+%define                cactidir                /usr/share/cacti
+%define                plugindir               %{cactidir}/plugins/%{plugin}
+
+# provided by package itself
+%define                _noautopear     pear(HTML_ImageMap.class.php) pear(Weathermap.class.php) pear(editor-config.php) pear(editor.inc.php)
+
+# put it together for rpmbuild
+%define                _noautoreq      %{?_noautophp} %{?_noautopear}
 
 %description
 Weathermap plugin for Cacti is a network visualisation tool, to take
@@ -37,15 +54,29 @@ oraz tekstowych rozdzielonych tabulacjami. Inne źródła są dostępne
 przez wtyczki lub zewnętrzne skrypty.
 
 %prep
-%setup -q -n %{namesrc}
+%setup -qc
+
+%undos -f php,inc
+
+# fix php path
+%{__sed} -i -e '1s,#!.*bin/php,#!%{_bindir}/php,' %{plugin}/%{plugin}
+
+mv %{plugin}/editor-config.php{-dist,}
+
+# in docs
+mv %{plugin}/{CHANGES,COPYING,README} .
+mv %{plugin}/docs .
 
-# undos the source
-find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
+# junk not neccessary for plugin run
+mv %{plugin}/random-bits .
+mv %{plugin}/net-data.txt .
+mv %{plugin}/convert-to-dsstats.php .
+rm -rf %{plugin}/output
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{webcactipluginroot}
-cp -a * $RPM_BUILD_ROOT%{webcactipluginroot}
+install -d $RPM_BUILD_ROOT%{plugindir}/output
+cp -a %{plugin}/* $RPM_BUILD_ROOT%{plugindir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -53,4 +84,4 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README CHANGES
-%{webcactipluginroot}
+%{plugindir}
This page took 0.05233 seconds and 4 git commands to generate.