]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - browser-plugin.spec
examples
[projects/template-specs.git] / browser-plugin.spec
index 729542292a926309830b1bc74d10df69d01a4f64..329cfe9a32a133a2394bb05fde0993d52018be06 100644 (file)
@@ -1,75 +1,46 @@
-#
-# NOTE: using symlinks will not have rpm file conflicts verification,
-# but that's okay since most of the plugins are cross browser, so you
-# won't be having any regular files in browser specific plugin dir.
-#
 Summary:       NAME Browser plugin
-Summary(pl):   NAME Browser plugin
+Summary(pl.UTF-8):     Wtyczka NAME dla przeglÄ…darek WWW
 Name:          template-browser-plugin
-Version:       0.1
-Release:       0.1
+Version:       2.0
+Release:       1
 License:       GPL
 Group:         X11/Applications/Multimedia
-BuildRequires: rpmbuild(macros) >= 1.236
-Requires:      browser-plugins(%{_target_cpu})
+BuildRequires: rpmbuild(macros) >= 1.357
+Requires:      browser-plugins >= 2.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# directory where you store the plugin
-%define                _plugindir      %{_libdir}/browser-plugins
-
 %description
-This spec is for demonstrating triggers used for linking package
-plugins to all browsers plugins dir capable for NSAPI plugins
+NAME browser plugin.
 
-See also browser-plugins.spec
+%description -l pl.UTF-8
+Wtyczka NAME dla przeglÄ…darek WWW.
 
 %prep
 %setup -q -c -T
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_plugindir}
+install -d $RPM_BUILD_ROOT%{_browserpluginsdir}
 
-cat >> $RPM_BUILD_ROOT%{_plugindir}/%{name}.so <<EOF
+cat >> $RPM_BUILD_ROOT%{_browserpluginsdir}/%{name}.so <<EOF
 # dummy plugin
 EOF
-cat >> $RPM_BUILD_ROOT%{_plugindir}/%{name}.xpi <<EOF
+cat >> $RPM_BUILD_ROOT%{_browserpluginsdir}/%{name}.xpi <<EOF
 # Second plugin file.
 EOF
 
-%triggerin -- mozilla-firefox
-%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins %{name}.so %{name}.xpi
-
-%triggerun -- mozilla-firefox
-%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins %{name}.so %{name}.xpi
-
-%triggerin -- mozilla
-%nsplugin_install -d %{_libdir}/mozilla/plugins %{name}.so %{name}.xpi
-
-%triggerun -- mozilla
-%nsplugin_uninstall -d %{_libdir}/mozilla/plugins %{name}.so %{name}.xpi
-
-%triggerin -- opera
-%nsplugin_install -d %{_libdir}/opera/plugins %{name}.so %{name}.xpi
-
-%triggerun -- opera
-%nsplugin_uninstall -d %{_libdir}/opera/plugins %{name}.so %{name}.xpi
-
-%triggerin -- konqueror
-%nsplugin_install -d %{_libdir}/kde3/plugins/konqueror %{name}.so %{name}.xpi
-
-%triggerun -- konqueror
-%nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror %{name}.so %{name}.xpi
-
-# as rpm removes the old obsoleted package files after the triggers
-# are ran, add another trigger to make the links there.
-%triggerpostun -- mozilla-firefox-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+%update_browser_plugins
+
+%postun
+if [ "$1" = 0 ]; then
+       %update_browser_plugins
+fi
+
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_plugindir}/*.so
-%{_plugindir}/*.xpi
+%attr(755,root,root) %{_browserpluginsdir}/*.so
+%{_browserpluginsdir}/*.xpi
This page took 0.071059 seconds and 4 git commands to generate.