]> git.pld-linux.org Git - packages/boost.git/blobdiff - boost.spec
- release 5 (by relup.sh)
[packages/boost.git] / boost.spec
index 11b90594885a96c67ed705dedb0d9b957057a6f5..866eed418436fe88fd16f28f5d3d44ec4998a2e7 100644 (file)
@@ -13,7 +13,7 @@ Summary:      The Boost C++ Libraries
 Summary(pl.UTF-8):     Biblioteki C++ "Boost"
 Name:          boost
 Version:       1.63.0
-Release:       1
+Release:       5
 License:       Boost Software License and others
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
@@ -22,6 +22,7 @@ Patch0:               %{name}-link.patch
 Patch1:                %{name}-x32-context.patch
 Patch2:                %{name}-clean-gcc-flags.patch
 Patch3:                %{name}-numpy3.patch
+Patch4:                hash-new-char-types.patch
 # FC Patches:
 Patch201:      %{name}-python-abi_letters.patch
 # https://github.com/boostorg/build/issues/163
@@ -34,7 +35,7 @@ URL:          http://www.boost.org/
 BuildRequires: bzip2-devel
 BuildRequires: expat-devel
 BuildRequires: libicu-devel
-BuildRequires: libstdc++-devel
+BuildRequires: libstdc++-devel >= 6:4.7
 BuildRequires: perl-base
 %if %{with python}
 BuildRequires: python-devel >= 2.2
@@ -45,15 +46,12 @@ BuildRequires:      python3-devel
 %{?with_numpy:BuildRequires:   python3-numpy-devel}
 %endif
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.734
 BuildRequires: zlib-devel
-BuildConflicts:        gcc = 5:3.3.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
 
-# __once_call, __once_callable non-function symbols from libstdc++
-%define                skip_post_check_so      libboost_context.so.*
-
 %description
 The Boost web site provides free peer-reviewed portable C++ source
 libraries. The emphasis is on libraries which work well with the C++
@@ -80,6 +78,7 @@ Requires:     %{name} = %{version}-%{release}
 Requires:      %{name}-chrono = %{version}-%{release}
 Requires:      %{name}-context = %{version}-%{release}
 Requires:      %{name}-date_time = %{version}-%{release}
+Requires:      %{name}-fiber = %{version}-%{release}
 Requires:      %{name}-filesystem = %{version}-%{release}
 Requires:      %{name}-graph = %{version}-%{release}
 Requires:      %{name}-locale = %{version}-%{release}
@@ -92,7 +91,7 @@ Requires:     %{name}-test = %{version}-%{release}
 Requires:      %{name}-thread = %{version}-%{release}
 Requires:      %{name}-timer = %{version}-%{release}
 Requires:      %{name}-wave = %{version}-%{release}
-Requires:      libstdc++-devel
+Requires:      libstdc++-devel >= 6:4.7
 Obsoletes:     boost-any-devel
 Obsoletes:     boost-array-devel
 Obsoletes:     boost-asio
@@ -295,6 +294,21 @@ A set of date-time libraries.
 %description date_time -l pl.UTF-8
 Zbiór bibliotek daty-czasu.
 
+%package fiber
+Summary:       A framework for micro-/userland-threads (fibers) scheduled cooperatively
+Summary(pl.UTF-8):     Szkielet mikrowątków przestrzeni użytkownika (fibers), szeregowanych kooperacyjnie
+Group:         Libraries
+
+%description fiber
+boost::fiber provides a framework for micro-/userland-threads (fibers)
+scheduled cooperatively. The API contains classes and functions
+to manage and synchronize fibers similiar to boost.thread.
+
+%description fiber -l pl.UTF-8
+boost::fiber to szkielt mikrowątków przestrzeni użytkownika (fibers)
+szeregowanych kooperacyjnie. API zawiera klasy i funkcje służące do
+zarządzania i synchronizacji wątków podobne do boost.thread.
+
 %package filesystem
 Summary:       Portable paths, iteration over directories, and other useful filesystem operations
 Summary(pl.UTF-8):     Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
@@ -471,6 +485,7 @@ Dokumentacja dla biblioteki Boost C++.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %patch201 -p1
 %patch202 -p1
@@ -478,7 +493,7 @@ Dokumentacja dla biblioteki Boost C++.
 %patch221 -p1
 
 cat << EOF > tools/build/src/user-config.jam
-using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -fPIC" <linkflags>"%{rpmldflags}" ;
+using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -std=c++11 -fPIC" <linkflags>"%{rpmldflags}" ;
 EOF
 
 # cleanup backups after patching
@@ -597,6 +612,9 @@ rm -rf $RPM_BUILD_ROOT
 %post  date_time -p /sbin/ldconfig
 %postun        date_time -p /sbin/ldconfig
 
+%post  fiber -p /sbin/ldconfig
+%postun        fiber -p /sbin/ldconfig
+
 %post  filesystem -p /sbin/ldconfig
 %postun        filesystem -p /sbin/ldconfig
 
@@ -656,6 +674,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libboost_context.so
 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
 %attr(755,root,root) %{_libdir}/libboost_date_time.so
+%attr(755,root,root) %{_libdir}/libboost_fiber.so
 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
 %attr(755,root,root) %{_libdir}/libboost_graph.so
 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
@@ -689,6 +708,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libboost_coroutine.a
 %{_libdir}/libboost_date_time.a
 %{_libdir}/libboost_exception.a
+%{_libdir}/libboost_fiber.a
 %{_libdir}/libboost_filesystem.a
 %{_libdir}/libboost_graph.a
 %{_libdir}/libboost_iostreams.a
@@ -776,6 +796,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
 
+%files fiber
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libboost_fiber.so.*.*.*
+
 %files filesystem
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
This page took 0.060285 seconds and 4 git commands to generate.