]> git.pld-linux.org Git - packages/beecrypt.git/blobdiff - beecrypt.spec
- strict deps.
[packages/beecrypt.git] / beecrypt.spec
index 1f9951b05b9f044e0aeb0ef2d2fcb627c5859087..c025ac454622d319969e8089a91d2683c81115a6 100644 (file)
@@ -1,26 +1,30 @@
 #
 # Conditional build:
-# _with_javaglue
+%bcond_with    javaglue        # build with Java support
+%bcond_without python          # don't build python module
 #
 %include       /usr/lib/rpm/macros.python
 Summary:       The BeeCrypt Cryptography Library
 Summary(pl):   Biblioteka kryptograficzna BeeCrypt
 Name:          beecrypt
-Version:       3.0.0
-Release:       1
+Version:       3.1.0
+Release:       3
 Epoch:         2
 License:       LGPL
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/beecrypt/%{name}-%{version}.tar.gz
-# Source0-md5: 18f20c22443f85bd4e285925b56198d9
+# Source0-md5: 1472cada46e2ab9f532f984de9740386
 Patch0:                %{name}-opt.patch
 Patch1:                %{name}-python.patch
+Patch2:                %{name}-lib64_fix.patch
 URL:           http://sourceforge.net/projects/beecrypt/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: libtool
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define        specflags_alpha         "-mno-explicit-relocs"
+
 %description
 BeeCrypt is an open source cryptography library that contains highly
 optimized C and assembler implementations of many well-known
@@ -36,7 +40,7 @@ szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
 Summary:       The BeeCrypt Cryptography Library - development files
 Summary(pl):   Pliki dla programistów u¿ywaj±cych biblioteki BeeCrypt
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description devel
 The BeeCrypt Cryptography Library - development files.
@@ -48,7 +52,7 @@ Biblioteka kryptograficzna BeeCrypt - pliki dla programist
 Summary:       The BeeCrypt Cryptography Library - static library
 Summary(pl):   Biblioteka statyczna BeeCrypt
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 The BeeCrypt Cryptography Library - static library.
@@ -60,7 +64,7 @@ Biblioteka statyczna BeeCrypt.
 Summary:       Python interface to BeeCrypt library
 Summary(pl):   Pythonowy interfejs do biblioteki BeeCrypt
 Group:         Development/Languages/Python
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 %pyrequires_eq python
 
 %description -n python-beecrypt
@@ -76,6 +80,7 @@ Pythonie na u
 %setup  -q
 %patch0 -p1
 %patch1 -p1
+%patch2
 
 %build
 rm -f missing
@@ -85,21 +90,34 @@ rm -f missing
 %{__autoheader}
 %{__automake}
 %configure \
-       --with%{?!_with_javaglue:out}-javaglue \
+       --with%{!?with_javaglue:out}-javaglue \
        --with-cpu=%{_target_cpu} \
-       --with-arch=%{_target_cpu}
-%{__make}
-
-%{__make} -C python
+       --with-arch=%{_target_cpu} \
+       --with-pic \
+       --with%{!?with_python:out}-python
+%{__make} \
+       libaltdir=%{_libdir} \
+       pylibdir=%{py_libdir}
+
+%if %{with python}
+%{__make} -C python \
+       pylibdir=%{py_libdir}
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}
 
 %{__make} install \
+       libaltdir=%{_libdir} \
        DESTDIR=$RPM_BUILD_ROOT
 
+%if %{with python}
 %{__make} install -C python \
+       libaltdir=%{_libdir} \
+       pylibdir=%{py_libdir} \
        DESTDIR=$RPM_BUILD_ROOT
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -114,7 +132,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%{_libdir}/lib*.so
+%attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
 %{_includedir}/*
 
@@ -122,6 +140,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
 
+%if %{with python}
 %files -n python-beecrypt
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/*.so
+%endif
This page took 0.057028 seconds and 4 git commands to generate.