]> git.pld-linux.org Git - packages/beagle.git/blobdiff - beagle.spec
- use xdg-open by default
[packages/beagle.git] / beagle.spec
index b8cb2885f7b8dc5c854ed08acdecaaea716bfaa8..8a9565cc16df65677be795a25f8a22334727eb5f 100644 (file)
@@ -1,20 +1,21 @@
 #
 # TODO:
 #       - kill bashisms in crawl stuff
-#      - mozilla extension?
+#      - add qyoto based settings (requires new packages)
+#      - replace epiphany-extension hack
 #
 %include       /usr/lib/rpm/macros.mono
 #
 # Conditional build:
 %bcond_without apidocs         # don't build API documentation
+%bcond_with    avahi           # enable Avahi support
 %bcond_without evolution       # don't include evolution support
 %bcond_without galago          # build without galago support
 %bcond_without gsf             # build without libgsf support
 %bcond_without gui             # don't build GNOME based GUI
 %bcond_without python          # don't build python libraries
 %bcond_without epiphany        # don't build epiphany extension
-%bcond_with    sqlite3         # use sqlite3 instead of sqlite2
-%bcond_with    thunderbird     # use Thunderbird backend
+%bcond_without thunderbird     # use Thunderbird backend
 #
 %if !%{with gui}
 %undefine      with_evolution
 Summary:       Beagle - An indexing subsystem
 Summary(pl.UTF-8):     Beagle - podsystem indeksujący
 Name:          beagle
-Version:       0.2.16
-Release:       1
+Version:       0.3.7
+Release:       0.1
 License:       Various
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
-# Source0-md5: 4818ca64dc2311208a27f03893836e49
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/beagle/0.3/%{name}-%{version}.tar.bz2
+# Source0-md5: 4845f674f540eeb24c09a1be1a5e2459
 Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-crawl.patch
-Patch2:                %{name}-kill_exec_a.patch
-Patch3:                %{name}-configure.patch
-Patch4:                %{name}-unary-plus-string.patch
+Patch2:                %{name}-configure.patch
 URL:           http://beagle-project.org/Main_Page
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: chmlib-devel
-%{?with_evolution:BuildRequires:       dotnet-evolution-sharp-devel >= 0.11.1}
+%{?with_evolution:BuildRequires:       dotnet-evolution-sharp-devel >= 0.13.3}
 %{?with_galago:BuildRequires:  dotnet-galago-sharp-devel >= 0.5.0}
 BuildRequires: dotnet-gmime-sharp-devel >= 2.2.3
 %{?with_gsf:BuildRequires:     dotnet-gsf-sharp-devel >= 0.8.1}
 #BuildRequires:        dotnet-gst-sharp-devel
 BuildRequires: dotnet-gtk-sharp2-devel >= 2.10.0
-%if %{with epiphany} 
-BuildRequires: epiphany-devel >= 2.16.1
+BuildRequires: dotnet-ndesk-dbus-glib-sharp-devel >= 0.3.0
+BuildRequires: dotnet-ndesk-dbus-sharp-devel >= 0.6.0
+%if %{with epiphany}
+BuildRequires: epiphany-devel >= 2.22.0
 %endif
-BuildRequires: gtk+2-devel >= 2:2.10.6
-%{?with_apidocs:BuildRequires: gtk-doc >= 1.7}
+BuildRequires: gtk+2-devel >= 2:2.10.10
+%{?with_apidocs:BuildRequires: gtk-doc >= 1.8}
 BuildRequires: libexif-devel >= 0.6.13
-BuildRequires: librsvg-devel >= 1:2.16.0
 BuildRequires: libpng-devel
+BuildRequires: librsvg-devel >= 1:2.16.1
 BuildRequires: libtool
-BuildRequires: libxml2-devel >= 1:2.6.26
+BuildRequires: libxml2-devel >= 1:2.6.27
 BuildRequires: mono-csharp >= 1.1.13.5
-# not used atm
-#BuildRequires:        mozilla-devel
-%{?with_python:BuildRequires:  python-pygtk-devel >= 2.10.3}
-BuildRequires: pkgconfig
 BuildRequires: perl-XML-Parser
+BuildRequires: pkgconfig
 BuildRequires: python-devel
-%if %{with sqlite3}
+%{?with_python:BuildRequires:  python-pygtk-devel >= 2:2.10.4}
 BuildRequires: sqlite3-devel >= 3.3.4
-%else
-BuildRequires: sqlite-devel
-%endif
 BuildRequires: wv-devel >= 1.2.4
 BuildRequires: xorg-lib-libXScrnSaver-devel
 BuildRequires: zip
 # GUI BRs
 %if %{with gui}
 BuildRequires: dotnet-gnome-sharp-devel >= 2.16.0
-BuildRequires: gnome-vfs2-devel >= 2.16.1
+BuildRequires: gnome-vfs2-devel >= 2.18.0.1
 %endif
-Requires:      %{name}-libs = %{version}-%{release}
 Requires:      dotnet-gmime-sharp >= 2.2.3
-%if %{with sqlite3}
+Requires:      dotnet-gsf-sharp
 Requires:      sqlite3
-%else
-Requires:      sqlite
-%endif
+Obsoletes:     beagle-libs
+Obsoletes:     beagle-static
+Obsoletes:     python-beagle
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
 ExclusiveArch: %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
-ExcludeArch:    i386
+ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -93,22 +89,23 @@ Lucene.Net.
 Beagle jest podsystemem indeksującym i wyszukującym zbudowanym na
 bazie Lucene.Net.
 
-%package libs
-Summary:       Beagle libraries
-Summary(pl.UTF-8):     Bibiloteki Beagle
-Group:         Libraries
+%package debug
+Summary:       Debug files for the Mono part of Beagle
+Summary(pl.UTF-8):     Pliki debugujące dla części Mono Beagle'a
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 
-%description libs
-Beagle libraries.
+%description debug
+Debug files for the Mono part of Beagle.
 
-%description libs -l pl.UTF-8
-Bibiloteki Beagle.
+%description -l pl.UTF-8
+Pliki debugujące dla części Mono Beagle'a.
 
 %package devel
 Summary:       Beagle development files
 Summary(pl.UTF-8):     Pliki programistyczne Beagle
 Group:         Development/Libraries
-Requires:      %{name}-libs = %{version}-%{release}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Beagle development files.
@@ -116,18 +113,6 @@ Beagle development files.
 %description devel -l pl.UTF-8
 Pliki programistyczne Beagle.
 
-%package static
-Summary:       Beagle static libraries
-Summary(pl.UTF-8):     Statyczne biblioteki Beagle
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description static
-Beagle static libraries.
-
-%description static -l pl.UTF-8
-Statyczne biblioteki Beagle.
-
 %package apidocs
 Summary:       libbeagle API documentation
 Summary(pl.UTF-8):     Dokumentacja API libbeagle
@@ -154,13 +139,53 @@ Beagle crawl system.
 %description crawl-system -l pl.UTF-8
 System przeszukujący beagle-crawl.
 
+%package search-gui
+Summary:       GNOME based Beagle GUI
+Summary(pl.UTF-8):     Oparty na GNOME graficzny interfejs dla Beagle
+Group:         Libraries/Python
+Requires:      %{name} = %{version}-%{release}
+Requires:      gtk+2 >= 2:2.10.10
+
+%description search-gui
+GNOME based Beagle GUI.
+
+%description search-gui -l pl.UTF-8
+Oparty na GNOME graficzny interfejs dla Beagle.
+
+%package startup
+Summary:       Automatic startup integration for Beagle
+Summary(pl.UTF-8):     Integracja funkcji automatycznego startu Beagle
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+Obsoletes:     beagle-gnome
+
+%description startup
+Automatic session startup integration for Beagle.
+
+%description startup -l pl.UTF-8
+Integracja funkcji automatycznego startu Beagle.
+
+%package webinterface
+Summary:       A web interface for Beagle
+Summary(pl.UTF-8):     Interfejs sieciowy dla Beagle
+Group:         Applications
+Requires:      %{name} = %{version}-%{release}
+
+%description webinterface
+An AJAX interface that allows users to search for data through their
+web browser.
+
+%description webinterface -l pl.UTF-8
+AJAX-owy interfejs pozwalający użytkownikom wyszukiwać dane za pomocą
+przeglądarki internetowej.
+
 %package evolution
 Summary:       Beagle Evolution backend
 Summary(pl.UTF-8):     Backend Beagle dla Evolution
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
 Requires:      dotnet-evolution-sharp >= 0.11.1
-Requires:      evolution >= 2.8.0
+Requires:      evolution >= 2.10.0
 
 %description evolution
 Beagle Evolution backend.
@@ -180,27 +205,12 @@ Beagle Mozilla Thunderbird backend.
 %description thunderbird -l pl.UTF-8
 Backend Beagle dla Mozilli Thunderbird.
 
-%package -n mozilla-firefox-extension-beagle
-Summary:       Mozilla Firefox extension - beagle
-Summary(pl.UTF-8):     Rozszerzenie dla Mozilla Firefox - beagle
-Group:         X11/Applications/Networking
-Requires:      %{name} = %{version}-%{release}
-Requires:      mozilla-firefox >= 2.0.0.1-2
-
-%description -n mozilla-firefox-extension-beagle
-Mozilla Firefox extension that allows Beagle to index every page the
-user views.
-
-%description -n mozilla-firefox-extension-beagle -l pl.UTF-8
-Rozszerzenie dla Mozilla Firefox sprawiające, że Beagle indeksuje
-każdą odwiedzaną stronę.
-
 %package -n epiphany-extension-beagle
 Summary:       Epiphany extension - beagle
 Summary(pl.UTF-8):     Rozszerzenie dla Epiphany - beagle
 Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
-Requires:      epiphany-extensions >= 2.16.1
+Requires:      epiphany-extensions >= 2.22.0
 
 %description -n epiphany-extension-beagle
 Epiphany extension that allows Beagle to index every page the user
@@ -210,70 +220,44 @@ views.
 Rozszerzenie dla Epiphany sprawiające, że Beagle indeksuje każdą
 odwiedzaną stronę.
 
-%package -n python-%{name}
-Summary:       Beagle Python bindings
-Summary(pl.UTF-8):     Wiązania języka Python dla Beagle
-Group:         Libraries/Python
-Requires:      %{name} = %{version}-%{release}
-%pyrequires_eq  python-libs
-
-%description -n python-%{name}
-Beagle Python bindings.
-
-%description -n python-%{name} -l pl.UTF-8
-Wiązania języka Python dla Beagle.
-
-%package search-gui
-Summary:       GNOME based Beagle GUI
-Summary(pl.UTF-8):     Oparty na GNOME graficzny interfejs dla Beagle
-Group:         Libraries/Python
-Requires:      %{name} = %{version}-%{release}
-Requires:      gtk+2 >= 2:2.10.6
-
-%description search-gui
-GNOME based Beagle GUI.
-
-%description search-gui -l pl.UTF-8
-Oparty na GNOME graficzny interfejs dla Beagle.
-
-%package startup
-Summary:       Automatic startup integration for Beagle
-Summary(pl.UTF-8):     Integracja funkcji automatycznego startu Beagle
-Group:         X11/Applications
+%package -n mozilla-firefox-extension-beagle
+Summary:       Mozilla Firefox extension - beagle
+Summary(pl.UTF-8):     Rozszerzenie dla przeglądarki Mozilla Firefox - beagle
+Group:         X11/Applications/Networking
 Requires:      %{name} = %{version}-%{release}
-Obsoletes:     beagle-gnome
+Requires:      mozilla-firefox >= 2.0.0.1-2
 
-%description startup
-Automatic session startup integration for Beagle.
+%description -n mozilla-firefox-extension-beagle
+Mozilla Firefox extension that allows Beagle to index every page the
+user views.
 
-%description startup -l pl.UTF-8
-Integracja funkcji automatycznego startu Beagle.
+%description -n mozilla-firefox-extension-beagle -l pl.UTF-8
+Rozszerzenie dla przeglądarki Mozilla Firefox sprawiające, że Beagle
+indeksuje każdą odwiedzaną stronę.
 
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
+#%patch1 -p1
+#%patch2 -p1
 
 %build
+%{__intltoolize}
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__automake}
 %configure \
-       --enable-static \
+       --disable-static \
        %{?with_apidocs:--enable-gtk-doc} \
        --with-html-dir=%{_gtkdocdir} \
        --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
        --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
        --%{!?with_gui:dis}%{?with_gui:en}able-gui \
-       --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird
+       --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird \
+       --%{!?with_avahi:dis}%{?with_avahi:en}able-avahi
 
-%{__make} \
-       MOZILLA_HOME=%{_libdir}/mozilla \
-       pythondir=%{py_sitedir}
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -281,22 +265,33 @@ install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       pythondir=%{py_sitedir}
+       pythondir=%{py_sitedir} \
+       monodocdir=%{_libdir}/monodoc/sources
+
+rm $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*glue.la
 
 dest=$RPM_BUILD_ROOT%{_datadir}/mozilla-firefox/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
 install -d $dest $dest/chrome
-install mozilla-extension/{chrome.manifest,install.rdf} $dest
-install mozilla-extension/chrome/beagle.jar $dest/chrome
-
-# Kill useless files
-rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/2.16/extensions/*.{la,a} \
-       $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
+install firefox-extension/{chrome.manifest,install.rdf} $dest
+cp -r firefox-extension/chrome/* $dest/chrome
 
-rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
+%if %{with epiphany}
+install -d $RPM_BUILD_ROOT%{_libdir}/epiphany/2.22/extensions
+sed -e "s|\@localedir\@|\%{_localedir}|g" \
+       < epiphany-extension/beagle.py.in > epiphany-extension/beagle.py
+install epiphany-extension/beagle.py $RPM_BUILD_ROOT%{_libdir}/epiphany/2.22/extensions/beagle.py
+install epiphany-extension/beagle.ephy-extension.in $RPM_BUILD_ROOT%{_libdir}/epiphany/2.22/extensions/beagle.ephy-extension
+%endif
 
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
+%if %{with thunderbird}
+tdest=$RPM_BUILD_ROOT%{_libdir}/mozilla-thunderbird/extensions/\{b656ef18-fd76-45e6-95cc-8043f26361e7\}
+install -d $tdest
+install thunderbird-extension/{chrome.manifest,install.rdf} $tdest
+cp -r thunderbird-extension/{chrome,components,defaults} $tdest
+%endif
 
+[ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
+       mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
 %find_lang %{name}
 
 %clean
@@ -312,26 +307,23 @@ if [ "$1" = "0" ]; then
         %groupremove beagleindex
 fi
 
-%post  libs -p /sbin/ldconfig
-%postun        libs -p /sbin/ldconfig
-
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS COPYING ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/beagle-config
-%attr(755,root,root) %{_bindir}/beagled
 %attr(755,root,root) %{_bindir}/beagle-doc-extractor
-%attr(755,root,root) %{_bindir}/beagle-exercise-file-system
 %attr(755,root,root) %{_bindir}/beagle-extract-content
 %attr(755,root,root) %{_bindir}/beagle-index-info
-%attr(755,root,root) %{_bindir}/beagle-index-url
 %attr(755,root,root) %{_bindir}/beagle-info
 %attr(755,root,root) %{_bindir}/beagle-ping
 %attr(755,root,root) %{_bindir}/beagle-query
 %attr(755,root,root) %{_bindir}/beagle-shutdown
+%attr(755,root,root) %{_bindir}/beagle-static-query
 %attr(755,root,root) %{_bindir}/beagle-status
-%attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
+%attr(755,root,root) %{_bindir}/beagled
+%attr(755,root,root) %{_bindir}/blocate
 %attr(755,root,root) %{_libdir}/%{name}/*.exe
+%attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/Backends
 %dir %{_libdir}/%{name}/Filters
@@ -339,37 +331,82 @@ fi
 %{_libdir}/%{name}/*.dll.config
 %{_libdir}/%{name}/Filters/*.dll
 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
-%{_mandir}/man*/*
-
-%files libs
+%{_mandir}/man1/beagle-config.1*
+%{_mandir}/man1/beagle-query.1*
+%{_mandir}/man1/beagle-search.1*
+%{_mandir}/man1/beagle-shutdown.1*
+%{_mandir}/man1/beagle-status.1*
+%{_mandir}/man1/beagled.1*
+
+%files debug
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%{_libdir}/%{name}/Backends/*.mdb
+%{_libdir}/%{name}/Filters/*.mdb
+%{_libdir}/%{name}/*.mdb
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/*.so
-%{_includedir}/libbeagle
-%{_libdir}/*.la
-%{_pkgconfigdir}/*
-
-%files static
-%defattr(644,root,root,755)
-%{_libdir}/*.a
+%{_pkgconfigdir}/beagle-0.0.pc
+%{_pkgconfigdir}/beagle-ui-0.0.pc
+%{_pkgconfigdir}/beagle-daemon.pc
 
 %if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
-%{_gtkdocdir}/beagle
+%{_libdir}/monodoc/sources/*
 %endif
 
 %files crawl-system
 %defattr(644,root,root,755)
-%attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
 %dir %{_sysconfdir}/beagle
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
+%dir %{_sysconfdir}/beagle/config-files
+%dir %{_sysconfdir}/beagle/crawl-rules
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/blocate.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/query-mapping.xml
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/BeagleSearch.xml
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Daemon.xml
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/FilesQueryable.xml
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/GoogleBackends.xml
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Networking.xml
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-applications
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-documentation
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-manpages
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-monodoc
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-windows
+# XXX: samples not here
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/external-filters.xml.sample
+%attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/beagle-crawl-system
 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
-%attr(755,root,root) %{_sbindir}/*
+%attr(755,root,root) %{_sbindir}/beagle-build-index
+%attr(755,root,root) %{_sbindir}/beagle-dump-index
+%attr(755,root,root) %{_sbindir}/beagle-manage-index
+%attr(755,root,root) %{_sbindir}/beagle-master-delete-button
+%{_mandir}/man1/beagle-dump-index.1*
+%{_mandir}/man8/beagle-build-index.8*
+%{_mandir}/man8/beagle-extract-content.8*
+%{_mandir}/man8/beagle-manage-index.8*
+%{_libdir}/%{name}/Backends/GoogleBackends*.dll
+
+%if %{with gui}
+%files search-gui
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/beagle-imlogviewer
+%attr(755,root,root) %{_bindir}/beagle-search
+%attr(755,root,root) %{_bindir}/beagle-settings
+%attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
+%{_mandir}/man8/beagle-imlogviewer.8*
+%{_desktopdir}/*.desktop
+%endif
+
+%files startup
+%defattr(644,root,root,755)
+%{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
+%{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
+
+%files webinterface
+%defattr(644,root,root,755)
+%{_datadir}/%{name}
 
 %if %{with evolution}
 %files evolution
@@ -380,40 +417,17 @@ fi
 %if %{with thunderbird}
 %files thunderbird
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/beagle-contactviewer
 %{_libdir}/%{name}/Backends/Thunderbird*.dll
+%{_libdir}/mozilla-thunderbird/extensions/{b656ef18-fd76-45e6-95cc-8043f26361e7}
 %endif
 
-%files -n mozilla-firefox-extension-beagle
-%defattr(644,root,root,755)
-%{_datadir}/mozilla-firefox/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
-
 %if %{with epiphany}
 %files -n epiphany-extension-beagle
 %defattr(644,root,root,755)
-%doc epiphany-extension/README
-%attr(755,root,root) %{_libdir}/epiphany/2.16/extensions/libbeagleextension.so*
-%{_libdir}/epiphany/2.16/extensions/*.xml
+%attr(755,root,root) %{_libdir}/epiphany/2.22/extensions/beagle.py
+%{_libdir}/epiphany/2.22/extensions/*.ephy-extension
 %endif
 
-%if %{with python}
-%files -n python-%{name}
-%defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/*.so
-%endif
-
-%if %{with gui}
-%files search-gui
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/beagle-imlogviewer
-%attr(755,root,root) %{_bindir}/beagle-search
-%attr(755,root,root) %{_bindir}/beagle-settings
-%attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
-%{_pixmapsdir}/*.png
-%{_desktopdir}/*.desktop
-%endif
-
-%files startup
+%files -n mozilla-firefox-extension-beagle
 %defattr(644,root,root,755)
-%{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
-%{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
+%{_datadir}/mozilla-firefox/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
This page took 0.073836 seconds and 4 git commands to generate.