]> git.pld-linux.org Git - packages/autofs.git/blobdiff - autofs.spec
- changed all BuildRoot definitons
[packages/autofs.git] / autofs.spec
index fe14985aad5b59e4835e86206ffa72849567c1cf..06aac5f2effca3bddd76bda9f629b6341844640a 100644 (file)
@@ -4,147 +4,122 @@ Summary(fr):        d
 Summary(pl):   Demon autofs 
 Summary(tr):   autofs sunucu süreci
 Name:          autofs
-Version:       3.1.3
-Release:       3
-Copyright:     GPL
+Version:       4.0.0pre6
+Release:       1
+License:       GPL
 Group:         Daemons
-Group(pl):     Demony
-URL:           ftp://ftp.kernel.org/pub/linux/daemons/autofs
-Source0:       %{name}-%{version}.tar.bz2
-Source1:       %{name}.init
-Patch:         %{name}-%{version}.patch
-Buildroot:     /tmp/%{name}-%{version}-root
+Group(pl):     Serwery
+Source0:       ftp://ftp.kernel.org/pub/linux/daemons/autofs/%{name}-%{version}.tar.gz
+Source1:       autofs.init
+Source2:       autofs-auto.master
+Source3:       autofs-auto.misc
+Source4:       autofs-auto.mnt
+Source5:       autofs-auto.net
+Source6:       autofs.sysconfig
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Prereq:                /sbin/chkconfig
 Requires:      mktemp
-Exclusivearch: i386
+Requires:      rc-scripts
+
+%define                _sysconfdir     /etc/autofs
 
 %description
 autofs is a daemon which automatically mounts filesystems when you use
 them, and unmounts them later when you are not using them.  This can
 include network filesystems, CD-ROMs, floppies, and so forth.
 
-%description -l pl
-Autofs jest demonem, który montuje automatycznie systemy plików je¿eli
-je u¿ywasz i odmontowuje pó¼niej, je¿eli ich nie u¿ywasz. Mo¿e montowaæ
-sieciowy system plików, CD-romy, stacje dyskietek i inne.
-
 %description -l de
-autofs ist ein Dämon, der Dateisysteme automatisch montiert, wenn sie 
-benutzt werden, und sie später bei Nichtbenutzung wieder demontiert. 
-Dies kann Netz-Dateisysteme, CD-ROMs, Disketten und ähnliches einschließen. 
+autofs ist ein Dämon, der Dateisysteme automatisch montiert, wenn sie
+benutzt werden, und sie später bei Nichtbenutzung wieder demontiert.  Dies
+kann Netz-Dateisysteme, CD-ROMs, Disketten und ähnliches einschließen.
 
 %description -l fr
 autofs est un démon qui monte automatiquement les systèmes de fichiers
 lorsqu'on les utilise et les démonte lorsqu'on ne les utilise plus. Cela
 inclus les systèmes de fichiers réseau, les CD-ROMs, les disquettes, etc.
 
+%description -l pl
+Autofs jest demonem, który montuje automatycznie systemy plików je¿eli je
+u¿ywasz i odmontowuje pó¼niej, je¿eli ich nie u¿ywasz. Mo¿e montowaæ
+sieciowy system plików, CD-romy, stacje dyskietek i inne.
+
 %description -l tr
-autofs, kullanýlan dosya sistemlerini gerek olunca kendiliðinden baðlar
-ve kullanýmlarý sona erince yine kendiliðinden çözer. Bu iþlem, að dosya
+autofs, kullanýlan dosya sistemlerini gerek olunca kendiliðinden baðlar ve
+kullanýmlarý sona erince yine kendiliðinden çözer. Bu iþlem, að dosya
 sistemleri, CD-ROM'lar ve disketler üzerinde yapýlabilir.
 
 %prep
 %setup -q
-%patch -p1 
 
 %build
-CFLAGS=$RPM_OPT_FLAGS LDFLAGS=-s \
-    ./configure \
-    --prefix=/usr \
-    --sysconfdir=/etc/autofs
-
+LDFLAGS="-s"; export LDFLAGS
+%configure
 make 
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/usr/{sbin,lib/autofs,man/{man5,man8}}
-install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,autofs}
+install -d $RPM_BUILD_ROOT/{misc,net,%{_sbindir},%{_libdir}/autofs,%{_mandir}/man{5,8}} \
+       $RPM_BUILD_ROOT/etc/{rc.d/init.d,autofs,sysconfig}
 
-make sbindir=$RPM_BUILD_ROOT/usr/sbin \
-mandir=$RPM_BUILD_ROOT/usr/man \
-autofslibdir=$RPM_BUILD_ROOT/usr/lib/autofs install
+make install \
+       INSTALLROOT=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/autofs
-install samples/auto.* $RPM_BUILD_ROOT/etc/autofs
+install %{SOURCE1}     $RPM_BUILD_ROOT/etc/rc.d/init.d/autofs
 
-install -d $RPM_BUILD_ROOT/misc
+install %{SOURCE2}     $RPM_BUILD_ROOT%{_sysconfdir}/auto.master
+install %{SOURCE3}     $RPM_BUILD_ROOT%{_sysconfdir}/auto.misc
+install %{SOURCE4}     $RPM_BUILD_ROOT%{_sysconfdir}/auto.mnt
+install %{SOURCE5}     $RPM_BUILD_ROOT%{_sysconfdir}/auto.net
+install %{SOURCE6}     $RPM_BUILD_ROOT/etc/sysconfig/autofs
 
-for i in auto.home auto.misc auto.var auto.tmp; do
-touch $RPM_BUILD_ROOT/etc/autofs/$i; done
+touch                  $RPM_BUILD_ROOT%{_sysconfdir}/auto.{home,misc,var,tmp}
 
-gzip -9nf $RPM_BUILD_ROOT/usr/man/man[58]/* \
-       NEWS README 
+strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/autofs/*
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man[58]/* \
+       NEWS README 
 
 %post
 /sbin/chkconfig --add autofs
+if test -r /var/lock/subsys/automount; then
+       /etc/rc.d/init.d/autofs restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/autofs start\" to start autofs daemon."
+fi
 
 %preun
-if [ $1 = 0 ]; then
-    /sbin/chkconfig --del autofs
+if [ "$1" = "0" ]; then
+       /sbin/chkconfig --del autofs
+       if [ -f /var/lock/subsys/automount ]; then
+               /etc/rc.d/init.d/autofs stop 1>&2
+       fi
 fi
 
+%clean
+rm -rf $RPM_BUILD_ROOT
+
 %files
 %defattr(644,root,root,755)
 %doc {NEWS,README}.gz 
 
-%attr(750,root,root) %config /etc/rc.d/init.d/autofs
-%attr(-,root,root,750) %dir /etc/autofs
-%attr(640,root,root) %config %verify(not size mtime md5) /etc/autofs/*
-%attr(755,root,root) /usr/sbin/automount
+%attr(754,root,root) %config /etc/rc.d/init.d/autofs
+%dir %{_sysconfdir}
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/autofs
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/auto.home
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/auto.master
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/auto.misc
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/auto.mnt
+%attr(750,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/auto.net
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/auto.tmp
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/auto.var
+%attr(755,root,root) %{_sbindir}/automount
 
 %dir /misc
+%dir /net
+
+%dir %{_libdir}/autofs
+%attr(755,root,root) %{_libdir}/autofs/*
 
-%dir /usr/lib/autofs
-%attr(755,root,root) /usr/lib/autofs/*
-/usr/man/man[58]/*
-
-%changelog
-* Mon Apr  5 1999 Piotr Czerwiñski <pius@pld.org.pl>
-  [3.1.3-3]
-- changed Group(pl) to Demony,
-- gzipping documentation,
-- added -nf to gzip parameters,
-- removed man group from man pages,
-- fixed dir permissions,
-- cosmetic changes for common l&f.
-
-* Sat Oct 10 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
-  [3.1.3-1d]
-- fixed pl translation,
-- fixed invalid modules/Makefile;
-- fixed files permissions,
-- moved sysconfdir to /etc/autofs,
-- fixed rc.autofs to work wiht bash-2.02.1 and higher,
-- added some samples auto.* config files.
-
-* Fri Jun 12 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
-  [3.1.1-4d]
-- build against glibc-2.1,
-- translation modified for pl,
-- added %defattr support,
-- build from non root's account,
-- moved %changelog at the end of spec.
-
-* Thu May 07 1998 Prospector System <bugs@redhat.com>
-- translations modified for de, fr, tr
-
-* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
-- updated to 3.1.1
-
-* Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
-- enhanced initscripts
-
-* Fri Dec 05 1997 Michael K. Johnson <johnsonm@redhat.com>
-- Link with -lnsl for glibc compliance.
-
-* Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
-- exclusivearch for i386 for now, since our kernel packages on
-  other platforms don't include autofs yet.
-- improvements to initscripts.
-
-* Thu Oct 16 1997 Michael K. Johnson <johnsonm@redhat.com>
-- Built package from 0.3.14 for 5.0
+%{_mandir}/man[58]/*
This page took 0.089617 seconds and 4 git commands to generate.