]> git.pld-linux.org Git - packages/aubio.git/blobdiff - aubio.spec
- added python subpackage
[packages/aubio.git] / aubio.spec
index 9df1ddaa288aea1aacf9647998d998c6667626e2..1e81bcc16faaf2fda3a06577e35432cab6b9d989 100644 (file)
@@ -1,6 +1,11 @@
 # TODO:
 #      - unpackaged /usr/share/sounds/aubio/woodblock.aiff
-#      - package python stuff
+#      - python package NFY (_aubiowrapper.a in sitescriptdir?)
+#      - create lash.spec (http://www.nongnu.org/lash) and
+#        --enable-lash
+#
+# Conditional build:
+%bcond_with    python  # build python bindings
 #
 Summary:       aubio is a library for audio labelling
 Name:          aubio
@@ -16,6 +21,10 @@ BuildRequires:       fftw3-single-devel
 BuildRequires: jack-audio-connection-kit-devel
 BuildRequires: libsamplerate-devel
 BuildRequires: libsndfile-devel
+%if %{with python}
+BuildRequires: python-devel
+BuildRequires: swig-python
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -45,14 +54,36 @@ Static aubio library.
 %description static -l pl.UTF-8
 Statyczna biblioteka aubio.
 
+%package progs
+Summary:       Example applications using aubio library
+Group:         Applications
+Requires:      %{name} = %{version}-%{release}
+
+%description progs
+A few examples of applications using aubio library:
+- aubioonset: outputs the onset detected
+- aubionotes: uses both onset and pitch to extract symbolic music data
+    from an audio source and emit MIDI like data.
+- aubiocut: a python script that takes an input sound and creates one
+    new sample at each detected onset or beat. The slices produced by
+    aubiocut are useful for use with a sequencer such as Hydrogen.
+- aubiopitch: a python script to extract pitch tracks from sound files
+
+%package -n python-aubio
+Summary:       aubio python bindings
+Group:         Libraries/Python
+Requires:      %{name} = %{version}-%{release}
+
+%description -n python-aubio
+aubio python bindings.
+
 %prep
 %setup -q
 
 %build
 %configure \
        --enable-alsa \
-       --enable-jack \
-       --enable-lash
+       --enable-jack
 
 %{__make}
 
@@ -62,10 +93,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -rf $RPM_BUILD_ROOT/%{py_sitedir}
-rm -rf $RPM_BUILD_ROOT/%{py_libdir}
-rm -rf $RPM_BUILD_ROOT/%{py_scriptdir}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -75,7 +102,6 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README THANKS TODO
-%attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
 
 %files devel
@@ -88,3 +114,17 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
+
+%files progs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/aubionotes
+%attr(755,root,root) %{_bindir}/aubioonset
+%attr(755,root,root) %{_bindir}/aubiotrack
+%if %{with python}
+%attr(755,root,root) %{_bindir}/aubiocut
+%attr(755,root,root) %{_bindir}/aubiopitch
+%endif
+
+%files -n python-aubio
+%defattr(644,root,root,755)
+%{py_sitescriptdir}/aubio
This page took 0.050129 seconds and 4 git commands to generate.