]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - apache1-module.spec
- removed duplicate debug_packages disabling, added dune example
[projects/template-specs.git] / apache1-module.spec
index 49ba912995549c1870b030150c989c741d1aad98..07dfd36d6b23b4316840e8602f2cb9830ff02d36 100644 (file)
@@ -2,12 +2,14 @@
 %bcond_without ipv6            # disable IPv6 support
 #
 # Replace MODNAME with real module name (example for mod_example)
-# Replace VERSION with version since what confdir support was introduced for the module.
+# Replace VERSION with version since what confdir support was
+# introduced for the module. only needed for older .specs, not needed
+# for new packages.
 #
 %define                mod_name        MODNAME
-%define        apxs            %{_sbindir}/apxs1
-Summary:       Apache module: ...
-Summary(pl):   Modu³ Apache'a: ...
+%define                apxs            %{_sbindir}/apxs1
+Summary:       Apache HTTPD module: ..
+Summary(pl.UTF-8):     Moduł Apache'a: ...
 Name:          apache1-mod_%{mod_name}
 Version:       -
 Release:       0.1
@@ -17,22 +19,23 @@ Source0:    -
 # Source0-md5: -
 Source1:       %{name}.conf
 URL:           -
-BuildRequires: apache1-devel >= 1.3.33-2
 %{?with_ipv6:BuildRequires:    apache1(ipv6)-devel}
+BuildRequires: apache1-devel >= 1.3.33-2
+BuildRequires: rpmbuild(macros) >= 1.228
 %{!?with_ipv6:BuildConflicts:  apache1(ipv6)-devel}
 Requires(triggerpostun):       %{apxs}
 Requires(triggerpostun):       grep
 Requires(triggerpostun):       sed >= 4.0
-Requires:      apache1 >= 1.3.33-2
+Requires:      apache1(EAPI)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 %define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
-MODNAME is Apache module...
+MODNAME is Apache HTTPD module...
 
-%description -l pl
+%description -l pl.UTF-8
 
 %prep
 %setup -q -n mod_%{mod_name}-%{version}
@@ -59,22 +62,17 @@ echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
 rm -rf $RPM_BUILD_ROOT
 
 %post
-if [ -f /var/lock/subsys/apache ]; then
-       /etc/rc.d/init.d/apache restart 1>&2
-fi
+%service apache restart
 
 %postun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/apache ]; then
-               /etc/rc.d/init.d/apache restart 1>&2
-       fi
+       %service -q apache restart
 fi
 
-# trigger for upgrading from pre confdir module
-
-# if they had Include modulename.conf
+%if 0 # triggers for upgrading from pre confdir module
+# if there was "Include modulename.conf"
 %triggerpostun -- %{name} < VERSION
-if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
+if grep -q '^Include conf\.d/\*\.conf' /etc/apache/apache.conf; then
        %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
        sed -i -e '
                /^Include.*mod_%{mod_name}\.conf/d
@@ -85,17 +83,17 @@ else
                s,^Include.*mod_%{mod_name}\.conf,Include %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf,
 ' /etc/apache/apache.conf
 fi
-if [ -f /var/lock/subsys/apache ]; then
-       /etc/rc.d/init.d/apache restart 1>&2
-fi
+%service -q apache restart
 
-# or it was just apxs
+# or, if there was just apxs usage
 %triggerpostun -- apache1-mod_%{mod_name} < VERSION
 # check that they're not using old apache.conf
-if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
+if grep -q '^Include conf\.d/\*\.conf' /etc/apache/apache.conf; then
        %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
 fi
 
+%endif
+
 %files
 %defattr(644,root,root,755)
 %doc README
This page took 0.102991 seconds and 4 git commands to generate.