]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blobdiff - apache1-mod_fastcgi.spec
- use %service
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
index 573e4f92d754e8fca9d054f3ccdf3aae9993449d..dba35ca1ce087afc76cd383a1958d25a40b732bf 100644 (file)
@@ -7,22 +7,24 @@ Summary(uk):  FastCGI - ¦
 Name:          apache1-mod_%{mod_name}
 # NOTE: remember about apache-mod_fastcgi.spec when messing here
 Version:       2.4.2
-Release:       1.4
+Release:       3
 License:       distributable
 Group:         Networking/Daemons
 Source0:       http://www.FastCGI.com/dist/mod_%{mod_name}-%{version}.tar.gz
 # Source0-md5: e994414304b535cb99e10b7d1cad1d1e
 Patch0:                %{name}-allow-uid-gid.patch
+Patch1:                %{name}-socketdir.patch
 URL:           http://www.FastCGI.com/
 BuildRequires: %{apxs}
 BuildRequires: apache1-devel >= 1.3.33-2
 BuildRequires: libtool
+BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      apache1 >= 1.3.33-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 %define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
-%define                _pkglogdir      %(%{apxs} -q PREFIX 2>/dev/null)/logs
+%define                _socketdir      /var/run/apache/fastcgi
 
 %description
 This 3rd party module provides support for the FastCGI protocol.
@@ -52,13 +54,14 @@ FastCGI - 
 %prep
 %setup -q -n mod_%{mod_name}-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{apxs} -o mod_%{mod_name}.so -c *.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,%{_pkglogdir}/fastcgi/dynamic}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,%{_socketdir}/dynamic}
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
@@ -69,23 +72,17 @@ echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
 rm -rf $RPM_BUILD_ROOT
 
 %post
-if [ -f /var/lock/subsys/apache ]; then
-       /etc/rc.d/init.d/apache restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
-fi
+%service -q apache restart
 
 %postun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/apache ]; then
-               /etc/rc.d/init.d/apache restart 1>&2
-       fi
+       %service -q apache restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc docs/LICENSE.TERMS CHANGES docs/*.html
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*.so
-%attr(770,root,http) %{_pkglogdir}/fastcgi
-%attr(770,root,http) %{_pkglogdir}/fastcgi/dynamic
+%dir %attr(770,root,http) %{_socketdir}
+%dir %attr(770,root,http) %{_socketdir}/dynamic
This page took 0.335652 seconds and 4 git commands to generate.