]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blobdiff - apache1-mod_fastcgi.spec
- adapterized
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
index f30dedb1391283245f39546b683fa330ac9a34e1..c44a749900fb7c7f8f62e99febead894c0ab7322 100644 (file)
@@ -1,26 +1,29 @@
-%define        apxs    /usr/sbin/apxs
+%define                mod_name        fastcgi
+%define        apxs            /usr/sbin/apxs1
 Summary:       Support for the FastCGI protocol for apache webserver
 Summary(pl):   Obs³uga protoko³u FastCGI dla serwera apache
 Summary(ru):   FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
 Summary(uk):   FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
-Name:          apache-mod_fastcgi
+Name:          apache1-mod_%{mod_name}
+# NOTE: remember about apache-mod_fastcgi.spec when messing here
 Version:       2.4.2
-Release:       1
+Release:       3
 License:       distributable
 Group:         Networking/Daemons
-Source0:       http://www.FastCGI.com/dist/mod_fastcgi-%{version}.tar.gz
+Source0:       http://www.FastCGI.com/dist/mod_%{mod_name}-%{version}.tar.gz
 # Source0-md5: e994414304b535cb99e10b7d1cad1d1e
-Source1:       70_mod_fastcgi.conf
+Patch0:                %{name}-allow-uid-gid.patch
+Patch1:                %{name}-socketdir.patch
 URL:           http://www.FastCGI.com/
 BuildRequires: %{apxs}
-BuildRequires: apache-devel
+BuildRequires: apache1-devel >= 1.3.33-2
 BuildRequires: libtool
-Requires(post,preun):  %{apxs}
-Requires:      apache >= 1.3.1
+Requires:      apache1 >= 1.3.33-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define         _libexecdir     %{_libdir}/apache
-%define         _htmldocdir     /home/httpd/manual/mod
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
+%define                _socketdir      /var/run/apache/fastcgi
 
 %description
 This 3rd party module provides support for the FastCGI protocol.
@@ -48,41 +51,43 @@ FastCGI - 
 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
 
 %prep
-%setup -q -n mod_fastcgi-%{version}
+%setup -q -n mod_%{mod_name}-%{version}
+%patch0 -p1
+%patch1 -p1
 
 %build
-%{__make} -f Makefile.AP2 top_dir=%{_libexecdir} INCLUDES="-I%{_includedir}/apache"
+%{apxs} -o mod_%{mod_name}.so -c *.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_libexecdir},%{_htmldocdir}}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,%{_socketdir}/dynamic}
 
-libtool --mode=install install mod_fastcgi.la $RPM_BUILD_ROOT%{_libexecdir}
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
-install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
-
-install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/httpd.conf/
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-if [ -f /var/lock/subsys/httpd ]; then
-        /etc/rc.d/init.d/httpd restart 1>&2
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
 else
-        echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
-%preun
+
+%postun
 if [ "$1" = "0" ]; then
-        if [ -f /var/lock/subsys/httpd ]; then
-                /etc/rc.d/init.d/httpd restart 1>&2
-        fi
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
+       fi
 fi
+
 %files
 %defattr(644,root,root,755)
-%doc docs/LICENSE.TERMS CHANGES
-%doc %{_htmldocdir}/*
-%attr(755,root,root) %{_libexecdir}/*
-%config %{_sysconfdir}/httpd/httpd.conf/*.conf
+%doc docs/LICENSE.TERMS CHANGES docs/*.html
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
+%dir %attr(770,root,http) %{_socketdir}
+%dir %attr(770,root,http) %{_socketdir}/dynamic
This page took 0.095136 seconds and 4 git commands to generate.