]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blobdiff - apache1-mod_fastcgi.spec
- adapterized
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
index d2735fc6d1feca0a15d84aa88ca85f2a0240b5f8..c44a749900fb7c7f8f62e99febead894c0ab7322 100644 (file)
@@ -1,66 +1,93 @@
+%define                mod_name        fastcgi
+%define        apxs            /usr/sbin/apxs1
 Summary:       Support for the FastCGI protocol for apache webserver
-Name:          apache-mod_fastcgi
-Version:       2.2.10
-Release:       1
-Copyright:     Open Market
+Summary(pl):   Obs³uga protoko³u FastCGI dla serwera apache
+Summary(ru):   FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
+Summary(uk):   FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
+Name:          apache1-mod_%{mod_name}
+# NOTE: remember about apache-mod_fastcgi.spec when messing here
+Version:       2.4.2
+Release:       3
+License:       distributable
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
-Source0:       http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
+Source0:       http://www.FastCGI.com/dist/mod_%{mod_name}-%{version}.tar.gz
+# Source0-md5: e994414304b535cb99e10b7d1cad1d1e
+Patch0:                %{name}-allow-uid-gid.patch
+Patch1:                %{name}-socketdir.patch
 URL:           http://www.FastCGI.com/
-BuildRequires: apache-devel
-Requires:      apache >= 1.3.1
+BuildRequires: %{apxs}
+BuildRequires: apache1-devel >= 1.3.33-2
+BuildRequires: libtool
+Requires:      apache1 >= 1.3.33-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
+%define                _socketdir      /var/run/apache/fastcgi
+
 %description
 This 3rd party module provides support for the FastCGI protocol.
 FastCGI is a language independent, scalable, open extension to CGI
 that provides high performance and persistence without the limitations
 of server specific APIs.
 
-%define         _libexecdir     /usr/lib/apache
-%define         _htmldocdir     /home/httpd/html/docs/%{name}_%{version}
+%description -l pl
+To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
+niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
+du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
+
+%description -l ru
+FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
+×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
+ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
+
+óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
+
+%description -l uk
+FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
+×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
+ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
+
+û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
 
 %prep
-%setup -q -n mod_fastcgi_%{version}
+%setup -q -n mod_%{mod_name}-%{version}
+%patch0 -p1
+%patch1 -p1
 
 %build
-apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_fastcgi.so -c *.c
-strip mod_fastcgi.so
+%{apxs} -o mod_%{mod_name}.so -c *.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
-
-install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,%{_socketdir}/dynamic}
 
-install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
-gzip -9nf docs/LICENSE.TERMS CHANGES
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
 
-strip --strip-unneeded $RPM_BUILD_ROOT%{_libexecdir}/*
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
 else
-       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%preun
+%postun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
-%doc docs/*.gz CHANGES.gz
-%doc %{_htmldocdir}
-%attr(755,root,root) %{_libexecdir}/*
+%doc docs/LICENSE.TERMS CHANGES docs/*.html
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
+%dir %attr(770,root,http) %{_socketdir}
+%dir %attr(770,root,http) %{_socketdir}/dynamic
This page took 0.025698 seconds and 4 git commands to generate.