]> git.pld-linux.org Git - packages/apache1-mod_auth_checkpasswd.git/blobdiff - apache1-mod_auth_checkpasswd.spec
- mass attack: s/%patch /%patch0 / -- usefull for overloaded %patch macro
[packages/apache1-mod_auth_checkpasswd.git] / apache1-mod_auth_checkpasswd.spec
index a882ba43a81df126593ffd0343a93862e9c7b19a..694dc9ea39b1cd62b866f21199b4e5079bfc603e 100644 (file)
@@ -1,22 +1,25 @@
 %define                mod_name        auth_checkpasswd
-%define        apxs            /usr/sbin/apxs
+%define        apxs            /usr/sbin/apxs1
 Summary:       This is the CHECKPASSWD authentication module for Apache
 Summary(pl):   To jest modu³ Apache uwierzytelniaj±cy przez CHECKPASSWD
-Name:          apache-mod_%{mod_name}
+Name:          apache1-mod_%{mod_name}
 Version:       1.0
-Release:       4
+Release:       2
 License:       GPL
 Group:         Networking/Daemons
 Source0:       mod_%{mod_name}-%{version}.tar.gz
 # Source0-md5: 7f699981ada026656affe2e35409bdf2
 Patch0:                %{name}-aplog.patch
 BuildRequires: %{apxs}
-BuildRequires: apache(EAPI)-devel
-Requires(post,preun):  %{apxs}
-Requires:      apache(EAPI)
+BuildRequires: apache1-devel >= 1.3.33-2
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires(triggerpostun):       %{apxs}
+Requires:      apache1 >= 1.3.33-2
+Obsoletes:     apache-mod_auth_checkpasswd <= 1.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
 This is an authentication module for Apache that uses an external
@@ -32,37 +35,39 @@ zwyk
 
 %prep
 %setup -q -c -n "mod_%{mod_name}-%{version}"
-%patch -p1
+%patch0 -p1
 
 %build
-%{apxs} \
-       -c mod_%{mod_name}.c \
-       -o mod_%{mod_name}.so
+%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
+%service -q apache restart
 
-%preun
+%postun
 if [ "$1" = "0" ]; then
+       %service -q apache restart
+fi
+
+%triggerpostun -- apache1-mod_%{mod_name} < 1.0-1.1
+# check that they're not using old apache.conf
+if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
        %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc README
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.093925 seconds and 4 git commands to generate.