]> git.pld-linux.org Git - packages/apache.git/blobdiff - apache.spec
- fixed, now apache builds --without ipv6
[packages/apache.git] / apache.spec
index d792c2d6acb02fc8fb57a7a4d8144f3b962b95ac..2d8e7e2febf14d63299c81cdc54d124dc7a6e0b2 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Conditional build:
-# mod_rewrite_ldap - enable ldap map supoort for mod_rewrite (alpha)
-# _without_apache_ipv6 - disable IPv6 support
+# mod_rewrite_ldap     - enable ldap map supoort for mod_rewrite (alpha)
+# _without_ipv6                - disable IPv6 support
 #
 %include       /usr/lib/rpm/macros.perl
 Summary:       The most widely used Web server on the Internet
@@ -26,12 +26,12 @@ Summary(tr):        Lider WWW taray
 Summary(uk):   îÁÊÐÏÐÕÌÑÒΦÛÉÊ Web-Server
 Summary(zh_CN):        Internet ÉÏÓ¦ÓÃ×î¹ã·ºµÄ Web ·þÎñ³ÌÐò¡£
 Name:          apache
-Version:       1.3.23
-Release:       6
-License:       Apache Group License
+Version:       1.3.26
+Release:       5
+License:       Apache Group 
 Group:         Networking/Daemons
 URL:           http://www.apache.org/
-Source0:       ftp://ftp.apache.org/dist/%{name}_%{version}.tar.gz
+Source0:       ftp://ftp.apache.org/dist/httpd/%{name}_%{version}.tar.gz
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
 Source3:       %{name}-icons.tar.gz
@@ -67,20 +67,24 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 BuildRequires: db3-devel
 BuildRequires: mm-devel >= 1.1.3
 %{?mod_rewrite_ldap:BuildRequires: openldap-devel}
-Provides:      httpd
-Provides:      webserver
-Provides:      %{name}(EAPI) = %{version}
-Prereq:                /sbin/chkconfig
-Prereq:                /usr/sbin/useradd
-Prereq:                /usr/bin/getgid
-Prereq:                /bin/id
-Prereq:                sh-utils
-Prereq:                rc-scripts
-Prereq:                mm
-Prereq:                perl
+PreReq:                rc-scripts
+PreReq:                mm
+PreReq:                perl
+Requires(pre): sh-utils
+Requires(pre): /usr/bin/getgid
+Requires(pre): /bin/id
+Requires(pre): /usr/sbin/useradd
+Requires(post,preun):  /sbin/chkconfig
+Requires(postun):      /usr/sbin/userdel
+Requires(postun):      /usr/sbin/groupdel
 Requires:      mailcap
 Requires:      /etc/mime.types
 Requires:      psmisc >= 20.1
+Provides:      httpd
+Provides:      webserver
+Provides:      %{name}(EAPI) = %{version}
+Obsoletes:     httpd
+Obsoletes:     webserver
 Obsoletes:     apache-extra
 Obsoletes:     apache6
 Obsoletes:     apache-doc
@@ -90,6 +94,7 @@ Obsoletes:    indexhtml
 %define                _includedir     %{_prefix}/include/apache
 %define                _datadir        /home/httpd
 %define                _libexecdir     %{_prefix}/lib/apache
+%define                apxs            /usr/sbin/apxs
 
 %description
 Apache is a powerful, full-featured, efficient and freely-available
@@ -250,7 +255,7 @@ Summary(uk):        
 Summary(zh_CN):        ÓÃÓÚ Apache Web ·þÎñ³ÌÐòµÄ¿ª·¢¹¤¾ß¡£
 Group:         Networking/Utilities
 Requires:      %{name}(EAPI) = %{version}
-Provides:      %{name}(EAPI)-devel
+Provides:      %{name}(EAPI)-devel = %{version}
 
 %description devel
 The apache-devel package contains header files for Apache.
@@ -655,7 +660,7 @@ wa
 %patch6 -p0
 %patch7 -p1
 %patch8 -p1
-%{!?_without_apache_ipv6:%patch9 -p1}
+%{!?_without_ipv6:%patch9 -p1}
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
@@ -665,7 +670,7 @@ wa
 %patch16 -p1
 %patch17 -p1
 %patch18 -p1
-%{?_without_apache_ipv6:%patch19 -p1}
+%{?_without_ipv6:%patch19 -p1}
 %patch20 -p1
 %patch21 -p1
 
@@ -696,7 +701,7 @@ OPTIM="%{rpmcflags}" \
        --suexec-docroot=%{_datadir} \
        --disable-rule=WANTHSREGEX \
        --enable-rule=EAPI \
-       %{!?_without_apache_ipv6:--enable-rule=INET6}
+       %{!?_without_ipv6:--enable-rule=INET6}
 
 %{__make} LIBS1="-lm -lcrypt -lmm -ldl"
 
@@ -733,50 +738,50 @@ install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/mod_proxy.conf
 
 ln -sf index.html.en $RPM_BUILD_ROOT%{_datadir}/html/index.html
 
-gzip -9nf ABOUT_APACHE src/CHANGES README
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre
 if [ -n "`getgid http`" ]; then
        if [ "`getgid http`" != "51" ]; then
-               echo "Warning: group http haven't gid=51. Correct this before installing apache" 1>&2
+               echo "Error: group http doesn't have gid=51. Correct this before installing apache." 1>&2
                exit 1
        fi
 else
-       echo "Adding group http GID=51"
+       echo "Adding group http GID=51."
        /usr/sbin/groupadd -g 51 -r -f http
 fi
 if [ -n "`id -u http 2>/dev/null`" ]; then
        if [ "`id -u http`" != "51" ]; then
-               echo "Warning: user http haven't uid=51. Correct this before installing apache" 1>&2
+               echo "Error: user http doesn't have uid=51. Correct this before installing apache." 1>&2
                exit 1
        fi
 else
-       echo "Adding user http UID=51"
+       echo "Adding user http UID=51."
        /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
 fi
 
 %post
-/sbin/chkconfig --add httpd
-%{_sbindir}/apxs -e -a -n access %{_libexecdir}/mod_access.so 1>&2
-%{_sbindir}/apxs -e -a -n alias %{_libexecdir}/mod_alias.so 1>&2
-%{_sbindir}/apxs -e -a -n asis %{_libexecdir}/mod_asis.so 1>&2
-%{_sbindir}/apxs -e -a -n autoindex %{_libexecdir}/mod_autoindex.so 1>&2
-%{_sbindir}/apxs -e -a -n cern_meta %{_libexecdir}/mod_cern_meta.so 1>&2
-%{_sbindir}/apxs -e -a -n cgi %{_libexecdir}/mod_cgi.so 1>&2
-%{_sbindir}/apxs -e -a -n env %{_libexecdir}/mod_env.so 1>&2
-%{_sbindir}/apxs -e -a -n include %{_libexecdir}/mod_include.so 1>&2
-%{_sbindir}/apxs -e -a -n log_agent %{_libexecdir}/mod_log_agent.so 1>&2
-%{_sbindir}/apxs -e -a -n log_config %{_libexecdir}/mod_log_config.so 1>&2
-%{_sbindir}/apxs -e -a -n log_referer %{_libexecdir}/mod_log_referer.so 1>&2
-%{_sbindir}/apxs -e -a -n mime_magic %{_libexecdir}/mod_mime_magic.so 1>&2
-%{_sbindir}/apxs -e -a -n mime %{_libexecdir}/mod_mime.so 1>&2
-%{_sbindir}/apxs -e -a -n negotiation %{_libexecdir}/mod_negotiation.so 1>&2
-%{_sbindir}/apxs -e -a -n setenvif %{_libexecdir}/mod_setenvif.so 1>&2
-%{_sbindir}/apxs -e -a -n speling %{_libexecdir}/mod_speling.so 1>&2
-%{_sbindir}/apxs -e -a -n userdir %{_libexecdir}/mod_userdir.so 1>&2
+if [ $1 = 1 ]; then
+       /sbin/chkconfig --add httpd
+fi
+%{apxs} -e -a -n access %{_libexecdir}/mod_access.so 1>&2
+%{apxs} -e -a -n alias %{_libexecdir}/mod_alias.so 1>&2
+%{apxs} -e -a -n asis %{_libexecdir}/mod_asis.so 1>&2
+%{apxs} -e -a -n autoindex %{_libexecdir}/mod_autoindex.so 1>&2
+%{apxs} -e -a -n cern_meta %{_libexecdir}/mod_cern_meta.so 1>&2
+%{apxs} -e -a -n cgi %{_libexecdir}/mod_cgi.so 1>&2
+%{apxs} -e -a -n env %{_libexecdir}/mod_env.so 1>&2
+%{apxs} -e -a -n include %{_libexecdir}/mod_include.so 1>&2
+%{apxs} -e -a -n log_agent %{_libexecdir}/mod_log_agent.so 1>&2
+%{apxs} -e -a -n log_config %{_libexecdir}/mod_log_config.so 1>&2
+%{apxs} -e -a -n log_referer %{_libexecdir}/mod_log_referer.so 1>&2
+%{apxs} -e -a -n mime_magic %{_libexecdir}/mod_mime_magic.so 1>&2
+%{apxs} -e -a -n mime %{_libexecdir}/mod_mime.so 1>&2
+%{apxs} -e -a -n negotiation %{_libexecdir}/mod_negotiation.so 1>&2
+%{apxs} -e -a -n setenvif %{_libexecdir}/mod_setenvif.so 1>&2
+%{apxs} -e -a -n speling %{_libexecdir}/mod_speling.so 1>&2
+%{apxs} -e -a -n userdir %{_libexecdir}/mod_userdir.so 1>&2
 umask 137
 touch /var/log/httpd/{access,error,agent,referer}_log
 if [ -f /var/lock/subsys/httpd ]; then
@@ -787,23 +792,23 @@ fi
 
 %preun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n access %{_libexecdir}/mod_access.so 1>&2
-       %{_sbindir}/apxs -e -A -n alias %{_libexecdir}/mod_alias.so 1>&2
-       %{_sbindir}/apxs -e -A -n asis %{_libexecdir}/mod_asis.so 1>&2
-       %{_sbindir}/apxs -e -A -n autoindex %{_libexecdir}/mod_autoindex.so 1>&2
-       %{_sbindir}/apxs -e -A -n cern_meta %{_libexecdir}/mod_cern_meta.so 1>&2
-       %{_sbindir}/apxs -e -A -n cgi %{_libexecdir}/mod_cgi.so 1>&2
-       %{_sbindir}/apxs -e -A -n env %{_libexecdir}/mod_env.so 1>&2
-       %{_sbindir}/apxs -e -A -n include %{_libexecdir}/mod_include.so 1>&2
-       %{_sbindir}/apxs -e -A -n log_agent %{_libexecdir}/mod_log_agent.so 1>&2
-       %{_sbindir}/apxs -e -A -n log_config %{_libexecdir}/mod_log_config.so 1>&2
-       %{_sbindir}/apxs -e -A -n log_referer %{_libexecdir}/mod_log_referer.so 1>&2
-       %{_sbindir}/apxs -e -A -n mime %{_libexecdir}/mod_mime.so 1>&2
-       %{_sbindir}/apxs -e -A -n mime_magic %{_libexecdir}/mod_mime_magic.so 1>&2
-       %{_sbindir}/apxs -e -A -n negotiation %{_libexecdir}/mod_negotiation.so 1>&2
-       %{_sbindir}/apxs -e -A -n setenvif %{_libexecdir}/mod_setenvif.so 1>&2
-       %{_sbindir}/apxs -e -A -n speling %{_libexecdir}/mod_speling.so 1>&2
-       %{_sbindir}/apxs -e -A -n userdir %{_libexecdir}/mod_userdir.so 1>&2
+       %{apxs} -e -A -n access %{_libexecdir}/mod_access.so 1>&2
+       %{apxs} -e -A -n alias %{_libexecdir}/mod_alias.so 1>&2
+       %{apxs} -e -A -n asis %{_libexecdir}/mod_asis.so 1>&2
+       %{apxs} -e -A -n autoindex %{_libexecdir}/mod_autoindex.so 1>&2
+       %{apxs} -e -A -n cern_meta %{_libexecdir}/mod_cern_meta.so 1>&2
+       %{apxs} -e -A -n cgi %{_libexecdir}/mod_cgi.so 1>&2
+       %{apxs} -e -A -n env %{_libexecdir}/mod_env.so 1>&2
+       %{apxs} -e -A -n include %{_libexecdir}/mod_include.so 1>&2
+       %{apxs} -e -A -n log_agent %{_libexecdir}/mod_log_agent.so 1>&2
+       %{apxs} -e -A -n log_config %{_libexecdir}/mod_log_config.so 1>&2
+       %{apxs} -e -A -n log_referer %{_libexecdir}/mod_log_referer.so 1>&2
+       %{apxs} -e -A -n mime %{_libexecdir}/mod_mime.so 1>&2
+       %{apxs} -e -A -n mime_magic %{_libexecdir}/mod_mime_magic.so 1>&2
+       %{apxs} -e -A -n negotiation %{_libexecdir}/mod_negotiation.so 1>&2
+       %{apxs} -e -A -n setenvif %{_libexecdir}/mod_setenvif.so 1>&2
+       %{apxs} -e -A -n speling %{_libexecdir}/mod_speling.so 1>&2
+       %{apxs} -e -A -n userdir %{_libexecdir}/mod_userdir.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd stop 1>&2
        fi
@@ -812,14 +817,14 @@ fi
 
 %postun
 if [ "$1" = "0" ]; then
-       echo "Removing user http UID=51"
+       echo "Removing user http."
        /usr/sbin/userdel http
-       echo "Removing group http GID=51"
+       echo "Removing group http."
        /usr/sbin/groupdel http
 fi
 
 %post mod_actions
-%{_sbindir}/apxs -e -a -n actions %{_libexecdir}/mod_actions.so 1>&2
+%{apxs} -e -a -n actions %{_libexecdir}/mod_actions.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -828,14 +833,14 @@ fi
 
 %preun mod_actions
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n actions %{_libexecdir}/mod_actions.so 1>&2
+       %{apxs} -e -A -n actions %{_libexecdir}/mod_actions.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_auth
-%{_sbindir}/apxs -e -a -n auth %{_libexecdir}/mod_auth.so 1>&2
+%{apxs} -e -a -n auth %{_libexecdir}/mod_auth.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -844,14 +849,14 @@ fi
 
 %preun mod_auth
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n auth %{_libexecdir}/mod_auth.so 1>&2
+       %{apxs} -e -A -n auth %{_libexecdir}/mod_auth.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_auth_anon
-%{_sbindir}/apxs -e -a -n auth_anon %{_libexecdir}/mod_auth_anon.so 1>&2
+%{apxs} -e -a -n auth_anon %{_libexecdir}/mod_auth_anon.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -860,14 +865,14 @@ fi
 
 %preun mod_auth_anon
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n auth_anon %{_libexecdir}/mod_auth_anon.so 1>&2
+       %{apxs} -e -A -n auth_anon %{_libexecdir}/mod_auth_anon.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_auth_db
-%{_sbindir}/apxs -e -a -n auth_db %{_libexecdir}/mod_auth_db.so 1>&2
+%{apxs} -e -a -n auth_db %{_libexecdir}/mod_auth_db.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -876,14 +881,14 @@ fi
 
 %preun mod_auth_db
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n auth_db %{_libexecdir}/mod_auth_db.so 1>&2
+       %{apxs} -e -A -n auth_db %{_libexecdir}/mod_auth_db.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_auth_digest
-%{_sbindir}/apxs -e -a -n auth_digest %{_libexecdir}/mod_auth_digest.so 1>&2
+%{apxs} -e -a -n auth_digest %{_libexecdir}/mod_auth_digest.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -892,17 +897,17 @@ fi
 
 %preun mod_auth_digest
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n auth_digest %{_libexecdir}/mod_auth_digest.so 1>&2
+       %{apxs} -e -A -n auth_digest %{_libexecdir}/mod_auth_digest.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %triggerpostun mod_auth_db -- apache-mod_auth_db <= 1.3.20-2
-%{_sbindir}/apxs -e -A -n auth_dbm %{_libexecdir}/mod_auth_dbm.so 1>&2
+%{apxs} -e -A -n auth_dbm %{_libexecdir}/mod_auth_dbm.so 1>&2
 
 %post mod_define
-%{_sbindir}/apxs -e -a -n define %{_libexecdir}/mod_define.so 1>&2
+%{apxs} -e -a -n define %{_libexecdir}/mod_define.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -911,14 +916,14 @@ fi
 
 %preun mod_define
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n define %{_libexecdir}/mod_define.so 1>&2
+       %{apxs} -e -A -n define %{_libexecdir}/mod_define.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_digest
-%{_sbindir}/apxs -e -a -n digest %{_libexecdir}/mod_digest.so 1>&2
+%{apxs} -e -a -n digest %{_libexecdir}/mod_digest.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -927,14 +932,14 @@ fi
 
 %preun mod_digest
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n digest %{_libexecdir}/mod_digest.so 1>&2
+       %{apxs} -e -A -n digest %{_libexecdir}/mod_digest.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_dir
-%{_sbindir}/apxs -e -a -n dir %{_libexecdir}/mod_dir.so 1>&2
+%{apxs} -e -a -n dir %{_libexecdir}/mod_dir.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -943,14 +948,14 @@ fi
 
 %preun mod_dir
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n dir %{_libexecdir}/mod_dir.so 1>&2
+       %{apxs} -e -A -n dir %{_libexecdir}/mod_dir.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_expires
-%{_sbindir}/apxs -e -a -n expires %{_libexecdir}/mod_expires.so 1>&2
+%{apxs} -e -a -n expires %{_libexecdir}/mod_expires.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -959,14 +964,14 @@ fi
 
 %preun mod_expires
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n expires %{_libexecdir}/mod_expires.so 1>&2
+       %{apxs} -e -A -n expires %{_libexecdir}/mod_expires.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_headers
-%{_sbindir}/apxs -e -a -n headers %{_libexecdir}/mod_headers.so 1>&2
+%{apxs} -e -a -n headers %{_libexecdir}/mod_headers.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -975,14 +980,14 @@ fi
 
 %preun mod_headers
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n headers %{_libexecdir}/mod_headers.so 1>&2
+       %{apxs} -e -A -n headers %{_libexecdir}/mod_headers.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_mmap_static
-%{_sbindir}/apxs -e -a -n mmap_static %{_libexecdir}/mod_mmap_static.so 1>&2
+%{apxs} -e -a -n mmap_static %{_libexecdir}/mod_mmap_static.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -991,14 +996,14 @@ fi
 
 %preun mod_mmap_static
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n mmap_static %{_libexecdir}/mod_mmap_static.so 1>&2
+       %{apxs} -e -A -n mmap_static %{_libexecdir}/mod_mmap_static.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_imap
-%{_sbindir}/apxs -e -a -n imap %{_libexecdir}/mod_imap.so 1>&2
+%{apxs} -e -a -n imap %{_libexecdir}/mod_imap.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -1007,14 +1012,14 @@ fi
 
 %preun mod_imap
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n imap %{_libexecdir}/mod_imap.so 1>&2
+       %{apxs} -e -A -n imap %{_libexecdir}/mod_imap.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_info
-%{_sbindir}/apxs -e -a -n info %{_libexecdir}/mod_info.so 1>&2
+%{apxs} -e -a -n info %{_libexecdir}/mod_info.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -1023,14 +1028,14 @@ fi
 
 %preun mod_info
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n info %{_libexecdir}/mod_info.so 1>&2
+       %{apxs} -e -A -n info %{_libexecdir}/mod_info.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_proxy
-%{_sbindir}/apxs -e -a -n proxy %{_libexecdir}/libproxy.so 1>&2
+%{apxs} -e -a -n proxy %{_libexecdir}/libproxy.so 1>&2
 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*mod_proxy.conf" /etc/httpd/httpd.conf; then
        echo "Include /etc/httpd/mod_proxy.conf" >> /etc/httpd/httpd.conf
 fi
@@ -1042,7 +1047,7 @@ fi
 
 %preun mod_proxy
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n proxy %{_libexecdir}/libproxy.so 1>&2
+       %{apxs} -e -A -n proxy %{_libexecdir}/libproxy.so 1>&2
        grep -v "^Include.*mod_proxy.conf" /etc/httpd/httpd.conf > \
                /etc/httpd/httpd.conf.tmp
        mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
@@ -1052,7 +1057,7 @@ if [ "$1" = "0" ]; then
 fi
 
 %post mod_rewrite
-%{_sbindir}/apxs -e -a -n rewrite %{_libexecdir}/mod_rewrite.so 1>&2
+%{apxs} -e -a -n rewrite %{_libexecdir}/mod_rewrite.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -1061,14 +1066,14 @@ fi
 
 %preun mod_rewrite
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n rewrite %{_libexecdir}/mod_rewrite.so 1>&2
+       %{apxs} -e -A -n rewrite %{_libexecdir}/mod_rewrite.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_status
-%{_sbindir}/apxs -e -a -n status %{_libexecdir}/mod_status.so 1>&2
+%{apxs} -e -a -n status %{_libexecdir}/mod_status.so 1>&2
 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*mod_status.conf" /etc/httpd/httpd.conf; then
        echo "Include /etc/httpd/mod_status.conf" >> /etc/httpd/httpd.conf
 fi
@@ -1080,7 +1085,7 @@ fi
 
 %preun mod_status
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n status %{_libexecdir}/mod_status.so 1>&2
+       %{apxs} -e -A -n status %{_libexecdir}/mod_status.so 1>&2
        grep -v "^Include.*mod_status.conf" /etc/httpd/httpd.conf > \
                /etc/httpd/httpd.conf.tmp
        mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
@@ -1090,7 +1095,7 @@ if [ "$1" = "0" ]; then
 fi
 
 %post mod_usertrack
-%{_sbindir}/apxs -e -a -n usertrack %{_libexecdir}/mod_usertrack.so 1>&2
+%{apxs} -e -a -n usertrack %{_libexecdir}/mod_usertrack.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -1099,14 +1104,14 @@ fi
 
 %preun mod_usertrack
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n usertrack %{_libexecdir}/mod_usertrack.so 1>&2
+       %{apxs} -e -A -n usertrack %{_libexecdir}/mod_usertrack.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_unique_id
-%{_sbindir}/apxs -e -a -n unique_id %{_libexecdir}/mod_unique_id.so 1>&2
+%{apxs} -e -a -n unique_id %{_libexecdir}/mod_unique_id.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -1115,14 +1120,14 @@ fi
 
 %preun mod_unique_id
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n unique_id %{_libexecdir}/mod_unique_id.so 1>&2
+       %{apxs} -e -A -n unique_id %{_libexecdir}/mod_unique_id.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
 %post mod_vhost_alias
-%{_sbindir}/apxs -e -a -n vhost_alias %{_libexecdir}/mod_vhost_alias.so 1>&2
+%{apxs} -e -a -n vhost_alias %{_libexecdir}/mod_vhost_alias.so 1>&2
 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*mod_vhost_alias.conf" /etc/httpd/httpd.conf; then
        echo "Include /etc/httpd/mod_vhost_alias.conf" >> /etc/httpd/httpd.conf
 fi
@@ -1134,7 +1139,7 @@ fi
 
 %preun mod_vhost_alias
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n vhost_alias %{_libexecdir}/mod_vhost_alias.so 1>&2
+       %{apxs} -e -A -n vhost_alias %{_libexecdir}/mod_vhost_alias.so 1>&2
        grep -v "^Include.*mod_vhost_alias.conf" /etc/httpd/httpd.conf > \
                /etc/httpd/httpd.conf.tmp
        mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
@@ -1145,7 +1150,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc ABOUT_APACHE.gz src/CHANGES.gz README.gz
+%doc ABOUT_APACHE src/CHANGES README
 %doc conf/mime.types
 
 %attr(754,root,root) /etc/rc.d/init.d/httpd
@@ -1176,6 +1181,7 @@ fi
 %attr(755,root,root) %{_libexecdir}/mod_speling.so
 %attr(755,root,root) %{_libexecdir}/mod_userdir.so
 
+%attr(755,root,root) %{_bindir}/checkgid
 %attr(755,root,root) %{_bindir}/htdigest
 
 %attr(755,root,root) %{_sbindir}/ab
@@ -1185,7 +1191,7 @@ fi
 %attr(755,root,root) %{_sbindir}/logresolve
 %attr(755,root,root) %{_sbindir}/rotatelogs
 
-%dir %attr(770,root,http) /var/run/apache
+%dir %attr(1773,root,http) /var/run/apache
 
 %{_mandir}/man1/htdigest.1*
 %{_mandir}/man8/*
@@ -1213,9 +1219,11 @@ fi
 %{_datadir}/manual/bind.html.html
 %{_datadir}/manual/bind.html.en
 %lang(fr) %{_datadir}/manual/bind.html.fr
+%lang(ja) %{_datadir}/manual/bind.html.ja.jis
 %{_datadir}/manual/cgi_path.html.html
 %{_datadir}/manual/cgi_path.html.en
 %lang(fr) %{_datadir}/manual/cgi_path.html.fr
+%lang(ja) %{_datadir}/manual/cgi_path.html.ja.jis
 %{_datadir}/manual/configuring.html.html
 %{_datadir}/manual/configuring.html.en
 %lang(fr) %{_datadir}/manual/configuring.html.fr
@@ -1258,8 +1266,12 @@ fi
 %{_datadir}/manual/new_features_1_3.html.html
 %{_datadir}/manual/new_features_1_3.html.en
 %lang(ja) %{_datadir}/manual/new_features_1_3.html.ja.jis
-%{_datadir}/manual/process-model.html
-%{_datadir}/manual/sections.html
+%{_datadir}/manual/process-model.html.html
+%{_datadir}/manual/process-model.html.en
+%lang(ja) %{_datadir}/manual/process-model.html.ja.jis
+%{_datadir}/manual/sections.html.html
+%{_datadir}/manual/sections.html.en
+%lang(ja) %{_datadir}/manual/sections.html.ja.jis
 %{_datadir}/manual/server-wide.html.html
 %{_datadir}/manual/server-wide.html.en
 %lang(fr) %{_datadir}/manual/server-wide.html.fr
@@ -1298,16 +1310,23 @@ fi
 %{_datadir}/manual/mod/index-bytype.html.html
 %{_datadir}/manual/mod/index-bytype.html.en
 %lang(fr) %{_datadir}/manual/mod/index-bytype.html.fr
+%lang(ja) %{_datadir}/manual/mod/index-bytype.html.ja.jis
 %{_datadir}/manual/mod/index.html.html
 %{_datadir}/manual/mod/index.html.en
 %lang(fr) %{_datadir}/manual/mod/index.html.fr
 %lang(ja) %{_datadir}/manual/mod/index.html.ja.jis
-%{_datadir}/manual/mod/mod_access.html
+%{_datadir}/manual/mod/mod_access.html.html
+%{_datadir}/manual/mod/mod_access.html.en
+%lang(ja) %{_datadir}/manual/mod/mod_access.html.ja.jis
 %{_datadir}/manual/mod/mod_alias.html
-%{_datadir}/manual/mod/mod_asis.html
+%{_datadir}/manual/mod/mod_asis.html.html
+%{_datadir}/manual/mod/mod_asis.html.en
+%lang(ja) %{_datadir}/manual/mod/mod_asis.html.ja.jis
 %{_datadir}/manual/mod/mod_autoindex.html
-%{_datadir}/manual/mod/mod_cgi.html
 %{_datadir}/manual/mod/mod_cern_meta.html
+%{_datadir}/manual/mod/mod_cgi.html.html
+%{_datadir}/manual/mod/mod_cgi.html.en
+%lang(ja) %{_datadir}/manual/mod/mod_cgi.html.ja.jis
 %{_datadir}/manual/mod/mod_env.html.html
 %{_datadir}/manual/mod/mod_env.html.en
 %lang(ja) %{_datadir}/manual/mod/mod_env.html.ja.jis
@@ -1325,22 +1344,34 @@ fi
 %{_datadir}/manual/mod/mod_setenvif.html.html
 %{_datadir}/manual/mod/mod_setenvif.html.en
 %lang(ja) %{_datadir}/manual/mod/mod_setenvif.html.ja.jis
-%{_datadir}/manual/mod/mod_so.html
-%{_datadir}/manual/mod/mod_speling.html
-%{_datadir}/manual/mod/mod_userdir.html
+%{_datadir}/manual/mod/mod_so.html.html
+%{_datadir}/manual/mod/mod_so.html.en
+%lang(ja) %{_datadir}/manual/mod/mod_so.html.ja.jis
+%{_datadir}/manual/mod/mod_speling.html.html
+%{_datadir}/manual/mod/mod_speling.html.en
+%lang(ja) %{_datadir}/manual/mod/mod_speling.html.ja.jis
+%{_datadir}/manual/mod/mod_userdir.html.html
+%{_datadir}/manual/mod/mod_userdir.html.en
+%lang(ja) %{_datadir}/manual/mod/mod_userdir.html.ja.jis
 %{_datadir}/manual/mod/module-dict.html.html
 %{_datadir}/manual/mod/module-dict.html.en
 %lang(ja) %{_datadir}/manual/mod/module-dict.html.ja.jis
 %dir %{_datadir}/manual/programs
 %{_datadir}/manual/programs/ab.html
-%{_datadir}/manual/programs/apachectl.html
+%{_datadir}/manual/programs/apachectl.html.html
+%{_datadir}/manual/programs/apachectl.html.en
+%lang(ja) %{_datadir}/manual/programs/apachectl.html.ja.jis
 %{_datadir}/manual/programs/apxs.html
 %{_datadir}/manual/programs/dbmmanage.html
 %{_datadir}/manual/programs/footer.html
 %{_datadir}/manual/programs/header.html
 %{_datadir}/manual/programs/htdigest.html
-%{_datadir}/manual/programs/htpasswd.html
-%{_datadir}/manual/programs/httpd.html
+%{_datadir}/manual/programs/htpasswd.html.html
+%{_datadir}/manual/programs/htpasswd.html.en
+%lang(ja) %{_datadir}/manual/programs/htpasswd.html.ja.jis
+%{_datadir}/manual/programs/httpd.html.html
+%{_datadir}/manual/programs/httpd.html.en
+%lang(ja) %{_datadir}/manual/programs/httpd.html.ja.jis
 %{_datadir}/manual/programs/index.html.html
 %{_datadir}/manual/programs/index.html.en
 %lang(ja) %{_datadir}/manual/programs/index.html.ja.jis
@@ -1350,7 +1381,9 @@ fi
 %dir %{_datadir}/manual/vhosts
 %{_datadir}/manual/vhosts/details.html
 %{_datadir}/manual/vhosts/examples.html
-%{_datadir}/manual/vhosts/fd-limits.html
+%{_datadir}/manual/vhosts/fd-limits.html.html
+%{_datadir}/manual/vhosts/fd-limits.html.en
+%lang(ja) %{_datadir}/manual/vhosts/fd-limits.html.ja.jis
 %{_datadir}/manual/vhosts/footer.html
 %{_datadir}/manual/vhosts/header.html
 %{_datadir}/manual/vhosts/host.html
@@ -1381,7 +1414,7 @@ fi
 %lang(it) %{_datadir}/html/index.html.it
 %lang(ja) %{_datadir}/html/index.html.ja.jis
 %lang(ko) %{_datadir}/html/index.html.kr.iso-kr
-%lang(de_LU) %{_datadir}/html/index.html.lu
+%lang(de_LU) %{_datadir}/html/index.html.lb.utf8
 %lang(nl) %{_datadir}/html/index.html.nl
 %lang(nn) %{_datadir}/html/index.html.nn
 %lang(no) %{_datadir}/html/index.html.no
@@ -1396,14 +1429,16 @@ fi
 %lang(ru) %{_datadir}/html/index.html.ru.ucs4
 %lang(ru) %{_datadir}/html/index.html.ru.utf8
 %lang(sv) %{_datadir}/html/index.html.se
-%lang(zh_TW) %{_datadir}/html/index.html.zh.Big5
+%lang(zh_TW) %{_datadir}/html/index.html.zh
 
 %{_datadir}/html/*.gif
 %{_datadir}/errordocs
 %dir %{_datadir}/icons
 %{_datadir}/icons/*.gif
+%{_datadir}/icons/*.png
 %dir %{_datadir}/icons/small
 %{_datadir}/icons/small/*.gif
+%{_datadir}/icons/small/*.png
 %attr(755,root,root) %{_datadir}/cgi-bin
 
 %files suexec
@@ -1412,7 +1447,9 @@ fi
 %{_datadir}/manual/suexec.html.html
 %{_datadir}/manual/suexec.html.en
 %lang(ja) %{_datadir}/manual/suexec.html.ja.jis
-%{_datadir}/manual/programs/suexec.html
+%{_datadir}/manual/programs/suexec.html.html
+%{_datadir}/manual/programs/suexec.html.en
+%lang(ja) %{_datadir}/manual/programs/suexec.html.ja.jis
 
 %files devel
 %defattr(644,root,root,755)
@@ -1421,12 +1458,15 @@ fi
 %files mod_actions
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libexecdir}/mod_actions.so
-%{_datadir}/manual/mod/mod_actions.html
+%{_datadir}/manual/mod/mod_actions.html.html
+%{_datadir}/manual/mod/mod_actions.html.en
+%lang(ja) %{_datadir}/manual/mod/mod_actions.html.ja.jis
 
 %files mod_auth
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libexecdir}/mod_auth.so
 %attr(755,root,root) %{_bindir}/htpasswd
+%{_datadir}/manual/howto/auth.html
 %{_datadir}/manual/mod/mod_auth.html
 
 %files mod_auth_anon
@@ -1487,7 +1527,9 @@ fi
 %files mod_info
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libexecdir}/mod_info.so
-%{_datadir}/manual/mod/mod_info.html
+%{_datadir}/manual/mod/mod_info.html.html
+%{_datadir}/manual/mod/mod_info.html.en
+%lang(ja) %{_datadir}/manual/mod/mod_info.html.ja.jis
 
 %files mod_proxy
 %defattr(644,root,root,755)
@@ -1517,7 +1559,9 @@ fi
 %files mod_unique_id
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libexecdir}/mod_unique_id.so
-%{_datadir}/manual/mod/mod_unique_id.html
+%{_datadir}/manual/mod/mod_unique_id.html.html
+%{_datadir}/manual/mod/mod_unique_id.html.en
+%lang(ja) %{_datadir}/manual/mod/mod_unique_id.html.ja.jis
 
 %files mod_vhost_alias
 %defattr(644,root,root,755)
This page took 1.266892 seconds and 4 git commands to generate.