]> git.pld-linux.org Git - packages/apache-mod_perl.git/blobdiff - apache-mod_perl.spec
- up to 2.0.10
[packages/apache-mod_perl.git] / apache-mod_perl.spec
index 702dab48a96aa17aea20357cb1e57bfca7287019..f589ad58018afb72a62c177e42d42871139e95b4 100644 (file)
@@ -9,6 +9,7 @@
 %define                apxs    /usr/sbin/apxs
 %define                mod_name        perl
 
+%define        ver     2.0.10
 Summary:       A Perl interpreter for the Apache Web server
 Summary(cs.UTF-8):     Vestavěný interpret Perlu pro WWW server Apache
 Summary(da.UTF-8):     En indbygget Perl-fortolker for webtjeneren Apache
@@ -29,31 +30,25 @@ Summary(sv.UTF-8):  En inbyggd Perl-interpretator för webbservern Apache
 Summary(uk.UTF-8):     Модуль вбудовування інтерпретатора Perl в сервер Apache
 Summary(zh_CN.UTF-8):  用于 Apache web 服务程序的 Perl 解释程序。
 Name:          apache-mod_perl
-%define        ver     2.0.4
 Version:       %{ver}
-Release:       4
+Release:       1
 Epoch:         1
 License:       Apache
 Group:         Networking/Daemons/HTTP
-Source0:       http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
-# Source0-md5: 1a05625ae6843085f985f5da8214502a
+Source0:       http://www.apache.org/dist/perl/mod_perl-%{ver}.tar.gz
+# Source0-md5: cef55e715b5770a63b3becbe9d271121
 Source1:       %{name}.conf
 Patch0:                %{name}-Makefile_PL.patch
-Patch1:                %{name}-path_info_secfix.patch
-Patch2:                %{name}-magic.patch
 URL:           http://perl.apache.org/
-# Fix in svn:
-# http://svn.apache.org/viewvc/perl/modperl/trunk/lib/Apache2/Status.pm?view=log
-BuildRequires: security(CVE-2009-0796)
 BuildRequires: apache-devel >= 2.0.55-1
 BuildRequires: apr-util-devel >= 1:1.0.0
 BuildRequires: expat-devel
 BuildRequires: gdbm-devel
 BuildRequires: openldap-devel >= 2.4.6
 %{?with_autodeps:BuildRequires:        perl-Data-Flow}
-BuildRequires: perl-devel >= 1:5.8.2
+BuildRequires: perl-devel >= 1:5.18.0
 BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.671
 %if %{with tests}
 BuildRequires: apache-mod_auth_basic
 BuildRequires: apache-mod_authz_host
@@ -66,9 +61,13 @@ BuildRequires:       perl-CGI >= 3.22
 %endif
 # older apache-mod_perl could make bad autodeps to perl-mod_perl
 BuildConflicts:        apache-mod_perl < 1:2.0.2-9
+Requires(post,preun,postun):   systemd-units >= 38
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      perl-mod_%{mod_name} = %{epoch}:%{version}-%{release}
+Requires:      rc-scripts
+Requires:      systemd-units >= 38
 Provides:      apache(mod_perl)
+Obsoletes:     perl-Apache-Reload
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # TODO: separate -devel with ExtUtils::Embed and friends?
@@ -237,7 +236,7 @@ Perlowe API dla mod_perla.
 %package -n perl-Apache-Test
 Summary:       Apache::Test - Test.pm wrapper with helpers for testing Apache
 Summary(pl.UTF-8):     Apache::Test - wrapper na Test.pm z funkcjami do testowania Apache
-Version:       1.31
+Version:       1.40
 Group:         Development/Languages/Perl
 Requires:      perl-mod_%{mod_name} = %{epoch}:%{ver}-%{release}
 Requires:      perl-dirs >= 2.0-5
@@ -262,8 +261,8 @@ pomocnicze do testowania serwera Apache.
        INSTALLDIRS=vendor
 
 %{__make} \
-       OPTIMIZE="%{rpmcflags}" \
-       MODPERL_OPTIMIZE="%{rpmcflags}" \
+       OPTIMIZE="%{rpmcflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
+       MODPERL_OPTIMIZE="%{rpmcflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
        CC="%{__cc}" \
        MP_APXS=%{apxs}
 
@@ -281,28 +280,36 @@ install xs/tables/current/Apache2/* $RPM_BUILD_ROOT%{perl_vendorarch}/Apache2
 install xs/tables/current/APR/* $RPM_BUILD_ROOT%{perl_vendorarch}/APR
 install xs/tables/current/ModPerl/* $RPM_BUILD_ROOT%{perl_vendorarch}/ModPerl
 
-rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle
-rm -f $RPM_BUILD_ROOT%{_mandir}/man?/Bundle*
-rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
-rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/mod_perl2/.packlist
 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/75_mod_perl.conf
 
+# apache1-specific version - but mod_perl1 contains older Apache::SizeLimit which doesn't use shared Apache::SizeLimit::Core
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Apache/SizeLimit.pm \
+       $RPM_BUILD_ROOT%{_mandir}/man3/Apache::SizeLimit.3pm
+# don't package Bundle::*
+%{__rm} -r $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/Bundle*
+# perl-specific cleanup
+%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/mod_perl2/.packlist
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 %service -q httpd restart
+%systemd_service_restart httpd.service
 
 %postun
 if [ "$1" = "0" ]; then
        %service -q httpd restart
+       %systemd_service_restart httpd.service
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc Changes INSTALL README STATUS
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*.conf
-%attr(755,root,root) %{apachelibdir}/*.so
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/75_mod_perl.conf
+%attr(755,root,root) %{apachelibdir}/mod_perl.so
 
 %files devel
 %defattr(644,root,root,755)
@@ -313,22 +320,26 @@ fi
 %defattr(644,root,root,755)
 %{perl_vendorarch}/APR.pm
 %{perl_vendorarch}/APR
+%{perl_vendorarch}/Apache/Reload.pm
+%{perl_vendorarch}/Apache/SizeLimit
 %{perl_vendorarch}/Apache2
 %{perl_vendorarch}/ModPerl
 %{perl_vendorarch}/mod_perl2.pm
 %dir %{perl_vendorarch}/auto/APR
-%{perl_vendorarch}/auto/APR/APR.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/APR/APR.so
 %dir %{perl_vendorarch}/auto/APR/[B-U]*
+%attr(755,root,root) %{perl_vendorarch}/auto/APR/[B-U]*/*.so
 %dir %{perl_vendorarch}/auto/Apache2
 %dir %{perl_vendorarch}/auto/Apache2/[A-U]*
+%{perl_vendorarch}/auto/Apache2/Build/autosplit.ix
+%attr(755,root,root) %{perl_vendorarch}/auto/Apache2/[A-U]*/*.so
 %{perl_vendorarch}/auto/Apache2/typemap
 %dir %{perl_vendorarch}/auto/ModPerl
-%dir %{perl_vendorarch}/auto/ModPerl/*
-%{perl_vendorarch}/auto/*/*/*.ix
-%{perl_vendorarch}/auto/*/*/*.bs
-%attr(755,root,root) %{perl_vendorarch}/auto/*/*/*.so
+%dir %{perl_vendorarch}/auto/ModPerl/[C-U]*
+%attr(755,root,root) %{perl_vendorarch}/auto/ModPerl/[C-U]*/*.so
 %{_mandir}/man3/APR*.3pm*
+%{_mandir}/man3/Apache::Reload.3pm*
+%{_mandir}/man3/Apache::SizeLimit::Core.3pm*
 %{_mandir}/man3/Apache2::*.3pm*
 %{_mandir}/man3/ModPerl::*.3pm*
 %{_mandir}/man3/mod_perl2.3pm*
This page took 0.06383 seconds and 4 git commands to generate.