]> git.pld-linux.org Git - packages/apache-mod_perl.git/blobdiff - apache-mod_perl.spec
- ver. 2.0.6
[packages/apache-mod_perl.git] / apache-mod_perl.spec
index 0ebfc07d8a16cfdaaf5689d141bb29d609b26702..30185fbca544e70fc71b9ce0474b20a484867c07 100644 (file)
@@ -8,8 +8,7 @@
 %include       /usr/lib/rpm/macros.perl
 %define                apxs    /usr/sbin/apxs
 %define                mod_name        perl
-# NB! leave this without *release*
-%define        apache_test_version     1.29
+
 Summary:       A Perl interpreter for the Apache Web server
 Summary(cs.UTF-8):     Vestavěný interpret Perlu pro WWW server Apache
 Summary(da.UTF-8):     En indbygget Perl-fortolker for webtjeneren Apache
@@ -30,13 +29,14 @@ Summary(sv.UTF-8):  En inbyggd Perl-interpretator för webbservern Apache
 Summary(uk.UTF-8):     Модуль вбудовування інтерпретатора Perl в сервер Apache
 Summary(zh_CN.UTF-8):  用于 Apache web 服务程序的 Perl 解释程序。
 Name:          apache-mod_perl
-Version:       2.0.3
+%define        ver     2.0.6
+Version:       %{ver}
 Release:       1
 Epoch:         1
 License:       Apache
-Group:         Networking/Daemons
+Group:         Networking/Daemons/HTTP
 Source0:       http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
-# Source0-md5: b40e2adf67c6be15a0041af1c67b6997
+# Source0-md5: 76f4154cffb15972246f03080e9d133c
 Source1:       %{name}.conf
 Patch0:                %{name}-Makefile_PL.patch
 URL:           http://perl.apache.org/
@@ -44,8 +44,7 @@ BuildRequires:        apache-devel >= 2.0.55-1
 BuildRequires: apr-util-devel >= 1:1.0.0
 BuildRequires: expat-devel
 BuildRequires: gdbm-devel
-BuildRequires: openldap-devel >= 2.3.0
-BuildRequires: perl-Apache-Test >= 1:%{apache_test_version}
+BuildRequires: openldap-devel >= 2.4.6
 %{?with_autodeps:BuildRequires:        perl-Data-Flow}
 BuildRequires: perl-devel >= 1:5.8.2
 BuildRequires: rpm-perlprov >= 3.0.3-16
@@ -69,8 +68,8 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # TODO: separate -devel with ExtUtils::Embed and friends?
 %define                _noautoreq      'perl(Apache::.*)' 'perl(mod_perl)' 'perl(ModPerl::.*)' 'perl(ExtUtils::Embed)' 'perl(Module::Build)'
-%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
-%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
+%define                apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 
 %description
 Mod_perl incorporates a Perl interpreter into the Apache web server,
@@ -207,9 +206,6 @@ Summary:    Files needed for building XS modules that use mod_perl
 Summary(pl.UTF-8):     Pliki potrzebne do budowania modułów XS korzystających z mod_perla
 Group:         Development/Libraries
 Requires:      apache-devel >= 2.0
-Requires:      perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
-Requires:      perl-Apache-Test
-Requires:      perl-mod_%{mod_name} = %{epoch}:%{version}-%{release}
 Obsoletes:     mod_perl
 Obsoletes:     mod_perl-common
 Conflicts:     perl-modules < 1:5.8.6-6
@@ -233,17 +229,26 @@ Perl APIs for mod_perl.
 %description -n perl-mod_%{mod_name} -l pl.UTF-8
 Perlowe API dla mod_perla.
 
+%package -n perl-Apache-Test
+Summary:       Apache::Test - Test.pm wrapper with helpers for testing Apache
+Summary(pl.UTF-8):     Apache::Test - wrapper na Test.pm z funkcjami do testowania Apache
+Version:       1.36
+Group:         Development/Languages/Perl
+Requires:      perl-mod_%{mod_name} = %{epoch}:%{ver}-%{release}
+Requires:      perl-dirs >= 2.0-5
+
+%description -n perl-Apache-Test
+Apache::Test is a wrapper around the standard Test.pm with helpers for
+testing an Apache server.
+
+%description -n perl-Apache-Test -l pl.UTF-8
+Apache::Test to moduł obudowujący standardowy Test.pm w funkcje
+pomocnicze do testowania serwera Apache.
+
 %prep
-%setup -q -n mod_%{mod_name}-%{version}
+%setup -q -n mod_%{mod_name}-%{ver}
 %patch0 -p1
 
-bundled=$(%{__perl} -IApache-Test/lib -MApache::Test -e 'print Apache::Test->VERSION')
-if [ "%apache_test_version" != "$bundled" ]; then
-       : "%%define apache_test_version to $bundled and retry."
-       exit 1
-fi
-rm -rf Apache-Test
-
 %build
 %{__perl} Makefile.PL \
        MP_APXS=%{apxs} \
@@ -261,9 +266,9 @@ rm -rf Apache-Test
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
+install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
 
-%{__make} install \
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 find $RPM_BUILD_ROOT -name \*.orig -exec rm -f '{}' \;
 
@@ -271,11 +276,17 @@ install xs/tables/current/Apache2/* $RPM_BUILD_ROOT%{perl_vendorarch}/Apache2
 install xs/tables/current/APR/* $RPM_BUILD_ROOT%{perl_vendorarch}/APR
 install xs/tables/current/ModPerl/* $RPM_BUILD_ROOT%{perl_vendorarch}/ModPerl
 
-rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle
-rm -f $RPM_BUILD_ROOT%{_mandir}/man?/Bundle*
-rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
-rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/mod_perl2/.packlist
-install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/75_mod_perl.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/75_mod_perl.conf
+
+# apache1-specific version - but mod_perl1 contains older Apache::SizeLimit which doesn't use shared Apache::SizeLimit::Core
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Apache/SizeLimit.pm \
+       $RPM_BUILD_ROOT%{_mandir}/man3/Apache::SizeLimit.3pm
+# don't package Bundle::*
+%{__rm} -r $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/Bundle*
+# perl-specific cleanup
+%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/mod_perl2/.packlist
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -291,28 +302,47 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc Changes INSTALL README STATUS
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*.conf
-%attr(755,root,root) %{_pkglibdir}/*.so
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/75_mod_perl.conf
+%attr(755,root,root) %{apachelibdir}/mod_perl.so
+
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}/apache/mod_perl.h
+%{_includedir}/apache/modperl_*.h
 
 %files -n perl-mod_%{mod_name}
 %defattr(644,root,root,755)
-%{perl_vendorarch}/*.pm
+%{perl_vendorarch}/APR.pm
 %{perl_vendorarch}/APR
+%{perl_vendorarch}/Apache/Reload.pm
+%{perl_vendorarch}/Apache/SizeLimit
 %{perl_vendorarch}/Apache2
 %{perl_vendorarch}/ModPerl
-
-%dir %{perl_vendorarch}/auto/*
-%{perl_vendorarch}/auto/*/*.bs
-%attr(755,root,root) %{perl_vendorarch}/auto/*/*.so
+%{perl_vendorarch}/mod_perl2.pm
+%dir %{perl_vendorarch}/auto/APR
+%{perl_vendorarch}/auto/APR/APR.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/APR/APR.so
 %dir %{perl_vendorarch}/auto/APR/[B-U]*
+%{perl_vendorarch}/auto/APR/[B-U]*/*.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/APR/[B-U]*/*.so
+%dir %{perl_vendorarch}/auto/Apache2
 %dir %{perl_vendorarch}/auto/Apache2/[A-U]*
-%dir %{perl_vendorarch}/auto/ModPerl/*
-%{perl_vendorarch}/auto/*/*/*.ix
-%{perl_vendorarch}/auto/*/*/*.bs
-%attr(755,root,root) %{perl_vendorarch}/auto/*/*/*.so
+%{perl_vendorarch}/auto/Apache2/Build/autosplit.ix
+%{perl_vendorarch}/auto/Apache2/[A-U]*/*.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/Apache2/[A-U]*/*.so
 %{perl_vendorarch}/auto/Apache2/typemap
-%{_mandir}/man?/*
-
-%files devel
+%dir %{perl_vendorarch}/auto/ModPerl
+%dir %{perl_vendorarch}/auto/ModPerl/[C-U]*
+%{perl_vendorarch}/auto/ModPerl/[C-U]*/*.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/ModPerl/[C-U]*/*.so
+%{_mandir}/man3/APR*.3pm*
+%{_mandir}/man3/Apache::Reload.3pm*
+%{_mandir}/man3/Apache::SizeLimit::Core.3pm*
+%{_mandir}/man3/Apache2::*.3pm*
+%{_mandir}/man3/ModPerl::*.3pm*
+%{_mandir}/man3/mod_perl2.3pm*
+
+%files -n perl-Apache-Test
 %defattr(644,root,root,755)
-%{_includedir}/apache/*.h
+%{perl_vendorarch}/Apache/Test*
+%{_mandir}/man3/Apache::Test*.3pm*
This page took 0.035549 seconds and 4 git commands to generate.