]> git.pld-linux.org Git - packages/apache-mod_gzip.git/blobdiff - apache-mod_gzip.spec
- up to 2.1.0
[packages/apache-mod_gzip.git] / apache-mod_gzip.spec
index b3a1dfed8ee717badca6fbb25a10e46df78d46a7..58c66836f0ec4bfc53fd36b5151a6ddd6c681512 100644 (file)
@@ -1,83 +1,69 @@
 %define                mod_name        gzip
 %define        apxs            /usr/sbin/apxs
 Summary:       Apache module: On-the-fly compression of HTML documents
-Summary(pl):   Modu³ do apache: kompresuje dokumenty HTML w locie
+Summary(pl.UTF-8):     Moduł do apache: kompresuje dokumenty HTML w locie
 Name:          apache-mod_%{mod_name}
-Version:       1.3.19.1a
-Release:       1
-License:       Apache Software License
-Group:         Networking/Daemons
-Group(cs):     Sí»ové/Démoni
-Group(da):     Netværks/Dæmoner
-Group(de):     Netzwerkwesen/Server
-Group(es):     Red/Servidores
-Group(fr):     Réseau/Serveurs
-Group(is):     Net/Púkar
-Group(it):     Rete/Demoni
-Group(no):     Nettverks/Daemoner
-Group(pl):     Sieciowe/Serwery
-Group(pt):     Rede/Servidores
-Group(ru):     óÅÔØ/äÅÍÏÎÙ
-Group(sl):     Omre¾ni/Stre¾niki
-Group(sv):     Nätverk/Demoner
-Group(uk):     íÅÒÅÖÁ/äÅÍÏÎÉ
-Source0:       http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/mod_%{mod_name}.c
-Source1:       http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/changes.txt
-Source2:       http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/commands.txt
-Source3:       http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/samples.txt
+Version:       2.1.0
+Release:       0.1
+License:       Apache
+Group:         Networking/Daemons/HTTP
+Source0:       http://www.gknw.net/development/apache/httpd-2.0/unix/modules/mod_%{mod_name}-%{version}.tar.gz
+# Source0-md5: 9011aa2dc4701c0301e6c608269f8835
+Source1:       %{name}.conf
+Source2:       %{name}.logrotate
+URL:           http://www.gknw.net/development/apache/
 BuildRequires: %{apxs}
-BuildRequires: apache(EAPI)-devel
+BuildRequires: apache-devel >= 2.0.40
+BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: zlib-devel
-Prereq:                %{_sbindir}/apxs
-Requires:      apache(EAPI)
+Requires:      apache(modules-api) = %apache_modules_api
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
 Apache module: On-the-fly compression of HTML documents. Browser will
 transparently decompress and display such documents.
 
-%description -l pl
-Modu³ do apache: kompresuje dokumenty HTML w locie. Przegl±darki w
-sposób przezroczysty dekompresuj± i wy¶wietlaj± takie dokumenty.
+%description -l pl.UTF-8
+Moduł do apache: kompresuje dokumenty HTML w locie. Przeglądarki w
+sposób przezroczysty dekompresują i wyświetlają takie dokumenty.
 
-%prep 
-%setup -q -T -c
-cp %{SOURCE0} .
-cp %{SOURCE1} .
-cp %{SOURCE2} .
-cp %{SOURCE3} .
+%prep
+%setup -q -n mod_%{mod_name}-%{version}
 
 %build
-%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
+%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.la
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf,/etc/logrotate.d,/var/log/httpd}
 
-install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
-gzip -9nf *.txt
+touch $RPM_BUILD_ROOT/var/log/httpd/mod_gzip_log
+
+install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       %{_sysconfdir}/rc.d/init.d/httpd restart 1>&2
-fi
+%service -q httpd restart
+touch /var/log/httpd/mod_gzip_log && chown root:http /var/log/httpd/mod_gzip_log && chmod 620 /var/log/httpd/mod_gzip_log
 
-%preun
+%postun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+       %service -q httpd restart
 fi
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%attr(755,root,root) %{_pkglibdir}/*
+%doc *.txt logos/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
+# append by webserver
+%attr(620,root,http) %ghost /var/log/httpd/mod_gzip_log
This page took 0.032201 seconds and 4 git commands to generate.