]> git.pld-linux.org Git - packages/anyterm.git/blobdiff - anyterm.spec
- remove extra unneeded slash
[packages/anyterm.git] / anyterm.spec
index 1a0aba94b5b5da3e3a7c7c6cdaffebbc33c641fd..726f5c03d9799de1ad1cf903b4f8abf00c611948 100644 (file)
@@ -1,8 +1,13 @@
+# TODO
+# - anygetty hangs due /bin/login calling vhangup()
+#   http://anyterm.org/1.0/config.html
+# - put anygetty to separate package?
 %define        apxs            /usr/sbin/apxs
 Summary:       Terminal emulator in a web browser
+Summary(pl):   Emulator terminala dzia³aj±cy w przegl±darce WWW
 Name:          anyterm
 Version:       1.1.4
-Release:       0.7
+Release:       0.10
 Epoch:         0
 License:       GPL
 Group:         Networking/Daemons
@@ -10,20 +15,24 @@ Source0:    http://anyterm.org/download/%{name}-%{version}.tbz2
 # Source0-md5: cf841703b7438866e573f5a33137ff6f
 Patch0:                %{name}-makefile.patch
 URL:           http://anyterm.org/
+BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.0.52-2
 BuildRequires: apr-devel
 BuildRequires: rote-devel >= 0.2.8
 BuildRequires: rpmbuild(macros) >= 1.228
-BuildRequires: %{apxs}
 Requires:      apache >= 2.0.52-2
+Requires:      apache(modules-api) = %apache_modules_api
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _appdir         %{_datadir}/%{name}
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
-%define                _sysconfdir /etc/httpd
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
-An apache module plus scripts to make a terminal within a web browser.
+An Apache module plus scripts to make a terminal within a web browser.
+
+%description -l pl
+Modu³ Apache'a i skrypty tworz±ce terminal w przegl±darce WWW.
 
 %prep
 %setup -q
@@ -52,28 +61,38 @@ LoadModule anyterm modules/%{name}.so
 
        <Files anyterm-module>
                SetHandler anyterm
+               <IfModule mod_setenv.c>
+                       # for this to work you need to change CustomLog:
+                       # CustomLog /path/to/logfile combined env=!DONTLOG
+                       # http://anyterm.org/security.html
+                       SetEnv DONTLOG
+               </IfModule>
        </Files>
 
-#      <Location /%{name}>
-#              allow from all
-#      </Location>
-
-    <Location /%{name}>
-        AuthType Basic
-        AuthUserFile /etc/httpd/user
-        AuthGroupFile /etc/httpd/group
-        AuthName "AnyTerm"
-        require group anyterm
-        satisfy any
-        order allow,deny
-    </Location>
+       <IfModule !mod_auth.c>
+               <Location /%{name}>
+                       allow from all
+               </Location>
+       </IfModule>
+
+       <IfModule mod_auth.c>
+               <Location /%{name}>
+                       AuthType Basic
+                       AuthUserFile /etc/httpd/user
+                       AuthGroupFile /etc/httpd/group
+                       AuthName "AnyTerm"
+                       require group anyterm
+                       satisfy any
+                       order allow,deny
+               </Location>
+       </IfModule>
 </IfModule>
 # vim: filetype=apache ts=4 sw=4 et
 END
 
 install apachemod/.libs/%{name}.so $RPM_BUILD_ROOT%{_pkglibdir}/%{name}.so
 cp -a browser/* $RPM_BUILD_ROOT%{_appdir}
-install anygetty/anygetty $RPM_BUILD_ROOT/%{_sbindir}
+install anygetty/anygetty $RPM_BUILD_ROOT%{_sbindir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -81,11 +100,10 @@ rm -rf $RPM_BUILD_ROOT
 %post
 %service httpd restart
 
-if [ "$1" = 1 ]; then
-       %banner %{name} <<-EOF
-       To use anygetty, you need to setuid it.
-       EOF
-fi
+%banner %{name} <<-EOF
+To use anygetty, you need to setuid it:
+chmod 4755 %{_sbindir}/anygetty
+EOF
 
 %preun
 if [ "$1" = "0" ]; then
This page took 0.10788 seconds and 4 git commands to generate.