]> git.pld-linux.org Git - packages/aethera.git/blobdiff - aethera.spec
- tabs in preamble
[packages/aethera.git] / aethera.spec
index ef368211cf474683eb75178d0d8f9f567d04a1bd..c18e41c6f27de6f3e95ab15119764ac61d6d2427 100644 (file)
@@ -1,6 +1,7 @@
-%define                _rel    0.1
+# TODO: optflags
+%define                _rel    0.3
 Summary:       Aethera - Email and PIM application
-Summary(pl):   Aethera - aplikacja e-mail i zarz±dcy informacji osobistej (PIM)
+Summary(pl.UTF-8):     Aethera - aplikacja poczty elektronicznej i zarządcy informacji osobistej (PIM)
 Name:          aethera
 Version:       1.2.1
 Release:       050331.%{_rel}
@@ -10,9 +11,12 @@ Source0:     %{name}-%{version}.tar.gz
 Patch0:                %{name}-libs.patch
 Patch1:                %{name}-includes.patch
 Patch2:                %{name}-install.patch
+Patch3:                %{name}-fpic.patch
+Patch4:                %{name}-typo.patch
 # Source0-md5: f3efd064b5e9884bd7adf49bf763e213
 URL:           http://www.thekompany.com/projects/aethera/
 BuildRequires: korelib-devel
+BuildRequires: qmake
 BuildRequires: qt-devel
 #Requires: thekompany-support
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -21,24 +25,32 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Aethera is a pim application, i.e. it handles all kinds of personal
 information: email, contacts, notes, tasks, todos, journals.
 
-%description -l pl
-Aethera jest aplikacj± zarz±dcy informacji osobistej (PIM). Obs³uguje
-wszystkie rodzaje informacji osobistych: e-mail, kontakty, notatki,
-zadania, sprawy do za³atwienia, dzienniki.
+%description -l pl.UTF-8
+Aethera jest aplikacją zarządcy informacji osobistej (PIM). Obsługuje
+wszystkie rodzaje informacji osobistych: pocztę elektroniczną,
+kontakty, notatki, zadania, sprawy do załatwienia, dzienniki.
 
 %package devel
-Summary:       Header files for Aethera
+Summary:       Header files for Aethera libraries
+Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek Aethery
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
-Header files for Aethera library.
+Header files for Aethera libraries.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe bibliotek Aethery.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%ifarch %{x8664}
+%patch3 -p1
+%endif
+%patch4 -p1
 
 mkdir -p include/aethera
 ln -sf ../../aethera/libs/clientskel/clientrmi.h include/aethera
@@ -54,7 +66,6 @@ dir=$(pwd)
 
 # Compile tkcBase
 cd tkcbase
-%if 0
 cat <<EOF > defines.pri
 TKCBASE_LIB=%{_libdir}
 TKCBASE_INCLUDE=%{_includedir}/tkcbase
@@ -105,7 +116,6 @@ EOF
 
 qmake aethera.pro
 %{__make}
-%endif
 
 # Compile KOrganizer plugin
 cd ../koplugin
@@ -163,24 +173,40 @@ export QTDIR=/usr
 %{__make} -C koplugin install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
+# x86 binary
+rm $RPM_BUILD_ROOT%{_libdir}/aethera/bin/sox
+# unneccessary wrappers
+rm $RPM_BUILD_ROOT%{_libdir}/aethera/bin/aethera_sound
+rm $RPM_BUILD_ROOT%{_prefix}/local/bin/aethera
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/aethera
-%dir %attr(755,root,root) %{_libdir}/aethera
-%dir %attr(755,root,root) %{_libdir}/aethera/plugins
+%attr(755,root,root) %{_libdir}/libaethera.so.1.0.1
+%attr(755,root,root) %{_libdir}/libfilebrowser.so.1.0.0
+%attr(755,root,root) %{_libdir}/libtino.so.1.0.0
+%attr(755,root,root) %{_libdir}/libtkcbase.so.1.0.0
+%attr(755,root,root) %{_libdir}/libtkcssl.so.1.0.0
+%dir %{_libdir}/aethera
+%dir %{_libdir}/aethera/plugins
+%attr(755,root,root) %{_libdir}/aethera/plugins/libhomeplugin.so.1.0.0
+%attr(755,root,root) %{_libdir}/aethera/plugins/libkomcontactsplugin.so.1.0.0
 %attr(755,root,root) %{_libdir}/aethera/plugins/libkommailplugin.so.1.0.0
 %attr(755,root,root) %{_libdir}/aethera/plugins/libkomnotesplugin.so.1.0.0
 %attr(755,root,root) %{_libdir}/aethera/plugins/libkorganizer.so.1.0.0
-%attr(755,root,root) %{_libdir}/aethera/plugins/libkomcontactsplugin.so.1.0.0
-%dir %{_libdir}/aethera
+%attr(755,root,root) %{_libdir}/aethera/plugins/libmailimport.so.1.0.0
 %{_libdir}/aethera/help
 %{_libdir}/aethera/pics
 %{_libdir}/aethera/sound
 %{_libdir}/aethera/data
 %dir %{_libdir}/aethera/i18n
+# XXX: are *.ts (translation sources) needed in binary package?
 %lang(de) %{_libdir}/aethera/i18n/aethera_de.qm
 %lang(de) %{_libdir}/aethera/i18n/aethera_de.ts
 %lang(de) %{_libdir}/aethera/i18n/koplugin_de.ts
@@ -204,6 +230,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%{_libdir}/libtkwidgets.a
+%{_libdir}/libwebdav.a
 %{_includedir}/aethera
 %{_includedir}/tino
 %{_includedir}/tkcbase
This page took 0.110786 seconds and 4 git commands to generate.