]> git.pld-linux.org Git - packages/acl.git/blobdiff - acl.spec
- updated to 2.2.51
[packages/acl.git] / acl.spec
index 0d361fe0c771b4d8c1eb3469d157f2b3b470accc..e3acb88a4bd73fce264361e3ff3b98c3176f4565 100644 (file)
--- a/acl.spec
+++ b/acl.spec
@@ -1,21 +1,23 @@
 Summary:       Command and library for manipulating access control lists
 Summary(pl.UTF-8):     Polecenie i biblioteka do manipulacji listami kontroli dostÄ™pu (ACL)
 Name:          acl
-Version:       2.2.44
+Version:       2.2.51
 Release:       1
 License:       LGPL v2+ (library), GPL v2 (utilities)
 Group:         Applications/System
-Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}_%{version}-1.tar.gz
-# Source0-md5: f92f56998a94735419ec932fb9d0118d
+Source0:       http://download.savannah.gnu.org/releases-noredirect/acl/%{name}-%{version}.src.tar.gz
+# Source0-md5: 3fc0ce99dc5253bdcce4c9cd437bc267
 Patch0:                %{name}-miscfix.patch
 Patch1:                %{name}-lt.patch
 Patch2:                %{name}-LDFLAGS.patch
-URL:           http://oss.sgi.com/projects/xfs/
+Patch3:                %{name}-pl.po-update.patch
+URL:           http://savannah.nongnu.org/projects/acl/
 BuildRequires: attr-devel >= 2.4.16-3
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: gettext-devel
 BuildRequires: libtool
+BuildRequires: rpmbuild(macros) >= 1.402
 Requires:      attr >= 2.4.15
 Obsoletes:     libacl
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -64,13 +66,17 @@ Statyczna biblioteka acl.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
-rm -f aclocal.m4
+%{__rm} aclocal.m4
 
 %build
+mv install-sh install-custom-sh
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
+cp -f /usr/share/automake/config.sub .
+mv install-custom-sh install-sh
 %configure \
        DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
        OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
@@ -83,11 +89,11 @@ rm -f aclocal.m4
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
 
-DIST_ROOT=$RPM_BUILD_ROOT
-DIST_INSTALL=`pwd`/install.manifest
-DIST_INSTALL_DEV=`pwd`/install-dev.manifest
-DIST_INSTALL_LIB=`pwd`/install-lib.manifest
-export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
+export DIST_ROOT=$RPM_BUILD_ROOT
+P=$(pwd)
+DIST_INSTALL=$P/install.manifest
+DIST_INSTALL_DEV=$P/install-dev.manifest
+DIST_INSTALL_LIB=$P/install-lib.manifest
 
 %{__make} install \
        DIST_MANIFEST=$DIST_INSTALL \
@@ -99,20 +105,19 @@ export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
        DIST_MANIFEST=$DIST_INSTALL_LIB \
        top_builddir="../"
 
-rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
-rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
-echo ".so acl_copy_ext.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
-echo ".so acl_get_fd.3"                > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
-echo ".so acl_get_file.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
-echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
-echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
-
-rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
-ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libacl.so.*.*.*) \
+ln -snf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libacl.so.*.*.*) \
        $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
        $RPM_BUILD_ROOT%{_libexecdir}/libacl.la
 
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
+
+# already in /usr
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libacl.{so,la,a}
+
+# fix perms (needed for debuginfo and autorequires/provides)
+chmod a+x $RPM_BUILD_ROOT%{_libdir}/libacl.so.*.*.*
+
 %find_lang %{name}
 
 %clean
@@ -124,9 +129,15 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README doc/{CHANGES,TODO}
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/libacl.so.*.*
-%{_mandir}/man[15]/*
+%attr(755,root,root) %{_bindir}/chacl
+%attr(755,root,root) %{_bindir}/getfacl
+%attr(755,root,root) %{_bindir}/setfacl
+%attr(755,root,root) %{_libdir}/libacl.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libacl.so.1
+%{_mandir}/man1/chacl.1*
+%{_mandir}/man1/getfacl.1*
+%{_mandir}/man1/setfacl.1*
+%{_mandir}/man5/acl.5*
 
 %files devel
 %defattr(644,root,root,755)
@@ -134,8 +145,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libexecdir}/libacl.so
 %{_libexecdir}/libacl.la
 %{_includedir}/acl
-%{_includedir}/sys/*
-%{_mandir}/man[23]/*
+%{_includedir}/sys/acl.h
+%{_mandir}/man3/acl_*.3*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.033604 seconds and 4 git commands to generate.