]> git.pld-linux.org Git - packages/PPerl.git/blobdiff - PPerl.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/PPerl.git] / PPerl.spec
index 0e46fe156570a6f3e1d91a2275f78831617796df..bf0be99677c0b9e68d1243beb1f97e9e2fd37f63 100644 (file)
@@ -1,42 +1,62 @@
-%include       /usr/lib/rpm/macros.perl
+#
+# Conditional build:
+%bcond_with    tests   # perform "make test" (one test fails)
+#
 Summary:       A persistent Perl interpreter system, designed to speed up Perl scripts
+Summary(pl.UTF-8):     Trwały system interpretera Perla służący do przyspieszenia skryptów
 Name:          PPerl
-Version:       0.24
-Release:       0.1
-License:       unknown
+Version:       0.25
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://search.cpan.org/CPAN/authors/id/M/MS/MSERGEANT/%{name}-%{version}.tar.gz
-# Source0-md5: ce1407d265e96e8a1185b699386eb14b
-BuildRequires: perl-devel >= 5.6
-BuildRequires: rpm-perlprov >= 4.0.2-104
-BuildArch:     noarch
+# Source0-md5: 32c94d7154494e292241a3d629eed4ea
+BuildRequires: gdbm-devel
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-PPerl provides a persistent environment for perl scripts. It makes
+PPerl provides a persistent environment for Perl scripts. It makes
 converting a useful old script into a persistent daemon process a
 breeze.
 
-Simply change your shebang line to #!/usr/bin/pperl, rather than
+Simply change your shebang line to "#!/usr/bin/pperl", rather than
 "perl", and you'll find your old slow scripts that take ages to start
 up, running like they were brand spanking new again. Well, that's the
 plan at least!
 
+%description -l pl.UTF-8
+PPerl dostarcza trwałe środowisko dla skryptów perlowych. Znacznie
+ułatwia zamianę starego, przydatnego skryptu na stale działającego
+demona.
+
+Wystarczy zmienić pierwszą linię na "#!/usr/bin/pperl" zamiast "perl",
+a stare, wolne skrypty, wcześniej potrzebujące wieków na uruchomienie,
+zaczną działać jakby znowu były nowe. A przynajmniej taki jest plan.
+
 %prep
 %setup -q
 
 %build
-%{__perl} Makefile.PL
-%{__make}
+%{__perl} Makefile.PL \
+       PERL_PATH=%{__perl} \
+       INSTALLDIRS=vendor
+%{__make} \
+       OPTIMIZE="%{rpmcflags}"
 
 %{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -44,9 +64,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc Changes README TODO examples
 %attr(755,root,root) %{_bindir}/pperl
-%{perl_sitearch}/%{name}.pm
-%dir %{perl_sitearch}/auto/%{name}
-%{perl_sitearch}/auto/%{name}/%{name}.bs
-%attr(755,root,root) %{perl_sitearch}/auto/%{name}/%{name}.so
+%{perl_vendorarch}/%{name}.pm
+%dir %{perl_vendorarch}/auto/%{name}
+%{perl_vendorarch}/auto/%{name}/%{name}.bs
+%attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
 %{_mandir}/man1/*
 %{_mandir}/man3/*
+%{_examplesdir}/%{name}-%{version}
This page took 0.133716 seconds and 4 git commands to generate.