]> git.pld-linux.org Git - packages/PHP-nuke.git/blobdiff - PHP-nuke.spec
- updated to 7.7
[packages/PHP-nuke.git] / PHP-nuke.spec
index 943c201f5667f114005701b8cddd4735176cfe67..1e2994123b54e3227c3fbab836ebdb85e583186c 100644 (file)
@@ -1,28 +1,31 @@
 Summary:       Slashdot-like webnews site written in php, easy to install and use
 Summary(pl):   Serwis nowinek WWW w stylu Slashdota napisany w PHP, ³atwy w instalacji i u¿ywaniu
 Name:          PHP-nuke
-Version:       6.0
-Release:       2
+Version:       7.7
+Release:       1
 License:       GPL
 Group:         Applications/Databases/Interfaces
-Source0:       http://prdownloads.sourceforge.net/phpnuke/PHP-Nuke-%{version}.tar.gz
+Source0:       http://phpnuke.org/files/PHP-Nuke-%{version}.zip
+# Source0-md5: 27a14521dc5aaa0ebaefe78dd78449f9
 Source1:       PHP-Nuke.README.first
-Patch0:                %{name}-official_fix.patch
-Icon:          phpnuke.gif
+Source2:       %{name}.conf
+#Icon:         phpnuke.gif
 URL:           http://phpnuke.org/
 Requires:      php-mysql
+Requires:      php-pcre
 Requires:      webserver
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                nukeroot        /home/httpd/html/nuke
+%define                _nukeroot       %{_datadir}/phpnuke
 
 %description
 Web-portal writen in php. Very powerful, yet easy to install and use:
 see documentation in %{_docdir}/%{name}-%{version} for details.
 
-You only have to run: mysqladmin create nuke mysql nuke < \
-%{_docdir}/%{name}-%{version}/nuke.sql
+You only have to run:
+mysqladmin create nuke
+mysql nuke < %{_docdir}/%{name}-%{version}/nuke.sql
 
 (read %{_docdir}/%{name}-%{version}/README.first for further
 information)
@@ -31,14 +34,15 @@ information)
 Portal WWW napisany w PHP. Ma du¿e mo¿liwo¶ci, jest ³atwy w instalacji
 u u¿ywaniu. Szczegó³y w dokumentacji w %{_docdir}/%{name}-%{version}.
 
-Wystarczy zrobiæ jedno: mysqladmin create nuke mysql nuke < \
-%{_docdir}/%{name}-%{version}/nuke.sql
+Wystarczy zrobiæ jedno:
+mysqladmin create nuke
+mysql nuke < %{_docdir}/%{name}-%{version}/nuke.sql
 
 (wiêcej informacji w %{_docdir}/%{name}-%{version}/README.first)
 
 %prep
-%setup -q -c %{name}-%{version}
-%patch0 -p1
+%setup -q -c
+
 install %{SOURCE1} README.first
 
 # (TV): workaround for bad tarball
@@ -49,18 +53,54 @@ chmod 755 */*/*/
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{nukeroot}
+install -d $RPM_BUILD_ROOT{%{_nukeroot},/etc/httpd}
+
+cp -ar html/* $RPM_BUILD_ROOT%{_nukeroot}
 
-cp -ar html/* $RPM_BUILD_ROOT%{nukeroot}
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/httpd/phpnuke.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%triggerpostun -- %{name} <= 7.4-2
+if [ -s /home/services/httpd/html/nuke/config.php ]; then
+       mv -f /home/services/httpd/html/nuke/config.php %{_nukeroot}
+fi
+
+%post
+if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*phpnuke.conf" /etc/httpd/httpd.conf; then
+       echo "Include /etc/httpd/phpnuke.conf" >> /etc/httpd/httpd.conf
+       if [ -f /var/lock/subsys/httpd ]; then
+               /usr/sbin/apachectl restart 1>&2
+       fi
+elif [ -d /etc/httpd/httpd.conf ]; then
+       ln -sf /etc/httpd/phpnuke.conf /etc/httpd/httpd.conf/phpnuke.conf
+       if [ -f /var/lock/subsys/httpd ]; then
+               /usr/sbin/apachectl restart 1>&2
+       fi
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       umask 027
+       if [ -d /etc/httpd/httpd.conf ]; then
+               rm -f /etc/httpd/httpd.conf/99_phpnuke.conf
+       else
+               grep -v "^Include.*phpnuke.conf" /etc/httpd/httpd.conf > \
+                       /etc/httpd/httpd.conf.tmp
+               mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
+       fi
+       if [ -f /var/lock/subsys/httpd ]; then
+               /usr/sbin/apachectl restart 1>&2
+       fi
+fi
+
 %files
 %defattr(644,root,root,755)
-%doc ADDONS-MODULES BLOCKS CHANGES CREDITS INSTALL README*
-%doc SUPPORT TODO TRANSLATIONS UPGRADE sql/nuke.sql upgrades
-%dir %{nukeroot}
-%config(noreplace) %attr(644,apache,apache) %{nukeroot}/config.php
-%{nukeroot}/[^c]*
+%doc Addons* Blocks* Changes* Credits* Install* README* Readme*
+%doc Support* Upgrade* sql/nuke.sql upgrades
+%config(noreplace) %verify(not size mtime md5) /etc/httpd/phpnuke.conf
+%dir %{_nukeroot}
+%config(noreplace) %attr(640,http,http) %{_nukeroot}/config.php
+%{_nukeroot}/[!c]*
 # more needed?
This page took 0.043549 seconds and 4 git commands to generate.