]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
up to 1.23.1
[packages/OpenAL.git] / OpenAL.spec
index fc3084fc0d6e341f61ffb21ca22fa5fcfce34285..81c3ae55d3ac07786f599b8b199672f3c89d426a 100644 (file)
@@ -2,51 +2,47 @@
 # Conditional build:
 %bcond_without alsa            # ALSA backend
 %bcond_without jack            # JACK backend
+%bcond_without pipewire        # PipeWire backend
 %bcond_without portaudio       # PortAudio backend
 %bcond_without pulseaudio      # PulseAudio backend
+%bcond_without rtkit           # RTKit support
 %bcond_with    sdl             # SDL2 backend
-%bcond_with    sse             # force use of SSE instructions (x86)
 %bcond_with    sse2            # force use of SSE2 instructions (x86)
 %bcond_without gui             # alsoft-config GUI
-%bcond_with    qt4             # Qt 4 instead of Qt 5 for GUI
-#
-%ifarch pentium3 pentium4
-%define        with_sse        1
-%endif
-%ifarch pentium4
+
+%ifarch pentium4 x32 %{x8664}
 %define        with_sse2       1
 %endif
 Summary:       Open Audio Library
 Summary(pl.UTF-8):     Otwarta Biblioteka Dźwięku
 Name:          OpenAL
-Version:       1.19.1
-Release:       2
+Version:       1.23.1
+Release:       1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
-# Source0-md5: af6f148c342276a51ea9c33ebd303f78
-Patch0:                %{name}-pc.patch
+Source0:       https://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
+# Source0-md5: 58a73698288d2787451b61f8f4431513
+Patch0:                %{name}-nosse.patch
 URL:           http://www.openal.org/
 %{?with_sdl:BuildRequires:     SDL2-devel >= 2}
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 BuildRequires: cmake >= 3.0.2
+%{?with_rtkit:BuildRequires:   dbus-devel}
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
+BuildRequires: libmysofa-devel
+BuildRequires: libstdc++-devel >= 6:5
+%{?with_pipewire:BuildRequires:        pipewire-devel >= 0.3.23}
 BuildRequires: pkgconfig
 %{?with_portaudio:BuildRequires:       portaudio-devel}
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
-BuildRequires: rpmbuild(macros) >= 1.605
+BuildRequires: rpmbuild(macros) >= 1.742
 %if %{with gui}
-%if %{with qt4}
-BuildRequires: QtCore-devel >= 4.8.0
-BuildRequires: QtGui-devel >= 4.8.0
-BuildRequires: qt4-build >= 4.8.0
-%else
 BuildRequires: Qt5Core-devel >= 5
 BuildRequires: Qt5Gui-devel >= 5
 BuildRequires: Qt5Widgets-devel >= 5
 BuildRequires: qt5-build >= 5
 %endif
-%endif
+%{?with_sse2:Requires: cpuinfo(sse2)}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -84,8 +80,9 @@ Summary:      OpenAL configuration GUI
 Summary(pl.UTF-8):     Graficzny interfejs do konfiguracji biblioteki OpenAL
 Group:         X11/Applications/Sound
 Requires:      %{name} = %{version}-%{release}
-Requires:      QtCore >= 4.8.0
-Requires:      QtGui >= 4.8.0
+Requires:      Qt5Core >= 5
+Requires:      Qt5Gui >= 5
+Requires:      Qt5Widgets >= 5
 
 %description gui
 OpenAL configuration GUI.
@@ -102,14 +99,14 @@ cd build
 %cmake .. \
        %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
        %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
+       %{cmake_on_off pipewire ALSOFT_BACKEND_PIPEWIRE} \
        %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
        %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
+       %{cmake_on_off rtkit ALSOFT_RTKIT} \
        %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
-       %{!?with_sse:-DALSOFT_ENABLE_SSE_CODEGEN=OFF} \
        %{!?with_sse2:-DALSOFT_ENABLE_SSE2_CODEGEN=OFF} \
        -DALSOFT_EXAMPLES=OFF \
        %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
-       %{?with_qt4:-DALSOFT_NO_QT5=ON} \
 
 %{__make}
 
@@ -122,9 +119,6 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
 
 install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
 
-# these look not really useful
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/altonegen
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -134,7 +128,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
-%attr(755,root,root) %{_bindir}/makehrtf
+%attr(755,root,root) %{_bindir}/makemhr
 %attr(755,root,root) %{_bindir}/openal-info
 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
This page took 0.079441 seconds and 4 git commands to generate.