]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
up to 1.19.0
[packages/OpenAL.git] / OpenAL.spec
index 5b05f2378902cbb270e52ed4bd7aabc0fcac0bc7..71a813a16d454d325a137fd3bd714294029f6a94 100644 (file)
@@ -1,38 +1,42 @@
 #
-# TODO:
-# - Build stops at:
-# arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
-# arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
-# arch/i386/x86_floatmul.c: In function `_alFloatMul':
-#arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
-# Please submit a full bug report,
-#
-# - autoconf provides undefined macro....
-
 # Conditional build:
+%bcond_without alsa            # ALSA backend
+%bcond_without jack            # JACK backend
+%bcond_without portaudio       # PortAudio backend
+%bcond_without pulseaudio      # PulseAudio backend
+%bcond_without gui             # alsoft-config GUI
+%bcond_with    qt4             # Qt 4 instead of Qt 5 for GUI
 #
-%bcond_without alsa    # without ALSA support
-%bcond_with    arts    # with aRts support
-%bcond_without esd     # without esd support
-%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
-
 Summary:       Open Audio Library
-Summary(pl):   Otwarta Biblioteka D¼wiêku
+Summary(pl.UTF-8):     Otwarta Biblioteka Dźwięku
 Name:          OpenAL
-Version:       0.0.8
+Version:       1.19.0
 Release:       1
-License:       LGPL
+License:       LGPL v2+
 Group:         Libraries
-Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
-# Source0-md5: 641cf53761f35ee979f3e888614797a0
+Source0:       http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
+# Source0-md5: 1f59accf1a187384e155e82663aa3f9a
+#URL:          http://kcat.strangesoft.net/openal.html
 URL:           http://www.openal.org/
-BuildRequires: SDL-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
-%{?with_arts:BuildRequires:    artsc-devel}
-%{?with_esd:BuildRequires:     esound-devel}
-BuildRequires: libvorbis-devel
-%{?with_mmx:BuildRequires:     nasm}
-BuildRequires: smpeg-devel
+BuildRequires: cmake >= 3.0.2
+%{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
+BuildRequires: pkgconfig
+%{?with_portaudio:BuildRequires:       portaudio-devel}
+%{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
+BuildRequires: rpmbuild(macros) >= 1.605
+%if %{with gui}
+%if %{with qt4}
+BuildRequires: QtCore-devel >= 4.8.0
+BuildRequires: QtGui-devel >= 4.8.0
+BuildRequires: qt4-build >= 4.8.0
+%else
+BuildRequires: Qt5Core-devel >= 5
+BuildRequires: Qt5Gui-devel >= 5
+BuildRequires: Qt5Widgets-devel >= 5
+BuildRequires: qt5-build >= 5
+%endif
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -43,65 +47,70 @@ developers and desktop users that rely on portable standards like
 OpenGL, for games and other multimedia applications. OpenAL is already
 supported by a number of hardware vendors and developers.
 
-%description -l pl
-OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
-stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
-interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
-Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
-którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
-aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
-dostarczycieli sprzêtu i programistów.
+%description -l pl.UTF-8
+OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
+stworzenia otwartego, niezależnego od producentów, międzyplatformowego
+interfejsu projektowania aplikacji w części obsługi dźwięku.
+Biblioteka adresowana jest do twórców aplikacji i użytkowników,
+którzy wybierają przenośne standardy, jak OpenGL, w grach i
+aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
+dostarczycieli sprzętu i programistów.
 
 %package devel
 Summary:       Headers for OpenAL
-Summary(pl):   Pliki nag³ówkowe do OpenAL
+Summary(pl.UTF-8):     Pliki nagłówkowe do OpenAL
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for OpenAL-based programs.
 
-%description devel -l pl
-Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
+%description devel -l pl.UTF-8
+Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
 OpenAL.
 
-%package static
-Summary:       OpenAL static library
-Summary(pl):   Statyczna biblioteka OpenAL
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
+%package gui
+Summary:       OpenAL configuration GUI
+Summary(pl.UTF-8):     Graficzny interfejs do konfiguracji biblioteki OpenAL
+Group:         X11/Applications/Sound
+Requires:      %{name} = %{version}-%{release}
+Requires:      QtCore >= 4.8.0
+Requires:      QtGui >= 4.8.0
 
-%description static
-OpenAL static library.
+%description gui
+OpenAL configuration GUI.
 
-%description static -l pl
-Biblioteka OpenAL do konsolidacji statycznej.
+%description gui -l pl.UTF-8
+Graficzny interfejs do konfiguracji biblioteki OpenAL.
 
 %prep
-%setup -q -n openal-%{version}
+%setup -q -n openal-soft-%{version}
 
 %build
-%configure \
-       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
-       %{?with_arts:--enable-arts --enable-arts-dlopen} \
-       %{?with_esd:--enable-esd --enable-esd-dlopen} \
-       --enable-sdl --enable-sdl-dlopen \
-       --enable-capture \
-       --enable-linux \
-       --enable-null \
-       --enable-waveout \
-       --enable-vorbis --enable-vorbis-dlopen \
-       --enable-mp3 --enable-mp3-dlopen \
-       --with-gcc=%{__cc}
+cd build
+%cmake .. \
+       %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
+       %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
+       %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
+       %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
+       -DALSOFT_EXAMPLES=OFF \
+       %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
+       %{?with_qt4:-DALSOFT_NO_QT5=ON} \
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
 
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
+install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
+
+# these look not really useful
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/altonegen
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -110,17 +119,22 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog NOTES TODO
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
+%attr(755,root,root) %{_bindir}/makehrtf
+%attr(755,root,root) %{_bindir}/openal-info
+%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
+%{_datadir}/openal
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*-config
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/*.la
-%{_pkgconfigdir}/*
+%attr(755,root,root) %{_libdir}/libopenal.so
 %{_includedir}/AL
+%{_pkgconfigdir}/openal.pc
+%{_libdir}/cmake/OpenAL
 
-%files static
+%if %{with gui}
+%files gui
 %defattr(644,root,root,755)
-%{_libdir}/*.a
+%attr(755,root,root) %{_bindir}/alsoft-config
+%endif
This page took 0.065777 seconds and 4 git commands to generate.