]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- lib64 fix
[packages/OpenAL.git] / OpenAL.spec
index a1eb4125e67f1e404e5e97f832030cd204a76796..01ab627a290edb07afafb371170584eb1458ef27 100644 (file)
@@ -1,24 +1,48 @@
+#
+# Conditional build:
+%bcond_without alsa    # without ALSA support
+%bcond_with    arts    # with aRts support
+%bcond_without doc     # don't build HTML documentation (from SGML source)
+%bcond_without esd     # without esd support
+%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
+                       # Currently broken.
+#
+# TODO:
+# - remove zip BR?
+#
+
+%define        _branch Linux_Spec1-0
+
 Summary:       Open Audio Library
 Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
-Version:       0.0.6
-Release:       1
+Version:       0.0.8
+%define        snap    20051015
+Release:       0.%{snap}.1
 License:       LGPL
-Group:         X11/Libraries
-Vendor:                Loki Entertainment Software - http://www.lokigames.com/
-# This is tarball taken directly form Mandrake Cooker .src.rpm
-Source0:       %{name}-linuxonly-20010805.tar.bz2
-# Those patches came from Mandrake Cooker (only changed names)
+Group:         Libraries
+# from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
+# (without all Win and Mac stuff and demos)
+Source0:       %{name}-%{_branch}-%{snap}.tar.bz2
+# Source0-md5: 013a571cf588bec1d3a5628b5ed527ea
 Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-build.patch
-URL:           http://www.openal.com/
-BuildRequires: alsa-lib-devel
+Patch1:                %{name}-info.patch
+URL:           http://www.openal.org/
 BuildRequires: SDL-devel
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
+BuildRequires: autoconf
+BuildRequires: automake
+%{?with_doc:BuildRequires:     docbook-utils}
+%{?with_esd:BuildRequires:     esound-devel}
+%{?with_doc:BuildRequires:     gnome-doc-tools}
 BuildRequires: libvorbis-devel
+%{?with_mmx:BuildRequires:     nasm}
 BuildRequires: smpeg-devel
+BuildRequires: texinfo
+BuildRequires: zip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-
 %description
 OpenAL, the Open Audio Library, is a joint effort to create an open,
 vendor-neutral, cross-platform API for interactive, primarily
@@ -29,7 +53,7 @@ supported by a number of hardware vendors and developers.
 
 %description -l pl
 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
-stworzenia otwartego, niezale¿nego od producentów, miedzyplatformowego
+stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
@@ -39,8 +63,8 @@ dostarczycieli sprz
 %package devel
 Summary:       Headers for OpenAL
 Summary(pl):   Pliki nag³ówkowe do OpenAL
-Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for OpenAL-based programs.
@@ -52,43 +76,52 @@ OpenAL.
 %package static
 Summary:       OpenAL static library
 Summary(pl):   Statyczna biblioteka OpenAL
-Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenAL static library.
 
 %description static -l pl
-Biblioteka OpenAL do statycznego linkowania.
+Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n tmp/openal
-%patch0 -p0
-%patch1 -p0
+%setup -q -n %{name}-%{_branch}-%{snap}
+%patch0 -p1
+%patch1 -p1
+
+cp CREDITS docs
 
 %build
 cd linux
-sh ./autogen.sh
-%configure  --enable-prefix=%{_prefix} \
-            --enable-optimization \
-           --enable-alsa \
-           --enable-sdl \
-           --enable-vorbis \
-           --enable-smpeg \
-           --enable-capture \
-           --with-gcc=%{__cc}                      
+cp -f /usr/share/automake/config.sub .
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%configure \
+       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
+       %{?with_arts:--enable-arts --enable-arts-dlopen} \
+       %{?with_esd:--enable-esd --enable-esd-dlopen} \
+       --enable-sdl \
+       --enable-vorbis \
+       --enable-smpeg \
+       --enable-capture \
+       --with-gcc=%{__cc}
+
 %{__make}
 
+cd ../docs/spec1-0
+%{?with_doc:%{__make} full-html}
+
 %install
 rm -rf $RPM_BUILD_ROOT
-cd linux
-%makeinstall
+install -d $RPM_BUILD_ROOT%{_infodir}
 
-mkdir -p $RPM_BUILD_ROOT%{_infodir}
-install -c  doc/openal.info $RPM_BUILD_ROOT%{_infodir}
+%{__make} -C linux install \
+       DESTLIB='$(DESTDIR)%{_libdir}' \
+       DESTDIR=$RPM_BUILD_ROOT
 
-# This needs patch, but is it worth to waste time ?
-rm -f $RPM_BUILD_ROOT%{_libdir}/libopenal.{so,so.0}
+install linux/doc/openal.info $RPM_BUILD_ROOT%{_infodir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -102,16 +135,20 @@ rm -rf $RPM_BUILD_ROOT
 %postun        devel
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
-
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/*.so*
+%doc linux/{CREDITS,ChangeLog,NOTES,TODO}
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc %{_infodir}/openal.info.*
-%{_includedir}/AL/*.h
+%doc linux/doc/LOKI* %{?with_doc:docs/spec1-0/oalspecs-full docs/spec1-1/OpenAL1-1Spec.pdf}
+%attr(755,root,root) %{_libdir}/lib*.so
+%attr(755,root,root) %{_bindir}/*-config
+%{_pkgconfigdir}/*
+%{_includedir}/AL
+%{_infodir}/openal.info*
 
 %files static
 %defattr(644,root,root,755)
-%attr(755,root,root)%{_libdir}/*.a
+%{_libdir}/*.a
This page took 0.029936 seconds and 4 git commands to generate.