]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
- updated some versioned dependencies
[packages/Mesa.git] / Mesa.spec
index 31c273058d21a3f57513f6325bb78944c7642adc..a047dafe2b4de341989225c2316e943428c8754d 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -1,18 +1,17 @@
 #
 # TODO:
 # - consider:
-#   --enable-shared-glapi (for libGL; required if the same app uses GL and GLES)
 #   --enable-shared-dricore
 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
 # - resurrect static if it's useful
 #
 # Conditional build:
-%bcond_without egl     # build egl
-%bcond_without gallium # don't build gallium
+%bcond_without egl             # EGL libraries
+%bcond_without gallium         # gallium drivers
 %bcond_with    gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
 %bcond_without gallium_nouveau # gallium nouveau driver
-%bcond_without osmesa  # don't build osmesa
-%bcond_without gbm     # with Graphics Buffer Manager
+%bcond_without osmesa          # OSMesa libraries
+%bcond_without gbm             # with Graphics Buffer Manager
 %bcond_with    static_libs     # static libraries
 #
 # minimal supported xserver version
 #
 %define                libdrm_ver      2.4.30
 %define                dri2proto_ver   2.6
-%define                glproto_ver     1.4.11
+%define                glproto_ver     1.4.14
 #
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       8.0
+Version:       8.0.1
 Release:       1
 License:       MIT (core), SGI (GLU) and others - see license.html file
 Group:         X11/Libraries
 Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: 1a5668fe72651a670611164cefc703b2
+# Source0-md5: 24eeebf66971809d8f40775a379b36c9
 Patch0:                %{name}-realclean.patch
 URL:           http://www.mesa3d.org/
 BuildRequires: autoconf >= 2.59
@@ -46,7 +45,7 @@ BuildRequires:        libselinux-devel
 BuildRequires: libstdc++-devel >= 5:3.3.0
 BuildRequires: libtalloc-devel >= 2:2.0.1
 BuildRequires: libtool >= 2:1.4d
-BuildRequires: libvdpau-devel
+BuildRequires: libvdpau-devel >= 0.4.1
 BuildRequires: llvm-devel >= 2.9
 BuildRequires: pixman-devel
 BuildRequires: pkgconfig
@@ -59,7 +58,7 @@ BuildRequires:        sed >= 4.0
 BuildRequires: xorg-lib-libXdamage-devel
 BuildRequires: xorg-lib-libXext-devel >= 1.0.5
 BuildRequires: xorg-lib-libXt-devel
-BuildRequires: xorg-lib-libXvMC-devel
+BuildRequires: xorg-lib-libXvMC-devel >= 1.0.6
 BuildRequires: xorg-lib-libXxf86vm-devel
 BuildRequires: xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 BuildRequires: xorg-proto-glproto-devel >= %{glproto_ver}
@@ -67,7 +66,7 @@ BuildRequires:        xorg-util-makedepend
 BuildRequires: xorg-xserver-server-devel
 %if %{with egl}
 BuildRequires: libxcb-devel
-BuildRequires: udev-devel >= 150
+BuildRequires: udev-devel >= 1:150
 %endif
 %if %{with gallium}
 BuildRequires: xorg-proto-xextproto-devel >= 7.0.99.1
@@ -112,7 +111,7 @@ Requires:   libdrm >= %{libdrm_ver}
 %if %{with gallium}
 # for egl_gallium.so
 Requires:      Mesa-libOpenVG = %{version}-%{release}
-Requires:      udev-libs >= 150
+Requires:      udev-libs >= 1:150
 %endif
 Provides:      EGL = 1.4
 
@@ -412,17 +411,18 @@ Header file for Mesa OpenVG library.
 Plik nagłówkowy biblioteki Mesa OpenVG.
 
 %package libXvMC
-Summary:       XvMC implementations
-Summary(pl.UTF-8):     Implementacje API XvMC
+Summary:       Mesa implementations of XvMC API
+Summary(pl.UTF-8):     Implementacje Mesa API XvMC
 License:       MIT
 Group:         Libraries
+Requires:      libdrm >= %{libdrm_ver}
 # doesn't require base
 
 %description libXvMC
-libXvMC implementations.
+Mesa implementations of XvMC API.
 
 %description libXvMC -l pl.UTF-8
-Implementacje API libXvMC.
+Implementacje Mesa API XvMC.
 
 %package dri-driver-ati-radeon-R100
 Summary:       X.org DRI driver for ATI R100 card family
@@ -488,37 +488,6 @@ X.org DRI driver for ATI R600 card family.
 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
 Sterownik X.org DRI dla rodziny kart ATI R600.
 
-%package dri-driver-ffb
-Summary:       X.org DRI driver for Sun FFB card family
-Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Sun FFB
-License:       MIT
-Group:         X11/Libraries
-Requires:      xorg-driver-video-sunffb
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
-
-%description dri-driver-ffb
-X.org DRI driver for SUN Creator3D and Elite3D card family.
-
-%description dri-driver-ffb -l pl.UTF-8
-Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
-
-%package dri-driver-glint
-Summary:       X.org DRI driver for GLINT/Permedia card family
-Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart GLINT/Permedia
-License:       MIT
-Group:         X11/Libraries
-Requires:      xorg-driver-video-glint
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
-Obsoletes:     X11-driver-glint-dri < 1:7.0.0
-
-%description dri-driver-glint
-X.org DRI driver for GLINT/Permedia card family.
-
-%description dri-driver-glint -l pl.UTF-8
-Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
-
 %package dri-driver-intel-i915
 Summary:       X.org DRI driver for Intel i915 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Intel i915
@@ -587,6 +556,7 @@ Summary:    X.org DRI driver for VMware
 Summary(pl.UTF-8):     Sterownik X.org DRI dla VMware
 License:       MIT
 Group:         X11/Libraries
+Requires:      xorg-driver-video-vmware
 Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
 Requires:      xorg-xserver-server >= %{xserver_ver}
 
@@ -597,16 +567,18 @@ X.org DRI driver for VMWare.
 Sterownik X.org DRI dla VMware.
 
 %package -n libvdpau-driver-mesa
-Summary:       Mesa driver for the vdpau API
-Summary(pl.UTF-8):     Sterownik Mesa dla API vdpau
+Summary:       Mesa drivers for the vdpau API
+Summary(pl.UTF-8):     Sterowniki Mesa dla API vdpau
 License:       MIT
 Group:         X11/Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libvdpau >= 0.4.1
 
 %description -n libvdpau-driver-mesa
-Mesa driver for the vdpau API.
+Mesa drivers for the vdpau API.
 
 %description -n libvdpau-driver-mesa -l pl.UTF-8
-Sterownik Mesa dla API vdpau.
+Sterowniki Mesa dla API vdpau.
 
 # llvm build broken
 %define                filterout_ld    -Wl,--as-needed
@@ -685,7 +657,7 @@ cp -p src/mesa/osmesa.pc osmesa8
        --enable-xvmc \
        --with-gallium-drivers=${gallium_drivers} \
 %else
-       --disable-gallium \
+       --without-gallium-drivers \
 %endif
        --with-driver=dri \
        --with-dri-drivers=${dri_drivers} \
@@ -914,20 +886,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
 
-# sunffb (sparc only)
-%ifarch sparc sparcv9 sparc64
-%files dri-driver-ffb
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
-%endif
-
-# glint (requires update)
-%if 0
-%files dri-driver-glint
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
-%endif
-
 %files dri-driver-intel-i915
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
This page took 0.116456 seconds and 4 git commands to generate.