]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
- libGL-devel requires xorg-proto-glproto-devel
[packages/Mesa.git] / Mesa.spec
index 558e163006cc7b7d29a40cdf7ca6d83aef6808eb..68b4fd6fd664656bfa8d970199278299fd66ea3e 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
 # (until they start to be somehow versioned themselves)
 %define                glapi_ver       7.1.0
 #
-%define                snap            -rc3
+%define                libdrm_ver      2.4.19
+%define                dri2proto_ver   1.99.3
+%define                glproto_ver     1.4.11
+#
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja standardu OpenGL
 Name:          Mesa
-Version:       7.7
-Release:       0.1%{?with_multigl:.mgl}
+Version:       7.8.1
+Release:       2%{?with_multigl:.mgl}
 License:       MIT (core), SGI (GLU,libGLw) and others - see license.html file
 Group:         X11/Libraries
-Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}%{snap}.tar.bz2
-# Source0-md5: 775c278a211deacd722ed599e706a20e
-Source1:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}%{snap}.tar.bz2
-# Source1-md5: 2404747b148e05ca74ffb243b6e26606
-Source2:       http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
-# Source2-md5: 6ae05158e678f4594343f32c2ca50515
+Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
+# Source0-md5: 25ec15f8e41fde6d206118cc786dbac4
+Source1:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
+# Source1-md5: 9ef47f911869657c6bf2f43ebce86b61
 Patch0:                %{name}-realclean.patch
+Patch1:                %{name}-tgsi_dump.patch
 URL:           http://www.mesa3d.org/
 %{?with_demos:BuildRequires:   OpenGL-glut-devel >= 3.8}
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: expat-devel
-%{?with_demos:BuildRequires:   glew-devel}
-BuildRequires: libdrm-devel >= 2.4.12-3
+#%%{?with_demos:BuildRequires: glew-devel}
+BuildRequires: libdrm-devel >= %{libdrm_ver}
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:1.4d
 %{?with_motif:BuildRequires:   motif-devel}
+BuildRequires: pixman-devel
 BuildRequires: pkgconfig
 BuildRequires: python
+BuildRequires: python-modules
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
 BuildRequires: xorg-lib-libXdamage-devel
 BuildRequires: xorg-lib-libXext-devel >= 1.0.5
 BuildRequires: xorg-lib-libXt-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
-BuildRequires: xorg-proto-dri2proto-devel >= 1.99.3
-BuildRequires: xorg-proto-glproto-devel
-BuildRequires: xorg-proto-printproto-devel
+BuildRequires: xorg-proto-dri2proto-devel >= %{dri2proto_ver}
+BuildRequires: xorg-proto-glproto-devel >= %{glproto_ver}
 BuildRequires: xorg-util-makedepend
+BuildRequires: xorg-xserver-server-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %if %{without gallium}
@@ -85,7 +89,7 @@ Summary:      Free Mesa3D implementation of libGL OpenGL library
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
 License:       MIT
 Group:         X11/Libraries
-Requires:      libdrm >= 2.4.5
+Requires:      libdrm >= %{libdrm_ver}
 Provides:      OpenGL = 2.1
 # reports version 1.3, but supports glXGetProcAddress() from 1.4
 Provides:      OpenGL-GLX = 1.4
@@ -122,7 +126,14 @@ License:   MIT
 Group:         X11/Development/Libraries
 # loose dependency on libGL to use with other libGL binaries
 Requires:      OpenGL >= 1.5
+Requires:      libdrm-devel >= %{libdrm_ver}
 Requires:      xorg-lib-libX11-devel
+Requires:      xorg-lib-libXdamage-devel
+Requires:      xorg-lib-libXext-devel
+Requires:      xorg-lib-libXxf86vm-devel
+Requires:      xorg-proto-dri2proto-devel >= %{dri2proto_ver}
+Requires:      xorg-proto-glproto-devel >= %{glproto_ver}
+Suggests:      OpenGL-doc-man
 Provides:      OpenGL-GLX-devel = 1.4
 Provides:      OpenGL-devel = 2.1
 Obsoletes:     Mesa-devel
@@ -619,15 +630,17 @@ X.org DRI driver for VMWare.
 Sterownik X.org DRI dla VMware.
 
 %prep
-%setup -q -b1 -a2
+%setup -q -b1
 %patch0 -p0
+%patch1 -p1
 
 # fix demos
 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
 
 %build
-%{__aclocal}
-%{__autoconf}
+autoreconf --install
+#%{__aclocal}
+#%{__autoconf}
 
 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
 %if %{without gallium_intel}
@@ -648,48 +661,44 @@ common_flags="\
        --enable-selinux \
        --enable-pic \
        --enable-glx-tls \
+       --disable-glut \
+       --disable-os-mesa \
        --%{?with_egl:en}%{!?with_egl:dis}able-egl \
        --with%{!?with_demos:out}-demos"
 
-%if %{with osmesa}
-# osmesa variants
-%configure $common_flags \
+osmesa_common_flags="\
        --with-driver=osmesa \
        --disable-asm \
+       --disable-glu"
+
+%if %{with osmesa}
+# osmesa variants
+%configure $common_flags $osmesa_common_flags \
        --with-osmesa-bits=8
-%{__make} \
-       SRC_DIRS=mesa
+%{__make}
 mv %{_lib} osmesa8
 %{__make} clean
 
-%configure $common_flags \
-       --with-driver=osmesa \
-       --disable-asm \
+%configure $common_flags $osmesa_common_flags \
        --with-osmesa-bits=16
-%{__make} \
-       SRC_DIRS=mesa
+%{__make}
 mv %{_lib} osmesa16
 %{__make} clean
 
-%configure $common_flags \
-       --with-driver=osmesa \
-       --disable-asm \
+%configure $common_flags $osmesa_common_flags \
        --with-osmesa-bits=32
-%{__make} \
-       SRC_DIRS=mesa
+%{__make}
 mv %{_lib} osmesa32
 %{__make} clean
 %endif
 
 %configure $common_flags \
-       --enable-glu \
-       --enable-glw \
-       --disable-glut \
 %if %{with gallium}
        --enable-gallium \
        --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
+       --enable-gallium-svga \
        --enable-gallium-nouveau \
-       --with-state-trackers=dri \
+       --with-state-trackers=dri,xorg,glx \
 %else
        --disable-gallium \
 %endif
@@ -703,10 +712,6 @@ mv %{_lib} osmesa32
 %{__make} -C progs/demos
 %endif
 
-cd gl-manpages-*
-%configure
-%{__make}
-
 %install
 rm -rf $RPM_BUILD_ROOT
 
@@ -716,12 +721,8 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-cd gl-manpages-*
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-cd ..
-
 %if %{with osmesa}
+rm -f osmesa*/libGLEW.*
 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
 %endif
 
@@ -743,7 +744,7 @@ rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{
 # strip out undesirable headers
 olddir=$(pwd)
 cd $RPM_BUILD_ROOT%{_includedir}/GL
-rm [a-fh-np-wyz]*.h gg*.h glf*.h
+rm [a-fh-np-wyz]*.h glf*.h
 cd $RPM_BUILD_ROOT%{_libdir}
 cd $olddir
 
@@ -801,8 +802,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/GL/internal/dri_interface.h
 %{_pkgconfigdir}/dri.pc
 %{_pkgconfigdir}/gl.pc
-%{_mandir}/man3/gl[^uX]*.3gl*
-%{_mandir}/man3/glX*.3gl*
 
 %if %{with static}
 %files libGL-static
@@ -821,7 +820,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/GL/glu.h
 %{_includedir}/GL/glu_mangle.h
 %{_pkgconfigdir}/glu.pc
-%{_mandir}/man3/glu*.3gl*
 
 %if %{with static}
 %files libGLU-static
@@ -929,6 +927,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with gallium}
 %files dri-driver-nouveau
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
 %endif
 
@@ -954,9 +953,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
 
+%if %{with gallium}
 %files dri-driver-vmwgfx
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/xorg/modules/drivers/vmwgfx_drv.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
+%endif
 
 %if %{with demos}
 %files demos
This page took 0.035379 seconds and 4 git commands to generate.