]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
up to 21.3.4
[packages/Mesa.git] / Mesa.spec
index 517a6670dbfb0269652847e054aadb10127fca67..689645fa6b7e446f0b7a0ec88c89e262e6316213 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -1,4 +1,6 @@
-# TODO: libtizonia >= 0.10.0 as an alternative for bellagio?
+# TODO:
+# - libtizonia >= 0.10.0 as an alternative for bellagio?
+# - bcond for perfetto peformance analysis? (BR: perfetto)
 #
 # Conditional build:
 %bcond_without gallium         # gallium drivers
@@ -12,7 +14,7 @@
 %bcond_without opencl          # OpenCL support
 %bcond_without opencl_spirv    # OpenCL SPIRV support
 %bcond_without ocl_icd         # OpenCL as ICD (installable client driver)
-%bcond_with    glvnd           # OpenGL vendor neutral dispatcher support
+%bcond_without glvnd           # OpenGL vendor neutral dispatcher support
 %bcond_without omx             # OpenMAX (Bellagio OMXIL) support
 %bcond_without va              # VA library
 %bcond_without wayland         # Wayland EGL
 # (until they start to be somehow versioned themselves)
 %define                glapi_ver               7.1.0
 # other packages
-%define                libdrm_ver              2.4.105
+%define                libdrm_ver              2.4.107
 %define                dri2proto_ver           2.8
 %define                glproto_ver             1.4.14
 %define                zlib_ver                1.2.8
 %define                wayland_ver             1.18
-%define                libglvnd_ver            1.3.2
-%define                llvm_ver                8.0.0
+%define                libglvnd_ver            1.3.4-2
+%define                llvm_ver                11.0.0
 %define                gcc_ver                 6:4.8.0
 
 %if %{without gallium}
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       21.1.1
+Version:       21.3.4
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 #Source0:      ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
 ## Source0-md5:        7c61a801311fb8d2f7b3cceb7b5cf308
 Source0:       https://gitlab.freedesktop.org/mesa/mesa/-/archive/mesa-%{version}/mesa-mesa-%{version}.tar.bz2
-# Source0-md5: 86f091acebe3052c8b8b300936063911
-Patch0:                nouveau_no_rtti.patch
-Patch1:                zink_x32.patch
+# Source0-md5: 0c1fd7c56b86e830d71c21e58d3eb026
+Patch0:                zink_x32.patch
 URL:           https://www.mesa3d.org/
 %{?with_opencl_spirv:BuildRequires:    SPIRV-LLVM-Translator-devel >= 8.0.1.3}
 %{?with_gallium_zink:BuildRequires:    Vulkan-Loader-devel}
@@ -96,7 +97,7 @@ BuildRequires:        libselinux-devel
 BuildRequires: libstdc++-devel >= %{gcc_ver}
 BuildRequires: libunwind-devel
 %{?with_va:BuildRequires:      libva-devel}
-%{?with_va:BuildRequires:      pkgconfig(libva) >= 0.39.0}
+%{?with_va:BuildRequires:      pkgconfig(libva) >= 1.8.0}
 %{?with_vdpau:BuildRequires:   libvdpau-devel >= 1.1}
 BuildRequires: libxcb-devel >= 1.13
 %{?with_gallium:BuildRequires: llvm-devel >= %{llvm_ver}}
@@ -265,6 +266,7 @@ Group:              X11/Development/Libraries
 %if %{with glvnd}
 Requires:      libglvnd-libGL-devel >= %{libglvnd_ver}
 %else
+Requires:      %{name}-khrplatform-devel = %{version}-%{release}
 Requires:      %{name}-libGL = %{version}-%{release}
 Requires:      libdrm-devel >= %{libdrm_ver}
 Requires:      libxcb-devel >= 1.13
@@ -521,6 +523,7 @@ Pliki nagłówkowe biblioteki akceleracji Gallium3D dla Xorg.
 Summary:       Khronos platform header file
 Summary(pl.UTF-8):     Plik nagłówkowy platformy Khronos
 Group:         Development/Libraries
+Provides:      khrplatform-devel
 Conflicts:     Mesa-libEGL-devel < 8.0.1-2
 
 %description khrplatform-devel
@@ -537,7 +540,7 @@ Requires:   libdrm-devel >= %{libdrm_ver}
 # <GL/gl.h>
 %if %{with glvnd}
 Requires:      libglvnd-libGL-devel >= %{libglvnd_ver}
-Conflicts:     Mesa-libGL-devel < 22.1.0-2
+Conflicts:     Mesa-libGL-devel < 21.1.0-2
 %else
 Requires:      Mesa-libGL-devel = %{version}-%{release}
 %endif
@@ -612,11 +615,12 @@ Summary:  X.org DRI driver for ATI R100 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart ATI R100
 License:       MIT
 Group:         X11/Libraries
-Requires:      xorg-driver-video-ati
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Suggests:      xorg-driver-video-amdgpu
+Suggests:      xorg-driver-video-ati
 Obsoletes:     X11-driver-radeon-dri < 1:7.0.0
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-ati-radeon-R100
 X.org DRI driver for ATI R100 card family (Radeon 7000-7500). It
@@ -631,11 +635,12 @@ Summary:  X.org DRI driver for ATI R200 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart ATI R200
 License:       MIT
 Group:         X11/Libraries
-Requires:      xorg-driver-video-ati
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Suggests:      xorg-driver-video-amdgpu
+Suggests:      xorg-driver-video-ati
 Obsoletes:     X11-driver-radeon-dri < 1:7.0.0
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-ati-radeon-R200
 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx). It
@@ -651,11 +656,12 @@ Summary(pl.UTF-8):        Sterownik X.org DRI dla rodziny kart ATI R300
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-Requires:      xorg-driver-video-ati
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Suggests:      xorg-driver-video-amdgpu
+Suggests:      xorg-driver-video-ati
 Obsoletes:     X11-driver-radeon-dri < 1:7.0.0
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-ati-radeon-R300
 X.org Gallium DRI driver for ATI R300/R400/RS690/R500 card family
@@ -678,10 +684,11 @@ License:  MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
 Requires:      radeon-ucode
-Requires:      xorg-driver-video-ati
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Suggests:      xorg-driver-video-amdgpu
+Suggests:      xorg-driver-video-ati
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-ati-radeon-R600
 X.org Gallium DRI driver for ATI R600/R700 card family (Radeon HD
@@ -704,10 +711,11 @@ License:  MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
 Requires:      radeon-ucode
-Requires:      xorg-driver-video-ati
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Suggests:      xorg-driver-video-amdgpu
+Suggests:      xorg-driver-video-ati
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-ati-radeon-SI
 X.org Gallium DRI driver for ATI Southern Islands card family (Radeon
@@ -727,10 +735,10 @@ Summary(pl.UTF-8):        Sterownik X.org DRI dla układów Vivante 3D
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-#Requires:     xorg-driver-video-?
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+#Suggests:     xorg-driver-video-?
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-etnaviv
 X.org Gallium DRI driver for Vivante 3D chips.
@@ -744,10 +752,10 @@ Summary(pl.UTF-8):        Sterownik X.org DRI dla układów Adreno
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-Requires:      xorg-driver-video-freedreno
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Suggests:      xorg-driver-video-freedreno
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-freedreno
 X.org Gallium DRI driver for Adreno chips.
@@ -755,6 +763,22 @@ X.org Gallium DRI driver for Adreno chips.
 %description dri-driver-freedreno -l pl.UTF-8
 Sterownik X.org DRI Gallium dla układów Adreno.
 
+%package dri-driver-intel-crocus
+Summary:       X.org DRI driver for Intel Gen4-Gen7 chips
+Summary(pl.UTF-8):     Sterownik X.org DRI dla układów Intel Gen4-Gen7
+License:       MIT
+Group:         X11/Libraries
+%{?with_swr:Requires:  cpuinfo(avx)}
+Requires:      zlib >= %{zlib_ver}
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
+
+%description dri-driver-intel-crocus
+X.org Gallium DRI driver for Intel Gen4/Gen5/Gen6/Gen7 chips.
+
+%description dri-driver-intel-crocus -l pl.UTF-8
+Sterownik X.org DRI dla układów Intel Gen4/Gen5/Gen6/Gen7.
+
 %package dri-driver-intel-i915
 Summary:       X.org DRI driver for Intel i915 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Intel i915
@@ -763,11 +787,11 @@ Group:            X11/Libraries
 %if %{with gallium_i915}
 %{?with_swr:Requires:  cpuinfo(avx)}
 %endif
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
 Obsoletes:     Mesa-dri-driver-intel-i830 < 6.5
 Obsoletes:     X11-driver-i810-dri < 1:7.0.0
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-intel-i915
 X.org DRI driver for Intel i915 card family (830, 845, 852/855, 865,
@@ -782,11 +806,11 @@ Summary:  X.org DRI driver for Intel i965 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Intel i965
 License:       MIT
 Group:         X11/Libraries
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
 Obsoletes:     Mesa-dri-driver-intel-i830 < 6.5
 Obsoletes:     X11-driver-i810-dri < 1:7.0.0
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-intel-i965
 X.org (non-Gallium) DRI driver for Intel i965 card family (946GZ,
@@ -810,9 +834,9 @@ Summary(pl.UTF-8):  Sterownik X.org DRI dla rodziny kart Intel Iris (Gen8+)
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-intel-iris
 X.org Gallium DRI driver for Intel Iris (Gen8+) card family
@@ -830,10 +854,10 @@ Summary(pl.UTF-8):        Sterownik X.org DRI Gallium wykorzystujący architekturę KMS
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-#Requires:     xorg-driver-video-?
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+#Suggests:     xorg-driver-video-?
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-kmsro
 X.org Gallium DRI driver using KMS Render-Only architecture.
@@ -848,10 +872,10 @@ Summary(pl.UTF-8):        Sterownik X.org DRI dla układów Mali Utgard
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-#Requires:     xorg-driver-video-???
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+#Suggests:     xorg-driver-video-???
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-lima
 X.org Gallium DRI driver for Mali Utgard chips.
@@ -867,10 +891,10 @@ Group:            X11/Libraries
 %if %{with gallium_nouveau}
 %{?with_swr:Requires:  cpuinfo(avx)}
 %endif
-Requires:      xorg-driver-video-nouveau
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Suggests:      xorg-driver-video-nouveau
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-nouveau
 X.org DRI drivers for NVIDIA card family.
@@ -884,10 +908,10 @@ Summary(pl.UTF-8):        Sterownik X.org DRI dla układów Mali Midgard/Bifrost
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-#Requires:     xorg-driver-video-???
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+#Suggests:     xorg-driver-video-???
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-panfrost
 X.org Gallium DRI driver for Mali Midgard/Bifrost chips.
@@ -901,9 +925,9 @@ Summary(pl.UTF-8):  Sterownik X.org DRI obsługujący rysowanie programowe
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-swrast
 X.org DRI software rasterizer driver.
@@ -917,10 +941,10 @@ Summary(pl.UTF-8):        Sterownik X.org DRI dla układów SoC Tegra
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-#Requires:     xorg-driver-video-???
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+#Suggests:     xorg-driver-video-???
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-tegra
 X.org Gallium DRI driver for Tegra SoC chips.
@@ -934,10 +958,10 @@ Summary(pl.UTF-8):        Sterownik X.org DRI dla układów Broadcom VC5
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-Requires:      xorg-driver-video-modesetting
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Suggests:      xorg-driver-video-modesetting
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-v3d
 X.org Gallium DRI driver for Broadcom VC5 chips.
@@ -951,10 +975,10 @@ Summary(pl.UTF-8):        Sterownik X.org DRI dla układów Broadcom VC4
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-Requires:      xorg-driver-video-modesetting
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Suggests:      xorg-driver-video-modesetting
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-vc4
 X.org Gallium DRI driver for Broadcom VC4 chips.
@@ -968,9 +992,9 @@ Summary(pl.UTF-8):  Sterownik X.org DRI dla QEMU VirGL
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-virgl
 X.org Gallium DRI driver for QEMU VirGL.
@@ -984,10 +1008,10 @@ Summary(pl.UTF-8):       Sterownik X.org DRI dla VMware
 License:       MIT
 Group:         X11/Libraries
 %{?with_swr:Requires:  cpuinfo(avx)}
-Requires:      xorg-driver-video-vmware
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Suggests:      xorg-driver-video-vmware
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-vmwgfx
 X.org Gallium DRI driver for VMWare.
@@ -1000,9 +1024,9 @@ Summary:  X.org DRI driver based on Vulkan
 Summary(pl.UTF-8):     Sterownik X.org DRI oparty na Vulkanie
 License:       MIT
 Group:         X11/Libraries
-Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
-Requires:      xorg-xserver-server >= %{xserver_ver}
 Requires:      zlib >= %{zlib_ver}
+Conflicts:     xorg-xserver-libglx(glapi) > %{glapi_ver}
+Conflicts:     xorg-xserver-libglx(glapi) < %{glapi_ver}
 
 %description dri-driver-zink
 X.org Gallium DRI driver based on Vulkan.
@@ -1010,6 +1034,20 @@ X.org Gallium DRI driver based on Vulkan.
 %description dri-driver-zink -l pl.UTF-8
 Sterownik X.org DRI Gallium oparty na Vulkanie.
 
+%package pipe-driver-crocus
+Summary:       crocus driver for Mesa Gallium dynamic pipe loader
+Summary(pl.UTF-8):     Sterownik crocus dla dynamicznego systemu potoków szkieletu Mesa Gallium
+Group:         Libraries
+Requires:      zlib >= %{zlib_ver}
+
+%description pipe-driver-crocus
+crocus driver for Mesa Gallium dynamic pipe loader. It supports Intel
+Gen4/Gen5/Gen6/Gen7 chips.
+
+%description pipe-driver-crocus -l pl.UTF-8
+Sterownik crocus dla dynamicznego systemu potoków szkieletu Mesa
+Gallium. Obsługuje układy Intela Gen4/Gen5/Gen6/Gen7.
+
 %package pipe-driver-i915
 Summary:       i915 driver for Mesa Gallium dynamic pipe loader
 Summary(pl.UTF-8):     Sterownik i915 dla dynamicznego systemu potoków szkieletu Mesa Gallium
@@ -1044,6 +1082,19 @@ Gallium. Obsługuje układy Intela z rodziny kart Intel Iris (Gen8+:
 Broadwell, Skylake, Broxton, Kabylake, Coffeelake, Geminilake, Whiskey
 Lake, Comet Lake, Cannonlake, Ice Lake, Elkhart Lake).
 
+%package pipe-driver-kmsro
+Summary:       kmsro driver for Mesa Gallium dynamic pipe loader
+Summary(pl.UTF-8):     Sterownik kmsro dla dynamicznego systemu potoków szkieletu Mesa Gallium
+Group:         Libraries
+Requires:      zlib >= %{zlib_ver}
+
+%description pipe-driver-kmsro
+kmsro driver for Mesa Gallium dynamic pipe loader.
+
+%description pipe-driver-kmsro -l pl.UTF-8
+Sterownik kmsro dla dynamicznego systemu potoków szkieletu Mesa
+Gallium.
+
 %package pipe-driver-msm
 Summary:       msm (freedreno) driver for Mesa Gallium dynamic pipe loader
 Summary(pl.UTF-8):     Sterownik msm (freedreno) dla dynamicznego systemu potoków szkieletu Mesa Gallium
@@ -1198,7 +1249,7 @@ Sterowniki VA do Gallium (r600, radeonsi & nouveau).
 Summary:       VA driver for ATI Radeon R600 series adapters
 Summary(pl.UTF-8):     Sterownik VA dla kart ATI Radeon z serii R600
 Group:         Libraries
-Requires:      libva >= 1.6.0
+Requires:      libva >= 1.8.0
 Requires:      zlib >= %{zlib_ver}
 
 %description -n libva-driver-r600
@@ -1211,7 +1262,7 @@ Sterownik VA dla kart ATI Radeon z serii R600.
 Summary:       VA driver for ATI Radeon SI adapters
 Summary(pl.UTF-8):     Sterownik VA dla kart ATI Radeon SI
 Group:         Libraries
-Requires:      libva >= 1.6.0
+Requires:      libva >= 1.8.0
 Requires:      zlib >= %{zlib_ver}
 
 %description -n libva-driver-radeonsi
@@ -1225,7 +1276,7 @@ Islands.
 Summary:       VA driver for NVidia adapters
 Summary(pl.UTF-8):     Sterownik VA dla kart NVidia
 Group:         Libraries
-Requires:      libva >= 1.6.0
+Requires:      libva >= 1.8.0
 Requires:      zlib >= %{zlib_ver}
 
 %description -n libva-driver-nouveau
@@ -1296,8 +1347,8 @@ Group:            X11/Libraries
 Requires:      libdrm >= %{libdrm_ver}
 Requires:      libvdpau >= 1.1
 Requires:      zlib >= %{zlib_ver}
-Conflicts:     libvdpau-driver-mesa
 Obsoletes:     Mesa-libllvmradeon < 9.2
+Conflicts:     libvdpau-driver-mesa
 
 %description -n libvdpau-driver-mesa-radeonsi
 Mesa radeonsi driver for the vdpau API. It supports ATI Radeon
@@ -1313,8 +1364,8 @@ Summary(pl.UTF-8):        Sterownik Mesa nouveau dla API Bellagio OpenMAX IL
 License:       MIT
 Group:         X11/Libraries
 Requires:      libdrm >= %{libdrm_ver}
-Requires:      libxcb >= 1.13
 Requires:      libomxil-bellagio
+Requires:      libxcb >= 1.13
 Requires:      zlib >= %{zlib_ver}
 Obsoletes:     omxil-mesa-nouveau < 10.3
 Obsoletes:     omxil-mesa-r600 < 10.3
@@ -1411,6 +1462,27 @@ lavapipe - Mesa software Vulkan driver.
 %description vulkan-icd-lavapipe -l pl.UTF-8
 lavapipe - programowy sterownik Vulkan.
 
+%package vulkan-icd-panfrost
+Summary:       panfrost - Mesa Vulkan driver for Mali Midgard and Bifrost GPUs
+Summary(pl.UTF-8):     panfrost - sterownik Vulkan dla układów Mali Midgard i Bifrost
+License:       MIT
+Group:         Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.13
+Requires:      xorg-lib-libXrandr >= 1.3
+Requires:      xorg-lib-libxshmfence >= 1.1
+# wayland-client
+Requires:      wayland >= %{wayland_ver}
+Requires:      zlib >= %{zlib_ver}
+Suggests:      vulkan(loader)
+Provides:      vulkan(icd) = 1.0.3
+
+%description vulkan-icd-panfrost
+panfrost - Mesa Vulkan driver for Mali Midgard and Bifrost GPUs.
+
+%description vulkan-icd-panfrost -l pl.UTF-8
+panfrost - sterownik Vulkan dla układów Mali Midgard i Bifrost.
+
 %package vulkan-icd-radeon
 Summary:       radv - experimental Mesa Vulkan driver for AMD Radeon GPUs
 Summary(pl.UTF-8):     radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD
@@ -1435,7 +1507,6 @@ radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD.
 %prep
 %setup -q -n mesa-mesa-%{version}
 %patch0 -p1
-%patch1 -p1
 
 %build
 %if %{with opencl}
@@ -1458,7 +1529,7 @@ dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
 
 gallium_drivers="virgl swrast %{?with_gallium_zink:zink} \
 %ifarch %{ix86} %{x8664} x32
-svga iris %{?with_swr:swr} %{?with_gallium_i915:i915} \
+svga iris %{?with_swr:swr} %{?with_gallium_i915:i915} crocus \
 %endif
 %if %{with gallium_radeon}
 r300 r600 radeonsi \
@@ -1476,6 +1547,7 @@ v3d \
 vc4 \
 %endif
 "
+# TODO: asahi (Apple Silicon) - arm/aarch64?
 
 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
 
@@ -1484,7 +1556,7 @@ vulkan_drivers="swrast %{?with_radv:amd} \
 intel \
 %endif
 %ifarch %{arm} aarch64
-freedreno broadcom \
+freedreno broadcom panfrost \
 %endif
 "
 
@@ -1533,6 +1605,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %ninja_install -C build
 
+install -d $RPM_BUILD_ROOT%{_libdir}/gbm
+
 # not used externally
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libglapi.so
 
@@ -1698,6 +1772,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libgbm.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
+%dir %{_libdir}/gbm
 
 %files libgbm-devel
 %defattr(644,root,root,755)
@@ -1800,6 +1875,7 @@ rm -rf $RPM_BUILD_ROOT
 %ifarch %{ix86} %{x8664} x32
 %files dri-driver-intel-i915
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
 
 %files dri-driver-intel-i965
@@ -1807,6 +1883,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
 
 %if %{with gallium}
+%files dri-driver-intel-crocus
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/crocus_dri.so
+
 %files dri-driver-intel-iris
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/iris_dri.so
@@ -1848,6 +1928,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-dcss_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-drm_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ingenic-drm_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/kirin_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/mali-dp_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mcde_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mediatek_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/meson_dri.so
@@ -1906,6 +1988,10 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with gallium}
 %if %{with opencl}
 %ifarch %{ix86} %{x8664} x32
+%files pipe-driver-crocus
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/gallium-pipe/pipe_crocus.so
+
 %if %{with gallium_i915}
 %files pipe-driver-i915
 %defattr(644,root,root,755)
@@ -1917,7 +2003,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_iris.so
 %endif
 
-%ifarch %{arm}
+%ifarch %{arm} aarch64
+%files pipe-driver-kmsro
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/gallium-pipe/pipe_kmsro.so
+
 %files pipe-driver-msm
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_msm.so
@@ -1947,10 +2037,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_swrast.so
 
+%ifarch %{ix86} %{x8664} x32
 %files pipe-driver-vmwgfx
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_vmwgfx.so
 %endif
+%endif
 
 # currently disabled as cannot be built with swrast
 %if %{with swr}
@@ -2041,6 +2133,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libvulkan_freedreno.so
 %{_datadir}/vulkan/icd.d/freedreno_icd.*.json
+
+%files vulkan-icd-panfrost
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libvulkan_panfrost.so
+%{_datadir}/vulkan/icd.d/panfrost_icd.*.json
 %endif
 
 %ifarch %{ix86} %{x8664} x32
This page took 1.84129 seconds and 4 git commands to generate.