]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
- updated to 9.0.2
[packages/Mesa.git] / Mesa.spec
index e5e4e02a03059e6de186cdcfd0142c4e3081a85c..1615f93d0a3046cc9a9d360084a8f18b8e2e92ac 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -1,17 +1,17 @@
 #
 # TODO:
+# - check if gallium_intel note is still valid, switch the bcond if not
 # - consider:
-#   --enable-shared-dricore
 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
 # - resurrect static if it's useful (using plain xorg target? DRI doesn't support static)
 #
 # Conditional build:
-%bcond_without egl             # EGL libraries
 %bcond_without gallium         # gallium drivers
-%bcond_with    gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
+%bcond_with    gallium_intel   # gallium i915 driver (instead of plain dri; doesn't work with AIGLX)
 %bcond_without gallium_nouveau # gallium nouveau driver
-%bcond_without osmesa          # OSMesa libraries
+%bcond_without egl             # EGL libraries
 %bcond_without gbm             # Graphics Buffer Manager
+%bcond_without opencl          # OpenCL library
 %bcond_without wayland         # Wayland EGL
 %bcond_without xa              # XA state tracker (for vmwgfx xorg driver)
 %bcond_with    static_libs     # static libraries [not supported for DRI, thus broken currently]
 # (until they start to be somehow versioned themselves)
 %define                glapi_ver       7.1.0
 #
-%define                libdrm_ver      2.4.30
+%define                libdrm_ver      2.4.39
 %define                dri2proto_ver   2.6
 %define                glproto_ver     1.4.14
-#
+
+%define                snap            20120921
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       8.0.1
-Release:       2
-License:       MIT (core), SGI (GLU) and others - see license.html file
+Version:       9.0.2
+Release:       1
+License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: 24eeebf66971809d8f40775a379b36c9
-Patch0:                %{name}-realclean.patch
-Patch1:                %{name}-link.patch
-Patch2:                %{name}-wayland.patch
+# Source0-md5: dc45d1192203e418163e0017640e1cfc
+Patch0:                %{name}-link.patch
+Patch1:                %{name}-llvm3.2-support.patch
 URL:           http://www.mesa3d.org/
-BuildRequires: autoconf >= 2.59
+BuildRequires: autoconf >= 2.60
 BuildRequires: automake
+%{?with_opencl:BuildRequires:  clang-devel >= 3.1}
 BuildRequires: expat-devel
 BuildRequires: gcc >= 5:3.3
+%{?with_opencl:BuildRequires:  gcc >= 6:4.6}
 BuildRequires: libdrm-devel >= %{libdrm_ver}
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 5:3.3.0
 BuildRequires: libtalloc-devel >= 2:2.0.1
-BuildRequires: libtool >= 2:1.4d
+BuildRequires: libtool >= 2:2.2
 BuildRequires: libvdpau-devel >= 0.4.1
-BuildRequires: llvm-devel >= 2.9
+BuildRequires: libxcb-devel >= 1.9
+BuildRequires: llvm-devel >= 3.1
+%{?with_opencl:BuildRequires:  llvm-libclc}
+BuildRequires: perl-base
 BuildRequires: pixman-devel
 BuildRequires: pkgconfig
 BuildRequires: pkgconfig(talloc) >= 2.0.1
-BuildRequires: python
+BuildRequires: python >= 2
 BuildRequires: python-libxml2
-BuildRequires: python-modules
+BuildRequires: python-modules >= 2
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
+%{?with_egl:BuildRequires:     udev-devel >= 1:150}
 # wayland-{client,server}
-%{?with_wayland:BuildRequires: wayland-devel}
+%{?with_wayland:BuildRequires: wayland-devel >= 1.0.0}
 BuildRequires: xorg-lib-libXdamage-devel
 BuildRequires: xorg-lib-libXext-devel >= 1.0.5
 BuildRequires: xorg-lib-libXfixes-devel
@@ -70,11 +76,7 @@ BuildRequires:       xorg-lib-libXxf86vm-devel
 BuildRequires: xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 BuildRequires: xorg-proto-glproto-devel >= %{glproto_ver}
 BuildRequires: xorg-util-makedepend
-BuildRequires: xorg-xserver-server-devel
-%if %{with egl}
-BuildRequires: libxcb-devel
-BuildRequires: udev-devel >= 1:150
-%endif
+BuildRequires: xorg-xserver-server-devel >= %{xserver_ver}
 %if %{with gallium}
 BuildRequires: xorg-proto-xextproto-devel >= 7.0.99.1
 BuildRequires: xorg-xserver-server-devel >= 1.6.0
@@ -84,6 +86,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %if %{without gallium}
 %undefine      with_gallium_intel
 %undefine      with_gallium_nouveau
+%undefine      with_opencl
 %undefine      with_xa
 %endif
 
@@ -92,8 +95,11 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %undefine      with_wayland
 %endif
 
-# _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
-%define                skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.*
+# libGLESv1_CM, libGLESv2, libGL, libOSMesa:
+#  _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
+# libdricore: internal library, not linked with libglapi
+# libgbm: circular dependency with libEGL (wayland_buffer_is_drm symbol)
+%define                skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libOSMesa.so.* libdricore.*.so.* libgbm.*.so.*
 
 # llvm build broken
 %define                filterout_ld    -Wl,--as-needed
@@ -122,6 +128,8 @@ Requires:   %{name}-libglapi = %{version}-%{release}
 # glx driver in libEGL dlopens libGL.so
 Requires:      OpenGL >= 1.2
 Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.9
+%{?with_wayland:Requires:      wayland >= 1.0.0}
 %if %{with gallium}
 # for egl_gallium.so
 Requires:      %{name}-libOpenVG = %{version}-%{release}
@@ -187,7 +195,7 @@ License:    MIT
 Group:         X11/Libraries
 Requires:      %{name}-libglapi = %{version}-%{release}
 Requires:      libdrm >= %{libdrm_ver}
-Provides:      OpenGL = 2.1
+Provides:      OpenGL = 3.1
 Provides:      OpenGL-GLX = 1.4
 Obsoletes:     Mesa
 Obsoletes:     Mesa-dri
@@ -231,7 +239,7 @@ Requires:   xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 Requires:      xorg-proto-glproto-devel >= %{glproto_ver}
 Suggests:      OpenGL-doc-man
 Provides:      OpenGL-GLX-devel = 1.4
-Provides:      OpenGL-devel = 2.1
+Provides:      OpenGL-devel = 3.1
 Obsoletes:     Mesa-devel
 Obsoletes:     X11-OpenGL-devel < 1:7.0.0
 Obsoletes:     X11-OpenGL-devel-base < 1:7.0.0
@@ -250,7 +258,7 @@ Summary(pl.UTF-8):  Statyczna biblioteka libGL z projektu Mesa3D
 License:       MIT
 Group:         X11/Development/Libraries
 Requires:      %{name}-libGL-devel = %{version}-%{release}
-Provides:      OpenGL-static = 2.1
+Provides:      OpenGL-static = 3.1
 Obsoletes:     Mesa-static
 Obsoletes:     X11-OpenGL-static < 1:7.0.0
 Obsoletes:     XFree86-OpenGL-static < 1:7.0.0
@@ -267,6 +275,9 @@ Summary:    Mesa implementation of GLES (OpenGL ES) libraries
 Summary(pl.UTF-8):     Implementacja Mesa bibliotek GLES (OpenGL ES)
 Group:         Libraries
 Requires:      %{name}-libglapi = %{version}-%{release}
+Provides:      OpenGLES
+Provides:      OpenGLESv1 = 1.1
+Provides:      OpenGLESv2 = 2.0
 
 %description libGLES
 This package contains shared libraries of Mesa implementation of GLES
@@ -291,6 +302,9 @@ Requires:   %{name}-khrplatform-devel = %{version}-%{release}
 # <EGL/egl.h> for <GLES/egl.h>
 Requires:      %{name}-libEGL-devel = %{version}-%{release}
 Requires:      %{name}-libGLES = %{version}-%{release}
+Provides:      OpenGLES-devel
+Provides:      OpenGLESv1-devel = 1.1
+Provides:      OpenGLESv2-devel = 2.0
 
 %description libGLES-devel
 Header files for Mesa GLES libraries.
@@ -298,56 +312,6 @@ Header files for Mesa GLES libraries.
 %description libGLES-devel -l pl.UTF-8
 Pliki nagłówkowe bibliotek Mesa GLES.
 
-%package libGLU
-Summary:       SGI implementation of libGLU OpenGL library
-Summary(pl.UTF-8):     Implementacja SGI biblioteki libGLU ze standardu OpenGL
-License:       SGI Free Software License B v2.0 (MIT-like)
-Group:         Libraries
-# loose dependency on libGL.so.1 to use with other libGL binaries
-Requires:      OpenGL >= 1.2
-Provides:      OpenGL-GLU = 1.3
-Obsoletes:     Mesa-devel
-Obsoletes:     X11-OpenGL-libs < 1:7.0.0
-Obsoletes:     XFree86-OpenGL-libs < 1:7.0.0
-
-%description libGLU
-SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
-1.3 specifications.
-
-%description libGLU -l pl.UTF-8
-Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
-specyfikację OpenGL GLU 1.3.
-
-%package libGLU-devel
-Summary:       Header files for SGI libGLU library
-Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki SGI libGLU
-License:       SGI Free Software License B v2.0 (MIT-like)
-Group:         Development/Libraries
-Requires:      %{name}-libGLU = %{version}-%{release}
-Requires:      OpenGL-devel >= 1.2
-Requires:      libstdc++-devel
-Provides:      OpenGL-GLU-devel = 1.3
-
-%description libGLU-devel
-Header files for SGI libGLU library.
-
-%description libGLU-devel -l pl.UTF-8
-Pliki nagłówkowe biblioteki SGI libGLU.
-
-%package libGLU-static
-Summary:       Static SGI libGLU library
-Summary(pl.UTF-8):     Statyczna biblioteka SGI libGLU
-License:       SGI Free Software License B v2.0 (MIT-like)
-Group:         Development/Libraries
-Requires:      %{name}-libGLU-devel = %{version}-%{release}
-Provides:      OpenGL-GLU-static = 1.3
-
-%description libGLU-static
-Static SGI libGLU library.
-
-%description libGLU-static -l pl.UTF-8
-Statyczna biblioteka SGI libGLU.
-
 %package libOSMesa
 Summary:       OSMesa (off-screen renderer) library
 Summary(pl.UTF-8):     Biblioteka OSMesa (renderująca bitmapy w pamięci)
@@ -391,11 +355,147 @@ Static OSMesa (off-screen renderer) library.
 %description libOSMesa-static -l pl.UTF-8
 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
 
+%package libOpenCL
+Summary:       Mesa implementation of OpenCL (Compuing Language) API
+Summary(pl.UTF-8):     Implementacja Mesa API OpenCL (języka obliczeń)
+License:       MIT
+Group:         Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      llvm-libclc
+Requires:      udev-libs >= 1:150
+Provides:      OpenCL = 1.1
+
+%description libOpenCL
+This package contains Mesa implementation of OpenCL - standard for
+cross-platform, parallel programming of modern processors found in
+personal computers, servers and handheld/embedded devices. OpenCL
+specification can be found on Khronos Group site:
+<http://www.khronos.org/opencl/>. Mesa implements OpenCL 1.1.
+
+%description libOpenCL -l pl.UTF-8
+Ten pakiet zawiera implementację Mesa standardu OpenCL - standardu
+wieloplatformowego, równoległego programowania nowoczesnych
+procesorów, jakie znajdują się w komputerach osobistych, serwerach
+oraz urządzeniach przenośnych/wbudowanych. Specyfikację OpenCL można
+znaleźć na stronie Khronos Group: <http://www.khronos.org/opencl/>.
+Mesa zawiera implementację OpenCL w wersji 1.1.
+
+%package libOpenCL-devel
+Summary:       Header files for Mesa OpenCL library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Mesa OpenCL
+License:       MIT
+Group:         Development/Libraries
+Requires:      %{name}-libOpenCL = %{version}-%{release}
+Provides:      OpenCL-devel = 1.1
+
+%description libOpenCL-devel
+Header files for Mesa OpenCL library.
+
+%description libOpenCL-devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki Mesa OpenCL.
+
+%package opencl-driver-i915
+Summary:       i915 driver for Mesa OpenCL implementation
+Summary(pl.UTF-8):     Sterownik i915 dla implementacji Mesa OpenCL
+Group:         Libraries
+Requires:      %{name}-libOpenCL = %{version}-%{release}
+
+%description opencl-driver-i915
+i915 driver for Mesa OpenCL implementation. It supports Intel
+915/945/G33/Q33/Q35/Pineview chips.
+
+%description opencl-driver-i915 -l pl.UTF-8
+Sterownik i915 dla implementacji Mesa standardu OpenCL. Obsługuje
+układy Intela z serii 915/945/G33/Q33/Q35/Pineview.
+
+%package opencl-driver-nouveau
+Summary:       nouveau driver for Mesa OpenCL implementation
+Summary(pl.UTF-8):     Sterownik nouveau dla implementacji Mesa OpenCL
+Group:         Libraries
+Requires:      %{name}-libOpenCL = %{version}-%{release}
+
+%description opencl-driver-nouveau
+nouveau driver for Mesa OpenCL implementation. It supports NVidia
+adapters.
+
+%description opencl-driver-nouveau -l pl.UTF-8
+Sterownik nouveau dla implementacji Mesa standardu OpenCL. Obsługuje
+karty graficzne firmy NVidia.
+
+%package opencl-driver-r300
+Summary:       r300 driver for Mesa OpenCL implementation
+Summary(pl.UTF-8):     Sterownik r300 dla implementacji Mesa OpenCL
+Group:         Libraries
+Requires:      %{name}-libOpenCL = %{version}-%{release}
+
+%description opencl-driver-r300
+r300 driver for Mesa OpenCL implementation. It supports ATI Radeon
+adapters based on R300/R400/RS690/R500 chips.
+
+%description opencl-driver-r300 -l pl.UTF-8
+Sterownik r300 dla implementacji Mesa standardu OpenCL. Obsługuje
+karty graficzne ATI Radeon oparte na układach R300/R400/RS690/R500.
+
+%package opencl-driver-r600
+Summary:       r600 driver for Mesa OpenCL implementation
+Summary(pl.UTF-8):     Sterownik r600 dla implementacji Mesa OpenCL
+Group:         Libraries
+Requires:      %{name}-libOpenCL = %{version}-%{release}
+
+%description opencl-driver-r600
+r600 driver for Mesa OpenCL implementation. It supports ATI Radeon
+adapters based on R600/R700 chips.
+
+%description opencl-driver-r600 -l pl.UTF-8
+Sterownik r600 dla implementacji Mesa standardu OpenCL. Obsługuje
+karty graficzne ATI Radeon oparte na układach R600/R700.
+
+%package opencl-driver-radeonsi
+Summary:       radeonsi driver for Mesa OpenCL implementation
+Summary(pl.UTF-8):     Sterownik radeonsi dla implementacji Mesa OpenCL
+Group:         Libraries
+Requires:      %{name}-libOpenCL = %{version}-%{release}
+
+%description opencl-driver-radeonsi
+radeonsi driver for Mesa OpenCL implementation. It supports ATI Radeon
+adapters based on Southern Islands chips.
+
+%description opencl-driver-radeonsi -l pl.UTF-8
+Sterownik radeonsi dla implementacji Mesa standardu OpenCL. Obsługuje
+karty graficzne ATI Radeon oparte na układach Southern Islands.
+
+%package opencl-driver-swrast
+Summary:       Software (swrast) driver for Mesa OpenCL implementation
+Summary(pl.UTF-8):     Sterownik programowy (swrast) dla implementacji Mesa OpenCL
+Group:         Libraries
+Requires:      %{name}-libOpenCL = %{version}-%{release}
+
+%description opencl-driver-swrast
+Software (swrast) driver for Mesa OpenCL implementation.
+
+%description opencl-driver-swrast -l pl.UTF-8
+Sterownik programowy (swrast) dla implementacji Mesa standardu OpenCL.
+
+%package opencl-driver-vmwgfx
+Summary:       vmwgfx driver for Mesa OpenCL implementation
+Summary(pl.UTF-8):     Sterownik vmwgfx dla implementacji Mesa OpenCL
+Group:         Libraries
+Requires:      %{name}-libOpenCL = %{version}-%{release}
+
+%description opencl-driver-vmwgfx
+vmwgfx driver for Mesa OpenCL implementation. It supports VMware
+virtual video adapter.
+
+%description opencl-driver-vmwgfx -l pl.UTF-8
+Sterownik vmwgfx dla implementacji Mesa standardu OpenCL. Obsługuje
+wirtualną kartę graficzną VMware.
+
 %package libOpenVG
 Summary:       Mesa implementation of OpenVG (Vector Graphics Accelleration) API
 Summary(pl.UTF-8):     Implementacja Mesa API OpenVG (akceleracji grafiki wektorowej)
 License:       MIT
 Group:         Libraries
+Provides:      OpenVG = 1.1
 
 %description libOpenVG
 This package contains Mesa implementation of OpenVG - cross-platform
@@ -419,6 +519,7 @@ License:    MIT
 Group:         Development/Libraries
 Requires:      %{name}-khrplatform-devel = %{version}-%{release}
 Requires:      %{name}-libOpenVG = %{version}-%{release}
+Provides:      OpenVG-devel = 1.1
 
 %description libOpenVG-devel
 Header file for Mesa OpenVG library.
@@ -576,6 +677,34 @@ Sterownik r600 dla szkieletu Mesa Graphics Buffer Manager (zarządcy
 bufora graficznego). Obsługuje karty graficzne ATI Radeon oparte na
 układach R600/R700.
 
+%package gbm-driver-radeonsi
+Summary:       radeonsi driver for Mesa GBM framework
+Summary(pl.UTF-8):     Sterownik radeonsi dla szkieletu Mesa GBM
+Group:         Libraries
+Requires:      %{name}-libgbm = %{version}-%{release}
+
+%description gbm-driver-radeonsi
+radeonsi driver for Mesa Graphics Buffer Manager. It supports ATI
+Radeon adapters based on Southern Islands chips.
+
+%description gbm-driver-radeonsi -l pl.UTF-8
+Sterownik radeonsi dla szkieletu Mesa Graphics Buffer Manager
+(zarządcy bufora graficznego). Obsługuje karty graficzne ATI Radeon
+oparte na układach Southern Islands.
+
+%package gbm-driver-swrast
+Summary:       Software (swrast) driver for Mesa GBM framework
+Summary(pl.UTF-8):     Sterownik programowy (swrast) dla szkieletu Mesa GBM
+Group:         Libraries
+Requires:      %{name}-libgbm = %{version}-%{release}
+
+%description gbm-driver-swrast
+Software (swrast) driver for Mesa Graphics Buffer Manager.
+
+%description gbm-driver-swrast -l pl.UTF-8
+Sterownik programowy (swrast) dla szkieletu Mesa Graphics Buffer
+Manager (zarządcy bufora graficznego).
+
 %package gbm-driver-vmwgfx
 Summary:       vmwgfx driver for Mesa GBM framework
 Summary(pl.UTF-8):     Sterownik vmwgfx dla szkieletu Mesa GBM
@@ -621,7 +750,6 @@ Summary(pl.UTF-8):  Pliki programistyczne biblioteki Wayland EGL
 Group:         Development/Libraries
 Requires:      %{name}-libwayland-egl = %{version}-%{release}
 Requires:      libdrm-devel >= %{libdrm_ver}
-Requires:      wayland-devel
 
 %description libwayland-egl-devel
 Development files for Wayland EGL platform library.
@@ -667,11 +795,26 @@ Khronos platform header file.
 %description khrplatform-devel -l pl.UTF-8
 Plik nagłówkowy platformy Khronos.
 
+%package dri-core
+Summary:       X.org DRI core library
+Summary(pl.UTF-8):     Biblioteka X.org DRI core
+License:       MIT
+Group:         X11/Libraries
+Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
+Requires:      xorg-xserver-server >= %{xserver_ver}
+
+%description dri-core
+X.org DRI core library.
+
+%description dri-core -l pl.UTF-8
+Biblioteka X.org DRI core.
+
 %package dri-driver-ati-radeon-R100
 Summary:       X.org DRI driver for ATI R100 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart ATI R100
 License:       MIT
 Group:         X11/Libraries
+Requires:      %{name}-dri-core = %{version}-%{release}
 Requires:      xorg-driver-video-ati
 Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
 Requires:      xorg-xserver-server >= %{xserver_ver}
@@ -688,6 +831,7 @@ Summary:    X.org DRI driver for ATI R200 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart ATI R200
 License:       MIT
 Group:         X11/Libraries
+Requires:      %{name}-dri-core = %{version}-%{release}
 Requires:      xorg-driver-video-ati
 Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
 Requires:      xorg-xserver-server >= %{xserver_ver}
@@ -731,11 +875,30 @@ X.org DRI driver for ATI R600/R700 card family.
 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
 Sterownik X.org DRI dla rodziny kart ATI R600/R700.
 
+%package dri-driver-ati-radeon-SI
+Summary:       X.org DRI driver for ATI Southern Islands card family
+Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart ATI Southern Islands
+License:       MIT
+Group:         X11/Libraries
+Requires:      radeon-ucode
+Requires:      xorg-driver-video-ati
+Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
+Requires:      xorg-xserver-server >= %{xserver_ver}
+
+%description dri-driver-ati-radeon-SI
+X.org DRI driver for ATI Southern Islands card family.
+
+%description dri-driver-ati-radeon-SI -l pl.UTF-8
+Sterownik X.org DRI dla rodziny kart ATI Southern Islands.
+
 %package dri-driver-intel-i915
 Summary:       X.org DRI driver for Intel i915 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Intel i915
 License:       MIT
 Group:         X11/Libraries
+%if %{without gallium_intel}
+Requires:      %{name}-dri-core = %{version}-%{release}
+%endif
 Requires:      xorg-driver-video-intel
 Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
 Requires:      xorg-xserver-server >= %{xserver_ver}
@@ -755,6 +918,7 @@ Summary:    X.org DRI driver for Intel i965 card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart Intel i965
 License:       MIT
 Group:         X11/Libraries
+Requires:      %{name}-dri-core = %{version}-%{release}
 Requires:      xorg-driver-video-intel
 Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
 Requires:      xorg-xserver-server >= %{xserver_ver}
@@ -774,6 +938,7 @@ Summary:    X.org DRI driver for NVIDIA card family
 Summary(pl.UTF-8):     Sterownik X.org DRI dla rodziny kart NVIDIA
 License:       MIT
 Group:         X11/Libraries
+Requires:      %{name}-dri-core = %{version}-%{release}
 Requires:      xorg-driver-video-nouveau
 Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
 Requires:      xorg-xserver-server >= %{xserver_ver}
@@ -789,6 +954,7 @@ Summary:    X.org DRI software rasterizer driver
 Summary(pl.UTF-8):     Sterownik X.org DRI obsługujący rysowanie programowe
 License:       MIT
 Group:         X11/Libraries
+Requires:      %{name}-dri-core = %{version}-%{release}
 Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
 Requires:      xorg-xserver-server >= %{xserver_ver}
 
@@ -864,6 +1030,23 @@ based on R600/R700 chips.
 Sterownik Mesa r600 dla API vdpau. Obsługuje karty ATI Radeon oparte
 na układach R600/R700.
 
+%package -n libvdpau-driver-mesa-radeonsi
+Summary:       Mesa radeonsi driver for the vdpau API
+Summary(pl.UTF-8):     Sterownik Mesa radeonsi dla API vdpau
+License:       MIT
+Group:         X11/Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libvdpau >= 0.4.1
+Conflicts:     libvdpau-driver-mesa
+
+%description -n libvdpau-driver-mesa-radeonsi
+Mesa radeonsi driver for the vdpau API. It supports ATI Radeon
+adapters based on Southern Islands chips.
+
+%description -n libvdpau-driver-mesa-radeonsi -l pl.UTF-8
+Sterownik Mesa radeonsi dla API vdpau. Obsługuje karty ATI Radeon
+oparte na układach Southern Islands.
+
 %package -n libvdpau-driver-mesa-softpipe
 Summary:       Mesa softpipe driver for the vdpau API
 Summary(pl.UTF-8):     Sterownik Mesa softpipe dla API vdpau
@@ -881,19 +1064,21 @@ Sterownik Mesa softpipe dla API vdpau.
 
 %prep
 %setup -q
-%patch0 -p0
+%patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
-%{__aclocal}
+%{__libtoolize}
+%{__aclocal} -I m4
 %{__autoconf}
+%{__automake}
 
 dri_drivers="r200 radeon \
 %if %{without gallium_intel}
 i915 \
 %endif
 i965
+nouveau
 %ifarch sparc sparcv9 sparc64
 ffb \
 %endif
@@ -907,39 +1092,23 @@ i915 \
 %endif
 r300 \
 r600 \
+radeonsi \
 %if %{with gallium_nouveau}
-nouveau \
+nouveau
 %endif
 "
 
 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
 
-common_flags="\
+%configure \
+       --disable-silent-rules \
        --enable-shared \
        --enable-glx-tls \
        --enable-pic \
        --enable-selinux \
        %{?with_static_libs:--enable-static} \
-"
-
-osmesa_common_flags="\
-       --with-driver=osmesa \
-       --disable-asm \
-       --disable-egl \
-       --disable-glu"
-
-%if %{with osmesa}
-%configure $common_flags $osmesa_common_flags \
-       --with-osmesa-bits=8
-%{__make}
-%{__make} -C src/mesa osmesa.pc
-mv %{_lib} osmesa8
-cp -p src/mesa/osmesa.pc osmesa8
-%{__make} clean
-%endif
-
-%configure $common_flags \
        %{__enable gbm} \
+       --enable-osmesa \
        --enable-shared-glapi \
 %if %{with egl}
        --enable-egl \
@@ -949,8 +1118,10 @@ cp -p src/mesa/osmesa.pc osmesa8
 %endif
 %if %{with gallium}
        --enable-gallium-llvm \
+       --with-llvm-shared-libs \ \
        %{__enable egl gallium-egl} \
        %{__enable gbm gallium-gbm} \
+       %{?with_opencl:--enable-opencl} \
        %{?with_egl:--enable-openvg} \
        --enable-vdpau \
        %{?with_xa:--enable-xa} \
@@ -959,7 +1130,6 @@ cp -p src/mesa/osmesa.pc osmesa8
 %else
        --without-gallium-drivers \
 %endif
-       --with-driver=dri \
        --with-dri-drivers=${dri_drivers} \
        --with-dri-driverdir=%{_libdir}/xorg/modules/dri
 
@@ -971,17 +1141,18 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%if %{with osmesa}
-cp -dp osmesa8/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
-cp -p osmesa8/osmesa.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
-%endif
-
+# omitted by make install (as of 9.0)
+cp -pr include/CL $RPM_BUILD_ROOT%{_includedir}
 # strip out undesirable headers
 %{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/{vms_x_fix,wglext,wmesa}.h
 # dlopened by soname
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libXvMC*.so
 # not used externally
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libglapi.so
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{dricore%{version},glapi}.so
+# dlopened
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri/*.la
+# not defined by standards; and not needed, there is pkg-config support
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
 
 # remove "OS ABI: Linux 2.4.20" tag, so private copies (nvidia or fglrx),
 # set up via /etc/ld.so.conf.d/*.conf will be preferred over this
@@ -999,12 +1170,12 @@ rm -rf $RPM_BUILD_ROOT
 %post  libGLES -p /sbin/ldconfig
 %postun        libGLES -p /sbin/ldconfig
 
-%post  libGLU -p /sbin/ldconfig
-%postun        libGLU -p /sbin/ldconfig
-
 %post  libOSMesa -p /sbin/ldconfig
 %postun        libOSMesa -p /sbin/ldconfig
 
+%post  libOpenCL -p /sbin/ldconfig
+%postun        libOpenCL -p /sbin/ldconfig
+
 %post  libOpenVG -p /sbin/ldconfig
 %postun        libOpenVG -p /sbin/ldconfig
 
@@ -1029,6 +1200,9 @@ rm -rf $RPM_BUILD_ROOT
 %post  libxatracker -p /sbin/ldconfig
 %postun        libxatracker -p /sbin/ldconfig
 
+%post  dri-core -p /sbin/ldconfig
+%postun        dri-core -p /sbin/ldconfig
+
 %if %{with egl}
 %files libEGL
 %defattr(644,root,root,755)
@@ -1102,25 +1276,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/glesv1_cm.pc
 %{_pkgconfigdir}/glesv2.pc
 
-%files libGLU
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libGLU.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
-
-%files libGLU-devel
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libGLU.so
-%{_includedir}/GL/glu.h
-%{_includedir}/GL/glu_mangle.h
-%{_pkgconfigdir}/glu.pc
-
-%if %{with static_libs}
-%files libGLU-static
-%defattr(644,root,root,755)
-%{_libdir}/libGLU.a
-%endif
-
-%if %{with osmesa}
 %files libOSMesa
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
@@ -1137,6 +1292,50 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libOSMesa.a
 %endif
+
+%if %{with opencl}
+%files libOpenCL
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libOpenCL.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libOpenCL.so.1
+%dir %{_libdir}/opencl
+
+%files libOpenCL-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libOpenCL.so
+%{_includedir}/CL
+
+%if %{with gallium_intel}
+%files opencl-driver-i915
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/opencl/pipe_i915.so
+%endif
+
+%if %{with gallium_nouveau}
+%files opencl-driver-nouveau
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/opencl/pipe_nouveau.so
+%endif
+
+%files opencl-driver-r300
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/opencl/pipe_r300.so
+
+%files opencl-driver-r600
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/opencl/pipe_r600.so
+
+%files opencl-driver-radeonsi
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/opencl/pipe_radeonsi.so
+
+%files opencl-driver-swrast
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/opencl/pipe_swrast.so
+
+%files opencl-driver-vmwgfx
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/opencl/pipe_vmwgfx.so
 %endif
 
 %if %{with egl} && %{with gallium}
@@ -1214,6 +1413,14 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gbm/pipe_r600.so
 
+%files gbm-driver-radeonsi
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/gbm/pipe_radeonsi.so
+
+%files gbm-driver-swrast
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/gbm/pipe_swrast.so
+
 %files gbm-driver-vmwgfx
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gbm/pipe_vmwgfx.so
@@ -1260,6 +1467,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/KHR/khrplatform.h
 %endif
 
+%files dri-core
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libdricore%{version}.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdricore%{version}.so.1
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/drirc
+
 %files dri-driver-ati-radeon-R100
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
@@ -1276,6 +1489,11 @@ rm -rf $RPM_BUILD_ROOT
 %files dri-driver-ati-radeon-R600
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
+%endif
+
+%files dri-driver-ati-radeon-SI
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/radeonsi_dri.so
 
 %files dri-driver-intel-i915
 %defattr(644,root,root,755)
@@ -1285,12 +1503,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
 
-%if %{with gallium_nouveau}
 %files dri-driver-nouveau
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_vieux_dri.so
+%if %{with gallium_nouveau}
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
 %endif
-%endif
 
 %files dri-driver-swrast
 %defattr(644,root,root,755)
@@ -1324,6 +1542,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1
 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so
 
+%files -n libvdpau-driver-mesa-radeonsi
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_radeonsi.so.1.0
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_radeonsi.so.1
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_radeonsi.so
+
 %files -n libvdpau-driver-mesa-softpipe
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1.0
This page took 0.070421 seconds and 4 git commands to generate.