]> git.pld-linux.org Git - packages/DirectFB-extra.git/blobdiff - DirectFB-extra.spec
- up to 1.2.0-rc1
[packages/DirectFB-extra.git] / DirectFB-extra.spec
index 4a8d936799b4045e727fa6e5e885d09e80815858..454614e1df5e222398f7d3c97953af29d89c606a 100644 (file)
@@ -2,32 +2,40 @@
 # Conditional build:
 %bcond_without flash   # don't build FLASH video provider
 %bcond_without mpg     # don't build support for MPG/MPEG3
+%bcond_without swfdec  # don't build swfdec video provider
 #
+# broken currently (needs update for DirectFB 1.2.x)
+%undefine      with_flash
+# needs update for swfdec 0.6.x
+%undefine      with_swfdec
 Summary:       Additional providers and drivers for DirectFB
 Summary(pl.UTF-8):     DirectFB - dodatkowe wtyczki i sterowniki do DirectFB
 Name:          DirectFB-extra
-Version:       0.9.25
-Release:       1
+Version:       1.2.0
+%define        subver  rc1
+Release:       0.%{subver}.0.1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://www.directfb.org/download/DirectFB-extra/%{name}-%{version}.tar.gz
-# Source0-md5: 2acb95b87adf0feefd282ac29cd72ab2
+Source0:       http://www.directfb.org/downloads/Extras/%{name}-%{version}-%{subver}.tar.gz
+# Source0-md5: c3c160c167c20f320b0c0562168d0579
 Patch0:                %{name}-acfix.patch
+Patch1:                %{name}-mpeg3_open.patch
 URL:           http://www.directfb.org/
 BuildRequires: DirectFB-devel >= 1:%{version}
+BuildRequires: FusionSound-devel >= 0.9.25
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
-BuildRequires: FusionSound-devel >= 0.9.25
 BuildRequires: ffmpeg-devel
 %{?with_flash:BuildRequires:   gplflash-devel >= 0.4.10-5}
 BuildRequires: imlib2-devel
+BuildRequires: jasper-devel
 %{?with_mpg:BuildRequires:     libmpeg3-devel}
 BuildRequires: libsvg-cairo-devel >= 0.1.6
 BuildRequires: libtool
 BuildRequires: openquicktime-devel
 BuildRequires: pkgconfig >= 1:0.9
-BuildRequires: swfdec-devel >= 0.3.0
-BuildRequires: xine-lib-devel >= 2:1.0-0.rc3
+%{?with_swfdec:BuildRequires:  swfdec-devel >= 0.5.0}
+BuildRequires: xine-lib-devel >= 2:1.0.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                dfbdir          %(pkg-config --variable=moduledir directfb-internal)
@@ -43,6 +51,18 @@ fonty oraz sterowniki grafiki i wejściowe (aktualnie: wtyczkę
 dostarczającą grafikę poprzez Imlib2 oraz wtyczkę dostarczającą obraz
 OpenQuicktime).
 
+%package -n DirectFB-image-bmp
+Summary:       BMP image provider for DirectFB
+Summary(pl.UTF-8):     DirectFB - wtyczka dostarczająca grafikę BMP
+Group:         Libraries
+%requires_eq   DirectFB
+
+%description -n DirectFB-image-bmp
+This package contains BMP mage provider for DirectFB.
+
+%description -n DirectFB-image-bmp -l pl.UTF-8
+Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę BMP.
+
 %package -n DirectFB-image-imlib2
 Summary:       Imlib2 image provider for DirectFB
 Summary(pl.UTF-8):     DirectFB - wtyczka dostarczająca grafikę poprzez Imlib2
@@ -56,6 +76,31 @@ This package contains image provider based on Imlib2 for DirectFB.
 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę poprzez
 bibliotekę Imlib2.
 
+%package -n DirectFB-image-jpeg2000
+Summary:       JPEG-2000 image provider for DirectFB
+Summary(pl.UTF-8):     DirectFB - wtyczka dostarczająca grafikę JPEG-2000
+Group:         Libraries
+%requires_eq   DirectFB
+
+%description -n DirectFB-image-jpeg2000
+This package contains JPEG-2000 image provider.
+
+%description -n DirectFB-image-jpeg2000 -l pl.UTF-8
+Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę
+JPEG-2000.
+
+%package -n DirectFB-image-mpeg2
+Summary:       MPEG-2 image provider for DirectFB
+Summary(pl.UTF-8):     DirectFB - wtyczka dostarczająca grafikę MPEG-2
+Group:         Libraries
+%requires_eq   DirectFB
+
+%description -n DirectFB-image-mpeg2
+This package contains MPEG-2 image provider.
+
+%description -n DirectFB-image-mpeg2 -l pl.UTF-8
+Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę MPEG-2.
+
 %package -n DirectFB-image-pnm
 Summary:       PNM image provider for DirectFB
 Summary(pl.UTF-8):     DirectFB - wtyczka dostarczająca grafikę PNM
@@ -80,14 +125,15 @@ Group:             Libraries
 This package contains SVG image provider using Cairo library.
 
 %description -n DirectFB-image-svg -l pl.UTF-8
-Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę SVG
-przy użyciu biblioteki Cairo.
+Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę SVG przy
+użyciu biblioteki Cairo.
 
 %package -n DirectFB-video-ffmpeg
 Summary:       FFmpeg video provider for DirectFB
 Summary(pl.UTF-8):     DirectFB - wtyczka dostarczająca obraz FFmpeg
 Group:         Libraries
 %requires_eq   DirectFB
+%requires_eq   FusionSound
 
 %description -n DirectFB-video-ffmpeg
 DirectFB video provider using FFmpeg codecs.
@@ -185,8 +231,9 @@ Interfejs użytkownika XINE oparty na DirectFB. Zawiera także wtyczkę
 wyjścia obrazu DirectFB dla XINE.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}-%{subver}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -197,12 +244,13 @@ wyjścia obrazu DirectFB dla XINE.
 CPPFLAGS="-I/usr/include/libmpeg3"
 %configure \
        --disable-avifile \
-       %{!?with_flash:--disable-flash} \
-       %{!?with_mpg:--disable-libmpeg3} \
-       --enable-svg \
-       --enable-swfdec
+       %{?with_flash:--enable-flash} \
+       %{?with_mpg:--enable-libmpeg3} \
+       --enable-openquicktime \
+       %{!?with_swfdec:--disable-swfdec}
 
 %{__make} \
+       FFMPEG_CFLAGS="-I/usr/include/libavcodec -I/usr/include/libavformat" \
        MODULEDIR=%{dfbdir}
 
 %install
@@ -218,11 +266,26 @@ rm -f $RPM_BUILD_ROOT%{dfbdir}/interfaces/*/*.la \
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%files -n DirectFB-image-bmp
+%defattr(644,root,root,755)
+%doc ChangeLog README
+%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_bmp.so
+
 %files -n DirectFB-image-imlib2
 %defattr(644,root,root,755)
 %doc ChangeLog README
 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_imlib2.so
 
+%files -n DirectFB-image-jpeg2000
+%defattr(644,root,root,755)
+%doc ChangeLog README
+%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg2000.so
+
+%files -n DirectFB-image-mpeg2
+%defattr(644,root,root,755)
+%doc ChangeLog README
+%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
+
 %files -n DirectFB-image-pnm
 %defattr(644,root,root,755)
 %doc ChangeLog README
@@ -233,11 +296,6 @@ rm -rf $RPM_BUILD_ROOT
 %doc ChangeLog README
 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_svg.so
 
-%files -n DirectFB-video-openquicktime
-%defattr(644,root,root,755)
-%doc ChangeLog README
-%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_openquicktime.so
-
 %files -n DirectFB-video-ffmpeg
 %defattr(644,root,root,755)
 %doc ChangeLog README
@@ -250,6 +308,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.so
 %endif
 
+%files -n DirectFB-video-openquicktime
+%defattr(644,root,root,755)
+%doc ChangeLog README
+%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_openquicktime.so
+
 %if %{with flash}
 %files -n DirectFB-video-swf
 %defattr(644,root,root,755)
@@ -257,10 +320,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_swf.so
 %endif
 
+%if %{with swfdec}
 %files -n DirectFB-video-swfdec
 %defattr(644,root,root,755)
 %doc ChangeLog README
 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_swfdec.so
+%endif
 
 %files -n DirectFB-video-xine
 %defattr(644,root,root,755)
This page took 0.068845 seconds and 4 git commands to generate.