]> git.pld-linux.org Git - packages/CGAL.git/blobdiff - CGAL.spec
- updated to 4.14.2
[packages/CGAL.git] / CGAL.spec
index fd2a624d17bd9596be3e0f285d40bc5034cc6305..53ed0d78f54b4b476dde0da7e813199401ee9bb1 100644 (file)
--- a/CGAL.spec
+++ b/CGAL.spec
@@ -1,39 +1,49 @@
 # TODO
-# - force use of qt4, otherwise it may pick qt3! add bcond?
-# - check these:
-#   blas-devel may be superfluous !
-#   gmp-c++-devel may be superfluous !
-#   lapack-devel may be superfluous !
-# - cleanup?
-#   warning: Installed (but unpackaged) file(s) found:
-#   /usr/bin/cgal_make_macosx_app
-
-%define boost_version 1.32
+# - move qt stuff to subpackages? (libCGAL_Qt5.so, include/CGAL/Qt, some cmake files)
+# - MPFI (>= 1.5.2, mpfr >= 4.0.0)
+# - LEDA, RS, RS3 (rather old, non-free; no longer available?)
+#
+# Conditional build:
+%bcond_with    examples        # demo+examples build
+
+%define        boost_ver       1.48
+%define        qt5_ver         5.3
 Summary:       Computational Geometry Algorithms Library
+Summary(pl.UTF-8):     Computational Geometry Algorithms Library - biblioteka algorytmów geometrii obliczeniowej
 Name:          CGAL
-Version:       4.6
+Version:       4.14.2
 Release:       1
-License:       GPLv3+ and LGPLv3+
+License:       GPL v3+ and LGPL v3+
 Group:         Libraries
-Source0:       https://gforge.inria.fr/frs/download.php/file/34705/%{name}-%{version}.tar.xz
-# Source0-md5: 65fa7e17cd654ef68da47df608000007
-URL:           http://www.cgal.org/
+#Source0Download: https://github.com/CGAL/cgal/releases
+Source0:       https://github.com/CGAL/releases/archive/%{name}-%{version}.tar.gz
+# Source0-md5: 60dcfe9cf3b44ccfca1411f8276837f5
+Patch0:                %{name}-buildtype.patch
+URL:           https://www.cgal.org/
 BuildRequires: OpenGL-GLU-devel
-BuildRequires: QtCore-devel
-BuildRequires: QtGui-devel
-BuildRequires: QtOpenGL-devel
-BuildRequires: QtSvg-devel
-BuildRequires: blas-devel
-BuildRequires: boost-devel >= %{boost_version}
-BuildRequires: cmake
-BuildRequires: gmp-c++-devel
-BuildRequires: gmp-devel
-BuildRequires: lapack-devel
-BuildRequires: mpfr-devel
-BuildRequires: qt4-build
-BuildRequires: qt4-qmake
+BuildRequires: Qt5Core-devel >= %{qt5_ver}
+BuildRequires: Qt5Gui-devel >= %{qt5_ver}
+BuildRequires: Qt5OpenGL-devel >= %{qt5_ver}
+BuildRequires: Qt5Svg-devel >= %{qt5_ver}
+BuildRequires: Qt5Widgets-devel >= %{qt5_ver}
+BuildRequires: boost-devel >= %{boost_ver}
+BuildRequires: cmake >= 3.1
+BuildRequires: gmp-devel >= 4.1.4
+BuildRequires: libstdc++-devel
+BuildRequires: mpfr-devel >= 2.2.1
+BuildRequires: qt5-build >= %{qt5_ver}
+BuildRequires: qt5-qmake >= %{qt5_ver}
+BuildRequires: rpmbuild(macros) >= 1.605
 BuildRequires: sed >= 4.0
 BuildRequires: zlib-devel
+%if %{with examples}
+BuildRequires: blas-devel
+BuildRequires: eigen3 >= 3.1.91
+BuildRequires: gmp-c++-devel >= 4.1.4
+BuildRequires: ipe-devel >= 7
+BuildRequires: lapack-devel
+BuildRequires: tbb
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -44,56 +54,87 @@ geometry available to users in industry and academia in a C++ library.
 The goal is to provide easy access to useful, reliable geometric
 algorithms.
 
+%description -l pl.UTF-8
+Biblioteka dla aplikacji CGAL (Computational Geometry Algorithms
+Library). CGAL to wspólny projekt kilku placówek w Europie i Izraelu.
+Celem jest udostępnienie najważniejszych rozwiązań i metod powstałych
+w geometrii obliczeniowej dla użytkowników przemysłowych i naukowych w
+postaci biblioteki C++. Ma ona za zadanie zapewniać łatwy dostęp do
+przydatnych, wiarygodnych algorytmów geometrycznych.
+
 %package devel
 Summary:       Development files and tools for CGAL applications
+Summary(pl.UTF-8):     Pliki i narzędzia programistyczne dla aplikacji CGAL
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      boost-devel >= %{boost_ver}
+Requires:      libstdc++-devel
+# for Qt5 component
+Requires:      Qt5Core-devel >= %{qt5_ver}
+Requires:      Qt5Gui-devel >= %{qt5_ver}
+Requires:      Qt5OpenGL-devel >= %{qt5_ver}
+Requires:      Qt5Widgets-devel >= %{qt5_ver}
+# CGAL header interfaces for (using their headers) - use Suggests?
+Requires:      gmp-c++-devel >= 4.1.4
+Requires:      gmp-devel >= 4.1.4
+Requires:      mpfr-devel >= 2.2.1
+#Suggests: eigen3 >= 3.1 gsl-devel tbb-devel vtk-devel
+#Suggests(TODO): <rs_exports.h> <rs3_fncts.h> <taucs.h> <OpenMesh/Core/Mesh/PolyMesh_ArrayKernelT.hh> <NTL/ZZX.h> <mpfi.h> <LEDA/*.h> <ipelib.h>
+Requires:      zlib-devel
+# CGAL header interfaces for (without using their headers) - use Suggests?
 Requires:      blas-devel
-Requires:      boost-devel >= %{boost_version}
-Requires:      gmp-c++-devel
-Requires:      gmp-devel
 Requires:      lapack-devel
-Requires:      mpfr-devel
-Requires:      qt-devel
-Requires:      zlib-devel
 
 %description devel
-The %{name}-devel package provides the headers files and tools you may
-need to develop applications using CGAL.
+This package provides the header files and tools you may need to
+develop applications using CGAL.
+
+%description devel -l pl.UTF-8
+Ten pakiet zawiera pliki nagłówkowe i narzędzia potrzebne do tworzenia
+aplikacji wykorzystujących CGAL.
 
 %package demos-source
 Summary:       Examples and demos of CGAL algorithms
+Summary(pl.UTF-8):     Przykłady i programy demonstracyjne do algorytmów CGAL
 Group:         Documentation
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description demos-source
-The %{name}-demos-source package provides the sources of examples and
-demos of CGAL algorithms.
+This package provides the sources of examples and demos of CGAL
+algorithms.
 
+%description demos-source -l pl.UTF-8
+Ten pakiet zawiera kod źrodłowy programów przykładowych i
+demonstracyjnych do algorytmów CGAL.
 
 %prep
-%setup -q
+%setup -q -n releases-%{name}-%{version}
+%patch0 -p1
 
 %build
 install -d build
 cd build
-# override build type, because:
-# PLD is not a valid build type: only Release or Debug is allowed
-
-# XXX: what is ${CHANGE_SOVERSION} here?
-%cmake \
-       -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
+%cmake .. \
+       -DCGAL_CXX_FLAGS="%{rpmcxxflags} %{rpmcppflags}" \
+       -DCGAL_SHARED_LINKER_FLAGS="%{rpmldflags}" \
        -DCGAL_INSTALL_LIB_DIR=%{_lib} \
-       -DCGAL_INSTALL_DOC_DIR= ${CHANGE_SOVERSION} \
-       ..
+       -DCGAL_INSTALL_DOC_DIR= \
+%if %{with examples}
+       -DWITH_demos=ON \
+       -DWITH_examples=ON
+%endif
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# useless for Linux
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/cgal_make_macosx_app
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -102,21 +143,24 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS LICENSE LICENSE.FREE_USE LICENSE.LGPL CHANGES
+%doc AUTHORS CHANGES.md LICENSE LICENSE.BSL LICENSE.FREE_USE README
 %attr(755,root,root) %{_libdir}/libCGAL.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libCGAL.so.11
+%attr(755,root,root) %ghost %{_libdir}/libCGAL.so.13
 %attr(755,root,root) %{_libdir}/libCGAL_Core.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libCGAL_Core.so.11
+%attr(755,root,root) %ghost %{_libdir}/libCGAL_Core.so.13
 %attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libCGAL_ImageIO.so.11
-%attr(755,root,root) %{_libdir}/libCGAL_Qt4.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libCGAL_Qt4.so.11
+%attr(755,root,root) %ghost %{_libdir}/libCGAL_ImageIO.so.14
+%attr(755,root,root) %{_libdir}/libCGAL_Qt5.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libCGAL_Qt5.so.14
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/cgal_create_CMakeLists
 %attr(755,root,root) %{_bindir}/cgal_create_cmake_script
+%attr(755,root,root) %{_libdir}/libCGAL.so
+%attr(755,root,root) %{_libdir}/libCGAL_Core.so
+%attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so
+%attr(755,root,root) %{_libdir}/libCGAL_Qt5.so
 %{_includedir}/CGAL
-%{_libdir}/CGAL
-%attr(755,root,root) %{_libdir}/libCGAL*.so
+%{_libdir}/cmake/CGAL
 %{_mandir}/man1/cgal_create_cmake_script.1*
This page took 0.184903 seconds and 4 git commands to generate.