]> git.pld-linux.org Git - packages/AfterStep.git/blobdiff - AfterStep.spec
- up to 2.2.4
[packages/AfterStep.git] / AfterStep.spec
index 2f9cb83abe94cec0ed56096f7699dbefa62119f6..5d0a2a579e9586fb9bbd9207e2890f0d6bf20307 100644 (file)
@@ -1,32 +1,46 @@
+# TODO: what are man3 pages?
+# if not API docs - shouldn't be in another section?
+# if API docs - no devel files are installed (well, except perl, but AFAICS perl is not installed at all)
+#
+# Conditional build:
+%bcond_with    mmx     # use MMX
+#
+%ifarch pentium3 pentium4 athlon %{x8664}
+%define                with_mmx        1
+%endif
 Summary:       AfterStep Window Manager
 Summary(ja):   AfterStep ¥¦¥£¥ó¥É¥¦¥Þ¥Í¡¼¥¸¥ã (NeXTÉ÷)
-Summary(pl):   AfterStep - mened¿er okien
+Summary(pl):   AfterStep - zarz±dca okien
 Name:          AfterStep
-Version:       1.8.4
-Release:       2
-License:       GPL
-Group:         X11/Window Managers
-Group(de):     X11/Fenstermanager
-Group(es):     X11/Administraadores De Ventanas
-Group(fr):     X11/Gestionnaires De Fenêtres
-Group(pl):     X11/Zarz±dcy Okien
+Version:       2.2.4
+Release:       0.1
+License:       GPL v2+
 Vendor:                The AfterStep Team (see TEAM in docdir)
+Group:         X11/Window Managers
 Source0:       ftp://ftp.afterstep.org/stable/%{name}-%{version}.tar.bz2
-Source1:       %{name}.RunWM
-Source2:       %{name}.wm_style
-Patch0:                %{name}-Wharf_maxsize.patch
-Patch1:                %{name}-no_bash_fix.patch
-Patch2:                ftp://ftp.afterstep.org/stable/patches/1.8.4-01-sasha-audio_delay_mystyle_property.patch.gz
-Patch3:                ftp://ftp.afterstep.org/stable/patches/1.8.4-02-sasha-shaped_icons_menu_error.patch.gz
+# Source0-md5: a382ad2fd2947d26010d1ec5f6a80392
+#Source1:      %{name}.RunWM
+Source3:       %{name}-xsession.desktop
+Patch0:                %{name}-no_bash_fix.patch
+Patch1:                %{name}-install_man.patch
+Patch2:                %{name}-opt.patch
+Patch3:                %{name}-link.patch
 URL:           http://www.afterstep.org/
+BuildRequires: autoconf >= 2.59-9
+BuildRequires: automake
+BuildRequires: giflib-devel
+BuildRequires: gtk+2-devel >= 1:2.0.0
+BuildRequires: libjpeg-devel
+BuildRequires: libpng-devel
+BuildRequires: libtiff-devel
+BuildRequires: pkgconfig
 BuildRequires: sgml-tools
-BuildRequires: XFree86-devel
-Requires:      wmconfig >= 0.9.9-5
-Requires:      xinitrc >= 3.0
+BuildRequires: xorg-lib-libXext-devel
+BuildRequires: xorg-lib-libXinerama-devel
+#Requires:     wmconfig >= 0.9.9-5
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
+%define                _wmpropsdir     /usr/share/wm-properties
 
 %description
 AfterStep is a continuation of the BowMan window manager which was
@@ -35,78 +49,124 @@ window manager, written by Robert Nation. Fvwm was based on code from
 twm. And so on... It was originally designed to emulate some of the
 look and feel of the NEXTSTEP user interface, but has since taken
 steps towards adding more useful, requested, and neat features
-especially in 1.4 version ! The changes which comprise AfterStep's
-personality were originally part of bowman development, but due to a
+especially in 1.4 version! The changes which comprise AfterStep's
+personality were originally part of BowMan development, but due to a
 desire to move past simple emulation and into a niche as its own
 valuable window manager, AfterStep designers decided to change the
 project name and move on.
 
 Important features of AfterStep include:
-
-1. Wharf: a free-floating application loader which can "Swallow"
-running programs and also can contain "Folders" of more applications.
-2. Gradient filled TitleBars with 5 button : help/zap, action/tasks,
-iconize/maximise, shade/stick & close/destroy buttons 3. Gradient
-filled root window PopUp menus which can be configured to accomodate
-different tastes and styles of management 4. NEXTSTEP style icons
-which give a consistent look to the entire desktop 5. Pixmapped Pager
-with desktop pixmmaping 6. Easy to use look files, to share you
-desktop appearance with your friends 7. Start menu entries in a
-hierarchy of directories 8. WinList : a tasklist which can be
-horizontal or vertical 9. Many modules & asapps to give a good look to
-your X window station
+- 1. Wharf: a free-floating application loader which can "Swallow"
+  running programs and also can contain "Folders" of more
+  applications.
+- 2. Gradient filled TitleBars with 5 button: help/zap, action/tasks,
+  iconize/maximise, shade/stick & close/destroy buttons
+- 3. Gradient filled root window PopUp menus which can be configured
+  to accomodate different tastes and styles of management
+- 4. NEXTSTEP style icons which give a consistent look to the entire
+  desktop
+- 5. Pixmapped Pager with desktop pixmmaping
+- 6. Easy to use look files, to share you desktop appearance with your
+  friends
+- 7. Start menu entries in a hierarchy of directories
+- 8. WinList: a tasklist which can be horizontal or vertical
+- 9. Many modules & asapps to give a good look to your X window
+  station
 
 %description -l pl
-AfterStep jest kontynuacj± zarz±dcy okienek o nazwie BowMan który
-zosta³ opracowany przez Bo Yanga. BowMan bazowa³ na innym mened¿e¿e
+AfterStep jest kontynuacj± zarz±dcy okienek o nazwie BowMan, który
+zosta³ opracowany przez Bo Yanga. BowMan bazowa³ na innym zarz±dcy
 okien o nazwie fvwm napisanym przez Roberta Nationa, a sam fvwm
-bazowa³ na kodzie ¼ród³owym mened¿era twm.
+bazowa³ na kodzie ¼ród³owym zarz±dcy okien twm. I tak dalej...
+AfterStep pocz±tkowo mia³ imitowaæ czê¶æ zachowania interfejsu
+u¿ytkownika NEXTSTEP, ale potem rozwin±³ siê w kierunku dodawania
+bardziej przydatnych, po¿±danych i przyjemnych mo¿liwo¶ci, szczególnie
+w wersji 1.4. Zmiany obejmuj±ce osobowo¶æ AfterStepa by³y pocz±tkowo
+czê¶ci± rozwoju BowMana, ale ze wzglêdu na chêæ wykroczenia poza
+prost± imitacjê do niszy samodzielnego warto¶ciowego zarz±dcy okien,
+projektanci AfterStepa zdecydowali siê zmieniæ nazwê.
+
+Najwa¿niejsze cechy AfterStepa obejmuj±:
+- 1. Dok - obiekt do ³adowania aplikacji mog±cy "po³ykaæ" uruchomione
+  programy i zawieraæ "foldery" wiêkszej liczby aplikacji
+- 2. Wype³nione gradientem paski tytu³owe z 5 przyciskami:
+  pomoc/zabicie, akcja/zadania, ikona/maksymalizacja,
+  cieñ/przyklejenie oraz zamkniêcie/zniszczenie
+- 3. Wype³nione gradientem wyskakuj±ce menu w g³ównym oknie,
+  konfigurowalne aby sprostaæ ró¿nym smakom i stylom zarz±dzania
+- 4. Ikony w stylu NEXTSTEPA daj±ce spójny wygl±d ca³ego pulpitu
+- 5. Pager z pixmapami pulpitu
+- 6. £atwe w u¿yciu pliki wygl±du, dziêki którym mo¿na dzieliæ wygl±d
+  pulpitu z kolegami
+- 7. Wpisy menu Start o hierarchii katalogowej
+- 8. WinList - pozioma lub pionowa lista zadañ
+- 9. Wiele modu³ów i aplikacji AfterStepa (asapps) daj±cych dobry
+  wygl±d stacji X Window
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 
+cp -f autoconf/configure*.in .
+
 %build
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+cd libAfterBase
+%{__autoconf}
+%{__autoheader}
+cd ../libAfterImage
+%{__autoconf}
+%{__autoheader}
+cd ..
 %configure \
-       --with-imageloader="xv -root -quit" \
+       %{!?with_mmx:--disable-mmx-optimization} \
+       --enable-i18n \
+       --enable-sharedlibs \
+       --with-gif \
        --with-helpcommand="xterm -e man" \
-       --disable-availability \
-       --enable-makemenusonboot \
-       --enable-different-looknfeels \
-       --with-xpm \
-       --enable-i18n
+       --with-jpeg \
+       --with-png \
+       --with-xpm
+
 %{__make}
 sgml2html doc/afterstep.sgml
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_datadir}/gnome/wm-properties,/etc/sysconfig/wmstyle}
+install -d $RPM_BUILD_ROOT{%{_wmpropsdir},%{_datadir}/xsessions,/etc/sysconfig/wmstyle}
 
-%{__make} install install.man DESTDIR=$RPM_BUILD_ROOT
+%{__make} install install.man \
+       DESTDIR=$RPM_BUILD_ROOT
 
-install AfterStep.desktop $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
+install AfterStep.desktop $RPM_BUILD_ROOT%{_wmpropsdir}
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/wmstyle/%{name}.sh
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/wmstyle/%{name}.names
+#install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/wmstyle/afterstep.sh
+install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/xsessions/AfterStep.desktop
 
 rm -f $RPM_BUILD_ROOT%{_bindir}/{sessreg,xpmroot}
 rm -rf $RPM_BUILD_ROOT%{_datadir}/afterstep/doc
 
-gzip -9nf UPGRADE NEW README TEAM README.RedHat doc/languages/*
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc doc/code doc/languages TODO *.html
-%doc {UPGRADE,NEW,README,TEAM,README.RedHat}.gz
-%attr(755,root,root) /etc/sysconfig/wmstyle/*.sh
-/etc/sysconfig/wmstyle/*.names
+%doc UPGRADE NEW README TEAM README.RedHat doc/languages/*
+#%attr(755,root,root) /etc/sysconfig/wmstyle/*.sh
 %attr(755,root,root) %{_bindir}/*
-%{_datadir}/gnome/wm-properties/AfterStep.desktop
+%attr(755,root,root) %{_libdir}/libAfter*.so.*.*
+%{_wmpropsdir}/AfterStep.desktop
 %{_datadir}/afterstep
+%{_datadir}/xsessions/AfterStep.desktop
 %{_mandir}/man1/*
+# ???
+#%%{_mandir}/man3/*
This page took 0.032669 seconds and 4 git commands to generate.