]> git.pld-linux.org Git - packages/perl-DBI.git/blobdiff - perl-DBI.spec
- rebuild with perl 5.26
[packages/perl-DBI.git] / perl-DBI.spec
index b63c474755fbe79a37b86675da5ea08f3007290f..db0f934d594a3b6ae82219df9c446073f6a7ce9d 100644 (file)
@@ -1,10 +1,11 @@
 #
 # Conditional build:
 #
 # Conditional build:
+%bcond_with    coro            # don't package Coro transport
 %bcond_without tests           # perform "make test"
 %bcond_without tests           # perform "make test"
-#
-%include       /usr/lib/rpm/macros.perl
+
 %define                pdir    DBI
 %define                pnam    DBI
 %define                pdir    DBI
 %define                pnam    DBI
+%include       /usr/lib/rpm/macros.perl
 Summary:       DBI - database independent interface for Perl
 Summary(cs.UTF-8):     API pro přístup k databázím pro Perl
 Summary(da.UTF-8):     En database-API for Perl
 Summary:       DBI - database independent interface for Perl
 Summary(cs.UTF-8):     API pro přístup k databázím pro Perl
 Summary(da.UTF-8):     En database-API for Perl
@@ -22,12 +23,12 @@ Summary(ru.UTF-8):  Библиотека для доступа к базам да
 Summary(sv.UTF-8):     Ett databasåtkomst-API för Perl
 Summary(zh_CN.UTF-8):  Perl 的数据库访问 API。
 Name:          perl-DBI
 Summary(sv.UTF-8):     Ett databasåtkomst-API för Perl
 Summary(zh_CN.UTF-8):  Perl 的数据库访问 API。
 Name:          perl-DBI
-Version:       1.628
-Release:       1
+Version:       1.636
+Release:       2
 License:       GPL or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/DBI/%{pnam}-%{version}.tar.gz
 License:       GPL or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/DBI/%{pnam}-%{version}.tar.gz
-# Source0-md5: 4273f8cc6ee3979ce448c7eb3f8a6a5a
+# Source0-md5: 60f291e5f015550dde71d1858dfe93ba
 URL:           http://search.cpan.org/dist/DBI/
 BuildRequires: perl-ExtUtils-MakeMaker >= 6.48
 BuildRequires: perl-devel >= 1:5.8.1
 URL:           http://search.cpan.org/dist/DBI/
 BuildRequires: perl-ExtUtils-MakeMaker >= 6.48
 BuildRequires: perl-devel >= 1:5.8.1
@@ -163,6 +164,16 @@ Nie jest to oczywiście potrzebne dla sterowników DBI które same
 obsługują łączenie się ze zdalną bazą danych, ale oprócz nich są
 silniki, które nie oferują łączności sieciowej.
 
 obsługują łączenie się ze zdalną bazą danych, ale oprócz nich są
 silniki, które nie oferują łączności sieciowej.
 
+%package Coro
+Summary:       Asynchronous DBD::Gofer stream transport using Coro
+Group:         Development/Languages/Perl
+Requires:      %{name} = %{version}-%{release}
+
+%description Coro
+This is an experimental asynchronous DBD::Gofer stream transport for
+DBI implemented on top of Coro. The BIG WIN from using Coro is that it
+enables the use of existing DBI frameworks like DBIx::Class.
+
 %package ProfileDumper-Apache
 Summary:       DBI::ProfileDumper::Apache - capture DBI profiling data from Apache/mod_perl
 Summary(pl.UTF-8):     DBI::ProfileDumper::Apache - przechwytywanie danych parametryzujących DBI z Apache/mod_perl
 %package ProfileDumper-Apache
 Summary:       DBI::ProfileDumper::Apache - capture DBI profiling data from Apache/mod_perl
 Summary(pl.UTF-8):     DBI::ProfileDumper::Apache - przechwytywanie danych parametryzujących DBI z Apache/mod_perl
@@ -201,7 +212,6 @@ mv t/80proxy.t{,-needs-syslog}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -217,6 +227,10 @@ install -d $RPM_BUILD_ROOT{%{perl_vendorlib}/DBIx,%{perl_vendorarch}/{DBIx,auto/
 # already in doc
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/DBI/Changes.pod
 
 # already in doc
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/DBI/Changes.pod
 
+%if %{without coro}
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/DBD/Gofer/Transport/corostream.pm
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -243,7 +257,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{perl_vendorarch}/auto/DBIx
 %{perl_vendorarch}/auto/DBI/*.h
 %{perl_vendorarch}/auto/DBI/Driver.xst
 %dir %{perl_vendorarch}/auto/DBIx
 %{perl_vendorarch}/auto/DBI/*.h
 %{perl_vendorarch}/auto/DBI/Driver.xst
-%{perl_vendorarch}/auto/DBI/DBI.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/DBI/DBI.so
 %{_mandir}/man1/dbilogstrip.1p*
 %{_mandir}/man1/dbiprof.1p*
 %attr(755,root,root) %{perl_vendorarch}/auto/DBI/DBI.so
 %{_mandir}/man1/dbilogstrip.1p*
 %{_mandir}/man1/dbiprof.1p*
@@ -258,6 +271,9 @@ rm -rf $RPM_BUILD_ROOT
 %exclude %{perl_vendorarch}/DBD/Proxy.pm
 %exclude %{perl_vendorarch}/DBI/ProfileDumper/Apache.pm
 %exclude %{perl_vendorarch}/DBI/ProxyServer.pm
 %exclude %{perl_vendorarch}/DBD/Proxy.pm
 %exclude %{perl_vendorarch}/DBI/ProfileDumper/Apache.pm
 %exclude %{perl_vendorarch}/DBI/ProxyServer.pm
+%if %{with coro}
+%exclude %{perl_vendorarch}/DBD/Gofer/Transport/corostream.pm
+%endif
 
 %files -n perl-DBD-Proxy
 %defattr(644,root,root,755)
 
 %files -n perl-DBD-Proxy
 %defattr(644,root,root,755)
@@ -266,6 +282,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/DBD::Proxy.3pm*
 %{_mandir}/man3/DBI::ProxyServer.3pm*
 
 %{_mandir}/man3/DBD::Proxy.3pm*
 %{_mandir}/man3/DBI::ProxyServer.3pm*
 
+%if %{with coro}
+%files Coro
+%defattr(644,root,root,755)
+%doc ex/corogofer.pl
+%{perl_vendorarch}/DBD/Gofer/Transport/corostream.pm
+%endif
+
 %files ProfileDumper-Apache
 %defattr(644,root,root,755)
 %dir %{perl_vendorarch}/DBI/ProfileDumper
 %files ProfileDumper-Apache
 %defattr(644,root,root,755)
 %dir %{perl_vendorarch}/DBI/ProfileDumper
This page took 0.064624 seconds and 4 git commands to generate.