]> git.pld-linux.org Git - packages/zziplib.git/blob - zziplib.spec
- confgiure.ac looks for python3, not python
[packages/zziplib.git] / zziplib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  tests   # do not perform "make check"
5 #
6 Summary:        ZZipLib - libZ-based ZIP-access Library
7 Summary(pl.UTF-8):      ZZipLib - biblioteka dostępu do archiwów ZIP
8 Name:           zziplib
9 Version:        0.13.72
10 Release:        1
11 Epoch:          1
12 License:        LGPL v2 or MPL 1.1
13 Group:          Libraries
14 #Source0Download: https://github.com/gdraheim/zziplib/tags
15 Source0:        https://github.com/gdraheim/zziplib/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  43555e7eafc5c1a1178a35e716c40500
17 Patch0:         %{name}-fpe.patch
18 Patch1:         %{name}-manpages.patch
19 URL:            http://zziplib.sourceforge.net/
20 BuildRequires:  autoconf >= 2.61
21 BuildRequires:  automake >= 1:1.7
22 BuildRequires:  docbook-dtd412-xml
23 BuildRequires:  libtool >= 1:1.4.3
24 BuildRequires:  pkgconfig
25 BuildRequires:  python3
26 BuildRequires:  python3-modules
27 BuildRequires:  rpm-build >= 4.6
28 BuildRequires:  xmlto
29 BuildRequires:  zip
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 ZZipLib provides read access to zipped files in a zip-archive, using
35 compression based solely on free algorithms provided by zlib. ZZipLib
36 provides an additional API to transparently access files being either
37 real files or zipped files with the same filepath argument. This is
38 handy to package many files being shared data into a single zip file -
39 as it is sometimes used with gamedata or script repositories. The
40 library itself is fully multithreaded, and it is namespace clean using
41 the zzip_ prefix for its exports and declarations.
42
43 %description -l pl.UTF-8
44 ZZipLib pozwala na odczyt plików skompresowanych w archiwach zip,
45 używając do dekompresji wolnodostępnych algorytmów z biblioteki zlib.
46 ZZipLib dostarcza dodatkowe API do przezroczystego dostępu do plików
47 rzeczywistych lub umieszczonych w archiwach zip przy pomocy takiej
48 samej ścieżki. Jest to przydatne przy trzymaniu wielu plików w jednym
49 archiwum, co bywa stosowane w przypadku danych dla gier lub
50 repozytoriów. Biblioteka jest w pełni wielowątkowa i ma czystą
51 przestrzeń nazw (używa prefiksu zzip_).
52
53 %package devel
54 Summary:        ZZipLib - Development Files
55 Summary(pl.UTF-8):      Pliki dla programistów ZZipLib
56 Group:          Development/Libraries
57 Requires:       %{name} = %{epoch}:%{version}-%{release}
58
59 %description devel
60 These are the header files needed to develop programs using zziplib.
61
62 %description devel -l pl.UTF-8
63 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
64 korzystających z biblioteki zziplib.
65
66 %package static
67 Summary:        ZZipLib static library
68 Summary(pl.UTF-8):      Statyczna biblioteka ZZipLib
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
71
72 %description static
73 ZZipLib static library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka ZZipLib.
77
78 %package apidocs
79 Summary:        API documentation for ZZipLib library
80 Summary(pl.UTF-8):      Dokumentacja API biblioteki ZZipLib
81 Group:          Documentation
82 BuildArch:      noarch
83
84 %description apidocs
85 API documentation for ZZipLib library.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API biblioteki ZZipLib.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94
95 # stick to autotools for now
96 %{__mv} old.configure.ac configure.ac
97 %{__rm} GNUmakefile
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure
106
107 %{__make}
108 %{?with_tests:%{__make} -j1 check}
109 %if %{with apidocs}
110 %{__make} doc
111 %endif
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %if %{with apidocs}
120 %{__make} -C docs install-man3 \
121         DESTDIR=$RPM_BUILD_ROOT
122 %endif
123
124 # we don't need these compat symlinks
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libzzip*-0.so.{10,11,12}
126 # obsoleted by pkg-config
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libzzip*.la
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc ChangeLog README TODO docs/COPYING.ZLIB
138 %attr(755,root,root) %{_bindir}/zzcat
139 %attr(755,root,root) %{_bindir}/zzdir
140 %attr(755,root,root) %{_bindir}/zzxor*
141 %attr(755,root,root) %{_bindir}/unzip-mem
142 %attr(755,root,root) %{_bindir}/unzzip*
143 %attr(755,root,root) %{_libdir}/libzzip-0.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libzzip-0.so.13
145 %attr(755,root,root) %{_libdir}/libzzipfseeko-0.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libzzipfseeko-0.so.13
147 %attr(755,root,root) %{_libdir}/libzzipmmapped-0.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libzzipmmapped-0.so.13
149 %attr(755,root,root) %{_libdir}/libzzipwrap-0.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libzzipwrap-0.so.13
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libzzip.so
155 %attr(755,root,root) %{_libdir}/libzzipfseeko.so
156 %attr(755,root,root) %{_libdir}/libzzipmmapped.so
157 %attr(755,root,root) %{_libdir}/libzzipwrap.so
158 %{_includedir}/zzip
159 %{_includedir}/zzip*.h
160 %if %{with apidocs}
161 %{_mandir}/man3/__zzip_*.3*
162 %{_mandir}/man3/zzip_*.3*
163 %endif
164 %{_pkgconfigdir}/zzip-zlib-config.pc
165 %{_pkgconfigdir}/zzipfseeko.pc
166 %{_pkgconfigdir}/zziplib.pc
167 %{_pkgconfigdir}/zzipmmapped.pc
168 %{_pkgconfigdir}/zzipwrap.pc
169 %{_aclocaldir}/zziplib.m4
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/libzzip.a
174 %{_libdir}/libzzipfseeko.a
175 %{_libdir}/libzzipmmapped.a
176 %{_libdir}/libzzipwrap.a
177
178 %if %{with apidocs}
179 %files apidocs
180 %defattr(644,root,root,755)
181 %doc docs/*.{html,css}
182 %endif
This page took 0.388536 seconds and 3 git commands to generate.