]> git.pld-linux.org Git - packages/zziplib.git/blob - zziplib.spec
- more verbose files, ghost soname symlinks
[packages/zziplib.git] / zziplib.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # build without documentation
4 #
5 Summary:        ZZipLib - libZ-based ZIP-access Library
6 Summary(pl.UTF-8):      ZZipLib - biblioteka dostępu do archiwów ZIP
7 Name:           zziplib
8 Version:        0.13.49
9 Release:        1
10 Epoch:          1
11 License:        LGPL with exceptions (see COPYING.ZZIP)
12 Group:          Libraries
13 Source0:        http://dl.sourceforge.net/zziplib/%{name}-%{version}.tar.bz2
14 # Source0-md5:  5f7b88ebb2bcd7e8044328482d079661
15 Patch0:         %{name}-ac.patch
16 URL:            http://zziplib.sourceforge.net/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  libtool >= 1:1.4.3
20 BuildRequires:  xmlto
21 BuildRequires:  zlib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 ZZipLib provides read access to zipped files in a zip-archive, using
26 compression based solely on free algorithms provided by zlib. ZZipLib
27 provides an additional API to transparently access files being either
28 real files or zipped files with the same filepath argument. This is
29 handy to package many files being shared data into a single zip file -
30 as it is sometimes used with gamedata or script repositories. The
31 library itself is fully multithreaded, and it is namespace clean using
32 the zzip_ prefix for its exports and declarations.
33
34 %description -l pl.UTF-8
35 ZZipLib pozwala na odczyt plików skompresowanych w archiwach zip,
36 używając do dekompresji wolnodostępnych algorytmów z biblioteki zlib.
37 ZZipLib dostarcza dodatkowe API do przezroczystego dostępu do plików
38 rzeczywistych lub umieszczonych w archiwach zip przy pomocy takiej
39 samej ścieżki. Jest to przydatne przy trzymaniu wielu plików w jednym
40 archiwum, co bywa stosowane w przypadku danych dla gier lub
41 repozytoriów. Biblioteka jest w pełni wielowątkowa i ma czystą
42 przestrzeń nazw (używa prefiksu zzip_).
43
44 %package devel
45 Summary:        ZZipLib - Development Files
46 Summary(pl.UTF-8):      Pliki dla programistów ZZipLib
47 Group:          Development/Libraries
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49
50 %description devel
51 These are the header files needed to develop programs using zziplib.
52
53 %description devel -l pl.UTF-8
54 Ten pakiet zawiera plikia nagłówkowe potrzebne do tworzenia programów
55 korzystających z biblioteki zziplib.
56
57 %package static
58 Summary:        ZZipLib static library
59 Summary(pl.UTF-8):      Statyczna biblioteka ZZipLib
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
62
63 %description static
64 ZZipLib static library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka ZZipLib.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 %{__libtoolize}
75 %{__aclocal} -I m4
76 %{__autoconf}
77 %{__autoheader}
78 %{__automake}
79 %configure \
80         --disable-builddir
81
82 %{__make}
83 %{__make} check
84 %if %{with doc}
85 %{__make} doc
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %if %{with doc}
95 %{__make} install-man3 -C docs \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 rm -f docs/zziplib[012].html
99 %endif
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc ChangeLog TODO docs/COPYING.Z*
110 %attr(755,root,root) %{_bindir}/zzcat
111 %attr(755,root,root) %{_bindir}/zzdir
112 %attr(755,root,root) %{_bindir}/zzxor*
113 %attr(755,root,root) %{_bindir}/unzip-mem
114 %attr(755,root,root) %{_bindir}/unzzip*
115 %attr(755,root,root) %{_libdir}/libzzip-0.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libzzip-0.so.13
117 %attr(755,root,root) %{_libdir}/libzzipfseeko-0.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libzzipfseeko-0.so.13
119 %attr(755,root,root) %{_libdir}/libzzipmmapped-0.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libzzipmmapped-0.so.13
121 %attr(755,root,root) %{_libdir}/libzzipwrap-0.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libzzipwrap-0.so.13
123
124 %files devel
125 %defattr(644,root,root,755)
126 %if %{with doc}
127 %doc docs/*.html
128 %endif
129 %attr(755,root,root) %{_libdir}/libzzip.so
130 %attr(755,root,root) %{_libdir}/libzzipfseeko.so
131 %attr(755,root,root) %{_libdir}/libzzipmmapped.so
132 %attr(755,root,root) %{_libdir}/libzzipwrap.so
133 %{_libdir}/libzzip.la
134 %{_libdir}/libzzipfseeko.la
135 %{_libdir}/libzzipmmapped.la
136 %{_libdir}/libzzipwrap.la
137 %{_includedir}/zzip
138 %{_includedir}/zzip*.h
139 %if %{with doc}
140 %{_mandir}/man3/__zzip_*.3*
141 %{_mandir}/man3/zzip_*.3*
142 %endif
143 %{_pkgconfigdir}/zzip-zlib-config.pc
144 %{_pkgconfigdir}/zzipfseeko.pc
145 %{_pkgconfigdir}/zziplib.pc
146 %{_pkgconfigdir}/zzipmmapped.pc
147 %{_pkgconfigdir}/zzipwrap.pc
148 %{_aclocaldir}/zziplib.m4
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libzzip.a
153 %{_libdir}/libzzipfseeko.a
154 %{_libdir}/libzzipmmapped.a
155 %{_libdir}/libzzipwrap.a
This page took 0.046412 seconds and 3 git commands to generate.