]> git.pld-linux.org Git - SPECS.git/blob - zeroinstall-injector.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / zeroinstall-injector.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 Summary:        The Zero Install Injector (0launch)
6 Summary(pl.UTF-8):      Bardzo łatwy instalator
7 Name:           zeroinstall-injector
8 Version:        2.3.3
9 Release:        1
10 License:        LGPL v2
11 Group:          Applications/File
12 Source0:        http://downloads.sourceforge.net/zero-install/0install-%{version}.tar.bz2
13 # Source0-md5:  00d567d9086d0b030ac610df6e4cb237
14 URL:            http://0install.net/injector.html
15 %if %{with tests}
16 BuildRequires:  gettext
17 BuildRequires:  gnupg
18 BuildRequires:  python-coverage
19 BuildRequires:  python-pygobject
20 %if %(locale -a | grep -q '^en_US$'; echo $?)
21 BuildRequires:  glibc-localedb-all
22 %endif
23 %endif
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  python
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  sed >= 4.0
28 Requires:       applnk
29 Requires:       bzip2
30 Requires:       desktop-file-utils
31 Requires:       gnupg
32 Requires:       gtk-update-icon-cache
33 Requires:       gzip
34 Requires:       hicolor-icon-theme
35 Requires:       python-dbus
36 Requires:       python-pygtk-gtk
37 Requires:       sudo
38 Requires:       tar
39 Requires:       xdg-utils
40 Requires:       xz
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 The Zero Install Injector makes it easy for users to install software
46 without needing root privileges. It takes the URL of a program and
47 runs it (downloading it first if necessary). Any dependencies of the
48 program are fetched in the same way. The user controls which version
49 of the program and its dependencies to use.
50
51 %description -l pl.UTF-8
52 Bardzo łatwy instalator umożliwia zwykłemu użytkownikowi instalację
53 programu bez konieczności posiadania uprawnień administratora. Pobiera
54 URL aplikacji i ją uruchamia (ściąga na lokalny udział o ile to
55 konieczne). Jakiekolwiek zależności obsługiwane są w ten sam sposób.
56 Użytkownik może wybrać którą wersję programu i bibliotek zależnych
57 zainstalować.
58
59 %prep
60 %setup -q -n 0install-%{version}
61
62 %{__sed} -i -e '/data_files/ s#man/man1#share/man/man1#' setup.py
63
64 # network tests of failing ones
65 mv tests/testdownload.py{,.off}
66 mv tests/testpackagekit.py{,.off}
67
68 # check these
69 mv tests/testunpack.py{,.fail}
70 mv tests/testdistro.py{,.fail}
71 mv tests/testlaunch.py{,.fail}
72 mv tests/testrun.py{,.fail}
73
74 %build
75 %{__python} setup.py build
76
77 %if %{with tests}
78 export PYTHONPATH=${PWD:-$(pwd)}
79 cd tests
80 ./testall.py
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 %{__python} setup.py install \
86         --skip-build \
87         --optimize=2 \
88         --root=$RPM_BUILD_ROOT
89
90 %find_lang zero-install
91
92 desktop-file-validate \
93     $RPM_BUILD_ROOT%{_desktopdir}/0install.desktop
94
95 # not yet packaged
96 rm $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/0install
97 rm $RPM_BUILD_ROOT%{_datadir}/fish/completions/0install.fish
98 rm $RPM_BUILD_ROOT%{_datadir}/zsh/site-functions/_0install
99
100 %py_postclean
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 %update_desktop_database
107 %update_icon_cache hicolor
108
109 %postun
110 %update_desktop_database
111 %update_icon_cache hicolor
112
113 %files -f zero-install.lang
114 %defattr(644,root,root,755)
115 %doc README.md
116 %attr(755,root,root) %{_bindir}/0alias
117 %attr(755,root,root) %{_bindir}/0desktop
118 %attr(755,root,root) %{_bindir}/0install
119 %attr(755,root,root) %{_bindir}/0launch
120 %attr(755,root,root) %{_bindir}/0store
121 %attr(755,root,root) %{_bindir}/0store-secure-add
122 %{_mandir}/man1/0alias.1*
123 %{_mandir}/man1/0desktop.1*
124 %{_mandir}/man1/0install.1*
125 %{_mandir}/man1/0launch.1*
126 %{_mandir}/man1/0store-secure-add.1*
127 %{_mandir}/man1/0store.1*
128 %{_iconsdir}/hicolor/*/apps/zeroinstall.*
129 %{_desktopdir}/0install.desktop
130
131 %dir %{py_sitescriptdir}/zeroinstall
132 %{py_sitescriptdir}/zeroinstall/*.py[co]
133 %dir %{py_sitescriptdir}/zeroinstall/0launch-gui
134 %{py_sitescriptdir}/zeroinstall/0launch-gui/*.py[co]
135 %{py_sitescriptdir}/zeroinstall/0launch-gui/0launch-gui
136 %{py_sitescriptdir}/zeroinstall/0launch-gui/zero-install.ui
137 %dir %{py_sitescriptdir}/zeroinstall/injector
138 %{py_sitescriptdir}/zeroinstall/injector/*.py[co]
139 %{py_sitescriptdir}/zeroinstall/injector/EquifaxSecureCA.crt
140 %dir %{py_sitescriptdir}/zeroinstall/gtkui
141 %{py_sitescriptdir}/zeroinstall/gtkui/*.py[co]
142 %{py_sitescriptdir}/zeroinstall/gtkui/cache.ui
143 %{py_sitescriptdir}/zeroinstall/gtkui/desktop.ui
144 %dir %{py_sitescriptdir}/zeroinstall/support
145 %{py_sitescriptdir}/zeroinstall/support/*.py[co]
146 %dir %{py_sitescriptdir}/zeroinstall/zerostore
147 %{py_sitescriptdir}/zeroinstall/zerostore/*.py[co]
148 %{py_sitescriptdir}/zeroinstall/zerostore/_unlzma
149 %dir %{py_sitescriptdir}/zeroinstall/cmd
150 %{py_sitescriptdir}/zeroinstall/cmd/*.py[co]
151 %{py_sitescriptdir}/zeroinstall_injector-%{version}-py*.egg-info
This page took 1.929034 seconds and 3 git commands to generate.