]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
up to 6.0.15 (latest lts)
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-server, zabbix-proxy and zabbix-java
3 # - unpackaged files:
4 #   /usr/bin/zabbix_js
5 #   /var/lib/zabbix/zabbix.db
6 #
7 # Conditional build:
8 %bcond_without  pgsql   # enable PostgreSQL support
9 %bcond_without  sqlite3 # enable sqlite3 support
10 %bcond_without  mysql   # enable MySQL support
11 %bcond_without  java    # disable java support
12 %bcond_without  agent2  # disable bulding of Go based agent2
13
14 %define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
15 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
16
17 %ifnarch %{go_arches}
18 %undefine       with_agent2
19 %endif
20
21 %{?with_java:%{?use_default_jdk}}
22
23 %define         php_min_version 7.2.5
24 Summary:        Zabbix - network monitoring software
25 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
26 Name:           zabbix
27 Version:        6.0.15
28 Release:        1
29 License:        GPL v2+
30 Group:          Networking/Utilities
31 # https://www.zabbix.com/download_sources
32 Source0:        https://cdn.zabbix.com/zabbix/sources/stable/6.0/%{name}-%{version}.tar.gz
33 # Source0-md5:  54712b943e39287ed47a5118edff295b
34 Source100:      go-vendor.tar.xz
35 # Source100-md5:        e8ffa2ed45f01a1c1df2545c1efa7917
36 Source1:        %{name}-apache.conf
37 Source2:        %{name}_server.service
38 Source3:        %{name}_agentd.service
39 Source4:        %{name}_proxy.service
40 Source5:        %{name}_java.service
41 Source6:        %{name}.tmpfiles
42 Source7:        %{name}_agentd.init
43 Source8:        %{name}_agent2.init
44 %if 0
45 cd src/go/
46 go mod vendor
47 tar -caf ~/go-vendor.tar.xz -C ../../ src/go/vendor
48 %endif
49 Patch0:         config.patch
50 Patch1:         sqlite3_dbname.patch
51 Patch2:         always_compile_ipc.patch
52 Patch3:         go-destdir.patch
53 Patch4:         go-vendor.patch
54 URL:            https://www.zabbix.com/
55 BuildRequires:  OpenIPMI-devel
56 BuildRequires:  autoconf
57 BuildRequires:  automake >= 1:1.15
58 BuildRequires:  curl-devel
59 BuildRequires:  iksemel-devel
60 %{?with_java:%{?use_jdk:%buildrequires_jdk}%{!?use_jdk:BuildRequires:   jdk}}
61 BuildRequires:  rpm-build >= 4.6
62 %{?with_java:BuildRequires:     rpm-pld-macros-javaprov}
63 %{?with_agent2:BuildRequires:   golang >= 1.13}
64 BuildRequires:  libevent-devel
65 BuildRequires:  libssh2-devel
66 BuildRequires:  libtool
67 BuildRequires:  libxml2-devel
68 %{?with_mysql:BuildRequires:    mysql-devel}
69 BuildRequires:  net-snmp-devel
70 BuildRequires:  openldap-devel >= 2.4.6
71 BuildRequires:  openssl-devel >= 0.9.7d
72 BuildRequires:  pcre-devel
73 %{?with_pgsql:BuildRequires:    postgresql-devel}
74 BuildRequires:  rpmbuild(macros) >= 2.021
75 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
76 BuildRequires:  tar >= 1:1.22
77 BuildRequires:  unixODBC-devel
78 BuildRequires:  xz
79 BuildRequires:  zlib-devel
80 Requires:       %{name}-agentd = %{version}-%{release}
81 Requires:       %{name}-frontend-php = %{version}-%{release}
82 Requires:       %{name}-server = %{version}-%{release}
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _sysconfdir     /etc/%{name}
86 %define         _appdir         %{_datadir}/%{name}
87 %define         _webapps        /etc/webapps
88 %define         _webapp         %{name}
89
90 %description
91 Zabbix is software that monitors numerous parameters of a network and
92 the servers on that network. It is a useful tool for monitoring the
93 health and integrity of servers. Zabbix uses a flexible notification
94 mechanism that allows users to configure email based alerts for
95 virtually any event. All monitored parameters are stored in a
96 database. Zabbix offers excellent reporting and data visualisation
97 features based on the stored data. Zabbix supports both polling and
98 trapping. All Zabbix reports and statistics, as well as configuration
99 parameters, are accessed through a web-based front end.
100
101 %description -l pl.UTF-8
102 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
103 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
104 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
105 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
106 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
107 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
108 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
109 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
110 statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
111
112 %package common
113 Summary:        Common files for Zabbix monitoring software
114 Summary(pl.UTF-8):      Wspólne pliki dla oprogramowania monitorującego Zabbix
115 Group:          Networking/Utilities
116 Requires(postun):       /usr/sbin/groupdel
117 Requires(postun):       /usr/sbin/userdel
118 Requires(pre):  /bin/id
119 Requires(pre):  /usr/bin/getgid
120 Requires(pre):  /usr/sbin/groupadd
121 Requires(pre):  /usr/sbin/useradd
122 Provides:       group(zabbix)
123 Provides:       user(zabbix)
124
125 %description common
126 Common files for Zabbix monitoring software.
127
128 %description common -l pl.UTF-8
129 Wspólne pliki dla oprogramowania monitorującego Zabbix.
130
131 %package agentd
132 Summary:        Zabbix Agent
133 Summary(pl.UTF-8):      Agenta Zabbiksa
134 Group:          Networking/Utilities
135 Requires:       %{name}-common = %{version}-%{release}
136 Requires:       systemd-units >= 38
137 Obsoletes:      zabbix-agent-inetd
138 Obsoletes:      zabbix-agent-standalone
139 Requires(post,preun):   /sbin/chkconfig
140 Requires:       rc-scripts
141
142 %description agentd
143 Zabbix agent collects data from the local system for a Zabbix server.
144
145 %description agentd -l pl.UTF-8
146 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
147
148 %package agent2
149 Summary:        Zabbix Agent 2
150 Group:          Networking/Utilities
151 URL:            https://www.zabbix.com/documentation/current/manual/concepts/agent2
152 Requires:       %{name}-common = %{version}-%{release}
153 Requires(post,preun):   /sbin/chkconfig
154 Requires:       rc-scripts
155
156 %description agent2
157 Zabbix agent 2 is a new generation of Zabbix agent and may be used in
158 place of Zabbix agent.
159
160 Zabbix agent 2 has been developed to:
161 - reduce the number of TCP connections
162 - have greater check concurrency
163 - be easily extendible with plugins.
164
165 A plugin should be able to:
166 - provide trivial checks consisting of only a few simple lines of code
167 - provide complex checks consisting of long-running scripts and
168   standalone data gathering with periodic sending back of the data
169 - be a drop-in replacement for Zabbix agent (in that it supports all
170   the previous functionality)
171
172 Passive checks work similarly to Zabbix agent. Active checks support
173 scheduled/flexible intervals and check concurrency within one active
174 server.
175
176 %package frontend-php
177 Summary:        PHP frontend for Zabbix
178 Summary(pl.UTF-8):      Interfejs PHP dla Zabbiksa
179 Group:          Applications/WWW
180 Requires:       php(bcmath)
181 Requires:       php(core) >= %{php_min_version}
182 Requires:       php(ctype)
183 Requires:       php(gd)
184 Requires:       php(gettext)
185 Requires:       php(json)
186 Requires:       php(mbstring)
187 Requires:       php(openssl)
188 Requires:       php(pcre)
189 Requires:       php(session)
190 Requires:       php(sockets)
191 Requires:       php(xml)
192 Requires:       php(xmlreader)
193 Requires:       php(xmlwriter)
194 Requires:       webapps
195 Requires:       webserver(alias)
196 Requires:       webserver(indexfile)
197 Requires:       webserver(php)
198 Suggests:       php(mysql)
199 Suggests:       php(pgsql)
200 Suggests:       php(sqlite3)
201 # used with sqlite3
202 Suggests:       php(sysvsem)
203 BuildArch:      noarch
204
205 %description frontend-php
206 This package provides web based (PHP) frontend for Zabbix.
207
208 %description frontend-php -l pl.UTF-8
209 Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
210
211 %package get
212 Summary:        Program retrieving data from Zabbix agent
213 Summary(pl.UTF-8):      Program odpytujÄcy agenta Zabbiksa
214 Group:          Networking/Utilities
215
216 %description get
217 This package provides a program retrieving data from Zabbix agent.
218
219 %description get -l pl.UTF-8
220 Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
221
222 %package proxy
223 Summary:        Zabbix proxy
224 Summary(pl.UTF-8):      Proxy do Zabbiksa
225 Group:          Networking/Utilities
226 Requires:       %{name}-common = %{version}-%{release}
227 Requires:       systemd-units >= 38
228 Requires:       zabbix-proxy(db) = %{version}-%{release}
229
230 %description proxy
231 This package provides the Zabbix proxy.
232
233 %description proxy -l pl.UTF-8
234 Ten pakiet zawiera proxy Zabbix.
235
236 %package proxy-mysql
237 Summary:        MySQL support for Zabbix proxy
238 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbiksa
239 Group:          Networking/Utilities
240 Provides:       %{name}-proxy(db) = %{version}-%{release}
241 Obsoletes:      zabbix-proxy-postgresql
242 Obsoletes:      zabbix-proxy-sqlite3
243
244 %description proxy-mysql
245 This package provides the Zabbix proxy binary with MySQL support.
246
247 %description proxy-mysql -l pl.UTF-8
248 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
249
250 %package proxy-postgresql
251 Summary:        PostgreSQL support for Zabbix proxy
252 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbiksa
253 Group:          Networking/Utilities
254 Provides:       %{name}-proxy(db) = %{version}-%{release}
255 Obsoletes:      zabbix-proxy-mysql
256 Obsoletes:      zabbix-proxy-sqlite3
257
258 %description proxy-postgresql
259 This package provides the Zabbix proxy binary with PostgreSQL support.
260
261 %description proxy-postgresql -l pl.UTF-8
262 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
263
264 %package proxy-sqlite3
265 Summary:        SQLite 3 support for Zabbix proxy
266 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbiksa
267 Group:          Networking/Utilities
268 Provides:       %{name}-proxy(db) = %{version}-%{release}
269 Obsoletes:      zabbix-proxy-mysql
270 Obsoletes:      zabbix-proxy-postgresql
271
272 %description proxy-sqlite3
273 This package provides the Zabbix proxy binary with SQLite 3 support.
274
275 %description proxy-sqlite3 -l pl.UTF-8
276 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
277
278 %package sender
279 Summary:        Zabbix sender
280 Summary(pl.UTF-8):      Program zawiadamiający Zabbiksa
281 Group:          Networking/Utilities
282
283 %description sender
284 This package provides the Zabbix sender.
285
286 %description sender -l pl.UTF-8
287 Ten pakiet zawiera program zawiadamiający Zabbiksa.
288
289 %package server
290 Summary:        Zabbix server
291 Summary(pl.UTF-8):      Serwer Zabbiksa
292 Group:          Networking/Utilities
293 Requires:       %{name}-common = %{version}-%{release}
294 Requires:       %{name}-server(db) = %{version}-%{release}
295 Requires:       systemd-units >= 38
296 Obsoletes:      zabbix-suckerd
297 Obsoletes:      zabbix-trapper-inetd
298 Obsoletes:      zabbix-trapper-standalone
299
300 %description server
301 This package provides the Zabbix server.
302
303 %description server -l pl.UTF-8
304 Ten pakiet zawiera serwer Zabbiksa.
305
306 %package server-mysql
307 Summary:        MySQL support for Zabbix server
308 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbiksa
309 Group:          Networking/Utilities
310 Provides:       %{name}-server(db) = %{version}-%{release}
311 Obsoletes:      zabbix-server-postgresql
312 Obsoletes:      zabbix-server-sqlite3
313
314 %description server-mysql
315 This package provides the Zabbix server binary for use with MySQL
316 database.
317
318 %description server-mysql -l pl.UTF-8
319 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
320
321 %package server-postgresql
322 Summary:        PostgreSQL support for Zabbix server
323 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbiksa
324 Group:          Networking/Utilities
325 Provides:       %{name}-server(db) = %{version}-%{release}
326 Obsoletes:      zabbix-server-mysql
327 Obsoletes:      zabbix-server-sqlite3
328
329 %description server-postgresql
330 This package provides the Zabbix server binary for use with PostgreSQL
331 database.
332
333 %description server-postgresql -l pl.UTF-8
334 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
335
336 %package java
337 Summary:        Zabbix Java Gateway
338 Group:          Networking/Utilities
339 Requires:       %{name}-common = %{version}-%{release}
340 Requires:       systemd-units >= 38
341
342 %description java
343 This package provides the Zabbix Java Gateway.
344
345 %prep
346 %setup -q -a100
347 %patch0 -p1
348 %patch1 -p1
349 %patch2 -p1
350 %patch3 -p1
351 %patch4 -p1
352
353 %build
354 %{__libtoolize}
355 %{__aclocal} -I m4
356 %{__autoconf}
357 %{__autoheader}
358 %{__automake}
359
360 configure() {
361         %configure \
362         %{?with_java:ac_cv_prog_JAVAC=%{java_home}/bin/javac} \
363         %{?with_java:ac_cv_prog_JAR=%{java_home}/bin/jar} \
364         --enable-dependency-tracking \
365         --enable-agent \
366         %{__enable_disable agent2} \
367         --enable-ipv6 \
368         %{__enable_disable java} \
369         --with-ldap \
370         --with-libcurl \
371         --with-libevent \
372         --with-libpcre \
373         --with-libxml2 \
374         --with-net-snmp \
375         --with-openipmi \
376         --with-openssl \
377         --with-ssh2 \
378         --with-unixodbc \
379         "$@"
380 }
381
382 configure \
383         --disable-server \
384         --disable-proxy
385
386 %{__make}
387
388 for database in %{databases} ; do
389         if [ "$database" = "sqlite3" ] ; then
390                 enable_server=""
391         else
392                 enable_server="--enable-server"
393         fi
394         configure \
395                 --with-$database \
396                 $enable_server \
397                 --enable-proxy
398
399         %{__make}
400
401         if [ "$enable_server" ] ; then
402                 %{__make} install \
403                         -C src/zabbix_server \
404                         DESTDIR=$PWD/install-${database}
405         fi
406
407         %{__make} install \
408                 -C src/zabbix_proxy \
409                 DESTDIR=$PWD/install-${database}
410 done
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414 install -d \
415         $RPM_BUILD_ROOT/etc/webapps/%{_webapp} \
416         $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_appdir}/frontends/php} \
417         $RPM_BUILD_ROOT{/var/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
418
419 %{__make} install \
420         DESTDIR=$RPM_BUILD_ROOT \
421         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
422
423 for database in %{databases} ; do
424         if [ "$database" != "sqlite3" ] ; then
425                 cp -p install-$database/%{_sbindir}/zabbix_server \
426                         $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
427         fi
428         cp -p install-$database/%{_sbindir}/zabbix_proxy \
429                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
430 done
431
432 if [ -n "$database" ] ; then
433         ln -sf zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
434         ln -sf zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
435 fi
436
437 %if %{with sqlite3}
438 install -d $RPM_BUILD_ROOT/var/lib/zabbix
439 touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
440 %endif
441
442 cp -r ui/* $RPM_BUILD_ROOT%{_appdir}/frontends/php
443
444 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
445 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
446
447 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
448 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
449 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
450 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agent2
451 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
452 %{?with_java:install    %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service}
453
454 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
455
456 mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
457 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/frontend,%{_appdir}/frontends/php/conf}
458 touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
459
460 %if %{with java}
461 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
462 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_java.conf,%{_datadir}/zabbix_java/settings.sh}
463 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
464 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback.xml,%{_datadir}/zabbix_java/lib/logback.xml}
465 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
466 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback-console.xml,%{_datadir}/zabbix_java/lib/logback-console.xml}
467
468 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
469 #!/bin/sh
470
471 exec %{_datadir}/zabbix_java/startup.sh "$@"
472 EOF
473
474 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
475 #!/bin/sh
476
477 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
478 EOF
479 %endif
480
481 %clean
482 rm -rf $RPM_BUILD_ROOT
483
484 %triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
485 %webapp_register apache %{_webapp}
486
487 %triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
488 %webapp_unregister apache %{_webapp}
489
490 %triggerin frontend-php -- apache < 2.2.0, apache-base
491 %webapp_register httpd %{_webapp}
492
493 %triggerun frontend-php -- apache < 2.2.0, apache-base
494 %webapp_unregister httpd %{_webapp}
495
496 %pre common
497 %groupadd -g 111 zabbix
498 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
499 %addusertogroup -q zabbix proc
500
501 %postun common
502 if [ "$1" = "0" ]; then
503         %userremove zabbix
504         %groupremove zabbix
505 fi
506
507 %post server-mysql
508 if [ "$1" = 1 ]; then
509         %banner -e %{name}-server <<-EOF
510         You should create database for Zabbix.
511
512         Running these should be fine in most cases:
513         mysqladmin create zabbix
514         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
515         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
516         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
517 EOF
518 fi
519 ln -sf zabbix_server-mysql %{_sbindir}/zabbix_server || :
520
521 %post server-postgresql
522 if [ "$1" = 1 ]; then
523         %banner -e %{name}-server <<-EOF
524         You should create database for Zabbix.
525
526         Running these should be fine in most cases:
527
528         createuser zabbix
529         createdb -O zabbix zabbix
530         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
531         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
532         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
533 EOF
534 fi
535 ln -sf zabbix_server-postgresql %{_sbindir}/zabbix_server || :
536
537 %post server
538 %systemd_post zabbix_server.service
539
540 %preun server
541 %systemd_preun zabbix_server.service
542
543 %postun server
544 if [ "$1" = "0" ]; then
545         if [ -L %{_sbindir}/zabbix_server ] ; then
546                 rm -f %{_sbindir}/zabbix_server || :
547         fi
548 fi
549 %systemd_reload
550
551 %post agentd
552 /sbin/chkconfig --add zabbix_agentd
553 %service zabbix_agentd restart
554 %systemd_post zabbix_agentd.service
555
556 %preun agentd
557 if [ "$1" = "0" ]; then
558         %service -q zabbix_agentd stop
559         /sbin/chkconfig --del zabbix_agentd
560 fi
561 %systemd_preun zabbix_agentd.service
562
563 %postun agentd
564 %systemd_reload
565
566 %post agent2
567 /sbin/chkconfig --add zabbix_agent2
568 %service zabbix_agent2 restart
569
570 %preun agent2
571 if [ "$1" = "0" ]; then
572         %service -q zabbix_agent2 stop
573         /sbin/chkconfig --del zabbix_agent2
574 fi
575
576 %post proxy-mysql
577 ln -sf zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
578
579 %post proxy-postgresql
580 ln -sf zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
581
582 %post proxy-sqlite3
583 ln -sf zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
584
585 %post proxy
586 %systemd_post zabbix_proxy.service
587
588 %preun proxy
589 %systemd_preun zabbix_proxy.service
590
591 %postun proxy
592 %systemd_reload
593
594 %post java
595 %systemd_post zabbix_java.service
596
597 %preun java
598 %systemd_preun zabbix_java.service
599
600 %postun java
601 %systemd_reload
602
603 %files
604 %defattr(644,root,root,755)
605 %doc AUTHORS ChangeLog README
606
607 %files common
608 %defattr(644,root,root,755)
609 %doc AUTHORS ChangeLog README
610 %attr(751,root,zabbix) %dir %{_sysconfdir}
611 %attr(751,root,http) %dir %{_sysconfdir}/frontend
612 %dir %{_appdir}
613 %dir %{_appdir}/frontends
614 %dir %attr(770,root,zabbix) /var/run/zabbix
615 %dir %attr(775,root,zabbix) /var/log/zabbix
616 %{systemdtmpfilesdir}/zabbix.conf
617
618 %files agentd
619 %defattr(644,root,root,755)
620 %doc conf/zabbix_agentd/*.conf
621 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
622 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
623 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agentd
624 %attr(755,root,root) %{_sbindir}/zabbix_agentd
625 %{_mandir}/man8/zabbix_agentd*
626 %{systemdunitdir}/zabbix_agentd.service
627
628 %if %{with agent2}
629 %files agent2
630 %defattr(644,root,root,755)
631 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.conf
632 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.d
633 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.d/plugins.d
634 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/*.conf
635 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agent2
636 %attr(755,root,root) %{_sbindir}/zabbix_agent2
637 %{_mandir}/man8/zabbix_agent2.8*
638 %endif
639
640 %files frontend-php
641 %defattr(644,root,root,755)
642 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
643 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
644 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
645 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
646 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
647 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
648 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
649 %{_appdir}/frontends/php
650
651 %files get
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_bindir}/zabbix_get
654 %{_mandir}/man1/zabbix_get*
655
656 %if %{any_database}
657 %files proxy
658 %defattr(644,root,root,755)
659 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
660 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
661 %ghost %{_sbindir}/zabbix_proxy
662 %{_mandir}/man8/zabbix_proxy*
663 %{systemdunitdir}/zabbix_proxy.service
664 %endif
665
666 %if %{with mysql}
667 %files proxy-mysql
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
670 %endif
671
672 %if %{with pgsql}
673 %files proxy-postgresql
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
676 %endif
677
678 %if %{with sqlite3}
679 %files proxy-sqlite3
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
682 %endif
683
684 %files sender
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_bindir}/zabbix_sender
687 %{_mandir}/man1/zabbix_sender*
688
689 %if %{any_database}
690 %files server
691 %defattr(644,root,root,755)
692 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
693 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
694 %ghost %{_sbindir}/zabbix_server
695 %{_mandir}/man8/zabbix_server*
696 %{systemdunitdir}/zabbix_server.service
697 %endif
698
699 %if %{with mysql}
700 %files server-mysql
701 %defattr(644,root,root,755)
702 %doc database/mysql/*.sql
703 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
704 %endif
705
706 %if %{with pgsql}
707 %files server-postgresql
708 %defattr(644,root,root,755)
709 %doc database/postgresql/*.sql
710 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
711 %endif
712
713 %if %{with java}
714 %files java
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_sbindir}/zabbix_java-start
717 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
718 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
719 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
720 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
721 %dir %{_datadir}/zabbix_java
722 %{_datadir}/zabbix_java/bin
723 %{_datadir}/zabbix_java/lib
724 %{_datadir}/zabbix_java/settings.sh
725 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
726 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
727 %{systemdunitdir}/zabbix_java.service
728 %endif
This page took 0.075525 seconds and 3 git commands to generate.