]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
Package /etc/zabbix/zabbix_agent2.conf.d dir
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-server, zabbix-proxy and zabbix-java
3 # - unpackaged files:
4 #   /lib/systemd/system/zabbix_java.service
5 #   /usr/bin/zabbix_js
6 #   /var/lib/zabbix/zabbix.db
7 #
8 # Conditional build:
9 %bcond_without  pgsql   # enable PostgreSQL support
10 %bcond_without  sqlite3 # enable sqlite3 support
11 %bcond_without  mysql   # enable MySQL support
12 %bcond_without  java    # disable java support
13 %bcond_without  agent2  # disable bulding of Go based agent2
14
15 %define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
16 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
17
18 %ifnarch %{ix86} %{x8664}
19 %undefine       with_agent2
20 %endif
21
22 %define         php_min_version 7.2.5
23 Summary:        Zabbix - network monitoring software
24 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
25 Name:           zabbix
26 Version:        5.4.3
27 Release:        0.7
28 License:        GPL v2+
29 Group:          Networking/Utilities
30 # https://www.zabbix.com/download_sources
31 Source0:        https://cdn.zabbix.com/zabbix/sources/stable/5.4/%{name}-%{version}.tar.gz
32 # Source0-md5:  5dccb536c164e45c7d5c1a5a9d64be43
33 Source1:        %{name}-apache.conf
34 Source2:        %{name}_server.service
35 Source3:        %{name}_agentd.service
36 Source4:        %{name}_proxy.service
37 Source5:        %{name}_java.service
38 Source6:        %{name}.tmpfiles
39 Source7:        %{name}_agentd.init
40 %if 0
41 cd src/go/
42 go mod vendor
43 tar -caf ~/go-vendor.tar.xz -C ../../ src/go/vendor
44 %endif
45 Source8:        go-vendor.tar.xz
46 # Source8-md5:  61f2ee9647280765b622a5e1e8cdfbba
47 Patch0:         config.patch
48 Patch1:         sqlite3_dbname.patch
49 Patch2:         always_compile_ipc.patch
50 Patch3:         go-destdir.patch
51 Patch4:         go-vendor.patch
52 URL:            https://www.zabbix.com/
53 BuildRequires:  OpenIPMI-devel
54 BuildRequires:  autoconf
55 BuildRequires:  automake >= 1:1.15
56 BuildRequires:  curl-devel
57 BuildRequires:  iksemel-devel
58 %{?with_java:BuildRequires:     jdk}
59 %{?with_java:BuildRequires:     rpm-pld-macros-javaprov}
60 %{?with_agent2:BuildRequires:   golang >= 1.13}
61 BuildRequires:  libevent-devel
62 BuildRequires:  libssh2-devel
63 BuildRequires:  libtool
64 BuildRequires:  libxml2-devel
65 %{?with_mysql:BuildRequires:    mysql-devel}
66 BuildRequires:  net-snmp-devel
67 BuildRequires:  openldap-devel >= 2.4.6
68 BuildRequires:  openssl-devel >= 0.9.7d
69 BuildRequires:  pcre-devel
70 %{?with_pgsql:BuildRequires:    postgresql-devel}
71 BuildRequires:  rpmbuild(macros) >= 1.671
72 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
73 BuildRequires:  unixODBC-devel
74 BuildRequires:  zlib-devel
75 Requires:       %{name}-agentd = %{version}-%{release}
76 Requires:       %{name}-frontend-php = %{version}-%{release}
77 Requires:       %{name}-server = %{version}-%{release}
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         _sysconfdir     /etc/%{name}
81 %define         _appdir         %{_datadir}/%{name}
82 %define         _webapps        /etc/webapps
83 %define         _webapp         %{name}
84
85 %description
86 Zabbix is software that monitors numerous parameters of a network and
87 the servers on that network. It is a useful tool for monitoring the
88 health and integrity of servers. Zabbix uses a flexible notification
89 mechanism that allows users to configure email based alerts for
90 virtually any event. All monitored parameters are stored in a
91 database. Zabbix offers excellent reporting and data visualisation
92 features based on the stored data. Zabbix supports both polling and
93 trapping. All Zabbix reports and statistics, as well as configuration
94 parameters, are accessed through a web-based front end.
95
96 %description -l pl.UTF-8
97 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
98 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
99 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
100 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
101 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
102 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
103 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
104 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
105 statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
106
107 %package common
108 Summary:        Common files for Zabbix monitoring software
109 Summary(pl.UTF-8):      Wspólne pliki dla oprogramowania monitorującego Zabbix
110 Group:          Networking/Utilities
111 Requires(postun):       /usr/sbin/groupdel
112 Requires(postun):       /usr/sbin/userdel
113 Requires(pre):  /bin/id
114 Requires(pre):  /usr/bin/getgid
115 Requires(pre):  /usr/sbin/groupadd
116 Requires(pre):  /usr/sbin/useradd
117 Provides:       group(zabbix)
118 Provides:       user(zabbix)
119
120 %description common
121 Common files for Zabbix monitoring software.
122
123 %description common -l pl.UTF-8
124 Wspólne pliki dla oprogramowania monitorującego Zabbix.
125
126 %package agentd
127 Summary:        Zabbix Agent
128 Summary(pl.UTF-8):      Agenta Zabbiksa
129 Group:          Networking/Utilities
130 Requires:       %{name}-common = %{version}-%{release}
131 Requires:       systemd-units >= 38
132 Obsoletes:      zabbix-agent-inetd
133 Obsoletes:      zabbix-agent-standalone
134 Requires(post,preun):   /sbin/chkconfig
135 Requires:       rc-scripts
136
137 %description agentd
138 Zabbix agent collects data from the local system for a Zabbix server.
139
140 %description agentd -l pl.UTF-8
141 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
142
143 %package agent2
144 Summary:        Zabbix Agent 2
145 Group:          Networking/Utilities
146 URL:            https://www.zabbix.com/documentation/current/manual/concepts/agent2
147 Requires:       %{name}-common = %{version}-%{release}
148
149 %description agent2
150 Zabbix agent 2 is a new generation of Zabbix agent and may be used in
151 place of Zabbix agent.
152
153 Zabbix agent 2 has been developed to:
154 - reduce the number of TCP connections
155 - have greater check concurrency
156 - be easily extendible with plugins.
157
158 A plugin should be able to:
159 - provide trivial checks consisting of only a few simple lines of code
160 - provide complex checks consisting of long-running scripts and
161   standalone data gathering with periodic sending back of the data
162 - be a drop-in replacement for Zabbix agent (in that it supports all
163   the previous functionality)
164
165 Passive checks work similarly to Zabbix agent. Active checks support
166 scheduled/flexible intervals and check concurrency within one active
167 server.
168
169 %package frontend-php
170 Summary:        PHP frontend for Zabbix
171 Summary(pl.UTF-8):      Interfejs PHP dla Zabbiksa
172 Group:          Applications/WWW
173 Requires:       php(bcmath)
174 Requires:       php(core) >= %{php_min_version}
175 Requires:       php(ctype)
176 Requires:       php(gd)
177 Requires:       php(gettext)
178 Requires:       php(json)
179 Requires:       php(mbstring)
180 Requires:       php(pcre)
181 Requires:       php(session)
182 Requires:       php(sockets)
183 Requires:       php(xml)
184 Requires:       php(xmlreader)
185 Requires:       php(xmlwriter)
186 Requires:       webapps
187 Requires:       webserver(alias)
188 Requires:       webserver(indexfile)
189 Requires:       webserver(php)
190 Suggests:       php(mysql)
191 Suggests:       php(pgsql)
192 Suggests:       php(sqlite3)
193 # used with sqlite3
194 Suggests:       php(sysvsem)
195 BuildArch:      noarch
196
197 %description frontend-php
198 This package provides web based (PHP) frontend for Zabbix.
199
200 %description frontend-php -l pl.UTF-8
201 Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
202
203 %package get
204 Summary:        Program retrieving data from Zabbix agent
205 Summary(pl.UTF-8):      Program odpytujÄcy agenta Zabbiksa
206 Group:          Networking/Utilities
207
208 %description get
209 This package provides a program retrieving data from Zabbix agent.
210
211 %description get -l pl.UTF-8
212 Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
213
214 %package proxy
215 Summary:        Zabbix proxy
216 Summary(pl.UTF-8):      Proxy do Zabbiksa
217 Group:          Networking/Utilities
218 Requires:       %{name}-common = %{version}-%{release}
219 Requires:       systemd-units >= 38
220 Requires:       zabbix-proxy(db) = %{version}-%{release}
221
222 %description proxy
223 This package provides the Zabbix proxy.
224
225 %description proxy -l pl.UTF-8
226 Ten pakiet zawiera proxy Zabbix.
227
228 %package proxy-mysql
229 Summary:        MySQL support for Zabbix proxy
230 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbiksa
231 Group:          Networking/Utilities
232 Provides:       %{name}-proxy(db) = %{version}-%{release}
233 Obsoletes:      zabbix-proxy-postgresql
234 Obsoletes:      zabbix-proxy-sqlite3
235
236 %description proxy-mysql
237 This package provides the Zabbix proxy binary with MySQL support.
238
239 %description proxy-mysql -l pl.UTF-8
240 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
241
242 %package proxy-postgresql
243 Summary:        PostgreSQL support for Zabbix proxy
244 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbiksa
245 Group:          Networking/Utilities
246 Provides:       %{name}-proxy(db) = %{version}-%{release}
247 Obsoletes:      zabbix-proxy-mysql
248 Obsoletes:      zabbix-proxy-sqlite3
249
250 %description proxy-postgresql
251 This package provides the Zabbix proxy binary with PostgreSQL support.
252
253 %description proxy-postgresql -l pl.UTF-8
254 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
255
256 %package proxy-sqlite3
257 Summary:        SQLite 3 support for Zabbix proxy
258 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbiksa
259 Group:          Networking/Utilities
260 Provides:       %{name}-proxy(db) = %{version}-%{release}
261 Obsoletes:      zabbix-proxy-mysql
262 Obsoletes:      zabbix-proxy-postgresql
263
264 %description proxy-sqlite3
265 This package provides the Zabbix proxy binary with SQLite 3 support.
266
267 %description proxy-sqlite3 -l pl.UTF-8
268 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
269
270 %package sender
271 Summary:        Zabbix sender
272 Summary(pl.UTF-8):      Program zawiadamiający Zabbiksa
273 Group:          Networking/Utilities
274
275 %description sender
276 This package provides the Zabbix sender.
277
278 %description sender -l pl.UTF-8
279 Ten pakiet zawiera program zawiadamiający Zabbiksa.
280
281 %package server
282 Summary:        Zabbix server
283 Summary(pl.UTF-8):      Serwer Zabbiksa
284 Group:          Networking/Utilities
285 Requires:       %{name}-common = %{version}-%{release}
286 Requires:       %{name}-server(db) = %{version}-%{release}
287 Requires:       systemd-units >= 38
288 Obsoletes:      zabbix-suckerd
289 Obsoletes:      zabbix-trapper-inetd
290 Obsoletes:      zabbix-trapper-standalone
291
292 %description server
293 This package provides the Zabbix server.
294
295 %description server -l pl.UTF-8
296 Ten pakiet zawiera serwer Zabbiksa.
297
298 %package server-mysql
299 Summary:        MySQL support for Zabbix server
300 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbiksa
301 Group:          Networking/Utilities
302 Provides:       %{name}-server(db) = %{version}-%{release}
303 Obsoletes:      zabbix-server-postgresql
304 Obsoletes:      zabbix-server-sqlite3
305
306 %description server-mysql
307 This package provides the Zabbix server binary for use with MySQL
308 database.
309
310 %description server-mysql -l pl.UTF-8
311 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
312
313 %package server-postgresql
314 Summary:        PostgreSQL support for Zabbix server
315 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbiksa
316 Group:          Networking/Utilities
317 Provides:       %{name}-server(db) = %{version}-%{release}
318 Obsoletes:      zabbix-server-mysql
319 Obsoletes:      zabbix-server-sqlite3
320
321 %description server-postgresql
322 This package provides the Zabbix server binary for use with PostgreSQL
323 database.
324
325 %description server-postgresql -l pl.UTF-8
326 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
327
328 %package java
329 Summary:        Zabbix Java Gateway
330 Group:          Networking/Utilities
331 Requires:       %{name}-common = %{version}-%{release}
332 Requires:       systemd-units >= 38
333
334 %description java
335 This package provides the Zabbix Java Gateway.
336
337 %prep
338 %setup -q -a8
339 %patch0 -p1
340 %patch1 -p1
341 %patch2 -p1
342 %patch3 -p1
343 %patch4 -p1
344
345 %build
346 %{__libtoolize}
347 %{__aclocal} -I m4
348 %{__autoconf}
349 %{__autoheader}
350 %{__automake}
351
352 configure() {
353         %configure \
354         --enable-dependency-tracking \
355         --enable-agent \
356         %{__enable_disable agent2} \
357         --enable-ipv6 \
358         %{__enable_disable java} \
359         --with-ldap \
360         --with-libcurl \
361         --with-libevent \
362         --with-libpcre \
363         --with-libxml2 \
364         --with-net-snmp \
365         --with-openipmi \
366         --with-openssl \
367         --with-ssh2 \
368         --with-unixodbc \
369         "$@"
370 }
371
372 configure \
373         --disable-server \
374         --disable-proxy
375
376 %{__make}
377
378 for database in %{databases} ; do
379         if [ "$database" = "sqlite3" ] ; then
380                 enable_server=""
381         else
382                 enable_server="--enable-server"
383         fi
384         configure \
385                 --with-$database \
386                 $enable_server \
387                 --enable-proxy
388
389         %{__make}
390
391         if [ "$enable_server" ] ; then
392                 %{__make} install \
393                         -C src/zabbix_server \
394                         DESTDIR=$PWD/install-${database}
395         fi
396
397         %{__make} install \
398                 -C src/zabbix_proxy \
399                 DESTDIR=$PWD/install-${database}
400 done
401
402 %install
403 rm -rf $RPM_BUILD_ROOT
404 install -d \
405         $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_agent2.conf.d,/etc/webapps/%{_webapp}} \
406         $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_appdir}/frontends/php} \
407         $RPM_BUILD_ROOT{/var/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
408
409 %{__make} install \
410         DESTDIR=$RPM_BUILD_ROOT \
411         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
412
413 for database in %{databases} ; do
414         if [ "$database" != "sqlite3" ] ; then
415                 cp -p install-$database/%{_sbindir}/zabbix_server \
416                         $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
417         fi
418         cp -p install-$database/%{_sbindir}/zabbix_proxy \
419                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
420 done
421
422 if [ -n "$database" ] ; then
423         ln -sf zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
424         ln -sf zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
425 fi
426
427 %if %{with sqlite3}
428 install -d $RPM_BUILD_ROOT/var/lib/zabbix
429 touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
430 %endif
431
432 cp -r ui/* $RPM_BUILD_ROOT%{_appdir}/frontends/php
433
434 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
435 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
436
437 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
438 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
439 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
440 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
441 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service
442
443 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
444
445 mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
446 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/frontend,%{_appdir}/frontends/php/conf}
447 touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
448
449 %if %{with java}
450 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
451 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_java.conf,%{_datadir}/zabbix_java/settings.sh}
452 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
453 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback.xml,%{_datadir}/zabbix_java/lib/logback.xml}
454 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
455 ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback-console.xml,%{_datadir}/zabbix_java/lib/logback-console.xml}
456
457 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
458 #!/bin/sh
459
460 exec %{_datadir}/zabbix_java/startup.sh "$@"
461 EOF
462
463 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
464 #!/bin/sh
465
466 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
467 EOF
468 %endif
469
470 %clean
471 rm -rf $RPM_BUILD_ROOT
472
473 %triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
474 %webapp_register apache %{_webapp}
475
476 %triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
477 %webapp_unregister apache %{_webapp}
478
479 %triggerin frontend-php -- apache < 2.2.0, apache-base
480 %webapp_register httpd %{_webapp}
481
482 %triggerun frontend-php -- apache < 2.2.0, apache-base
483 %webapp_unregister httpd %{_webapp}
484
485 %pre common
486 %groupadd -g 111 zabbix
487 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
488 %addusertogroup -q zabbix proc
489
490 %postun common
491 if [ "$1" = "0" ]; then
492         %userremove zabbix
493         %groupremove zabbix
494 fi
495
496 %post server-mysql
497 if [ "$1" = 1 ]; then
498         %banner -e %{name}-server <<-EOF
499         You should create database for Zabbix.
500
501         Running these should be fine in most cases:
502         mysqladmin create zabbix
503         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
504         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
505         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
506 EOF
507 fi
508 ln -sf zabbix_server-mysql %{_sbindir}/zabbix_server || :
509
510 %post server-postgresql
511 if [ "$1" = 1 ]; then
512         %banner -e %{name}-server <<-EOF
513         You should create database for Zabbix.
514
515         Running these should be fine in most cases:
516
517         createuser zabbix
518         createdb -O zabbix zabbix
519         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
520         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
521         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
522 EOF
523 fi
524 ln -sf zabbix_server-postgresql %{_sbindir}/zabbix_server || :
525
526 %post server
527 %systemd_post zabbix_server.service
528
529 %preun server
530 %systemd_preun zabbix_server.service
531
532 %postun server
533 if [ "$1" = "0" ]; then
534         if [ -L %{_sbindir}/zabbix_server ] ; then
535                 rm -f %{_sbindir}/zabbix_server || :
536         fi
537 fi
538 %systemd_reload
539
540 %post agentd
541 /sbin/chkconfig --add zabbix_agentd
542 %service zabbix_agentd restart
543 %systemd_post zabbix_agentd.service
544
545 %preun agentd
546 if [ "$1" = "0" ]; then
547         %service -q zabbix_agentd stop
548         /sbin/chkconfig --del zabbix_agentd
549 fi
550 %systemd_preun zabbix_agentd.service
551
552 %postun agentd
553 %systemd_reload
554
555 %post proxy-mysql
556 ln -sf zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
557
558 %post proxy-postgresql
559 ln -sf zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
560
561 %post proxy-sqlite3
562 ln -sf zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
563
564 %post proxy
565 %systemd_post zabbix_proxy.service
566
567 %preun proxy
568 %systemd_preun zabbix_proxy.service
569
570 %postun proxy
571 %systemd_reload
572
573 %post java
574 %systemd_post zabbix_java.service
575
576 %preun java
577 %systemd_preun zabbix_java.service
578
579 %postun java
580 %systemd_reload
581
582 %files
583 %defattr(644,root,root,755)
584 %doc AUTHORS ChangeLog README
585
586 %files common
587 %defattr(644,root,root,755)
588 %doc AUTHORS ChangeLog README
589 %attr(751,root,zabbix) %dir %{_sysconfdir}
590 %attr(751,root,http) %dir %{_sysconfdir}/frontend
591 %dir %{_appdir}
592 %dir %{_appdir}/frontends
593 %dir %attr(770,root,zabbix) /var/run/zabbix
594 %dir %attr(775,root,zabbix) /var/log/zabbix
595 %{systemdtmpfilesdir}/zabbix.conf
596
597 %files agentd
598 %defattr(644,root,root,755)
599 %doc conf/zabbix_agentd/*.conf
600 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
601 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
602 %attr(754,root,root) /etc/rc.d/init.d/zabbix_agentd
603 %attr(755,root,root) %{_sbindir}/zabbix_agentd
604 %{_mandir}/man8/zabbix_agentd*
605 %{systemdunitdir}/zabbix_agentd.service
606
607 %if %{with agent2}
608 %files agent2
609 %defattr(644,root,root,755)
610 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.conf
611 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.conf.d
612 %attr(755,root,root) %{_sbindir}/zabbix_agent2
613 %{_mandir}/man8/zabbix_agent2.8*
614 %endif
615
616 %files frontend-php
617 %defattr(644,root,root,755)
618 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
620 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
621 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
622 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
623 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
624 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
625 %{_appdir}/frontends/php
626
627 %files get
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_bindir}/zabbix_get
630 %{_mandir}/man1/zabbix_get*
631
632 %if %{any_database}
633 %files proxy
634 %defattr(644,root,root,755)
635 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
636 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
637 %ghost %{_sbindir}/zabbix_proxy
638 %{_mandir}/man8/zabbix_proxy*
639 %{systemdunitdir}/zabbix_proxy.service
640 %endif
641
642 %if %{with mysql}
643 %files proxy-mysql
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
646 %endif
647
648 %if %{with pgsql}
649 %files proxy-postgresql
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
652 %endif
653
654 %if %{with sqlite3}
655 %files proxy-sqlite3
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
658 %endif
659
660 %files sender
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_bindir}/zabbix_sender
663 %{_mandir}/man1/zabbix_sender*
664
665 %if %{any_database}
666 %files server
667 %defattr(644,root,root,755)
668 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
669 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
670 %ghost %{_sbindir}/zabbix_server
671 %{_mandir}/man8/zabbix_server*
672 %{systemdunitdir}/zabbix_server.service
673 %endif
674
675 %if %{with mysql}
676 %files server-mysql
677 %defattr(644,root,root,755)
678 %doc database/mysql/*.sql
679 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
680 %endif
681
682 %if %{with pgsql}
683 %files server-postgresql
684 %defattr(644,root,root,755)
685 %doc database/postgresql/*.sql
686 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
687 %endif
688
689 %if %{with java}
690 %files java
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_sbindir}/zabbix_java-start
693 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
694 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
695 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
696 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
697 %dir %{_datadir}/zabbix_java
698 %{_datadir}/zabbix_java/bin
699 %{_datadir}/zabbix_java/lib
700 %{_datadir}/zabbix_java/settings.sh
701 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
702 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
703 %{systemdunitdir}/zabbix_java.service
704 %endif
This page took 0.119325 seconds and 3 git commands to generate.