]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
Version: 3.4.4
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-agentd, zabbix-server, zabbix-proxy and zabbix-java
3 #
4 # Conditional build:
5 %bcond_without  pgsql   # enable PostgreSQL support
6 %bcond_without  sqlite3 # enable sqlite3 support
7 %bcond_without  mysql   # enable MySQL support
8 %bcond_without  java    # disable java support
9
10 %define databases %{?with_pgsql:postgresql} %{?with_mysql:mysql} %{?with_sqlite3:sqlite3}
11 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
12
13 %define         php_min_version 5.4.0
14 Summary:        Zabbix - network monitoring software
15 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
16 Name:           zabbix
17 Version:        3.4.4
18 Release:        1
19 License:        GPL v2+
20 Group:          Networking/Utilities
21 Source0:        http://downloads.sourceforge.net/zabbix/%{name}-%{version}.tar.gz
22 # Source0-md5:  3211dd373fa3424be3ab3a0ee9c48816
23 Source1:        %{name}-apache.conf
24 Source2:        %{name}_server.service
25 Source3:        %{name}_agentd.service
26 Source4:        %{name}_proxy.service
27 Source5:        %{name}_java.service
28 Source6:        %{name}.tmpfiles
29 Patch0:         config.patch
30 Patch1:         sqlite3_dbname.patch
31 Patch2:         sqlite3_dbname.patch
32 URL:            http://zabbix.sourceforge.net/
33 BuildRequires:  OpenIPMI-devel
34 BuildRequires:  curl-devel
35 BuildRequires:  iksemel-devel
36 %{?with_java:BuildRequires:     jdk}
37 BuildRequires:  libevent-devel
38 BuildRequires:  libssh2-devel
39 BuildRequires:  libxml2-devel
40 %{?with_mysql:BuildRequires:    mysql-devel}
41 BuildRequires:  net-snmp-devel
42 BuildRequires:  openldap-devel >= 2.4.6
43 BuildRequires:  openssl-devel >= 0.9.7d
44 BuildRequires:  pcre-devel
45 %{?with_pgsql:BuildRequires:    postgresql-devel}
46 BuildRequires:  rpmbuild(macros) >= 1.671
47 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
48 BuildRequires:  unixODBC-devel
49 Requires:       %{name}-agentd = %{version}-%{release}
50 Requires:       %{name}-frontend-php = %{version}-%{release}
51 Requires:       %{name}-server = %{version}-%{release}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         _sysconfdir     /etc/%{name}
55 %define         _appdir         %{_datadir}/%{name}
56 %define         _webapps        /etc/webapps
57 %define         _webapp         %{name}
58
59 %description
60 Zabbix is software that monitors numerous parameters of a network and
61 the servers on that network. It is a useful tool for monitoring the
62 health and integrity of servers. Zabbix uses a flexible notification
63 mechanism that allows users to configure email based alerts for
64 virtually any event. All monitored parameters are stored in a
65 database. Zabbix offers excellent reporting and data visualisation
66 features based on the stored data. Zabbix supports both polling and
67 trapping. All Zabbix reports and statistics, as well as configuration
68 parameters, are accessed through a web-based front end.
69
70 %description -l pl.UTF-8
71 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
72 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
73 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
74 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
75 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
76 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
77 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
78 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
79 statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
80
81 %package common
82 Summary:        Common files for Zabbix monitoring software
83 Summary(pl.UTF-8):      Wspólne pliki dla oprogramowania monitorującego Zabbix
84 Group:          Networking/Utilities
85 Requires(postun):       /usr/sbin/groupdel
86 Requires(postun):       /usr/sbin/userdel
87 Requires(pre):  /bin/id
88 Requires(pre):  /usr/bin/getgid
89 Requires(pre):  /usr/sbin/groupadd
90 Requires(pre):  /usr/sbin/useradd
91 Provides:       group(zabbix)
92 Provides:       user(zabbix)
93
94 %description common
95 Common files for Zabbix monitoring software.
96
97 %description common -l pl.UTF-8
98 Wspólne pliki dla oprogramowania monitorującego Zabbix.
99
100 %package agentd
101 Summary:        Zabbix Agent
102 Summary(pl.UTF-8):      Agenta Zabbiksa
103 Group:          Networking/Utilities
104 Requires:       %{name}-common = %{version}-%{release}
105 Requires:       systemd-units >= 38
106 Obsoletes:      zabbix-agent-inetd
107 Obsoletes:      zabbix-agent-standalone
108
109 %description agentd
110 Zabbix agent collects data from the local system for a Zabbix server.
111
112 %description agentd -l pl.UTF-8
113 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
114
115 %package frontend-php
116 Summary:        PHP frontend for Zabbix
117 Summary(pl.UTF-8):      Interfejs PHP dla Zabbiksa
118 Group:          Applications/WWW
119 Requires:       php(bcmath)
120 Requires:       php(core) >= %{php_min_version}
121 Requires:       php(ctype)
122 Requires:       php(gd)
123 Requires:       php(gettext)
124 Requires:       php(json)
125 Requires:       php(mbstring)
126 Requires:       php(pcre)
127 Requires:       php(session)
128 Requires:       php(sockets)
129 Requires:       php(xml)
130 Requires:       php(xmlreader)
131 Requires:       php(xmlwriter)
132 Requires:       webapps
133 Requires:       webserver(alias)
134 Requires:       webserver(indexfile)
135 Requires:       webserver(php)
136 Suggests:       php(mysql)
137 Suggests:       php(pgsql)
138 Suggests:       php(sqlite3)
139 # used with sqlite3
140 Suggests:       php(sysvsem)
141 BuildArch:      noarch
142
143 %description frontend-php
144 This package provides web based (PHP) frontend for Zabbix.
145
146 %description frontend-php -l pl.UTF-8
147 Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
148
149 %package get
150 Summary:        Program retrieving data from Zabbix agent
151 Summary(pl.UTF-8):      Program odpytujÄcy agenta Zabbiksa
152 Group:          Networking/Utilities
153
154 %description get
155 This package provides a program retrieving data from Zabbix agent.
156
157 %description get -l pl.UTF-8
158 Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
159
160 %package proxy
161 Summary:        Zabbix proxy
162 Summary(pl.UTF-8):      Proxy do Zabbiksa
163 Group:          Networking/Utilities
164 Requires:       %{name}-common = %{version}-%{release}
165 Requires:       systemd-units >= 38
166 Requires:       zabbix-proxy(db) = %{version}-%{release}
167
168 %description proxy
169 This package provides the Zabbix proxy.
170
171 %description proxy -l pl.UTF-8
172 Ten pakiet zawiera proxy Zabbix.
173
174 %package proxy-mysql
175 Summary:        MySQL support for Zabbix proxy
176 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbiksa
177 Group:          Networking/Utilities
178 Provides:       %{name}-proxy(db) = %{version}-%{release}
179 Obsoletes:      zabbix-proxy-postgresql
180 Obsoletes:      zabbix-proxy-sqlite3
181
182 %description proxy-mysql
183 This package provides the Zabbix proxy binary with MySQL support.
184
185 %description proxy-mysql -l pl.UTF-8
186 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
187
188 %package proxy-postgresql
189 Summary:        PostgreSQL support for Zabbix proxy
190 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbiksa
191 Group:          Networking/Utilities
192 Provides:       %{name}-proxy(db) = %{version}-%{release}
193 Obsoletes:      zabbix-proxy-mysql
194 Obsoletes:      zabbix-proxy-sqlite3
195
196 %description proxy-postgresql
197 This package provides the Zabbix proxy binary with PostgreSQL support.
198
199 %description proxy-postgresql -l pl.UTF-8
200 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
201
202 %package proxy-sqlite3
203 Summary:        SQLite 3 support for Zabbix proxy
204 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbiksa
205 Group:          Networking/Utilities
206 Provides:       %{name}-proxy(db) = %{version}-%{release}
207 Obsoletes:      zabbix-proxy-mysql
208 Obsoletes:      zabbix-proxy-postgresql
209
210 %description proxy-sqlite3
211 This package provides the Zabbix proxy binary with SQLite 3 support.
212
213 %description proxy-sqlite3 -l pl.UTF-8
214 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
215
216 %package sender
217 Summary:        Zabbix sender
218 Summary(pl.UTF-8):      Program zawiadamiający Zabbiksa
219 Group:          Networking/Utilities
220
221 %description sender
222 This package provides the Zabbix sender.
223
224 %description sender -l pl.UTF-8
225 Ten pakiet zawiera program zawiadamiający Zabbiksa.
226
227 %package server
228 Summary:        Zabbix server
229 Summary(pl.UTF-8):      Serwer Zabbiksa
230 Group:          Networking/Utilities
231 Requires:       %{name}-common = %{version}-%{release}
232 Requires:       %{name}-server(db) = %{version}-%{release}
233 Requires:       systemd-units >= 38
234 Obsoletes:      zabbix-suckerd
235 Obsoletes:      zabbix-trapper-inetd
236 Obsoletes:      zabbix-trapper-standalone
237
238 %description server
239 This package provides the Zabbix server.
240
241 %description server -l pl.UTF-8
242 Ten pakiet zawiera serwer Zabbiksa.
243
244 %package server-mysql
245 Summary:        MySQL support for Zabbix server
246 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbiksa
247 Group:          Networking/Utilities
248 Provides:       %{name}-server(db) = %{version}-%{release}
249 Obsoletes:      zabbix-server-postgresql
250 Obsoletes:      zabbix-server-sqlite3
251
252 %description server-mysql
253 This package provides the Zabbix server binary for use with MySQL
254 database.
255
256 %description server-mysql -l pl.UTF-8
257 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
258
259 %package server-postgresql
260 Summary:        PostgreSQL support for Zabbix server
261 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbiksa
262 Group:          Networking/Utilities
263 Provides:       %{name}-server(db) = %{version}-%{release}
264 Obsoletes:      zabbix-server-mysql
265 Obsoletes:      zabbix-server-sqlite3
266
267 %description server-postgresql
268 This package provides the Zabbix server binary for use with PostgreSQL
269 database.
270
271 %description server-postgresql -l pl.UTF-8
272 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
273
274 %package java
275 Summary:        Zabbix Java Gateway
276 Group:          Networking/Utilities
277 Requires:       %{name}-common = %{version}-%{release}
278 Requires:       systemd-units >= 38
279
280 %description java
281 This package provides the Zabbix Java Gateway.
282
283 %prep
284 %setup -q
285
286 %patch0 -p1
287 %patch1 -p1
288 %patch2 -p1
289
290 %build
291
292 configure() {
293         %configure \
294         --enable-agent \
295         --enable-ipv6 \
296         %{__enable_disable java} \
297         --with-jabber \
298         --with-ldap \
299         --with-libcurl \
300         --with-libxml2 \
301         --with-net-snmp \
302         --with-openipmi \
303         --with-openssl \
304         --with-ssh2 \
305         --with-unixodbc \
306         "$@"
307 }
308
309 configure \
310         --disable-server \
311         --disable-proxy
312
313 %{__make}
314
315 # keep timestamps to prevent unneccessary rebuilds
316 cp -a include/config.h include/config.h.old
317 cp -a include/stamp-h1 include/stamp-h1.old
318
319 for database in %{databases} ; do
320         configure \
321                 --with-$database \
322                 --enable-server \
323                 --enable-proxy
324
325         # restore timestamps
326         touch --reference=include/config.h.old include/config.h
327         touch --reference=include/stamp-h1.old include/stamp-h1
328
329         # clean what needs rebuilding
330         for dir in src/libs/zbxdb* src/libs/zbxserver ; do
331                 %{__make} -C $dir clean
332         done
333
334         touch include/zbxdb.h
335
336         %{__make}
337
338         %{__make} install \
339                 -C src/zabbix_server \
340                 DESTDIR=$PWD/install-${database}
341         %{__make} install \
342                 -C src/zabbix_proxy \
343                 DESTDIR=$PWD/install-${database}
344
345         # prepare dirs for %%doc
346         for dir in upgrades/dbpatches/* ; do
347                 [ -d $dir/${database} ] || continue
348                 mkdir -p install-${database}/upgrade/$(basename $dir)
349                 cp -a $dir/${databases}/* install-${database}/upgrade/$(basename $dir)
350         done
351 done
352
353 %install
354 rm -rf $RPM_BUILD_ROOT
355 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/webapps/%{_webapp},%{_appdir}} \
356         $RPM_BUILD_ROOT{/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
357
358 %{__make} install \
359         DESTDIR=$RPM_BUILD_ROOT \
360         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
361
362 for database in %{databases} ; do
363         cp -p install-$database/%{_sbindir}/zabbix_server \
364                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
365         cp -p install-$database/%{_sbindir}/zabbix_proxy \
366                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
367 done
368
369 if [ -n "$database" ] ; then
370         ln -sf %{_sbindir}/zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
371         ln -sf %{_sbindir}/zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
372 fi
373
374 %if %{with sqlite3}
375 install -d $RPM_BUILD_ROOT/var/lib/zabbix
376 touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
377 %endif
378
379 cp -r frontends $RPM_BUILD_ROOT%{_appdir}
380
381 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
382 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
383
384 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
385 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
386 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
387 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service
388
389 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
390
391 mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
392 ln -s %{_sysconfdir}/frontend $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf
393 touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
394
395 %if %{with java}
396 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
397 ln -s %{_sysconfdir}/zabbix_java.conf $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh
398 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
399 ln -s %{_sysconfdir}/java-logback.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml
400 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
401 ln -s %{_sysconfdir}/java-logback-console.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml
402
403 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
404 #!/bin/sh
405
406 exec %{_datadir}/zabbix_java/startup.sh "$@"
407 EOF
408
409 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
410 #!/bin/sh
411
412 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
413 EOF
414 %endif
415
416 %clean
417 rm -rf $RPM_BUILD_ROOT
418
419 %triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
420 %webapp_register apache %{_webapp}
421
422 %triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
423 %webapp_unregister apache %{_webapp}
424
425 %triggerin frontend-php -- apache < 2.2.0, apache-base
426 %webapp_register httpd %{_webapp}
427
428 %triggerun frontend-php -- apache < 2.2.0, apache-base
429 %webapp_unregister httpd %{_webapp}
430
431 %pre common
432 %groupadd -g 111 zabbix
433 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
434 %addusertogroup -q zabbix proc
435
436 %postun common
437 if [ "$1" = "0" ]; then
438         %userremove zabbix
439         %groupremove zabbix
440 fi
441
442 %post server-mysql
443 if [ "$1" = 1 ]; then
444         %banner -e %{name}-server <<-EOF
445         You should create database for Zabbix.
446
447         Running these should be fine in most cases:
448         mysqladmin create zabbix
449         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
450         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
451         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
452 EOF
453 fi
454 ln -sf %{_sbindir}/zabbix_server-mysql %{_sbindir}/zabbix_server || :
455
456 %post server-postgresql
457 if [ "$1" = 1 ]; then
458         %banner -e %{name}-server <<-EOF
459         You should create database for Zabbix.
460
461         Running these should be fine in most cases:
462
463         createuser zabbix
464         createdb -O zabbix zabbix
465         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
466         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
467         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
468 EOF
469 fi
470 ln -sf %{_sbindir}/zabbix_server-postgresql %{_sbindir}/zabbix_server || :
471
472 %post server
473 %systemd_post zabbix_server.service
474
475 %preun server
476 %systemd_preun zabbix_server.service
477
478 %postun server
479 if [ "$1" = "0" ]; then
480         if [ -L %{_sbindir}/zabbix_server ] ; then
481                 rm -f %{_sbindir}/zabbix_server || :
482         fi
483 fi
484 %systemd_reload
485
486 %post agentd
487 %systemd_post zabbix_agentd.service
488
489 %preun agentd
490 %systemd_preun zabbix_agentd.service
491
492 %postun agentd
493 %systemd_reload
494
495 %post proxy-mysql
496 ln -sf %{_sbindir}/zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
497
498 %post proxy-postgresql
499 ln -sf %{_sbindir}/zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
500
501 %post proxy-sqlite3
502 ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
503
504 %post proxy
505 %systemd_post zabbix_proxy.service
506
507 %preun proxy
508 %systemd_preun zabbix_proxy.service
509
510 %postun proxy
511 %systemd_reload
512
513 %post java
514 %systemd_post zabbix_java.service
515
516 %preun java
517 %systemd_preun zabbix_java.service
518
519 %postun java
520 %systemd_reload
521
522 %files
523 %defattr(644,root,root,755)
524 %doc AUTHORS ChangeLog README
525
526 %files common
527 %defattr(644,root,root,755)
528 %doc AUTHORS ChangeLog README
529 %attr(751,root,zabbix) %dir %{_sysconfdir}
530 %attr(751,root,http) %dir %{_sysconfdir}/frontend
531 %dir %{_appdir}
532 %dir %{_appdir}/frontends
533 %dir %attr(770,root,zabbix) /run/zabbix
534 %dir %attr(775,root,zabbix) /var/log/zabbix
535 %{systemdtmpfilesdir}/zabbix.conf
536
537 %files agentd
538 %defattr(644,root,root,755)
539 %doc conf/zabbix_agentd/*.conf
540 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
541 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
542 %attr(755,root,root) %{_sbindir}/zabbix_agentd
543 %{_mandir}/man8/zabbix_agentd*
544 %{systemdunitdir}/zabbix_agentd.service
545
546 %files frontend-php
547 %defattr(644,root,root,755)
548 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
549 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
550 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
551 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
552 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
553 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
554 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
555 %{_appdir}/frontends/php
556
557 %files get
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_bindir}/zabbix_get
560 %{_mandir}/man1/zabbix_get*
561
562 %if %{any_database}
563 %files proxy
564 %defattr(644,root,root,755)
565 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
566 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
567 %ghost %attr(755,root,root) %{_sbindir}/zabbix_proxy
568 %{_mandir}/man8/zabbix_proxy*
569 %{systemdunitdir}/zabbix_proxy.service
570 %endif
571
572 %if %{with mysql}
573 %files proxy-mysql
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
576 %endif
577
578 %if %{with pgsql}
579 %files proxy-postgresql
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
582 %endif
583
584 %if %{with sqlite3}
585 %files proxy-sqlite3
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
588 %endif
589
590 %files sender
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_bindir}/zabbix_sender
593 %{_mandir}/man1/zabbix_sender*
594
595 %if %{any_database}
596 %files server
597 %defattr(644,root,root,755)
598 %doc upgrades/dbpatches
599 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
600 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
601 %ghost %attr(755,root,root) %{_sbindir}/zabbix_server
602 %{_mandir}/man8/zabbix_server*
603 %{systemdunitdir}/zabbix_server.service
604 %endif
605
606 %if %{with mysql}
607 %files server-mysql
608 %defattr(644,root,root,755)
609 %doc database/mysql/*.sql install-mysql/upgrade
610 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
611 %endif
612
613 %if %{with pgsql}
614 %files server-postgresql
615 %defattr(644,root,root,755)
616 %doc database/postgresql/*.sql install-postgresql/upgrade
617 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
618 %endif
619
620 %if %{with java}
621 %files java
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_sbindir}/zabbix_java-start
624 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
625 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
626 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
627 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
628 %dir %{_datadir}/zabbix_java
629 %{_datadir}/zabbix_java/bin
630 %{_datadir}/zabbix_java/lib
631 %{_datadir}/zabbix_java/settings.sh
632 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
633 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
634 %{systemdunitdir}/zabbix_java.service
635 %endif
This page took 0.086905 seconds and 3 git commands to generate.