]> git.pld-linux.org Git - packages/yum-utils.git/blob - yum-utils.spec
740529cef3f66cbca60e9fe05015d1fe9194812e
[packages/yum-utils.git] / yum-utils.spec
1 #
2 # Conditional build:
3 %bcond_with     puppet          # puppet plugin
4
5 Summary:        A collection of utilities related to yum
6 Summary(pl.UTF-8):      Zestaw narzędzi związanych z yumem
7 Name:           yum-utils
8 Version:        1.1.31
9 Release:        8
10 License:        GPL
11 Group:          Applications/System
12 Source0:        http://yum.baseurl.org/download/yum-utils/%{name}-%{version}.tar.gz
13 # Source0-md5:  b2859b89321b98f2581243536e1b4993
14 Source1:        yum-plugin-pld-kernel.py
15 Source2:        yum-plugin-pld-kernel.conf
16 URL:            http://yum.baseurl.org/download/yum-utils/
17 BuildRequires:  gettext-devel
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.228
20 Requires:       python >= 1:2.5
21 Requires:       yum >= 3.2.29
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _libexecdir     %{_prefix}/lib/%{name}
26
27 %description
28 Yum-utils is a collection of utilities, plugins and examples related
29 to the yum package manager.
30
31 %description -l pl.UTF-8
32 yum-utils to zestaw narzędzi, wtyczek i przykładów związanych z
33 zarządcą pakietów yum.
34
35 %package -n yum-updateonboot
36 Summary:        Run yum update on system boot
37 Summary(pl.UTF-8):      Uruchamianie yum update przy starcie systemu
38 Group:          Base
39 Requires(post): /sbin/chkconfig
40 Requires(pre):  /sbin/chkconfig
41 Requires:       python
42 Requires:       yum >= 2.4
43
44 %description -n yum-updateonboot
45 Runs yum update on system boot. This allows machines that have been
46 turned off for an extended amount of time to become secure
47 immediately, instead of waiting until the next early morning cron job.
48
49 %description -n yum-updateonboot -l pl.UTF-8
50 Uruchamianie yum update przy starcie systemu. Pozwala to maszynom
51 wyłączonym na dłuższy czas stać się bezpiecznymi natychmiast, bez
52 czekania na kolejne poranne zadanie crona.
53
54 %package -n yum-plugin-changelog
55 Summary:        Yum plugin for viewing package changelogs before/after updating
56 Summary(pl.UTF-8):      Wtyczka yuma do oglądania list zmian pakietów przed/po uaktualnieniu
57 Group:          Base
58 # changelog requires new update_md.UpdateMetadata() API in 3.2.23
59 Requires:       python-dateutil
60 Requires:       yum >= 3.2.23
61 Obsoletes:      yum-changelog
62
63 %description -n yum-plugin-changelog
64 This plugin adds a command line option to allow viewing package
65 changelog deltas before or after updating packages.
66
67 %description -n yum-plugin-changelog -l pl.UTF-8
68 Ta wtyczka dodaje opcję linii poleceń pozwalającą oglądać przyrostowo
69 listę zmian pakietu (changelog) przed lub po uaktualnieniu.
70
71 %package -n yum-plugin-fastestmirror
72 Summary:        Yum plugin which chooses fastest repository from a mirrorlist
73 Summary(pl.UTF-8):      Wtyczka yuma wybierająca najszybsze repozytorium z listy serwerów lustrzanych
74 Group:          Base
75 Requires:       yum >= 3.0
76 Obsoletes:      yum-fastestmirror
77
78 %description -n yum-plugin-fastestmirror
79 This plugin sorts each repository's mirrorlist by connection speed
80 prior to downloading packages.
81
82 %description -n yum-plugin-fastestmirror -l pl.UTF-8
83 Ta wtyczka sortuje listy serwerów lustrzanych każdego repozytorium po
84 szybkości połączenia przed rozpoczęciem ściągania pakietów.
85
86 %package -n yum-plugin-protectbase
87 Summary:        Yum plugin to protect packages from certain repositories
88 Summary(pl.UTF-8):      Wtyczka yuma zabezpieczająca pakiety z pewnych repozytoriów
89 Group:          Base
90 Requires:       yum >= 3.0
91 Obsoletes:      yum-protectbase
92
93 %description -n yum-plugin-protectbase
94 This plugin allows certain repositories to be protected. Packages in
95 the protected repositories can't be overridden by packages in
96 non-protected repositories even if the non-protected repo has a later
97 version.
98
99 %description -n yum-plugin-protectbase -l pl.UTF-8
100 Ta wtyczka pozwala na zabezpieczenie pewnych repozytoriów. Pakiety z
101 zabezpieczonych repozytoriów nie mogą być przykryte przez pakiety z
102 repozytoriów niezabezpieczonych, nawet jeśli w niezabezpieczonym jest
103 nowsza wersja.
104
105 %package -n yum-plugin-versionlock
106 Summary:        Yum plugin to lock specified packages from being updated
107 Summary(pl.UTF-8):      Wtyczka yuma blokująca uaktualnianie określonych pakietów
108 Group:          Base
109 Requires:       yum >= 3.2.24
110 Obsoletes:      yum-versionlock
111
112 %description -n yum-plugin-versionlock
113 This plugin allows certain packages specified in a file to be
114 protected from being updated by newer versions.
115
116 %description -n yum-plugin-versionlock -l pl.UTF-8
117 Ta wtyczka pozwala chronić pewne pakiety określone w pliku przed
118 uaktualnieniem do nowszych wersji.
119
120 %package -n yum-plugin-tsflags
121 Summary:        Yum plugin to add tsflags by a commandline option
122 Summary(pl.UTF-8):      Wtyczka yuma dodająca flagi transakcji opcją linii poleceń
123 Group:          Base
124 Requires:       yum >= 3.0
125 Obsoletes:      yum-tsflags
126
127 %description -n yum-plugin-tsflags
128 This plugin allows you to specify optional transaction flags on the
129 yum command line.
130
131 %description -n yum-plugin-tsflags -l pl.UTF-8
132 Ta wtyczka pozwala określić dodatkowe flagi transakcji z linii
133 poleceń.
134
135 # TODO: figure if to remove in pld
136 %package -n yum-kernel-module
137 Summary:        Yum plugin to handle kernel-module-foo type of kernel module
138 Summary(pl.UTF-8):      Wtyczka yuma obsługująca moduły jądra typu kernel-module-foo
139 Group:          Base
140 Requires:       yum >= 3.0
141
142 %description -n yum-kernel-module
143 This plugin handle installation of kernel-module-foo type of kernel
144 modules when new version of kernels are installed.
145
146 %description -n yum-kernel-module -l pl.UTF-8
147 Ta wtyczka obsługuje instalację modułów jądra typu kernel-module-foo
148 kiedy zainstalowane są nowe wersje jądra.
149
150 %package -n yum-plugin-downloadonly
151 Summary:        Yum plugin to add downloadonly command option
152 Summary(pl.UTF-8):      Wtyczka yuma dodająca opcję linii poleceń downloadonly
153 Group:          Base
154 Requires:       yum >= 3.0
155 Obsoletes:      yum-downloadonly
156
157 %description -n yum-plugin-downloadonly
158 This plugin adds a --downloadonly flag to yum so that yum will only
159 download the packages and not install/update them.
160
161 %description -n yum-plugin-downloadonly -l pl.UTF-8
162 Ta wtyczka dodaje flagę --downloadonly do yuma, powodującą, że yum
163 tylko ściąga pakiety bez ich instalacji/uaktualniania.
164
165 %package -n yum-allowdowngrade
166 Summary:        Yum plugin to enable manual downgrading of packages
167 Summary(pl.UTF-8):      Wtyczka yuma umożliwiająca ręczne instalowanie starszych pakietów
168 Group:          Base
169 Requires:       yum >= 3.0
170
171 %description -n yum-allowdowngrade
172 This plugin adds a --allow-downgrade flag to yum to make it possible
173 to manually downgrade packages to specific versions.
174
175 %description -n yum-allowdowngrade -l pl.UTF-8
176 Ta wtyczka dodaje do yuma flagę --allow-downgrade, umożliwiającą
177 ręczne zastępowanie pakietów określonymi starszymi wersjami
178 (downgrade).
179
180 %package -n yum-plugin-pld-kernel
181 Summary:        Yum plugin to handle PLD kernel installs
182 Summary(pl.UTF-8):      Wtyczka yuma obsługująca instalację jąder PLD
183 Group:          Base
184 Requires:       yum >= 3.0
185 Obsoletes:      yum-pld-kernel
186
187 %description -n yum-plugin-pld-kernel
188 This plugin handle installation of PLD kernels.
189
190 %description -n yum-plugin-pld-kernel -l pl.UTF-8
191 Ta wtyczka obsługuje instalację jąder PLD.
192
193 %package -n yum-plugin-priorities
194 Summary:        Plugin to give priorities to packages from different repos
195 Summary(pl.UTF-8):      Wtyczka nadająca priorytety pakietom z różnych repozytoriów
196 Group:          Base
197 Requires:       yum >= 3.0
198 Obsoletes:      yum-priorities
199
200 %description -n yum-plugin-priorities
201 This plugin allows repositories to have different priorities. Packages
202 in a repository with a lower priority can't be overridden by packages
203 from a repository with a higher priority even if repo has a later
204 version.
205
206 %description -n yum-plugin-priorities -l pl.UTF-8
207 Ta wtyczka umożliwia przypisanie repozytoriom różnych priorytetów.
208 Pakiety z repozytorium o niższym priorytecie nie mogą być przykryte
209 przez pakiety z repozytorium o wyższym priorytecie nawet jeśli te
210 drugie mają nowszą wersję.
211
212 %package -n yum-plugin-refresh-updatesd
213 Summary:        Tell yum-updatesd to check for updates when yum exits
214 Summary(pl.UTF-8):      Sprawdzanie uaktualnień przez yum-updatesd przy zakończeniu yuma
215 Group:          Base
216 Requires:       yum >= 3.0
217 Requires:       yum-updatesd
218 Obsoletes:      yum-refresh-updatesd
219
220 %description -n yum-plugin-refresh-updatesd
221 yum-plugin-refresh-updatesd tells yum-updatesd to check for updates
222 when yum exits. This way, if you run 'yum update' and install all
223 available updates, puplet will almost instantly update itself to
224 reflect this.
225
226 %description -n yum-plugin-refresh-updatesd -l pl.UTF-8
227 yum-plugin-refresh-updatesd przekazuje yum-updatesd, aby sprawdzał
228 uaktualnienia kiedy yum kończy pracę. W ten sposób po uruchomieniu
229 "yum update" i zainstalowaniu wszystkich dostępnych uaktualnień puplet
230 prawie natychmiast uaktualni swoje informacje.
231
232 %package -n yum-plugin-merge-conf
233 Summary:        Yum plugin to merge configuration changes when installing packages
234 Summary(pl.UTF-8):      Wtyczka yuma do włączania zmian konfiguracji przy instalacji pakietów
235 Group:          Base
236 Requires:       yum >= 3.0
237 Obsoletes:      yum-merge-conf
238
239 %description -n yum-plugin-merge-conf
240 This yum plugin adds the "--merge-conf" command line option. With this
241 option, Yum will ask you what to do with config files which have
242 changed on updating a package.
243
244 %description -n yum-plugin-merge-conf -l pl.UTF-8
245 Ta wtyczka yuma dodaje opcję linii poleceń --merge-conf. Przy jej
246 użyciu yum pyta co zrobić z plikami konfiguracyjnymi, które zmieniły
247 się przy uaktualnianiu pakietu.
248
249 %package -n yum-plugin-security
250 Summary:        Yum plugin to enable security filters
251 Summary(pl.UTF-8):      Wtyczka yuma włączająca filtry bezpieczeństwa
252 Group:          Base
253 Requires:       yum >= 3.2.18
254 Obsoletes:      yum-security
255
256 %description -n yum-plugin-security
257 This plugin adds the options --security, --cve, --bz and --advisory
258 flags to yum and the list-security and info-security commands. The
259 options make it possible to limit list/upgrade of packages to specific
260 security relevant ones. The commands give you the security
261 information.
262
263 %description -n yum-plugin-security -l pl.UTF-8
264 Ta wtyczka dodaje do yuma flagi --security, --cve, --bz i --advisory
265 oraz polecenia list-security i info-security. Opcje te umożliwiają
266 ograniczenie listy/uaktualnień pakietów do związanych z
267 bezpieczeństwem w określony sposób. Polecenia podają informacje
268 związane z bezpieczeństwem.
269
270 %package -n yum-protect-packages
271 Summary:        Yum plugin to prevents Yum from removing itself and other protected packages
272 Summary(pl.UTF-8):      Wtyczka yuma zapobiegająca usunięciu siebie lub innych chronionych pakietów
273 Group:          Base
274 Requires:       yum >= 3.0
275
276 %description -n yum-protect-packages
277 This plugin prevents Yum from removing itself and other protected
278 packages. By default, yum is the only package protected, but by
279 extension this automatically protects everything on which yum depends
280 (rpm, python, glibc, and so on).Therefore, the plugin functions well
281 even without compiling careful lists of all important packages.
282
283 %description -n yum-protect-packages -l pl.UTF-8
284 Ta wtyczka zapobiega usunięciu przez yuma siebie samego lub innych
285 chronionych pakietów. Domyślnie jedynym chronionym pakietem jest yum,
286 ale poprzez rozszerzenie automatycznie zabezpiecza to wszystkie
287 pakiety będące zależnościami yuma (rpm, python, glibc itd.). W ten
288 sposób wtyczka funkcjonuje dobrze nawet bez troskliwego tworzenia list
289 wszystkich ważnych pakietów.
290
291 %package -n yum-basearchonly
292 Summary:        Yum plugin to let Yum install only basearch packages
293 Summary(pl.UTF-8):      Wtyczka yuma pozwalająca instalować tylko pakiety basearch
294 Group:          Base
295 Requires:       yum >= 3.0
296
297 %description -n yum-basearchonly
298 This plugin makes Yum only install basearch packages on multiarch
299 systems. If you type 'yum install foo' on a x68_64 system, only
300 'foo-x.y.x86_64.rpm' is installed. If you want to install the
301 foo-x.y.i386.rpm, you have to type 'yum install foo.i386'. The plugin
302 only works with 'yum install'.
303
304 %description -n yum-basearchonly -l pl.UTF-8
305 Ta wtyczka powoduje, że yum instaluje tylko pakiety basearch na
306 systemach multiarch. Po wpisaniu "yum install foo" na systemie x86_64
307 zostanie zainstalowany tylko "foo-x.y.x86_64.rpm. Aby zainstalować
308 foo-x.y.i386.rpm, trzeba wpisać "yum install foo.i386". Wtyczka działa
309 tylko z "yum install".
310
311 %package -n yum-plugin-upgrade-helper
312 Summary:        Yum plugin to help upgrades to the next distribution version
313 Summary(pl.UTF-8):      Wtyczka yuma pomagająca przy uaktualnianiu do kolejnej wersji dystrybucji
314 Group:          Base
315 Requires:       yum >= 3.0
316 Obsoletes:      yum-upgrade-helper
317
318 %description -n yum-plugin-upgrade-helper
319 This plugin allows yum to erase specific packages on install/update
320 based on an additional metadata file in repositories. It is used to
321 simplify distribution upgrade hangups.
322
323 %description -n yum-plugin-upgrade-helper -l pl.UTF-8
324 Ta wtyczka pozwala yumowi usunąć określone pakiety przy instalacji lub
325 uaktualnianiu w oparciu o dodatkowe pliki metadanych w repozytoriach.
326 Służy do uproszczenia uaktualnień wersji dystrybucji.
327
328 %package -n yum-plugin-aliases
329 Summary:        Yum plugin to enable aliases filters
330 Summary(pl.UTF-8):      Wtyczka yuma włączająca filtry aliasów
331 Group:          Base
332 # Requires args_hook
333 Requires:       yum >= 3.2.23
334 Obsoletes:      yum-aliases
335
336 %description -n yum-plugin-aliases
337 This plugin adds the command alias, and parses the aliases config.
338 file to enable aliases.
339
340 %description -n yum-plugin-aliases -l pl.UTF-8
341 Ta wtyczka dodaje polecenie alias i analizuje konfigurację aliasów w
342 celu włączenia aliasów.
343
344 %package -n yum-plugin-list-data
345 Summary:        Yum plugin to list aggregate package data
346 Summary(pl.UTF-8):      Wtyczka yuma wypisująca zagregowane dane pakietów
347 Group:          Base
348 Requires:       yum >= 3.0.5
349 Obsoletes:      yum-list-data
350
351 %description -n yum-plugin-list-data
352 This plugin adds the commands list- vendors, groups, packagers,
353 licenses, arches, committers, buildhosts, baseurls, package-sizes,
354 archive-sizes and installed-sizes.
355
356 %description -n yum-plugin-list-data -l pl.UTF-8
357 Ta wtyczka dodaje polecenia list- vendors, groups, packagers,
358 licenses, arches, committers, buildhosts, baseurls, package-sizes,
359 archive-sizes i installed-sizes.
360
361 %package -n yum-plugin-filter-data
362 Summary:        Yum plugin to list filter based on package data
363 Summary(pl.UTF-8):      Wtyczka yuma dodająca filtry oparte na danych pakietu
364 Group:          Base
365 Requires:       yum >= 3.2.17
366 Obsoletes:      yum-filter-data
367
368 %description -n yum-plugin-filter-data
369 This plugin adds the options --filter- vendors, groups, packagers,
370 licenses, arches, committers, buildhosts, baseurls, package-sizes,
371 archive-sizes and installed-sizes. Note that each package must match
372 at least one pattern/range in each category, if any were specified.
373
374 %description -n yum-plugin-filter-data -l pl.UTF-8
375 Ta wtyczka dodaje opcje --filter- vendors, groups, packagers,
376 licenses, arches, committers, buildhosts, baseurls, package-sizes,
377 archive-sizes i installed-sizes. Każdy pakiet musi pasować do
378 przynajmniej jednego wzorca/zakresu w każdej wybranej kategorii.
379
380 %package -n yum-plugin-tmprepo
381 Summary:        Yum plugin to add temporary repositories
382 Summary(pl.UTF-8):      Wtyczka yuma dodająca repozytoria tymczasowe
383 Group:          Base
384 Requires:       createrepo
385 Requires:       yum >= 3.2.11
386 Obsoletes:      yum-tmprepo
387
388 %description -n yum-plugin-tmprepo
389 This plugin adds the option --tmprepo which takes a URL to a .repo
390 file downloads it and enables it for a single run. This plugin tries
391 to ensure that temporary repositories are safe to use, by default, by
392 not allowing gpg checking to be disabled.
393
394 %description -n yum-plugin-tmprepo -l pl.UTF-8
395 Ta wtyczka dodaje opcję --tmprepo przyjmującą URL do pliku .repo i
396 włączająca go dla jednego uruchomienia. Wtyczka próbuje zapewnić
397 bezpieczne użycie repozytoriów tymczasowych domyślnie nie pozwalając
398 na wyłączenie sprawdzania gpg.
399
400 %package -n yum-plugin-verify
401 Summary:        Yum plugin to add verify command, and options
402 Summary(pl.UTF-8):      Wtyczka yuma dodająca polecenie i opcje weryfikacji
403 Group:          Base
404 Requires:       yum >= 3.2.12
405 Obsoletes:      yum-verify
406
407 %description -n yum-plugin-verify
408 This plugin adds the commands verify, verify-all and verify-rpm. There
409 are also a couple of options. This command works like rpm -V, to
410 verify your installation.
411
412 %description -n yum-plugin-verify -l pl.UTF-8
413 Ta wtyczka dodaje polecenia verify, verify-all i verify-rpm, a także
414 kilka opcji. Działa podobnie jak rpm -V, weryfikując instalację.
415
416 %package -n yum-plugin-keys
417 Summary:        Yum plugin to deal with signing keys
418 Group:          Base
419 Requires:       yum >= 3.2.19
420
421 %description -n yum-plugin-keys
422 This plugin adds the commands keys, keys-info, keys-data and
423 keys-remove. They allow you to query and remove signing keys.
424
425 %package -n yum-plugin-remove-with-leaves
426 Summary:        Yum plugin to remove dependencies which are no longer used because of a removal
427 Group:          Base
428 Requires:       yum >= 3.2.19
429
430 %description -n yum-plugin-remove-with-leaves
431 This plugin removes any unused dependencies that were brought in by an
432 install but would not normally be removed. It helps to keep a system
433 clean of unused libraries and packages.
434
435 %package -n yum-plugin-post-transaction-actions
436 Summary:        Yum plugin to run arbitrary commands when certain pkgs are acted on
437 Group:          Base
438 Requires:       yum >= 3.2.19
439
440 %description -n yum-plugin-post-transaction-actions
441 This plugin allows the user to run arbitrary actions immediately
442 following a transaction when specified packages are changed.
443
444 %package -n yum-NetworkManager-dispatcher
445 Summary:        NetworkManager script which tells yum to check it's cache on network change
446 Group:          Base
447 Requires:       yum >= 3.2.17
448
449 %description -n yum-NetworkManager-dispatcher
450 This NetworkManager "dispatch script" forces yum to check its cache
451 if/when a new network connection happens in NetworkManager. Note that
452 currently there is no checking of previous data, so if your WiFi keeps
453 going up and down (or you suspend/resume a lot) yum will recheck its
454 cached data a lot.
455
456 %package -n yum-plugin-rpm-warm-cache
457 Summary:        Yum plugin to access the rpmdb files early to warm up access to the db
458 Group:          Base
459 Requires:       yum >= 3.2.19
460
461 %description -n yum-plugin-rpm-warm-cache
462 This plugin reads the rpmdb files into the system cache before
463 accessing the rpmdb directly. In some cases this should speed up
464 access to rpmdb information
465
466 # Works by searching for *-debuginfo ... so it shouldn't trigger on
467 itself.
468 %package -n yum-plugin-auto-update-debug-info
469 Summary:        Yum plugin to enable automatic updates to installed debuginfo packages
470 Group:          Base
471 Requires:       yum >= 3.2.19
472
473 %description -n yum-plugin-auto-update-debug-info
474 This plugin looks to see if any debuginfo packages are installed, and
475 if there are it enables all debuginfo repositories that are "children"
476 of enabled repositories.
477
478 %package -n yum-plugin-show-leaves
479 Summary:        Yum plugin which shows newly installed leaf packages
480 Group:          Base
481 Requires:       yum >= 3.2.23
482
483 %description -n yum-plugin-show-leaves
484 Yum plugin which shows newly installed leaf packages and packages that
485 became leaves after a transaction
486
487 %package -n yum-plugin-local
488 Summary:        Yum plugin to automatically manage a local repo. of downloaded packages
489 Group:          Base
490 # Who the hell knows what version:)
491 Requires:       createrepo
492 Requires:       yum >= 3.2.22
493
494 %description -n yum-plugin-local
495 When this plugin is installed it will automatically copy all
496 downloaded packages to a repository on the local filesystem, and
497 (re)build that repository. This means that anything you've downloaded
498 will always exist, even if the original repo. removes it (and can
499 thus. be reinstalled/downgraded/etc.).
500
501 %package -n yum-plugin-fs-snapshot
502 Summary:        Yum plugin to automatically snapshot your filesystems during updates
503 Group:          Base
504 Requires:       yum >= 3.2.22
505
506 %description -n yum-plugin-fs-snapshot
507 When this plugin is installed it will automatically snapshot any
508 filesystem that is touched by the packages in a yum update or yum
509 remove.
510
511 %package -n yum-plugin-ps
512 Summary:        Yum plugin to look at processes, with respect to packages
513 Group:          Base
514 Requires:       yum >= 3.2.27
515
516 %description -n yum-plugin-ps
517 When this plugin is installed it adds the yum command "ps", which
518 allows you to see which running processes are accociated with which
519 packages (and if they need rebooting, or have updates, etc.)
520
521 %package -n yum-plugin-puppetverify
522 Summary:        Yum plugin to add puppet checksums to verify data
523 Group:          Base
524 Requires:       puppet
525 Requires:       python-PyYAML >= 3.09
526 Requires:       yum >= 3.2.12
527
528 %description -n yum-plugin-puppetverify
529 Supplies checksums for files in packages from puppet's state file.
530
531 %package -n bash-completion-%{name}
532 Summary:        bash-completion for Yum Utils
533 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla Yum Utils
534 Group:          Applications/Shells
535 Requires:       %{name}
536 Requires:       bash-completion
537
538 %description -n bash-completion-%{name}
539 bash-completion for Yum Utils.
540
541 %description -n bash-completion-%{name} -l pl.UTF-8
542 bashowe uzupełnianie nazw dla Yum Utils.
543
544 %prep
545 %setup -q
546
547 mv plugins/README README.plugins
548
549 %build
550 %{__make}
551
552 %install
553 rm -rf $RPM_BUILD_ROOT
554 %{__make} install \
555         PYLIBDIR=%{py_scriptdir} \
556         DESTDIR=$RPM_BUILD_ROOT
557 %{__make} -C updateonboot install \
558         DESTDIR=$RPM_BUILD_ROOT
559
560 # Plugins to install
561 plugins="
562 changelog
563 fastestmirror
564 protectbase
565 versionlock
566 tsflags
567 kernel-module
568 downloadonly
569 allowdowngrade
570 priorities
571 refresh-updatesd
572 merge-conf
573 security
574 basearchonly
575 upgrade-helper
576 aliases
577 list-data
578 filter-data
579 tmprepo
580 verify
581
582 keys
583 remove-with-leaves
584 post-transaction-actions
585 rpm-warm-cache
586 auto-update-debuginfo
587 show-leaves
588 local
589 fs-snapshot
590 ps
591 %{?with_puppet:puppetverify}
592 "
593
594 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/yum/{pluginconf.d,post-actions},%{_libexecdir}}
595
596 cd plugins
597 for plug in $plugins; do
598         cp -p $plug/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/yum/pluginconf.d
599         cp -p $plug/*.py $RPM_BUILD_ROOT%{_libexecdir}
600 done
601
602 cp -p aliases/aliases $RPM_BUILD_ROOT%{_sysconfdir}/yum/aliases.conf
603 cp -p versionlock/versionlock.list $RPM_BUILD_ROOT%{_sysconfdir}/yum/pluginconf.d
604
605 # need for for the ghost in files section of yum-plugin-local
606 install -d $RPM_BUILD_ROOT%{_sysconfdir}/yum.repos.d
607 touch $RPM_BUILD_ROOT%{_sysconfdir}/yum.repos.d/_local.repo
608
609 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_libexecdir}/pld-kernel.py
610 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/yum/pluginconf.d/pld-kernel.conf
611
612 %py_postclean
613
614 %clean
615 rm -rf $RPM_BUILD_ROOT
616
617 %post -n yum-updateonboot
618 /sbin/chkconfig --add yum-updateonboot
619
620 %preun -n yum-updateonboot
621 if [ "$1" = 0 ]; then
622         %service yum-updateonboot stop
623         /sbin/chkconfig --del yum-updateonboot
624 fi
625
626 %files
627 %defattr(644,root,root,755)
628 %doc ChangeLog README README.plugins TODO
629 %doc yum-util-cli-template
630 %attr(755,root,root) %{_bindir}/debuginfo-install
631 %attr(755,root,root) %{_bindir}/find-repos-of-install
632 %attr(755,root,root) %{_bindir}/needs-restarting
633 %attr(755,root,root) %{_bindir}/package-cleanup
634 %attr(755,root,root) %{_bindir}/repo-graph
635 %attr(755,root,root) %{_bindir}/repo-rss
636 %attr(755,root,root) %{_bindir}/repoclosure
637 %attr(755,root,root) %{_bindir}/repodiff
638 %attr(755,root,root) %{_bindir}/repomanage
639 %attr(755,root,root) %{_bindir}/repoquery
640 %attr(755,root,root) %{_bindir}/reposync
641 %attr(755,root,root) %{_bindir}/repotrack
642 %attr(755,root,root) %{_bindir}/show-changed-rco
643 %attr(755,root,root) %{_bindir}/show-installed
644 %attr(755,root,root) %{_bindir}/verifytree
645 %attr(755,root,root) %{_bindir}/yum-builddep
646 %attr(755,root,root) %{_bindir}/yum-config-manager
647 %attr(755,root,root) %{_bindir}/yum-debug-dump
648 %attr(755,root,root) %{_bindir}/yum-debug-restore
649 %attr(755,root,root) %{_bindir}/yum-groups-manager
650 %attr(755,root,root) %{_bindir}/yumdownloader
651 %attr(755,root,root) %{_sbindir}/yum-complete-transaction
652 %attr(755,root,root) %{_sbindir}/yumdb
653 %dir %{_libexecdir}
654 %dir %{py_sitescriptdir}/yumutils
655 %{py_sitescriptdir}/yumutils/*.py[co]
656 %{_mandir}/man1/debuginfo-install.1*
657 %{_mandir}/man1/package-cleanup.1.*
658 %{_mandir}/man1/repo-rss.1.*
659 %{_mandir}/man1/repodiff.1*
660 %{_mandir}/man1/repoquery.1.*
661 %{_mandir}/man1/reposync.1.*
662 %{_mandir}/man1/show-changed-rco.1*
663 %{_mandir}/man1/show-installed.1*
664 %{_mandir}/man1/yum-aliases.1*
665 %{_mandir}/man1/yum-builddep.1.*
666 %{_mandir}/man1/yum-debug-dump.1*
667 %{_mandir}/man1/yum-groups-manager.1*
668 %{_mandir}/man1/yum-utils.1.*
669 %{_mandir}/man1/yum-versionlock.1*
670 %{_mandir}/man1/yumdownloader.1.*
671 %{_mandir}/man5/yum-versionlock.conf.5*
672 %{_mandir}/man8/yum-complete-transaction.8.*
673 %{_mandir}/man8/yumdb.8*
674
675 %files -n yum-updateonboot
676 %defattr(644,root,root,755)
677 %doc updateonboot/README
678 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/yum-updateonboot
679 %attr(754,root,root) /etc/rc.d/init.d/yum-updateonboot
680
681 %files -n yum-plugin-changelog
682 %defattr(644,root,root,755)
683 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/changelog.conf
684 %{_libexecdir}/changelog.*
685 %{_mandir}/man1/yum-changelog.1.*
686 %{_mandir}/man5/yum-changelog.conf.5.*
687
688 %files -n yum-plugin-fastestmirror
689 %defattr(644,root,root,755)
690 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/fastestmirror.conf
691 %{_libexecdir}/fastestmirror.*
692
693 %files -n yum-plugin-protectbase
694 %defattr(644,root,root,755)
695 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/protectbase.conf
696 %{_libexecdir}/protectbase.*
697
698 %files -n yum-plugin-versionlock
699 %defattr(644,root,root,755)
700 %doc plugins/versionlock/README
701 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/versionlock.conf
702 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/versionlock.list
703 %{_libexecdir}/versionlock.*
704
705 %files -n yum-plugin-tsflags
706 %defattr(644,root,root,755)
707 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/tsflags.conf
708 %{_libexecdir}/tsflags.*
709
710 # TODO: remove in pld? removed in fedora
711 %files -n yum-kernel-module
712 %defattr(644,root,root,755)
713 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/kernel-module.conf
714 %{_libexecdir}/kernel-module.*
715
716 %files -n yum-plugin-downloadonly
717 %defattr(644,root,root,755)
718 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/downloadonly.conf
719 %{_libexecdir}/downloadonly.*
720
721 # TODO: remove like fedora?
722 %files -n yum-allowdowngrade
723 %defattr(644,root,root,755)
724 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/allowdowngrade.conf
725 %{_libexecdir}/allowdowngrade.*
726
727 %files -n yum-plugin-pld-kernel
728 %defattr(644,root,root,755)
729 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/pld-kernel.conf
730 %{_libexecdir}/pld-kernel.*
731
732 %files -n yum-plugin-priorities
733 %defattr(644,root,root,755)
734 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/priorities.conf
735 %{_libexecdir}/priorities.*
736
737 %files -n yum-plugin-refresh-updatesd
738 %defattr(644,root,root,755)
739 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/refresh-updatesd.conf
740 %{_libexecdir}/refresh-updatesd.*
741
742 %files -n yum-plugin-merge-conf
743 %defattr(644,root,root,755)
744 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/merge-conf.conf
745 %{_libexecdir}/merge-conf.*
746
747 %files -n yum-plugin-security
748 %defattr(644,root,root,755)
749 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/security.conf
750 %{_libexecdir}/security.*
751 %{_mandir}/man8/yum-security.8.*
752
753 %if 0
754 # TODO: renamed to protectbase?
755 %files -n yum-protect-packages
756 %defattr(644,root,root,755)
757 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/protect-packages.conf
758 %{_libexecdir}/protect-packages.*
759 %endif
760
761 # TODO: rename to basearchonly like fedora?
762 %files -n yum-basearchonly
763 %defattr(644,root,root,755)
764 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/basearchonly.conf
765 %{_libexecdir}/basearchonly.*
766
767 %files -n yum-plugin-upgrade-helper
768 %defattr(644,root,root,755)
769 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/upgrade-helper.conf
770 %{_libexecdir}/upgrade-helper.*
771
772 %files -n yum-plugin-aliases
773 %defattr(644,root,root,755)
774 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/aliases.conf
775 %config(noreplace) %{_sysconfdir}/yum/aliases.conf
776 %{_libexecdir}/aliases.*
777
778 %files -n yum-plugin-list-data
779 %defattr(644,root,root,755)
780 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/list-data.conf
781 %{_libexecdir}/list-data.*
782 %{_mandir}/man1/yum-list-data.1.*
783
784 %files -n yum-plugin-filter-data
785 %defattr(644,root,root,755)
786 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/filter-data.conf
787 %{_libexecdir}/filter-data.*
788 %{_mandir}/man1/yum-filter-data.1.*
789
790 %files -n yum-plugin-tmprepo
791 %defattr(644,root,root,755)
792 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/tmprepo.conf
793 %{_libexecdir}/tmprepo.*
794
795 %files -n yum-plugin-verify
796 %defattr(644,root,root,755)
797 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/verify.conf
798 %{_libexecdir}/verify.*
799 %{_mandir}/man1/yum-verify.1.*
800
801 %files -n yum-plugin-keys
802 %defattr(644,root,root,755)
803 %config(noreplace) %{_sysconfdir}/yum/pluginconf.d/keys.conf
804 %{_libexecdir}/keys.*
805
806 %files -n yum-NetworkManager-dispatcher
807 %defattr(644,root,root,755)
808 %{_sysconfdir}/NetworkManager/dispatcher.d/yum-NetworkManager-dispatcher
809
810 %files -n yum-plugin-remove-with-leaves
811 %defattr(644,root,root,755)
812 %{_libexecdir}/remove-with-leaves.*
813 %config(noreplace) %{_sysconfdir}/yum/pluginconf.d/remove-with-leaves.conf
814
815 %files -n yum-plugin-post-transaction-actions
816 %defattr(644,root,root,755)
817 %{_libexecdir}/post-transaction-actions.*
818 %config(noreplace) %{_sysconfdir}/yum/pluginconf.d/post-transaction-actions.conf
819 %doc plugins/post-transaction-actions/sample.action
820 # Default *.action file dropping dir.
821 %dir %{_sysconfdir}/yum/post-actions
822
823 %files -n yum-plugin-rpm-warm-cache
824 %defattr(644,root,root,755)
825 %{_libexecdir}/rpm-warm-cache.*
826 %config(noreplace) %{_sysconfdir}/yum/pluginconf.d/rpm-warm-cache.conf
827
828 %files -n yum-plugin-auto-update-debug-info
829 %defattr(644,root,root,755)
830 %{_libexecdir}/auto-update-debuginfo.*
831 %config(noreplace) %{_sysconfdir}/yum/pluginconf.d/auto-update-debuginfo.conf
832
833 %files -n yum-plugin-show-leaves
834 %defattr(644,root,root,755)
835 %{_libexecdir}/show-leaves.*
836 %config(noreplace) %{_sysconfdir}/yum/pluginconf.d/show-leaves.conf
837
838 %files -n yum-plugin-local
839 %defattr(644,root,root,755)
840 %ghost %{_sysconfdir}/yum.repos.d/_local.repo
841 %config(noreplace) %{_sysconfdir}/yum/pluginconf.d/local.conf
842 %{_libexecdir}/local.*
843
844 %files -n yum-plugin-fs-snapshot
845 %defattr(644,root,root,755)
846 %config(noreplace) %{_sysconfdir}/yum/pluginconf.d/fs-snapshot.conf
847 %{_libexecdir}/fs-snapshot.*
848 %{_mandir}/man1/yum-fs-snapshot.1.*
849 %{_mandir}/man5/yum-fs-snapshot.conf.5.*
850
851 %files -n yum-plugin-ps
852 %defattr(644,root,root,755)
853 %config(noreplace) %{_sysconfdir}/yum/pluginconf.d/ps.conf
854 %{_libexecdir}/ps.*
855
856 %if %{with puppet}
857 %files -n yum-plugin-puppetverify
858 %defattr(644,root,root,755)
859 %config(noreplace) %{_sysconfdir}/yum/pluginconf.d/puppetverify.conf
860 %{_libexecdir}/puppetverify.*
861 %endif
862
863 %files -n bash-completion-%{name}
864 %defattr(644,root,root,755)
865 /etc/bash_completion.d/*
This page took 0.088796 seconds and 3 git commands to generate.