]> git.pld-linux.org Git - packages/ykpers.git/blob - ykpers.spec
5b8f0180a46a5d755978aedb13ef1eea079fcbe0
[packages/ykpers.git] / ykpers.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_without  tests           # unit tests
5
6 Summary:        Yubikey personalization program
7 Summary(pl.UTF-8):      Program do personalizacji urządzeń Yubikey
8 Name:           ykpers
9 Version:        1.19.0
10 Release:        1
11 License:        BSD
12 Group:          Applications/System
13 Source0:        https://developers.yubico.com/yubikey-personalization/Releases/%{name}-%{version}.tar.gz
14 # Source0-md5:  22084c0e55f3c3259963c0136adb3950
15 URL:            https://developers.yubico.com/yubikey-personalization/
16 BuildRequires:  asciidoc
17 BuildRequires:  json-c-devel
18 BuildRequires:  libusb-devel >=1.0
19 BuildRequires:  libyubikey-devel >= 1.5
20 BuildRequires:  pkgconfig
21 BuildRequires:  udev-devel >= 1:1.188
22 Requires:       libyubikey >= 1.5
23 Conflicts:      udev-core < 1:1.188
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Yubico's YubiKey can be re-programmed with a new AES key. This is a
28 library that makes this an easy task.
29
30 %description -l pl.UTF-8
31 Urządzenia Yubico YubiKey można ponownie zaprogramować nowym kluczem
32 AES. Ta biblioteka pozwala zrobić to łatwo.
33
34 %package devel
35 Summary:        Development files for ykpers library
36 Summary(pl.UTF-8):      Pliki programistyczne biblioteki ykpers
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 This package contains the header files needed to develop applications
42 that use ykpers library.
43
44 %description devel -l pl.UTF-8
45 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
46 wykorzystujących bibliotekę ykpers.
47
48 %package static
49 Summary:        Static ykpers library
50 Summary(pl.UTF-8):      Statyczna biblioteka ykpers
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static ykpers library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka ykpers.
59
60 %prep
61 %setup -q
62
63 %build
64 %configure \
65         --disable-silent-rules \
66         %{!?with_static_libs:--disable-static} \
67         --with-backend=libusb-1.0 \
68         --with-udevrulesdir=/lib/udev/rules.d
69 %{__make}
70
71 %if %{with tests}
72 export LD_LIBRARY_PATH=$(pwd)/.libs
73 # disable valgrind, it reports false positives from libc sscanf() and strdup()
74 %{__make} check \
75         LOG_COMPILER=
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 # obsoleted by pkg-config
85 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libykpers-1.la
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS COPYING ChangeLog NEWS README doc/Compatibility.asciidoc
96 %attr(755,root,root) %{_bindir}/ykinfo
97 %attr(755,root,root) %{_bindir}/ykpersonalize
98 %attr(755,root,root) %{_bindir}/ykchalresp
99 %attr(755,root,root) %{_libdir}/libykpers-1.so.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libykpers-1.so.1
101 %{_mandir}/man1/ykpersonalize.1*
102 %{_mandir}/man1/ykchalresp.1*
103 %{_mandir}/man1/ykinfo.1*
104 /lib/udev/rules.d/69-yubikey.rules
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc doc/USB-Hid-Issue.asciidoc
109 %attr(755,root,root) %{_libdir}/libykpers-1.so
110 %{_includedir}/ykpers-1
111 %{_pkgconfigdir}/ykpers-1.pc
112
113 %if %{with static_libs}
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libykpers-1.a
117 %endif
This page took 0.095103 seconds and 3 git commands to generate.