]> git.pld-linux.org Git - SPECS.git/blob - yasmin.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / yasmin.spec
1 Summary:        8051 simulator
2 Summary(pl.UTF-8):      Symulator 8051
3 Name:           yasmin
4 Version:        0.6.0
5 Release:        3
6 Epoch:          1
7 License:        GPL
8 Group:          X11/Applications
9 Source0:        http://home.tiscalinet.be/genglebi/packages/%{name}-%{version}.tar.gz
10 # Source0-md5:  0726b969a1431b0e9f9834defe9fbbe3
11 Patch0:         %{name}-make.patch
12 Patch1:         %{name}-c++.patch
13 Patch2:         %{name}-cast.patch
14 URL:            http://home.tiscalinet.be/genglebi/
15 BuildRequires:  libpng-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  qt-devel
18 BuildRequires:  zlib-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21
22 %description
23 Yasmin (which stands for Yet Another Simulating Interpreter) is a
24 simple yet powerfull interpreted 80c51 simulator. The program reads
25 your assembler code, and simulates the execution of this on an intel
26 8051 microcontroler. The simulator contains a complete development
27 environment, which includes breakpoints, stepwise running through the
28 program (Step in, step out, step over), overview of the data memory,
29 clear overview of the special function registers, etc...
30
31 %description -l pl.UTF-8
32 Yasmin jest prostym ale o dużych możliwościach symulatorem
33 mikrokontrolera 80c51. Program czyta Twój kod asemblera i symuluje
34 jego wykonanie na mikrokontrolerze. Symylator zawiera pełne środowisko
35 developerskie włączając w to breakpointy, pracę krokową, przegląd
36 pamięci danych, rejestrów itp.
37
38 %prep
39 %setup -q
40 %patch0 -p1
41 %patch1 -p1
42 %patch2 -p1
43
44 %build
45 touch *.h
46 %{__make} \
47         SYSCONF_CXX="%{__cxx}" \
48         SYSCONF_LINK="%{__cxx}" \
49         OPT_FLAGS="%{rpmcflags} -I%{_includedir}/qt -Wno-deprecated" \
50         SYSCONF_MOC="%{_bindir}/moc"            \
51         SYSCONF_LFLAGS_QT="-L%{_libdir}"        \
52         SYSCONF_LIBS_QT="-lqt-mt"               \
53         SYSCONF_LFLAGS_X11="-L%{_libdir}"
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{_bindir}
58
59 install %{name} $RPM_BUILD_ROOT%{_bindir}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc AUTHORS BUGS README examples
67 %attr(755,root,root) %{_bindir}/*
This page took 0.51418 seconds and 3 git commands to generate.